Ubuntu

no sound on Dell D430 docking station

Reported by Martin-Éric Racine on 2008-08-16
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

On this Dell Latitude D430, I cannot get any sound out of the docking station's audio out.

The output of lspci is as follows:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
02:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)
02:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 18)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

The output of /proc/asound/cards is:
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xefebc000 irq 21

$ dpkg -l | grep alsa
ii alsa-base 1.0.16-0ubuntu4 ALSA driver configuration files
ii alsa-utils 1.0.15-3ubuntu2 ALSA utilities
ii gstreamer0.10-alsa 0.10.18-3 GStreamer plugin for ALSA
ii libesd-alsa0 0.2.38-0ubuntu9 Enlightened Sound Daemon (ALSA) - Shared lib
ii libpt-1.10.10-plugins-alsa 1.10.10-1ubuntu6 Portable Windows Library Audio Plugin for th
rc libsdl1.2debian-alsa 1.2.11-9ubuntu2 Simple DirectMedia Layer (with X11 and ALSA

This model is fairly similar to the previous D420 model that is used by a number of Ubuntu developers, as witnessed at UDS Intrepid in Prague.

Martin-Éric Racine (q-funk) wrote :

Additionally, the lspci -vv output for that particular device:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
        Subsystem: Dell Unknown device 0201
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at efebc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Unknown type IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled CommClk- ExtSynch-
                Link: Speed unknown, Width x0

Daniel T Chen (crimsun) on 2008-09-20
Changed in alsa-driver:
assignee: nobody → ubuntu-audio
importance: Undecided → Low
status: New → Confirmed
gogi (xamiw) wrote :

I've found a workaround by another distribution-user (in German):

http://wiki.archlinux.de/?title=Soundkarte:_hda-intel

Just do the following if you own an Latitude D430 (and maybe other Latitudes):

1. create/edit file "/etc/modprobe.d/sound" and change the content to:

      options snd-hda-intel model=dell-m22 enable=1 index=0
      alias snd-card-0 snd-hda-intel
      alias sound-slot-0 snd-hda-intel

2. reboot

Martin-Éric Racine (q-funk) wrote :

But how do I know which of those STAC9200 variants is correct?

PS: attached dump of /proc/asound/card0/codec#0 and /proc/asound/card0/codec#1 to this bug for completion.

Martin-Éric Racine (q-funk) wrote :
gogi (xamiw) wrote :

I believe no one who works with linux could answer your question. Try and error is the only way.

But if some got a list from Dell which Laptop uses which variant this could be used in conjunction with dmidecode:

        sudo dmidecode > systeminfo

The new file "systeminfo" shows many things and this:

Handle 0x0100, DMI type 1, 27 bytes
System Information
        Manufacturer: Dell Inc.
        Product Name: Latitude D430
        Version: Not Specified
        Serial Number: xxxxxxxx
        UUID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx <------- UID is erased by me
        Wake-up Type: Power Switch
        SKU Number: Not Specified
        Family:

With this an identification could be possible.

Gogi

Martin-Éric Racine (q-funk) wrote :

Btw, I tried the above suggested lines, but it did not fix the issue; the base station's sound output still doesn't work.

gogi (xamiw) wrote :

Did you set the "iec958" switch in your gnome volume control?

Activate the switch in edit->preferences and set it with the switch tab.

Martin-Éric Racine (q-funk) wrote :

OK, after activating the IEC958 switch and enabling it, I indeed get output on the base station. This is progress! :)

However, the D430's built-in speaker still outputs sound, which is undesirable. Connecting headphones to the D430's own headphone jack disconnects the built-in speaker, but doing the same with the base station's headphone jack doesn't.

gogi (xamiw) wrote :

Just toggle the master in your gnome volume control down to zero.

You will still get sound out of docking station but not of internal speaker. The master volume control does not control the docking station headphone jack.

What I think why Dell designs the hardware like this:

1. Both, the analogue and digital sound output of the docking station are having the same source. This source is activated by the iec958 switch.

2. The digital sound output has no way to detect if a cable is plugged in or not. So if activated by iec958 there's a signal on the digital output. It doesn't matter if a cable is plugged or not.

3. Combine 1. with 2. The analogue output of the docking station is activated at same time with digital output. So this jack does not recognize if a cable is plugged in or not. It's just activated by iec958.

4. The digital output does not have a volume control. The volume control is done by the amplifier.

So if my suggestions are right there's a reason why you have to activate the iec958 switch and toggle down the master.

But to understand why such a hardware design should be clever and smart you have to ask Dell. I do not know.

mehturt (mehturt) wrote :

I have Dell D630 and I have found out I need to have model=dell-m42 in order for the sound to work.
However the sound output in docking station does not work, even with iec958 on. Any suggestions?

Martin-Éric Racine (q-funk) wrote :

mehturt: Dell D630 is a completely separate hardware configuration. Can you please open a separate bug for it? Thanks!

Marcoussi (marc-alam) wrote :

Just installed Jaunty RC on my Dell D430 and I still have the same issue. No sound is getting out of the docking station jack. I tried to follow the above suggestions to switch on the IEC958 in the volume control preferences but I can't find that switch.

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
Martin-Éric Racine (q-funk) wrote :

Brian, why was this bug suddenly unassigned?

EclipseAgent (ben-kevan) wrote :

Yes.. this would be nice to have

EclipseAgent (ben-kevan) wrote :

This issue is resolved in the newest version of Ubuntu for me.. on the 430 and newer models.

Jeremy Foshee (jeremyfoshee) wrote :

Martin-Éric,
     Are you able to verify EclipseAgent's statement above?

Thanks!

~JFo

I can verify it. It's working.

Am Dienstag, den 27.04.2010, 22:47 +0000 schrieb Jeremy Foshee:
> Martin-Éric,
> Are you able to verify EclipseAgent's statement above?
>
> Thanks!
>
> ~JFo
>

Martin-Éric Racine (q-funk) wrote :

No, I'm not. I'd like instructions for how to reproduce his results.

EclipseAgent (ben-kevan) wrote :

I installed the most recent version of Ubuntu (about to be released tomorrow).

Which is Ubuntu 10.04.. Once I installed, issues were resolved.

Martin-Éric Racine (q-funk) wrote :

I'm also running Lucid here (upgraded from Karmic), but still no sound on the docking station.

gogi (xamiw) wrote :

Am Mittwoch, den 28.04.2010, 17:47 +0000 schrieb Martin-Éric Racine:
> No, I'm not. I'd like instructions for how to reproduce his results.

Here's what I've done (translated by myself from german gnome desktop;
maybe some translations are not correct):

1. Ubuntu 9.10
2. Right click on audio symbol
3. click on audio settings
4. click on tab hardware
5. click on profile "Digital Stereo (IEC 958) Output + Analog Stereo
Input"

Martin-Éric Racine (q-funk) wrote :

I don't see those options here on Ubuntu 10.4.

Martin-Éric Racine (q-funk) wrote :

I still don't see those options here on Natty.

I got this to work (Ubuntu 10.04), but I am not sure what I did that made the difference.

I did add a file /etc/modprobe.d/sound which contained

options snd-hda-intel model=dell-m22 enable=1 index=0
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

this did not seem to work right away.

I also ran

sudo alsactl store
edited /var/lib/alsa/asound.state
sudo alsactl restore

but I don't think the change I made was correct (I turned on the NVIDIA device by mistake) -- I think the subsequent reboot was the key step. I wish I could be sure -- it is possible that simply running alsactl fixed something that was missing.

In any case, IEC958 starting appearing as one of the profiles in the sound preferences.

I also started installing hidpoint, but it would not install because my kernel was too new, so again, I don't think this was it, either.

Martin-Éric Racine, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: kernel-sound needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers