iwl4965: kernel BUG at iwl4965-base.c:4222

Bug #258485 reported by Anton Blanchard on 2008-08-16
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Intel Linux Wireless
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned
linux-backports-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Medium
Unassigned

Bug Description

I've been experiencing regular lockups on my t61p laptop. The keyboard LEDs flash, suggesting a kernel panic. The panic never made it to disk and X prevented me from seeing it on the console.

I finally hooked up netconsole over the ethernet and managed to get the panic:

iwl4965: Error wrong command queue 3 command id 0x89
------------[ cut here ]------------
kernel BUG at /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/wireless/iwlwifi/iwlwifi/compatible/iwl4965-base.c:4222!
invalid opcode: 0000 [#1] SMP
Modules linked in: netconsole configfs af_packet binfmt_misc rfcomm l2cap kvm uinput ppdev tun ipv6 acpi_cpufreq cpufreq_powersave cpufreq_ondemand cpufreq_conservative cpufreq_userspace cpufreq_stats freq_table sbs sbshc bay dock container iptable_filter ip_tables x_tables aes_i586 dm_crypt dm_mod parport_pc lp parport arc4 ecb blkcipher joydev pcmcia thinkpad_acpi nvram serio_raw pcspkr psmouse evdev hci_usb bluetooth battery ac sdhci ricoh_mmc mmc_core nvidia(P) yenta_socket rsrc_nonstatic pcmcia_core iwl4965 iwlwifi_mac80211 i2c_core cfg80211 snd_hda_intel snd_pcm_oss snd_mixer_oss video output snd_pcm snd_page_alloc snd_hwdep snd_seq_dummy wmi_acer button snd_seq_oss snd_seq_midi snd_rawmidi iTCO_wdt iTCO_vendor_support snd_seq_midi_event snd_seq snd_timer snd_seq_device intel_agp snd agpgart soundcore shpchp pci_hotplug sr_mod cdrom ext3 jbd mbcache sg sd_mod ata_piix pata_acpi ahci ata_generic ohci1394 ieee1394 libata scsi_mod ehci_hcd uhci_hcd usbcore e1000 thermal processor fan fbcon tileblit font bitblit softcursor fuse

Pid: 0, comm: swapper Tainted: P (2.6.24-19-generic #1)
EIP: 0060:[<f8af112f>] EFLAGS: 00010092 CPU: 0
EIP is at iwl_irq_tasklet+0x30f/0x5a0 [iwl4965]
EAX: 00000047 EBX: 00000001 ECX: 00000092 EDX: 00000000
ESI: df989bd0 EDI: d44a16c0 EBP: df9892e0 ESP: c041de9c
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process swapper (pid: 0, ti=c041c000 task=c03ea3a0 task.ti=c041c000)
Stack: f8afad14 00000003 00000089 df989a18 df98b348 df98b248 df9897e8 df98b254
       00000000 00010000 00000296 00000000 0000005a 00000060 df989a28 00000000
       c0122796 74cd00e7 80000000 df98d07c 00000000 c04790b8 0000000a c01322cd
Call Trace:
 [<c0122796>] __update_rq_clock+0x26/0x170
 [<c01322cd>] tasklet_action+0x4d/0xc0
 [<c0131d72>] __do_softirq+0x82/0x110
 [<c0131e55>] do_softirq+0x55/0x60
 [<c013213d>] irq_exit+0x6d/0x80
 [<c0106f20>] do_IRQ+0x40/0x70
 [<c0105413>] common_interrupt+0x23/0x30
 [<c012007b>] __is_prefetch+0x9b/0x240
 [<f88873df>] acpi_idle_enter_bm+0x25b/0x2ce [processor]
 [<c02952fc>] cpuidle_idle_call+0x7c/0xb0
 [<c0102695>] cpu_idle+0x45/0xd0
 [<c0421a5f>] start_kernel+0x31f/0x3b0
 [<c0421130>] unknown_bootoption+0x0/0x1e0
 =======================
Code: 06 0f b6 d4 81 e2 bf 00 00 00 83 fa 04 0f 84 c6 00 00 00 0f b6 41 04 89 54 24 04 c7 04 24 14 ad af f8 89 44 24 08 e8 71 c0 63 c7 <0f> 0b eb fe 81 4c 24 20 00 00 00 08 f7 54 24 20 8b 44 24 20 23
EIP: [<f8af112f>] iwl_irq_tasklet+0x30f/0x5a0 [iwl4965] SS:ESP 0068:c041de9c

Looking at the source:

        /* If a Tx command is being handled and it isn't in the actual
         * command queue then there a command routing bug has been introduced
         * in the queue management code. */
        if (txq_id != IWL_CMD_QUEUE_NUM)
                IWL_ERROR("Error wrong command queue %d command id 0x%X\n",
                          txq_id, pkt->hdr.cmd);
        BUG_ON(txq_id != IWL_CMD_QUEUE_NUM);

Anton Blanchard (anton-samba) wrote :

Looks like this bug is being tracked at:

http://intellinuxwireless.org/bugzilla/show_bug.cgi?id=1666

and has been fixed upstream. This comment doesn't make sense though:

"This is not a reproducible error. But apparently it has been seen before. As Ubuntu has replaced the BUG_ON with a WARN_ON."

Perhaps that was done in Feisty and not Hardy?

Changed in intellinuxwireless:
status: Unknown → Fix Released

Hi Anton,

Care to test a few things . . . First can you try installing the linux-backports-modules package as I believe it has an updated version of the iwl4965 driver - you can check the output of 'modinfo iwl4965' to see which version you have. Along with that you might want to wait for the linux-backports-modules that is in the -proposed repository to be released as it looks to by sync'd with the upstream compat-wireless stack:

https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.24

Additionally, since the upcoming Intrepid Ibex 8.10 release is actively being developed, care to confirm if this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. If the issue still exists, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

And finally, just some info that beginning with the Intrepid Ibex 8.10 development cycle the linux-ubuntu-modules package was actually merged with the linux kernel package. Going forward, bugs that would have been reported against linux-ubuntu-modules should now just be reported against linux. I've gone ahead and opened the 'linux' task for this bug so that it remains open against the actively developed kernel. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-backports-modules-2.6.24:
status: New → Incomplete
Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Mark Mandel (mark-mandel) wrote :

This seems to be what is happening to me about every 30-60 minutes on Hardy.

I'm running the backport modules, and it has not helped at all.

The only issue I am having here, is that I can get the error to happen on the alt+ctrl+f1 screen, however, it is larger than the screen, so I cannot see all the details.

I am attaching the logs as requested. I have already had several kernel panics today, over the last 6 hours (15th of September).

If this continues, I will upgrade to Ibex, as I do not seem to have another option at this stage.

Mark Mandel (mark-mandel) wrote :
Mark Mandel (mark-mandel) wrote :
Anton Blanchard (anton-samba) wrote :

Just to follow up, I upgraded to linux-backports-modules in Hardy and it looks to have fixed the issue. I will be upgrading to Intrepid soon and will verify it is OK there too. Thanks for your help!

Thanks for the update Anton. Since you are the orignal bug reporter I'm marking this "Fix Released" for Hardy's linux-backports-modules package. Definitely let us know your results when you test Intrepid. Thanks.

Changed in linux-backports-modules-2.6.24:
status: Incomplete → Fix Released
Changed in linux-ubuntu-modules-2.6.24:
status: Triaged → Invalid

@Mark Mandel, if you are able to test Intrepid as well we'd appreciate your feedback. Thanks.

Mark Mandel (mark-mandel) wrote :

@Leann,

I've been running on Intrepid for a few months now, and I haven't seen this bug occur.

graingert (tagrain) wrote :

I just booted up Intrepid and I had this error after 20minutes of running from CD

For those of you running intrepid, if you could try the follwing that would be great:

1) Please try installing the linux-backports-modules-intrepid package to see if it helps as it contains an updated compat-wireless stack.
2) If that doesn't work, some iwlwifi patches have been marking their way into a few Stable Release Updates for the Intrepid kernel. If you could test the kernel that's in intrepid-proposed that would be great. Make sure linux-backports-modules-intrepid is uninstalled before trying the intrepid-proposed kernel. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Be sure to use "intrepid-proposed" not "hardy-proposed".

Please let us know your results of the above tests. Thanks.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

James Ward (jamesward) wrote :

I just started getting hit by possibly this bug. I have an Intel 5100 AGN. Only when I am using that device do I get kernel panics. It always happens when I put the network under high load. This is happening on intrepid and jaunty (with proposed enabled). I've had to switch back to a PCMCIA 802.11b device. So I'd love for this one to be fixed. Thanks.

Thanks James. Can you also comment if you've tested with linux-backports-modules? If so and the issue remains, can you do one last test of the upstream compat-wireless stack - see item 4 of https://wiki.ubuntu.com/KernelTeam/LinuxWireless . If it remains even after testing the upstream compat-wireless stack, we'll want to try to report this one upstream. Thanks.

James Ward (jamesward) wrote :

I did try linux-backports-modules and that didn't help. I'll give compat-wireless a try and see if that helps. Thanks Leann.

This problem is still not solved!

Hopfully in Ubuntu 9?

Just curious if anyone has tested the more recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/getubuntu/download . You may also want to give the linux-backports-modules-jaunty package a try as it has an updated compat-wireless stack as of master-2009-03-24 - https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.28 . Please let us know your results if you test. Thanks.

Changed in intellinuxwireless:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.