USB mouse/keyboard do no respond after resume from suspend-to-RAM on x86_64 systems with >4GB RAM

Bug #257293 reported by Arindam Nath on 2008-08-12
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
Hardy
Medium
Stefan Bader

Bug Description

Release:
Description: Ubuntu 8.04
Release: 8.04

Version of the package:
linux:
  Installed: (none)
  Candidate: 2.6.24.20.22

Expected Result:
USB mouse and keyboard should work normally after resume from suspend-to-RAM.

Actual Result:
USB mouse and keyboard do not respond after resume from suspend-to-RAM.

Steps to reproduce:
1. Install Ubuntu 8.04 64-bit.
2. Update to latest development kernel.
3. Reboot into the newly installed kernel.
4. Do S3 by typing "pm-suspend" from command line, or click "System->Quit->Suspend" from GUI.
5. System goes to sleep.
6. Press power button, and system resumes from sleep.
7. USB mouse/keyboard do not respond.

Arindam Nath (arindam-nath) wrote :
Arindam Nath (arindam-nath) wrote :
Arindam Nath (arindam-nath) wrote :
Arindam Nath (arindam-nath) wrote :
Arindam Nath (arindam-nath) wrote :

The GART should be reinitialized with aperture base address, and aperture size after resume from S3. The patch provides the necessary functionality. After applying this patch, USB mouse and keyboard work normally after resume from S3 with >4GB RAM on x86_64 systems.

Nick Ellery (nick.ellery) wrote :

Confirmed, as a patch has been attached.

Changed in linux:
status: New → Confirmed
Stefan Bader (smb) wrote :

There is a test kernel in my PPA on https://launchpad.net/~stefan-bader-canonical/+archive that contains those patches. Could you try that one and verify it fixes this problem? Thanks.

Changed in linux:
assignee: nobody → stefan-bader-canonical
status: Confirmed → In Progress
Stefan Bader (smb) wrote :

Fix is in 2.6.27-rc1 upstream.

Changed in linux:
importance: Undecided → Medium
milestone: none → intrepid-alpha-5
Stefan Bader (smb) on 2008-08-20
Changed in linux:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → In Progress
Arindam Nath (arindam-nath) wrote :

I have verified suspend-to-RAM and hibernate with kernel-image-2.6.24-21-generic_2.6.24-21.40smb3_amd64.deb and it works fine, both from console and GUI. Thanks.

Stefan Bader (smb) wrote :

SRU Justification:

Impact: The GART code is missing suspend resume support which means, certain
setup steps will not be performed after resume which can cause memory
corruption in the worst case.

Fix: The fix is done in two steps (following upstream): first this add suspend
and resume callbacks and then it adds the necessary code to set up the
registers after a suspend.

Testcase: See bug report.

Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Franck (alci) wrote :

I am using kernel package 2.6.27-2-generic in Intrepid (latest) and have the same problem: after resume from suspend, keyboard and mouse don't respond when asked for my password. Only way out I found was "hard" shut down...

Arindam Nath (arindam-nath) wrote :

Verified with Intrepid Ibex 8.10 Alpha5. Suspend-to-RAM works fine with < and >=4GB RAM on x86_64 systems. Thanks.

Franck (alci) wrote :

Works for me too with latest Intrepid (as of 2008/09/10)

Martin Pitt (pitti) wrote :

Whoops, sorry for mis-tagging, the testing happened on the Intrepid package, not the Hardy update (this still needs to be done by someone with the hardware).

Changed in linux:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
hara (harak-iitm) wrote :

I am on Intrepid RC... Still got the problem... working on a HP tx2500 laptop

miaviator278 (stormesi) wrote :

Yet another ubuntu bug that goes on for months with no comment. The solution on a desktop is to unplug the keyboard and plug it in again. That doesn't work so well for me. My laptop does not seem to have a usb cord coming from the keyboard.

uname -a
Linux peaktpalinjrd 2.6.27-11-generic #1 SMP Fri Dec 19 16:29:35 UTC 2008 x86_64 GNU/Linux

miaviator278 (stormesi) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers