Ubuntu

ata3: COMRESET failed (errno=-16)

Reported by perfran on 2008-08-10
80
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Debian)
Expired
Unknown
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by D2

Bug Description

At bootup I end up in busybox and I see the following message on the top of the screen "Gave up waiting for root device"
Actually I think that my hard drive "falls asleep" just after leaving grub. When I'm in the busybox I need to unplug my hard drive (serial ata) and to plug it again so that I can hear that it's restarting. After doing that I type exit in the busybox and the boot process restarts normally.
Dmesg shows me that:

[ 9.672007] ata3: link is slow to respond, please be patient (ready=0)
[ 14.320007] ata3: COMRESET failed (errno=-16)
[ 19.680006] ata3: link is slow to respond, please be patient (ready=0)
[ 24.328007] ata3: COMRESET failed (errno=-16)
[ 29.688007] ata3: link is slow to respond, please be patient (ready=0)
[ 59.092004] ata3: COMRESET failed (errno=-16)
[ 59.092004] ata3: limiting SATA link speed to 1.5 Gbps
[ 59.688009] ata3: SATA link down (SStatus 0 SControl 310)
[ 60.164017] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 60.196367] ata4.00: HPA detected: current 160834367, native 160836480
[ 60.196371] ata4.00: ATA-6: HDS722580VLSA80, V32OA6MA, max UDMA/100
[ 60.196373] ata4.00: 160834367 sectors, multi 16: LBA48

The COMRESET thing continues as far as I don't unplug and plug again my hard drive.

I'm not sure this bug concerns only Ubuntu because I tried recently other distributions with the same kernel and I get the same error (Debian and pmagic liveCD) So I think this bug is concerning the kernel 2.6.26 but I don't know how to report this bug upstream.
I also have to tell you that it's a SATA II hard drive (3gbps) on a (nforce 3) SATA I controller (1.5gbps). And it appears that the controller does not fully support the hard drive (or the SATA I retro-compatibility of the hard drive is malfunctioning I don't know) But with older kernel it did always work without any problem.

I'm running intrepid ibex up-to-date, kernel 2.6.26-5-generic
Please tell me if I should attach the entire dmesg or anything.
Thanks

Benjamin Drung (bdrung) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies Thanks in advance!

Changed in linux:
status: New → Incomplete
perfran (perfran) wrote :

uname -a :
Linux intrepid 2.6.26-5-generic #1 SMP Sun Aug 3 01:25:54 UTC 2008 i686 GNU/Linux
(AMD 64 3400+)

perfran (perfran) wrote :
perfran (perfran) wrote :
Benjamin Drung (bdrung) on 2008-08-11
Changed in linux:
status: Incomplete → New
Changed in linux:
status: Unknown → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

perfran (perfran) wrote :

the issue appears in both 2.6.26 and 2.6.27

Changed in linux:
status: Confirmed → In Progress
Changed in linux:
status: In Progress → Fix Released

From the upstream bug report, it looks like a patch has been isolated and making it's way into the mainline kernel. I'm reassigning this to the kernel team to try to get this patch merged prior to Intrepid's final release. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Colin King (colin-king) wrote :

From my understanding, this was fixed by commit 2fd673ecf0378ddeeeb87b3605e50212e0c0ddc6 and is now in the latest Intrepid kernel. Can you retest this for me and let me know if it has resolved the problem?

Thanks, Colin

perfran (perfran) wrote :

Yes I updated to the latest kernel and the fix works.
Thanks

Stefan Bader (smb) wrote :

Fix was included in Ubuntu-2.6.27-3.4

Changed in linux:
status: Triaged → Fix Released
Lanoxx (lanoxx) wrote :

I belive I am experiencing a similar bug on hardy 8.04.1:
Everytime i suspend and restart i get an error like this:
[timestamp] ata3: soft reset failed (device not ready)
[timestamp] ata3: COMRESET failed (errno=-16)

then the pc hangs for approx. 15-20 sec and resumes like normal.

Here is is additional info:
uname -a
Linux mars 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux
cat /proc/version
Linux version 2.6.24-19-generic (buildd@king) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Wed Aug 20 17:53:40 UTC 2008

perfran (perfran) wrote :

I did a fresh install of intrepid beta today with kernel 2.6.27-4 and everything was working fine.
But when I upgraded to kernel 2.6.27-7 I had again the bug described above though the fix was released and worked until now.
Here's the dmesg with kernel 2.6.27-7. I will test now if this happens with 2.6.27-6 that is still in the repo.

Changed in linux:
status: Fix Released → New
perfran (perfran) wrote :

this bug happens again with recent update to 2.6.27-7 after the beta (2.6.27-4)

perfran (perfran) wrote :

It happens already in 2.6.27-6
Has the patch provided upstream been removed?

Changed in linux:
status: Fix Released → Confirmed
Marcel Ibes (mibes-avaya) wrote :

I can confirm that I experience the same behavior with Intrepid kernels newer than: 2.6.27-4.

"ata2: COMRESET failed (errno=-16)" on kernels: 2.6.27-5 and 2.6.27-7.

The last kernel that boots fine is:

uname -a

  Linux silver-shark 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64 GNU/Linux

Please let me know if you need more information.

Brett Johnson (brett-d-b-s) wrote :

I can confirm the above posts. I tried both the stock kernel in Intrepid as well as the server version. Problem occurred prior to patch in 2.6.27-4 and then reverted and has occurred in all kernel releases since. Machine problem was seen on is using a 72 GB Raptor (10k rpm) drive. I fear this will cause issues with the coming Intrepid release as if the above is true, anyone with a SATA II drive on a SATA I controller is going to have a non-functional install out the box.

Can we get a status update on fixing? I can and will provide any additional details asked for - I think the above has pretty much summed it up though.

Lanoxx (lanoxx) wrote :

As of today 28.10.2008 the bug is still present after the latest updates have been made.
Im on Kubuntu 8.04.1

It is still there with the release version of server amd64

Peter Klotz (peter-klotz) wrote :

Ubuntu 8.10 amd64:

Very similar situation here using a SATA DVD writer (HL-DT-ST DVDRAM GSA-T50N) in an Asus B50A notebook:

[ 621.408096] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 621.408120] ata2.00: cmd a0/00:00:00:08:00/00:00:00:00:00/a0 tag 0 pio 16392 in
[ 621.408123] cdb 4a 01 00 00 10 00 00 00 08 00 00 00 00 00 00 00
[ 621.408125] res 40/00:03:00:fe:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 621.408132] ata2.00: status: { DRDY }
[ 621.408143] ata2: hard resetting link
[ 626.768099] ata2: link is slow to respond, please be patient (ready=0)
[ 631.416089] ata2: COMRESET failed (errno=-16)
[ 631.416107] ata2: hard resetting link
[ 636.776077] ata2: link is slow to respond, please be patient (ready=0)
[ 641.424093] ata2: COMRESET failed (errno=-16)
[ 641.424111] ata2: hard resetting link
[ 646.785044] ata2: link is slow to respond, please be patient (ready=0)
[ 676.464101] ata2: COMRESET failed (errno=-16)
[ 676.464122] ata2: limiting SATA link speed to 1.5 Gbps
[ 676.464128] ata2: hard resetting link
[ 681.488077] ata2: COMRESET failed (errno=-16)
[ 681.488095] ata2: reset failed, giving up
[ 681.488100] ata2.00: disabled
[ 681.488145] ata2: EH complete

This problem also occurs in 2.6.27-4 but with a much lower frequency than in 2.6.27-7.

The HDD connected to the other SATA port works fine. The hardware is Intel based.

Peter Klotz (peter-klotz) wrote :
joren (joren) wrote :

This bug also occurs here. This is my configuration:

Promise Fasttrack tx4310 SATA I PCI controller with three SATA II disks.

I am using Ubuntu 8.10 server:

Linux hostname 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
Linux version 2.6.27-7-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Tue Nov 4 19:33:20 UTC 2008

The error looks similar:

[ 6555.536167] ata1: hard resetting link
[ 6561.300083] ata1: link is slow to respond, please be patient (ready=-19)
[ 6590.588083] ata1: COMRESET failed (errno=-16)
[ 6590.588161] ata1: limiting SATA link speed to 1.5 Gbps
[ 6590.588185] ata1: hard resetting link
[ 6595.624080] ata1: COMRESET failed (errno=-16)
[ 6595.624156] ata1: reset failed, giving up
[ 6595.624213] ata1: EH complete
[ 6871.218398] EXT3-fs error (device sda1): ext3_find_entry: reading directory #30466049 offset 0
[ 6871.238934] EXT3-fs error (device sda1): ext3_find_entry: reading directory #30466049 offset 0

Changed in linux:
status: New → Triaged
Andy Whitcroft (apw) on 2008-11-25
Changed in linux:
assignee: ubuntu-kernel-team → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

A new fix for reset handling has been committed in the latest Intrepid kernel, 2.6.26-10.20 as released into -proposed. If you are able to test that kernel to see if this is fixed for you that would be very helpful.

Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Peter Klotz (peter-klotz) wrote :

The problem still occurs in 2.6.27-10.20 (SATA DVD Drive):

user@host:~$ uname -a
Linux host 2.6.27-10-generic #1 SMP Fri Nov 21 19:19:18 UTC 2008 x86_64 GNU/Linux

[ 1029.427799] UDF-fs: Partition marked readonly; forcing readonly mount
[ 1029.476928] UDF-fs INFO UDF: Mounting volume 'UDF Volume', timestamp 2008/01/21 21:00 (103c)
[ 1115.628122] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 1115.628146] ata2.00: cmd a0/01:00:00:00:08/00:00:00:00:00/a0 tag 0 dma 2048 in
[ 1115.628149] cdb 28 00 00 00 01 86 00 00 01 00 00 00 00 00 00 00
[ 1115.628152] res 40/00:03:00:fe:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 1115.628159] ata2.00: status: { DRDY }
[ 1115.628169] ata2: hard resetting link
[ 1120.988131] ata2: link is slow to respond, please be patient (ready=0)
[ 1125.636081] ata2: COMRESET failed (errno=-16)
[ 1125.636098] ata2: hard resetting link
[ 1130.996083] ata2: link is slow to respond, please be patient (ready=0)
[ 1135.644076] ata2: COMRESET failed (errno=-16)
[ 1135.644093] ata2: hard resetting link
[ 1141.004075] ata2: link is slow to respond, please be patient (ready=0)
[ 1170.684080] ata2: COMRESET failed (errno=-16)
[ 1170.684098] ata2: limiting SATA link speed to 1.5 Gbps
[ 1170.684104] ata2: hard resetting link
[ 1175.708079] ata2: COMRESET failed (errno=-16)
[ 1175.708094] ata2: reset failed, giving up
[ 1175.708100] ata2.00: disabled
[ 1175.708124] ata2: EH complete
[ 1175.708184] sr 1:0:0:0: [sr0] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK
[ 1175.708194] end_request: I/O error, dev sr0, sector 1560
[ 1175.709616] VFS: busy inodes on changed media.

awi (a-w-kinnunen) wrote :

I can confirm,

$ uname -r
2.6.27-10-generic

[ 18.960022] ata6: link is slow to respond, please be patient (ready=0)
[ 23.608020] ata6: COMRESET failed (errno=-16)
[ 28.968016] ata6: link is slow to respond, please be patient (ready=0)
[ 33.616020] ata6: COMRESET failed (errno=-16)
[ 38.976019] ata6: link is slow to respond, please be patient (ready=0)
[ 68.660021] ata6: COMRESET failed (errno=-16)
[ 68.660068] ata6: limiting SATA link speed to 1.5 Gbps
[ 73.684018] ata6: COMRESET failed (errno=-16)
[ 73.684062] ata6: reset failed, giving up
[ 73.684114] ata6: hard resetting link
[ 79.044019] ata6: link is slow to respond, please be patient (ready=0)
[ 83.692018] ata6: COMRESET failed (errno=-16)
[ 83.692062] ata6: hard resetting link
[ 84.012025] ata6: SATA link down (SStatus 0 SControl 310)
[ 84.012032] ata6: EH complete

plugging of drive works. Nforce-3 here too. Drive is barracude 7200.8, which is same age as chipset so sata-I i believe...

Andy Whitcroft (apw) wrote :

@Peter Klotz, @awi -- those must be different controllers from those quirked in the patches applied. Could we get the lspci -vv output and the dmidecode output for these systems attached to the bug please.

@perfran -- could you let me know if your system is now working with the 2.6.27-10.20 kernel, thanks.

Peter Klotz (peter-klotz) wrote :
Peter Klotz (peter-klotz) wrote :
awi (a-w-kinnunen) wrote :
awi (a-w-kinnunen) wrote :
Andy Whitcroft (apw) wrote :

@Peter Klotz -- your problems seem to be related to a different chipset than the original reporter here, and for which the fixes on this bug are targetted. So I guess we should not be supprised if you are not helped by the test kernel. Can you get the exact messages you see when the boot fails, I am wondering if your problem is more like that reported in bug #290153, so it would be useful to confirm which of these two your symptoms are close too.

@awi -- as yours was not fixed by these changes it would be good to get your particular card and that failure reported upstream in the main bugzilla entry at the top of this bug.

Peter Klotz (peter-klotz) wrote :

@Andy: I am not so sure, my problem is related to bug #290153.

My HDD is not affected by this freeze issue, only my SATA DVD drive.

The DVD drive spins up properly but after spinning down the restart results in a freeze. Since the drive works under Windows I would rule out a hardware problem.

Crimson_Fox (crimson-fox-) wrote :

New kernel does not fix this problem for me. I have to use 2.6.24-19 on my server to even boot off my raid 1.

Crimson_Fox (crimson-fox-) wrote :

Just upgraded to 2.6.27-4-server, no problems. Unable to boot from 2.6.27-10-server.

Adam Sterner (adam-kratta) wrote :

I have the same problem here.

Adam Sterner (adam-kratta) wrote :

Same problem with linux mint, not with linux mint's live CD though, just when it's installed. The problem occurs with the Ubuntu Live CD except when I let the keyboard settings stay at US English, if I try to change it to swedish before boot the comreset failed-thing happens.

sym_zo (jehan) wrote :

I still have the same problem with the latest Intrepid server and generic kernel as of today. I am in the same situation as Crimson Fox, unable to even boot my computer.

Like the others, my error messages are about "COMRESET failed (errno=-16)" until it times out.

2.6.27-11-generic didn't fix this.

Charles Profitt (cprofitt) wrote :

Here are the dmidecode outputs for my unit as well. My laptop is a recently purchased ASUS X83Vm-X1. I will attach the lspci below.

I did not suffer with this on an HP I had to return, but I do not know if it was using a SATA DVD Drive or not.

Charles Profitt (cprofitt) wrote :

lscpi output.

Peter Klotz (peter-klotz) wrote :

@PrivateVoid: Does your Asus Notebook come with a HL-DT-ST GSA-T50N SATA DVD drive? (Run command "sudo hdparm -I /dev/sr0" to obtain this information)

I had a discussion about mine (Asus B50A Notebook) on the linux-ide mailing list. They came to the conclusion that the problem I am seeing is a firmware issue of my SATA DVD drive.

See this thread for reference:

http://marc.info/?l=linux-ide&m=123036943617718&w=2

My drive uses firmware revision RR04 and I am currently in the process of trying to obtain an update from Asus. The manufacturer Hitachi LG Data Storage does not provide any firmware updates for its drives (http://www.hlds.co.jp/e_HLDS/faq.jsp).

Charles Profitt (cprofitt) wrote :

Peter:

My drive is an HL-DT-ST DVDRAM GSA-T50L with a SR04 firmware.

This just sucks... I have gone through three notebooks (two HPs with bad LCDs and this one) trying to get a new notebook... and I am growing tired of the carp.

Peter Klotz (peter-klotz) wrote :

@PrivateVoid:

You can try disabling AHCI in your BIOS. Maybe this fixes the problem. Change setting "Advanced"|"IDE Configuration"|"SATA Operation Mode" from "Enhanced" to "Compatible".
However if you have a parallel installation of Windows XP (made in AHCI mode) this will no longer boot.

You may also post to linux-ide to confirm the suspicion of a firmware issue.

If it is really a firmware issue then become an Asus Member (http://member.asus.com/) and file a request like I did. Maybe the more people complain about this issue the higher the chances that Asus reacts.

Charles Profitt (cprofitt) wrote :

Peter:

I ended up with other system instabilities (lock ups, etc) and ended up returning the laptop.

Charles Profitt (cprofitt) wrote :

As a side note I used 8.04, 8.10 and Fedora 10 liveCDs and had the problem.

volker (h345) wrote :

thanks Peter for your tip to disable AHCI on my laptop. (Thinkpad T61p running 2.6.24-23-rt Ubunutu-Studio)
Wakeup after supsend doesnt show COMRESET error anymore and and 30 sec pause before login window disappeared. Now even wlan is up again after suspend

Volker

Superklaus (klaus-muelheims) wrote :

Hi,
I have the same problem with kernel
    Linux mausi 2.6.27-11-generic #1 SMP Thu Jan 15 11:03:58 UTC 2009 i686 GNU/Linux
In 95% when I tried to boot, I got the above mentioned COMRESET failed (errno:-16).
Then, I tried to boot with an old PCI Sata Card with Sil3112-Chipset and.... everything works fine.
After that, I tried the all_generic_ide parameter with the build-in controller (nforce4) and it works too!
So here's my conclusion about this problem:
The sata_nv-driver used by kernel 2.6.27-11 has definetly a problem with some hd-drives like mine.

Greetings

Klaus

PS: Look at http://ubuntuforums.org/showthread.php?p=6585877#post6585877

Andy Whitcroft (apw) wrote :

@Suoerklaus -- could you attach the full dmesg output for a failing boot and also lspci -nnvv.

Superklaus (klaus-muelheims) wrote :

Hi Andy,

here's my dmesg output

Superklaus (klaus-muelheims) wrote :

... and here my lspci

I hope, this can help you.

Greetings

Klaus

I believe I have this issue with my Ubuntu 8.10 install. I dont remember exactly when I first experienced it, but it was probably sometimes late 2008. It seems that its somewhat random whether it will occur or not during boot. Attaching the files mentioned above in the hope that it will help you sort out this issue.

$ uname -a
Linux parelius 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

And here is the other log file.

George Mason (george-porthall) wrote :
Download full text (4.1 KiB)

I am also experiencing this bug on Ubuntu Hardy running on SATA disks. Below is an output of the errors (seem to be intermittent - didn't have them for some time and it's occurred twice today, resolved usually by rebooting - apps freeze and am unable to shut down normally):

[ 130.366078] ata1.00: exception Emask 0x10 SAct 0x1 SErr 0x400101 action 0x2 frozen
[ 130.366084] ata1.00: irq_stat 0x08000000, interface fatal error
[ 130.366087] ata1: SError: { RecovData UnrecovData Handshk }
[ 130.366094] ata1.00: cmd 61/30:00:87:f6:24/00:00:0f:00:00/40 tag 0 ncq 24576 out
[ 130.366095] res 40/00:04:87:f6:24/00:00:0f:00:00/40 Emask 0x10 (ATA bus error)
[ 130.366098] ata1.00: status: { DRDY }
[ 130.675177] ata1: soft resetting link
[ 130.839834] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 130.840883] ata1.00: configured for UDMA/133
[ 130.840894] ata1: EH complete
[ 130.841233] sd 0:0:0:0: [sda] 490234752 512-byte hardware sectors (251000 MB)
[ 130.841335] sd 0:0:0:0: [sda] Write Protect is off
[ 130.841339] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 130.860367] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 149.383870] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
[ 199.709149] ata1.00: exception Emask 0x10 SAct 0x1 SErr 0x400101 action 0x2 frozen
[ 199.709156] ata1.00: irq_stat 0x08000000, interface fatal error
[ 199.709160] ata1: SError: { RecovData UnrecovData Handshk }
[ 199.709166] ata1.00: cmd 61/18:00:97:58:a7/00:00:00:00:00/40 tag 0 ncq 12288 out
[ 199.709167] res 40/00:04:97:58:a7/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
[ 199.709171] ata1.00: status: { DRDY }
[ 200.019966] ata1: soft resetting link
[ 200.183626] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 200.184688] ata1.00: configured for UDMA/133
[ 200.184699] ata1: EH complete
[ 200.184983] sd 0:0:0:0: [sda] 490234752 512-byte hardware sectors (251000 MB)
[ 200.185075] sd 0:0:0:0: [sda] Write Protect is off
[ 200.185078] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 200.185345] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 200.186162] ata1: limiting SATA link speed to 1.5 Gbps
[ 200.186167] ata1.00: exception Emask 0x10 SAct 0x1 SErr 0x400100 action 0x6 frozen
[ 200.186171] ata1.00: irq_stat 0x08000000, interface fatal error
[ 200.186175] ata1: SError: { UnrecovData Handshk }
[ 200.186180] ata1.00: cmd 61/98:00:7f:47:00/00:00:00:00:00/40 tag 0 ncq 77824 out
[ 200.186182] res 40/00:04:7f:47:00/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
[ 200.186185] ata1.00: status: { DRDY }
[ 200.186192] ata1: hard resetting link
[ 205.915454] ata1: port is slow to respond, please be patient (Status 0x80)
[ 210.219315] ata1: COMRESET failed (errno=-16)
[ 210.219323] ata1: hard resetting link
[ 210.537646] ata1: SATA link down (SStatus 0 SControl 310)
[ 210.537655] ata1: failed to recover some devices, retrying in 5 secs
[ 215.531044] ata1: hard resetting link
[ 216.318376] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[ 216.319437] ata1.00: configured for UDMA/133
[ 216.319452] ata1: exception E...

Read more...

awi (a-w-kinnunen) wrote :

I thought I should report, this has been started to work for me a
while ago. I'm using proposed updates, and I'm guessing that it's been
working with maybe with kernel 2.6.27-13, but at least with 2.6.27-14
and 2.6.27-17.

After upgrading 8.04 to 8.10 I've experienced this problem too. Adding "rootdelay=240" in grub's boot menu makes the kernel boot, but the error message was still being reported:

ata4: link is slow to respond, please be patient (ready=0)
ata4: COMRESET failed (errno=-16)
ata4: hard resetting link

The kernel in question is 2.6.27-11-server. I had to make 2.6.24-23-server my default kernel for now, until this bug is fixed.

Does anybody have the information whether this bug is fixed in Jaunty (2.6.28.11.13 kernel, at the moment) or not?

I'm attaching outputs of dmesg, lspci -vv, lshw and dmidecode), in case someone needs that data.

Thanks,
Milan

I was having this problem with 2.6.27-11-generic, but since upgrading to 2.6.27-14-generic out of intrepid-proposed, it is fixed.

Mike of the Nile (aws910) wrote :

Noticed that this had gone quiet but it's the error I now get. I had this problem with 2.6.28-13-generic on 9.04. My symptom was this: I would get the COMRESET message that everyone else gets, then the filesystem(ext3) would be automatically remounted as read-only. Eventually it wouldn't mount, citing "bad superblock". It worked under a previous kernel(the last RT) but switching back to that kernel didn't help either.

Since I didn't have any more time to throw at this, I did the quick-fix:

edit /boot/grub/menu.lst

find the "kernel" line of the in-use kernel.

add " noapic nosmp" to the end of the line.

Save, restart, pray.

Hope this helps someone. Not sure if smp and apic really boost the speed of a system in the way that anyone would notice, though.

Newmeph (fabianndres) wrote :

yup, yup I was on the same problem ! but i found a different way to fix ... until now it works :) i just run the install disk of my (ubuntu) actually is gadalinex because is on spanish >,< (i'm from mexico) well ... i use the install disk, then i used the option for run for the primary disk...so it works !! ok ok before it happens i choose an option that said something to check for mistakes or something like that ...
i wonder what really happend ...for me the error was the same above ..errno#16 etc >.< if somebody can explain me something i really apreciate it .. i don't know how to include the attachment of the error (were to find it) or what should i know to discribe the whole error ...
 for me (i'm trying to fix the boot with "edit /boot/grub/menu.lst") the descriptions above doesn't work >.< so thanks anywere

Kev (ukev) wrote :
Download full text (3.2 KiB)

Hi, I can confirm the bug on a fresh installed ubuntu server (9.04).

Linux ubuntu 2.6.28-15-server #49-Ubuntu SMP Tue Aug 18 19:30:06 UTC 2009 i686 GNU/Linux

It's on a Via VT6421 based S-ATA/P-ATA raid controller for PCI.
(Kon Delock Control 70873)

It's not usable (no /dev/sdX for the devices connected to the controller).

CPU: model name : AMD Athlon(tm) XP 2000+

Here is the dmesg output:

[ 2.072243] input: Macintosh mouse button emulation as /devices/virtual/input/input3
[ 2.072285] Driver 'sd' needs updating - please use bus_type methods
[ 2.072298] Driver 'sr' needs updating - please use bus_type methods
[ 2.072469] sata_via 0000:00:06.0: version 2.4
[ 2.072498] sata_via 0000:00:06.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 2.072609] sata_via 0000:00:06.0: routed to hard irq line 5
[ 2.072815] scsi0 : sata_via
[ 2.072965] scsi1 : sata_via
[ 2.073060] scsi2 : sata_via
[ 2.073112] ata1: SATA max UDMA/133 port i16@0xd800 bmdma 0xc800 irq 17
[ 2.073117] ata2: SATA max UDMA/133 port i16@0xd400 bmdma 0xc808 irq 17
[ 2.073120] ata3: PATA max UDMA/133 port i16@0xd000 bmdma 0xc810 irq 17
[ 7.460011] ata1: link is slow to respond, please be patient (ready=0)
[ 12.080011] ata1: COMRESET failed (errno=-16)
[ 17.470011] ata1: link is slow to respond, please be patient (ready=0)
[ 22.090010] ata1: COMRESET failed (errno=-16)
[ 27.480011] ata1: link is slow to respond, please be patient (ready=0)
[ 57.120010] ata1: COMRESET failed (errno=-16)
[ 62.150011] ata1: COMRESET failed (errno=-16)
[ 62.150057] ata1: reset failed, giving up
[ 67.540011] ata2: link is slow to respond, please be patient (ready=0)
[ 72.160011] ata2: COMRESET failed (errno=-16)
[ 77.550011] ata2: link is slow to respond, please be patient (ready=0)
[ 82.170010] ata2: COMRESET failed (errno=-16)
[ 87.560011] ata2: link is slow to respond, please be patient (ready=0)
[ 117.200010] ata2: COMRESET failed (errno=-16)
[ 122.230011] ata2: COMRESET failed (errno=-16)
[ 122.230056] ata2: reset failed, giving up
[ 122.401603] pata_pdc2027x 0000:00:0c.0: version 1.0

lspci (bridge):
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]

lspci -vv (raid controller):
00:06.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
 Subsystem: VIA Technologies, Inc. VT6421 IDE RAID Controller
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32
 Interrupt: pin A routed to IRQ 17
 Region 0: I/O ports at d800 [size=16]
 Region 1: I/O ports at d400 [size=16]
 Region 2: I/O ports at d000 [size=16]
 Region 3: I/O ports at cc00 [size=16]
 Region 4: I/O ports at c800 [size=32]
 Region 5: I/O ports at c400 [size=256]
 Expansion ROM at dffe0000 [disabled] [size=64K]
 Capabilities: [e0] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driv...

Read more...

Martin Albisetti (beuno) wrote :

Same think happening here. HD seems to be wonky since my upgrade to karmic, fsck with all kinds of flags reports nothing of interest.
Attaching logs.

Martin Albisetti (beuno) wrote :
Martin Albisetti (beuno) wrote :
rofthorax (rofthorax) wrote :
Download full text (25.8 KiB)

I get similar errors on a NVidia 750i Motherboard with Pentium D Extreme Edition..
XFX, from whom I got this motherboard have deprecated the kernel and no longer support
the Pentium D Extreme Edition, I have a copy of the kernel flash image if you want
to have a look, and maybe compare it to the new BIOS flash.

I'm using Ubuntu 9.04 32-bit with the additional set of Ubuntu Studio packages,
was trying to run the realtime kernel (most recent), and with almost all my USB devices
disconnected, only PS/2 Keyboard and a USB Mouse. I tried a number of things,
without a clue what would work:

Running CPU in normal 3.73 Ghz mode with 800Mhz DRAM. I have overclockable ram,
BTW.. 4.256 Ghz, with 800Mhz RAM.. 4.256 with 1000Mhz ram. In every case I got errors.
I tried changing the PCI bus latency 32, then 128, then back to 64.. I tried turning
hyper-threading off. I haven't tried turning AHCI off.

I couldn't find the occurence of DRDY in my log files..

 Here is my lshw:
blackmesa
    description: Desktop Computer
    product: MB-750I-72P9
    vendor: nVidia
    version: 1.0
    serial: To Be Filled By O.E.M.
    width: 32 bits
    capabilities: smbios-2.5 dmi-2.5 smp-1.4 smp
    configuration: boot=normal chassis=desktop cpus=2
  *-core
       description: Motherboard
       product: MB-750I-72P9
       physical id: 0
       version: 1.0
       serial: To be filled by O.E.M.
       slot: To Be Filled By O.E.M.
     *-firmware
          description: BIOS
          vendor: American Megatrends Inc.
          physical id: 0
          version: V1.1B2 (10/17/2008)
          size: 64KiB
          capacity: 960KiB
          capabilities: isa pci pnp apm upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
     *-cpu:0
          description: CPU
          product: Intel(R) Pentium(R) D CPU 3.73GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: 15.6.4
          serial: 0000-0F64-0000-0000-0000-0000
          slot: CPU 1
          size: 4266MHz
          width: 64 bits
          clock: 267MHz
          capabilities: boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe x86-64 constant_tsc pebs bts pni dtes64 monitor ds_cpl vmx cid cx16 xtpr pdcm lahf_lm tpr_shadow
          configuration: id=0
        *-cache:0
             description: L1 cache
             physical id: 5
             slot: L1-Cache
             size: 32KiB
             capacity: 32KiB
             capabilities: internal write-back data
        *-cache:1
             description: L2 cache
             physical id: 6
             slot: L2-Cache
             size: 4MiB
             capacity: 4MiB
             capabilities: internal write-back unified
        *-cache:2 DISABLED
             description: L3 cache
             physical id: 7
             slot: L3-Cache
             capabilities: internal
        *-logicalcpu:0
             description: Logical CPU
             physic...

rofthorax (rofthorax) wrote :

BTW I mentioned "kernel flash", I meant BIOS flash..

Richie Ward (richies) wrote :

This problem affects me with 2.6.31-13... I do not have this problem with 2.6.28-15. It is definitely a regression.
I have
Gigabyte GA-P55-US3L Intel P55 (Socket 1156) DDR3 Motherboard

Attached lwhw as above.

pwerspire (tiagofserra) wrote :

i have the same problem with 2.6.31-14-generic and sata controler VT6421

knoobie (g63marty) wrote :

I have AMD Athlon x2 5000+ with nforce 430 chipset.
I use an eSata PCI controller - Silicon Image SiI 3114.
Two drives are connected to the controller, but only one has issue. Problem drive is WD 2TB My book. Not using RAID or SoftRAID. I do not boot from this drive.

Drive mounts ok if it is not plugged in during boot. The drive also goes away after sleep/resume with same error.

MOBO is HP/Asus M2N61-AR. Bios is latest and can see drive no problem. Win 7 also has no issue. Dual booting with Win7 64 bit and Kubuntu 64 bit kernel 2.6.31-15

I filed a bug 491558 which could probably be merged into this one.

sluuut (tsukai) wrote :

I'm having the same issue on Gentoo 2.6.30-r8 with the following hardware: Supermicro AOC-SAT2-MV8 8 port SATA2 software raid controller, 8x 1.5TB Seagate 1,5 TB SAT2 31500341AS. Most of the times it happens on sata port 2 but i believe it also happend on another port. Like earlier mentioned it can happen five times a day, but sometimes it takes 2 weeks to start this error messages (link is slow to respond, please be patient (ready=0), SRST failed (errno=16), limiting sata link speed to 1.5gbps, reset failed, giving up).

Untortunately i cannot add dmsg/pci info easily.

Changed in linux (Debian):
status: Confirmed → In Progress
obit (obit-live) wrote :

i got the same issue on mac book pro 7,1 with lastest stable kernel 2.6.34

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
devsk (funtoos) wrote :

Is this really a corner case bug or is it just the hardware?

I have had this happen to me with 3 different drives and the drives are brand new and they work fine otherwise.

I have checked the cabling and I have the locked SATAII cables. All the drives are SATAII and nothing in the system is 1.5Gbps. So, this is not a legacy drive phenomenon.

Could it be related to NCQ? When I saw these errors on a drive (which is the oldest of the 3), I disabled NCQ on it (set qdepth to 1) and I haven't seen this on that drive ever since.

Can other people having this issue try turning NCQ off and see if it goes away?

Patrick (94bc1052) wrote :

I have the same bug with 2.6.32-23 (Lucid). I'd appreciate very much if someone fixed this, I bought an eSATA drive for performance reasons and its very annoying I can't use it now.

Changed in linux (Ubuntu):
status: In Progress → Triaged
Pablo (itu-pablo) wrote :

I'm having this bug on 10.10 (2.6.35-28-generic).
I'd like to try the suggested NCQ solution but don't know how. Can you point me in the right direction?

Claire GM (nouche03) wrote :

I'm having this bug on 10.10 (2.6.35-28-generic). I get ata 4 SRST failed (errno=-16) etc...
Was working find until I download KDE to have along with Ubuntu but I was not able to boot either one from grub menu. I get the same message. I tried live cd but not able to boot from it, I don't even see my 2 dvd drives from F11 to chose boot. It has been 2 days that I tried to read pages and pages on the web without any real answer. newbie in linux word, please help!

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Changed in linux (Debian):
status: In Progress → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.