realtek RTL8187B wireless card does not work properly. Loss of speed, Range, Reliablity.

Bug #254438 reported by asmerm on 2008-08-03
This bug report is a duplicate of:  Bug #215802: rtl8187 link quality poor. Edit Remove
102
This bug affects 17 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Updated Description :
Linux KarmicLap 2.6.31-12-generic #39-Ubuntu SMP Mon Oct 5 22:08:01 UTC 2009 i686 GNU/Linux
 I386/amd64
Date 10/07/09
Releases affected: Ubuntu 8.10,9.04,9.10beta,9.10 (other distributions as well)
rtl8187b kernel module

possible updated driver source:
http://drivers76.com/drivers/laptops/star1/rtl8187B_linux_26.1052.0225.2009.release.tar.gz

#####################################################

uname -a:Linux plovak 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux

ProblemType: Bug
Architecture: amd64
Date: Sun Aug 3 18:46:33 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
Package: totem-gstreamer 2.22.1-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-19-generic x86_64

asmerm (asmerovski) wrote :
asmerm (asmerovski) wrote :

I reported this bug from totem accidentally, but it does not have any relationships with totem. But this wireless card does not work anyway ;-).

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

asmerm (asmerovski) wrote :

uname -a: Linux chiko 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux

asmerm (asmerovski) wrote :
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

mdshort (mdshort) wrote :

In my desperate attempt to get WPA support for my RTL8187B device, I have updated to 8.10 (which features the new 2.6.27 kernel). However, I regret to inform you that support for the device is extremely slow and unreliable. So unreliable in fact, that I was forced to switch back to the older 2.6.24 kernel featured in 8.04.

I have been able to install the driver hosted at http://www.datanorth.net/~cuervo/rtl8187b/ with very basic WEP only support. So basic in fact, that signal strength is incorrectly reported as very low (when it should be 100%). This bug is very much still present in the 2.6.27 kernel. I am still searching for solutions to this problem.

mdshort (mdshort) wrote :

A few days ago I decided to send an e-mail to Realtek regarding this issue. Today I received a reply containing Linux drivers for the RTL8187b. I have uploaded these drivers, perhaps they will be useful to someone else who needs them.

http://www.sictaar.com/files/rtl8187B_linux_26.1033.0611.2008_LedDefault.tar.gz

I have not personally tested these drivers as of yet.

asmerm (asmerovski) wrote :

Drivers provided from Realtek freeze every 64-bit distro. On 32-bit distros drivers are OK.
However, in 2.6.27 kernel RTL8187B is autodetected (out of box on Ubuntu 8.10). I haven't tested wireless connection, but when wireless networks are available, network manager pops out with message if you want to connect and it has signal strength indicator. Cool!

gertvv (gertvv) wrote :

I use a rtl8187b card (the usb netgear wg111v3) under ubuntu 8.10 (32-bit) with the native driver and can confirm that it has _many_ issues.

Under light use (IM, web browsing, ssh) it is slow, may 'hang' for a couple of seconds and after several minutes or hours it can freeze up completely. Under heavy use it is very unreliable, making DNS lookups impossible for several minutes on end (some apparently less sensitive services may still work) and usually freezing in under half an hour.

If the driver freezes, it may be possible to remove it (modprobe -r), and reload it, after a session restart it may work again. However more often a system restart or even physical disconnect of the device is required.

Pablo (pablo-annetta) wrote :

I have a Laptop Olibook series 500. This laptop has the Wireless Realtek 8187b card. I installed Xubuntu 8.10 in it. And with the native driver, I have the problem that from time to time the network loss packed on the network, so I can not navigate, or event make a ping to my router or others pc. When this happen, I have to but the laptop very close (30 cm) from the router. I didn't tried yet with the driver from above , since I'm still researching how to install it (I'm quite new on Linux ;-) ). If I get to install the Realtek driver or my laptop, I will let you know how this worked. Thanks.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Wireless card is now detected properly, although I have problems connecting with Network Manager (connection breaks every cca 20 seconds), but with ifup I have no probems.

Alex Antão (alexcarlosantao) wrote :

I also have the same problem with my positivo Z896. It has a RTL8187b and I can only browse if I am close to the AP.
Now I am runing Jaunty 9.04 with last updates and also tried ubuntu-backports-modules-jaunty, but the most I got was to browse in the same room. If I change the room I cannot even connect.

I also think that this is a high proirity bug, since a lot of notebooks are shipping with this wireless board...

Gaddar (gaddar) wrote :

The problem persists...
I have a Toshiba Satellite A210-15J which ships with RTL8187B. I can't connect to the same wireless network from the same position as I can connect from XP or Vista.
More annoyingly, most of the time I can conect to the network, but there's no communication between the computer and the router.
What I mean is, Ubuntu can connect to the wifi and the connection icon shows up in the notification area, but when I try to open up a web page or ping the router, all I get is the destination host cannot be reached or similar errors.

Also I agree with Alex. There are many laptops out there that ship with this chipset. This issue should be addressed with priority.

Confirmed here as well. This is a well known issue that does not yet seem to have a proper resolution. Others who follow this bug should keep digging up information and sources for good info and potential drivers.

#Ubuntu-Kernel on Freenode IRC network I have spoken with some of the Kernel team there. The over all explanation is that they are over loaded with more dominating bugs for the next release of Ubuntu. (Karmic 9.10) We need to locate and get more users involved in this to really show its true importance to the linux community.

This bug affects all linux distributions not just Ubuntu the scope of this issue is wide and other distributions may very well contribute to the further development of this chip support. If you use other distributions report the bug to them as well appropriately. The more we talk about it the sooner we will be heard.

That said, work is still in progress. This bug has not gone completely ignored. Albeit 3 releases are up and still not fixed. I have found a potential lead on drivers and if confirmed will be working to pass them along and pushing for them to be added into Lucid Lynx 10.04 LTS as Karmic is in a near frozen state for release. If the drivers are obtained and can be implemented by the end user in other releases then I will try to make them available here:

https://help.ubuntu.com/community/WifiDocs/Device/RealtekRTL8187b

Stefan Bader (smb) on 2009-10-07
summary: - realtek RTL8187B wireless card does not work on toshiba satellite
- A210-15J
+ realtek RTL8187B wireless card does not work reliable

Update, that potential resource has responded, Credit for the find goes to Carl Richell

I have not tested this as of yet. Try at your own risk.

get http://drivers76.com/drivers/laptops/star1/rtl8187B_linux_26.1052.0225.2009.release.tar.gz
tar -xzvf rtl8187B_linux_26.1052.0225.2009.release.tar.gz
sudo apt-get install linux-headers-`uname -r`
cd rtl8187B_linux_26.1052.0225.2009.release
make && sudo make install

After reboot, check if wireless is working. If not you may need to blacklist rtl8187 (the new module is r8187 IIRC).

echo blacklist rtl8187 | sudo tee -a /etc/modprobe.d/rtl8187.conf

description: updated
tags: added: rtl8187b
removed: apport-bug cft-2.6.27 r8169
summary: - realtek RTL8187B wireless card does not work reliable
+ realtek RTL8187B wireless card does not work properly. Loss of speed,
+ Range, Reliablity.
Jonas Schwabe (jonas-schwabe) wrote :

I am unable to compile this driver.
It returns "error: ‘struct net_device’ has no member named ‘hard_start_xmit’"
Are I am doing something wrong, or is it a bug?
Maybe I just need an additionally package...

Nick Howden (24doeway) wrote :

Ref Comment 17: The supplied drivers use the net_device API which has been removed with the shift the the 2.6.31 kernel.

Is a later version of the driver available from Realtek that uses the net_driver_ops structure?

This driver doesn't work anymlore on Lucid with the newest kernel. I have to use the 2.6.31-17-generic kernel for it to work.

What is the proper way to make it work on Lucid, I think it would be a very bad point if there is no way of having a working wifi with this chip since it is quite used on many computers.

lemurid (lemurspam) on 2010-02-25
description: updated
description: updated
lemurid (lemurspam) wrote :

I can confirm reliability issues on 9.10
Copying large files over smb results in ping rising with every second in an arithmetic progression from 1ms to 1500ms in 2 minutes. Speed drops from 1,5Mb/sec to 100kb/sec

2.6.31-19-server #56-Ubuntu SMP Thu Jan 28 03:40:48 UTC 2010 x86_64 GNU/Linux

Barry (barry-k-schulman) wrote :

Gigabyte Q1580L Laptop with RTL8187B won't work at all on 10.04 just says wireless is switched off and there is no way to switch it on

I also have the Realtek Semiconductor Corp. RTL8187 Wireless Adapter and it doesn't works after update to Lucid.

It works in Karmic and in Lucid, using the 2.6.31-21 kernel.

With the 2.6.32-22 and the 2.6.33-02063303 kernel versions it fails and looking to the syslog, it seems to be switched off:

May 3 21:56:20 my-laptop kernel: [ 19.041398] rtl8187: Customer ID is 0x00
May 3 21:56:20 my-laptop kernel: [ 19.041454] Registered led device: rtl8187-phy0::tx
May 3 21:56:20 my-laptop kernel: [ 19.041473] Registered led device: rtl8187-phy0::rx
May 3 21:56:20 my-laptop kernel: [ 19.043255] rtl8187: wireless switch is off

My laptop doesn't have a physical switch to control the wireless device.

I found a kernel bug that could be related to this problem:

https://bugzilla.kernel.org/show_bug.cgi?id=14743

I can't believe it, but today my RTL8187 Wireless Adapter starts to work and connect.
I still have the 2.6.32-22 kernel but now the wireless switch is on.

Anyone know what happened?

It works for me as well. But after some time, it becomes very unreliable. The connection is often dropped and I have a hard time reconnecting to AP. This happens allot of times. I investigated if the AP itself is problematic by connecting other devices to it simultaneously. I found out that my laptop is the only device whose connection is being dropped. I booted using vista and I didn't experience the same problem -- which means that the device driver in ubuntu 10.4 is the one with problems. I'm not using ndiswrapper by the way.

seraph (nandojanuario) wrote :

Medium priority? How can I tell to my friends to use Ubuntu, if they can't use wifi connection? Sounds like a joke say "linux is better, but please, you can only use wifi with windows drivers, ok? Linux native drivers for your card simply doesn't work properly! Be free, use linux (with windows drivers)!" Hardware compatibility must be always a high priority thing! In special for cheap chips like RTL series.

tags: added: kernel-needs-review kernel-net
tags: added: kernel-reviewed
removed: kernel-needs-review

Seems we got some hope, there is a patch that is being tested and reports look promissing for this driver, even on a 64bit machine.

see bug #210852

Changed in linux (Ubuntu):
status: Triaged → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.