No X with current kernel (downgrade fixes it)

Bug #253076 reported by Scott James Remnant (Canonical) on 2008-07-29
104
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned
Intrepid
Critical
Unassigned

Bug Description

With current kernel, unless I boot without "splash", the X server and ttys are unable to display anything but a black screen.

Hardy kernel works fine.

Intel i945, Dell Latitude D420, btw

Changed in linux:
importance: Undecided → Critical

Martin Pitt reported the same problem on his D430

Martin Pitt (pitti) wrote :

I just get red/white stripes, and it seems the boot does not even progress far enough to even attempt to start X. I have to enter my LUKS hard disk password at boot, and typing it blindly doesn't work. Hard to say what's wrong, I'm afraid.

Martin Pitt (pitti) wrote :

Further clarification: With Ctrl+Alt+F1 the pattern of the stripes changes, and there I can actually type in my LUKS password (as in text mode). Boot continues, and eventually X starts up fine.

So this doesn't break X for me, just kills the VTs and breaks usplash.

Martin Pitt (pitti) wrote :

See also bug 249037, which is much closer to the symptoms that I experience. Maybe Scott's issue is the same as well.

Martin Pitt (pitti) wrote :

Also related: bug 189621 and (even more so) bug 246269. Some of those should become duplicates, I think.

For the record, I just booted 2.6.26-5, no change.

Gabriel Ruiz (anakron) wrote :

Hi all!

I was looking when upgrade was running and i saw that when the new kernel is installed, xserver-xorg was deleted without reason. It happen with kernel 2.6.26-3. im upgrading now from 2.6.26-4 to 2.6.26-5 and all looks fine.

Changed in linux:
status: New → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Confirmed → Triaged
jdm64 (jdm64) wrote :

This seems similar to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/258381.
And that is a kernel regression/bug in hrtimer.

Does the boot splash display at all? Or does it go blank when entering graphical mode,
Or lock up (and/or go blank) midway thruough the boot splash.

I regularly build a custom kernel off the latest git tree, and first ran into this problem with 2.6.25.
The bug was fixed in 2.6.27, but that's not going into 8.10.

I tested the patch that disables hrtick and confirm it fixes the problem.

Timo Aaltonen (tjaalton) wrote :

Seems to be fixed in .27-1

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Hi Guys,

I seem to have spammed this report with the call for testing after we've had confirmations that 2.6.27 resolves this. Hopefully the decision to move to 2.6.27 will not need to be reverted. Once the call is made to stick with 2.6.27 we can mark this bug "Fix Released". Thanks.

Steve Langasek (vorlon) on 2008-08-29
Changed in linux:
milestone: none → ubuntu-8.10-beta
Steve Langasek (vorlon) on 2008-09-04
Changed in linux:
status: Triaged → Fix Committed

Flipping this to "Fix Released" per the decision to stick with 2.6.27 - https://lists.ubuntu.com/archives/kernel-team/2008-September/003107.html

Changed in linux:
status: Fix Committed → Fix Released
Nemes Ioan Sorin (nemes-sorin) wrote :

I have 2.6.27 - problem is still here

I do an upgrade from Hardy to Ibex 2 days ago
everything goes fine ...but after the splash for boot loader was gone the black screen step up and won't die.

Please see my last comment on https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/258381 -> xserver errors attached.

So I do a lot of 'tricks' to get back my Gnome but no any chance ( recovery mode, xfix ..etc ).

Yesterday I do an upgrade from CLI, (some 38 packages was on the upgrade list) and today I observed I can't use Ctrl + Alt + F2 to get my CLI interface. A blank screen with an clipping cursor is all I got.

The single place where I can give commands to Ubuntu now is the root console (recovery mode).

My machine : Intel CoreDuo 2 (6mb internal cache), Gygabyte Chipset, PCI Expres X16, ATI RADEON HD 2600 Pro 512Mb RAM, 2GB RAM memory.

the question is if I can recover my installation without reinstalling Ubuntu from CD ( I have a lot of usable things on /opt -> htdocs for example - but I don't have enough space to copy for save all my needed stuff - I can start apache and and I can dump out my databases but there are a lot of other things and too little space so save them all - I know it's a beta software but I can't imagine I can't start Ubuntu in a way or other... ).

Any help appreciated.

Nemes Ioan Sorin (nemes-sorin) wrote :

An other day - an other upgrade ( 117 packages including Xorg ) but the result was the same blank screen.

Greg Frank (greglarious) wrote :

just installed the daily build from 10/11 and the screen is still black. i dont think the status should say fix released.
for the record, i had no problems with several intrepid alpha releases and then updated to alpha 5 and the problem started.
i am using an aopen minipc model mp945.

UPDATE - Problem Solved.

I put the radeonhd video driver and voila ..it works.

But the problem is ..in the court of update-manager ===> Update Manager
must know to choose the right driver - Else, thousand of complains will put
the internet optical fiber on fire around the globe right in the first day
after Ibex launch ( I think the this situation is specific for all HD Radeon
Cards ).

I have an Radeon HD 2600 Pro with 512Mb RAM - so the Update Manager must
know in some way to put the right video driver automatically.

So no downgrade on my case - just the right driver.

2008/10/12 greggler <email address hidden>

> just installed the daily build from 10/11 and the screen is still black. i
> dont think the status should say fix released.
> for the record, i had no problems with several intrepid alpha releases and
> then updated to alpha 5 and the problem started.
> i am using an aopen minipc model mp945.
>
> --
> No X with current kernel (downgrade fixes it)
> https://bugs.launchpad.net/bugs/253076
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Nemes Ioan Sorin

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers