Ubuntu

[Intrepid] GRUB Boot mkdir / rm permission problems

Reported by BC7333 on 2008-07-19
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Following: (copied manually from boot screen so possibly some typo's)

mkdir: cannot create directory '/lib/modules/2.6.26-4-generic/volatile/':read only file system

later..

setting up resolvconf...
rm: cannot remove '/etc/resolvconf/run/interface/wlan0': read only file system

/etc/rcS.d/S07resolvconf: 114: cannot create /etc/resolvconf/run/enable-updates: read only file system

on each boot is having to make kernel modules etc and seems to get stuck with setting up networking.

Intrepid Alpha 2 upgrade from Hardy

Richard Rickwood (rickwookie) wrote :

I'm also getting:

mkdir: cannot create directory '/lib/modules/2.6.26-4-generic/volatile/':read only file system

Also when it states Setting up Networking - it will wait for about a minute or until I press any key before continuing to boot.

Connor Imes (rocket2dmn) wrote :

This afternoon I booted Intrepid after a few days of rest, X couldn't start and dropped me to a TTY. Tried to reconfigure X, found I had a read only filesystem, so I ran fsck and all checked out. My fstab file UUIDs still matched with blkid, so I rebooted and all was well. I saw on your UF post that you tried this a few times already, but I thought I would post my experience here.

You may need to cross reference the contents of fstab to the output of
 sudo blkid

Good luck.

BC7333 (brian-abtrafco) wrote :

>>You may need to cross reference the contents of fstab to the output of
>> sudo blkid

brian@brian-laptop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=7a352281-d258-4f93-ac5d-51a804db599d / ext3 defaults,errors=remount-ro 0 1
# /dev/sda5
UUID=88d97d83-af6a-5553-bd1e-04a503b5e0bb none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
brian@brian-laptop:~$

brian@brian-laptop:~$ sudo blkid
[sudo] password for brian:
/dev/sda1: UUID="7a352281-d258-4f93-ac5d-51a804db599d" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: TYPE="swap" UUID="88d97d83-af6a-5553-bd1e-04a503b5e0bb"

Anything strange here? maybe SEC_TYPE="ext2" TYPE="ext3"

Connor Imes (rocket2dmn) wrote :

No, it looks normal (ext3 is basically ext2 with journaling added - ext3 partitions can be mounted as ext2).

Connor Imes (rocket2dmn) wrote :

Two more things:
1) This bug didn't have a package assigned to it, so I have filed it under "linux" which is for the kernel.
2) For future reference, please don't confirm your own bugs, it is up to others to confirm your bug for you. Since Richard and I both experienced read only file systems, I will leave the bug as Confirmed this time. Though the incarnations of this bug seem to be different, the root cause appears to be the same - the read only file system.
Thanks.

Richard Rickwood (rickwookie) wrote :

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hdb1 :
UUID=7e99f2b0-3c6b-4d5a-bd87-3be01a378ec6 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hdb3 :
UUID=1e9446e3-51cd-4844-8cf2-c935c4e8c6f8 /home ext3 defaults 0 2
# Entry for /dev/hda1 :
UUID=2A8CB0C88CB08FB5 /media/hda1 ntfs-3g defaults,locale=en_GB.UTF-8 0 1
# Entry for /dev/hda2 :
UUID=061CA0C11CA0ACDD /media/hda2 ntfs-3g defaults,locale=en_GB.UTF-8 0 1
# Entry for /dev/hda3 :
UUID=EACC1DC9CC1D90C5 /media/hda3 ntfs-3g defaults,locale=en_GB.UTF-8 0 1
# Entry for /dev/hdb2 :
UUID=08149de0-a883-433e-b3f6-39eca8949d73 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
//192.168.11.2/media /media/nasmedia cifs defaults 0 0

$ sudo blkid
/dev/hda2: TYPE="ntfs" UUID="61CA0C11CA0ACDD" LABEL="Media"
/dev/sda1: UUID="2A8CB0C88CB08FB5" LABEL="System" TYPE="ntfs"
/dev/sda2: UUID="061CA0C11CA0ACDD" LABEL="Media" TYPE="ntfs"
/dev/sda3: UUID="EACC1DC9CC1D90C5" LABEL="Documents" TYPE="ntfs"
/dev/sdb1: UUID="7e99f2b0-3c6b-4d5a-bd87-3be01a378ec6" TYPE="ext3"
/dev/sdb2: TYPE="swap" UUID="08149de0-a883-433e-b3f6-39eca8949d73"
/dev/sdb3: UUID="1e9446e3-51cd-4844-8cf2-c935c4e8c6f8" SEC_TYPE="ext2" TYPE="ext3"

Hmm, what's with the two entries for the same UUID (/dev/hda2 and /dev/sda2) and why are all the ntfs partitions mounted as sdxn and not hdxn? Why am I getting from blkid /dev/hda2 when if I do:
$ ls /dev/hd*
I get:
ls: cannot access /dev/hd*: No such file or directory

I know this is not a help forum, but I wonder if any of this is relevant to the bug of the read only file system.

Ryan Kavanagh (ryanakca) wrote :

Prevents X from starting here as well.

Changed in linux:
importance: Undecided → High

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ryan Kavanagh (ryanakca) wrote :

The 2.6.27 solved the problem here, thanks, please reset to Confirmed if you are still experiencing the problem.

Changed in linux:
status: Confirmed → Fix Released
BC7333 (brian-abtrafco) wrote :

Still getting these messages when booting 2.6.27-1 using recovery boot. Can't boot 2.6.27-2 Fully updated alpha5 as of today.

Changed in linux:
status: Fix Released → Confirmed
BC7333 (brian-abtrafco) wrote :

Still getting these messages when booting 2.6.27-3

Montblanc (montblanc) wrote :
Download full text (3.3 KiB)

I get file system mounted in read only mode even with 2.6.27-7-generic. I still can boot from recovery mode, but my whole system is screwed up. Also, /etc/blkid.tab shows different drives than /etc/fstab. Fixing drive names doesn't resolve it, but screws up drives even more (e.g.: /dev/sda became /dev/sdb, /dev/hdc became permanently /dev/sdc and so on). Please, take a look at http://ubuntuforums.org/showthread.php?p=6020440#post6020440 .
$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

# Entry for /dev/sda3 :
UUID=1aa321e6-1d19-4b2d-9c44-2d0da26039f7 / ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 1
/dev/sdc1 /media/sdc1 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdb1 /media/sdb1 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sda5 /media/sda5 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sda6 /media/sda6 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdb1 /media/sdb1 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdb5 /media/sdb5 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdb6 /media/sdb6 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdb7 /media/sdb7 ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# Entry for /dev/sda7 :
UUID=0e73ad5b-1423-466c-88a9-1446e35bbfc8 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
# Entry for VirtualBox USB Proxy Service
none /proc/bus/usb usbfs devgid=1001,devmode=664 0 0

$ cat /etc/blkid.tab
<device DEVNO="0x0817" TIME="1224779494" UUID="2c6680c9-d431-464c-8023-ea63e898d36e" TYPE="ext3">/dev/sdb7</device>
<device DEVNO="0x0801" TIME="1224779494" UUID="2e9c0865-facf-4307-aecc-e61767f2f8f4" SEC_TYPE="ext2" TYPE="ext3">/dev/sda1</device>
<device DEVNO="0x0811" TIME="1224779494" UUID="fe026414-f57d-48ce-b11d-7255bc637ac6" SEC_TYPE="ext2" TYPE="ext3">/dev/sdb1</device>
<device DEVNO="0x0815" TIME="1224779494" UUID="46c11964-4dfd-4814-80f7-3f46fd26e233" SEC_TYPE="ext2" TYPE="ext3">/dev/sdb5</device>
<device DEVNO="0x0816" TIME="1224779494" UUID="13832e62-1e05-4d76-b4e0-95f93d436413" SEC_TYPE="ext2" TYPE="ext3">/dev/sdb6</device>
<device DEVNO="0x0821" TIME="1224779494" UUID="394b39e9-53f3-4fb0-ac66-b49532c5bf60" SEC_TYPE="ext2" TYPE="ext3" LABEL="Adam">/dev/sdc1</device>
<device DEVNO="0x0825" TIME="1224772288" UUID="46c11964-4dfd-4814-80f7-3f46fd26e233" SEC_TYPE="ext2" TYPE="ext3">/dev/sdc5</device>
<device DEVNO="0x0826" TIME="1224772288" UUID="13832e62-1e05-4d76-b4e0-95f93d436413" SEC_TYPE="ext2" TYPE="ext3">/dev/sdc6</device>
<device DEVNO="0x0827" TIME="1224772288" UUID="2c6680c9-d431-464c-8023-ea63e898d36e" SEC_TYPE="ext2" TYPE="ext3">/dev/sdc7</device>
<device DEVNO="0x0803" TIME="1224848881" UUID="1aa321e6-1d19-4b2d-9c44-2d0da26039f7" TYPE="ext3">/dev/sda3</device>
<device DEVNO="0x0805" TIME="1224779494" UUID="c107ba9f-72f7-43a2-bd1e-37e24550c0ff" TYPE="ext3">/dev/sda5</device>
<device DEV...

Read more...

Montblanc (montblanc) wrote :

File System gets mounted in read only mode with older kernels as well. Upgrade to 8.10 RC made boot hang at half of the process, earlier than before.

Alex Bernea (alex-bernea) wrote :

I don't get this error anymore. I reinstalled Hardy, then upgraded to Intrepid

Montblanc (montblanc) wrote :

A fresh install is not a real solution, but it could let us understand the source of the problem. I'm running Kubuntu for 2 years, when I discovered Dapper, and I sincerely would rather not to reinstall.
What is really strange in this kernel is that it always says "could not find map file", although the file is there. Check your /var/log/messages too. Could this be something important to solve this read only fs problem?

Montblanc (montblanc) wrote :

Please excuse my persistence. Googling around I found that names for IDE and SATA devices were merged since Feisty (/dev/hda being treated as /dev/sda). I got this changes only after upgrading to Intrepid, and I think it's causing more troubles than benefits. I think I've set up every file: /etc/fstab, /etc/blkid.tab, /boot/grub/menu.lst, and /boot/grub/device.map but still no luck with / being mounted as read only file system. hdparm, fsck and badblocks showed no anomaly in every partition. What I really don't understand is WHY linux boots fine from recovery mode but hangs in normal mode. I've even tried setting /etc/fstab as follows

UUID=1aa321e6-1d19-4b2d-9c44-2d0da26039f7 / ext3 rw,relatime 0 1

But it is just like the ro option is being forced by something I don't know anything about, but which doesn't apply in recovery mode.

Thorsten Kunz (sfire) wrote :

I get an error very similar to what others are seeing on a fresh 8.10 Release install on my laptop.
I get this during boot (manually typed so might not be 100% accurate):

[...]
* Setting up resolvconf...
rm: cannot remove `/etc/resolvconf/run/interface/*`: Read-only file system
/etc/rcS.d/S07resolvconf: 116: cannot create /etc/resolvconf/run/enable-updates: Read-only file system
* Setting up the system clock [OK]
[...]

This only happened after I installed the resolvconf package. Before I had no errors during the bootup. Also seems not to have any other ill effects on the system. Gnome and everything else seems to be as usable as before.

Hernando Torque (htorque) wrote :

I'm getting the same warnings as Thorsten Kunz. Fresh 8.10 install.

Brian Harkness (maestro-bwh) wrote :

Ditto here like Thorsten... fine in recovery mode and selecting resume... but not when using regular boot option. What gives?

acacha (sergi-tur) wrote :

More info and how I solved this problem....

At /var/log/messages there is a message That says Cannot find map file

I change to Virtual Console. Entre username an password and I remount root:

 $ sudo mount -o remount,rw /

I recovered network by typing:

 $ sudo dhclient eth0

I do a:

 $ sudo apt-get update
 $ sudo apt-get dist-upgrade
 $ sudo apt-get autoremove

Then I tried

 $ sudo dpkg-reconfigure linux-image2.6.27-7-generic

It gives me an error related with Virtual Box. something like:

 run-parts: executing /etc/kernel/postinst.d/dkms
 * Running DKMS auto installlation service for kernel 2.6.27-7-generic
 * vboxdrv (1.6.2)
 vboxdrv (1.6.2): Installing module
 ........... (bad exit status:10)
 Build failed. Installation Skipped
    [fail]

I remove virtualbox:

 $ sudo apt-get remove --purgue virtualbox

Another time:

 $ sudo dpkg-reconfigure linux-image2.6.27-7-generic

Another error related with virtualbox. I installed VirtualBox again:

 $ sudo apt-get install virtualbox

and:

 $ sudo dpkg-reconfigure linux-image2.6.27-7-generic

Now everything is Ok.

Now I have other problems but the filesystem is mounted rw after reboot.

Some notes I take In catalan:

http://acacha.dyndns.org/mediawiki/index.php/Upgrade/Actualitzaci%C3%B3_a_8.10

I had VirtualBox installed too, and the same DKMS error messages. I removed
VirtualBox without reinstalling it and reconfigured the kernel as you've
done, but it didn't fix the problem. It seems there are troubles with file
systems other than ext3, so I installed Intrepid on another partition. I had
to install grub2 because of the 256 Inode size (Intrepid install finished
with grub error 1) and manually fix drive numbers incorrectly read by grub2.
Now everything seems to work fine, but it's been the hardest upgrade since
Dapper. I should have sticked with LTS releases.

2008/11/18 acacha <email address hidden>

> More info and how I solved this problem....
>
> At /var/log/messages there is a message That says Cannot find map file
>
> I change to Virtual Console. Entre username an password and I remount
> root:
>
> $ sudo mount -o remount,rw /
>
> I recovered network by typing:
>
> $ sudo dhclient eth0
>
> I do a:
>
> $ sudo apt-get update
> $ sudo apt-get dist-upgrade
> $ sudo apt-get autoremove
>
> Then I tried
>
> $ sudo dpkg-reconfigure linux-image2.6.27-7-generic
>
> It gives me an error related with Virtual Box. something like:
>
> run-parts: executing /etc/kernel/postinst.d/dkms
> * Running DKMS auto installlation service for kernel 2.6.27-7-generic
> * vboxdrv (1.6.2)
> vboxdrv (1.6.2): Installing module
> ........... (bad exit status:10)
> Build failed. Installation Skipped
> [fail]
>
> I remove virtualbox:
>
> $ sudo apt-get remove --purgue virtualbox
>
> Another time:
>
> $ sudo dpkg-reconfigure linux-image2.6.27-7-generic
>
> Another error related with virtualbox. I installed VirtualBox again:
>
> $ sudo apt-get install virtualbox
>
> and:
>
> $ sudo dpkg-reconfigure linux-image2.6.27-7-generic
>
> Now everything is Ok.
>
> Now I have other problems but the filesystem is mounted rw after reboot.
>
> Some notes I take In catalan:
>
>
> http://acacha.dyndns.org/mediawiki/index.php/Upgrade/Actualitzaci%C3%B3_a_8.10
>
> --
> [Intrepid] GRUB Boot mkdir / rm permission problems
> https://bugs.launchpad.net/bugs/250189
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
http://pippamentis.wordpress.com

acacha (sergi-tur) wrote :

Weird problem...

My system stills have problems after desinstalling virtualbox a reinstall and reconfiguring kernel too...

The weird think is that sometimes boots up correctly and sometines not. I quit at /boot/grub/menu.lst the quiet option. If during boot I changed to Virtual Consoles: Crtl+Alt+F1 an Ctrl+Alt+F2 the system boots whithout read only problem. But if I boot without doing nothing then I have the read only problem....

I see during boot a problem with mount (It says something like "Note that one no really mount a device....."). I think this is the help message of mount command when you miss some parameters. How can I see the boot messages? is there any log?

acacha (sergi-tur) wrote :

I manage to see where is the mount error.

The problem raised at file /etc/rcS.d/S01mounkernfs.sh. This file calls a function called domount

I put some echo lines to debug and some "read CONTINUE" to stop execution....

It seems theres is and Incorrect use of mount when executing:

 mount -n -t tmpfs -omode=0755,nodev,noexec,nosuid /var/run

and

 mount -n -t usbfs -odevgid=127,devmode=664 -onoexec,nosuid,nodev,devgid=127,devmode=664 /proc/bus/usb

and also

 mount -n -t tmpfs -omode=1777,nodev,noexec,nosuid /var/lock

I all this examples seems that DEVNAME parameter is missing.... I read somewhere that /lib/init/mount-functions.sh has changed the number of parameters....

Then I've gone to /etc/init.d and fount two files mountkernfs:

 mountkernfs.sh

and

 mountkernfs.sh.dpkg-dist

It seems that during upgrading, I say NO to reemplacing my modified mountkernfs.sh file (This modification I think that is related with Virtual Vox if I remember well). I found that at upgrade log:

 $ sudo cat /var/log/dist-upgrade/apt-term.log | grep mount

My solution:

 $ cd /etc/init.d
 $ sudo mv mountkernfs.sh.dpkg-dist mountkernfs.sh

acacha (sergi-tur) wrote :

I also have to change

 $ cd /etc/init.d
 $ sudo mv mountdevsubfs.sh.dpkg-dist mountdevsubhs.sh

Amit Kucheria (amitk) wrote :

It seems this bug was a result of saying 'NO' to change to a modified version of mountkernfs.sh during a dist-upgrade. Can you confirm this?

Marking the bug as Invalid because of it. Please reopen it if you feel the issue is still not addressed. In any case, this bug should be against 'initscripts' rather than the kernel.

If unfortunately it seems this bug is still an issue, can you confirm this issue exists with the most recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/news/ubuntu-9.04-desktop . Please let us know your results. Thanks.

Changed in linux (Ubuntu):
importance: High → Undecided
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers