Ubuntu

Bluetooth mouse does not re-establish connection after reboot

Reported by Steve Langasek on 2008-07-17
114
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Hardy
Medium
Tim Gardner
Intrepid
Undecided
Tim Gardner

Bug Description

Summary:
Bluetooth device connections are not re-established after reboot

Steps to Reproduce:
1) Associate a bluetooth mouse to a system using bluetooth device (PCI ID: 0x0a5c2151)
2) Ensure mouse is now working
3) Reboot system
4) Try to use mouse

Expected result:
All trusted device connections are re-established each time the system is booted

Actual result:
Bluetooth mouse is non-functional until it is deleted from Bluetooth Manager and re-added.

This is a public bug on the kernel package corresponding to the private bug #241749, for SRU tracking.

Steve Langasek (vorlon) on 2008-07-17
Changed in linux:
importance: Undecided → Medium
status: New → In Progress
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Triaged
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
milestone: none → ubuntu-8.04.2
Tim Gardner (timg-tpi) wrote :

Hardy SAUCE patch has been carried forward.

Changed in linux:
status: Triaged → Fix Committed

Changing HIDD_ENABLED from 0 to 1 in /etc/default/bluetooth
makes my mouse reconnect after restart in 8.10 (2.6.27-4).

Brian Watson (vertexoflife) wrote :

This seems to affect more than just bluetooth mice, my Microsoft Wireless Laser Mouse 5000 and Wireless Comfort Keyboard 4000 exhibit the same behavior.

Brian Watson (vertexoflife) wrote :

Nevermind, this is resolved with the latest update.

This is "Fix Released" for Intrepid.

Changed in linux:
status: Fix Committed → Fix Released
Peng Deng (d6g) wrote :

After I upgraded to the latest version (4.12) of bluez/bluez-utils, my bluetooth mouse doesn't automatically reconnect anymore after reboot. I have to remove it from "Known devices" in the "Bluetooth Preferences" dialog and re-establish the connection using the "Setup new device" wizard.

Since there is no more hidd command in the system, I suppose it won't make sense to write the HIDD_ENABLED=1 in the file /etc/default/bluetooth, which has also been replaced during the upgrade with a new but simpler version where there is no such a line for hidd. (I actually tried this, but it did work)

I know this report has been tagged as "Fix Released" and I am not sure if I should open a new one for my problem.

----------------------

Package: bluez
Priority: optional
Section: admin
Installed-Size: 1228
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Version: 4.12-0ubuntu2
Replaces: bluez-audio, bluez-input, bluez-network, bluez-serial, bluez-utils (<= 4.9)
Depends: libbluetooth3 (>= 4.9), libc6 (>= 2.4), libdbus-1-3 (>= 1.1.1), libglib2.0-0 (>= 2.14.0), libnl1, libusb-0.1-4 (>= 2:0.1.12), module-init-tools, makedev | udev, lsb-base, dbus

Package: bluez-utils
Priority: optional
Section: admin
Installed-Size: 56
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: all
Source: bluez
Version: 4.12-0ubuntu2
Depends: bluetooth

Stephen Young (scy-stephen) wrote :

I'm having this problem in Intrepid right now with bluez 4.12-0ubuntu2. After a reboot, or coming back from a suspend, I must delete the mouse from know devices list and then add it again.

Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
Peng Deng (d6g) on 2008-10-14
Changed in linux:
status: Fix Released → Confirmed
James Schriver (dashua) wrote :

sudo apt-get install bluez-input

That did the trick for me constantly losing my Microsoft 5000 Bluetooth Notebook Mouse upon every reboot, suspend, screensaver, etc.

2.6.27-7-generic

Dell XPS m1530 Internal Bluetooth.

Stephen Young (scy-stephen) wrote :

I already have the bluez-input package installed so that's not the problem here.

Peng Deng (d6g) wrote :

dashua, I've already had this package installed. Even after I tried reinstalled it, the situation is the same as before, connection losts after reboot, suspend, idle.

BTW, my mouse is also MS Bluetooth 5000, is yours working now?

James Schriver (dashua) wrote :

Peng,

Yes, it is working flawlessly. Wasn't working until I installed bluez-input.

Here's my /etc/default/bluetooth :

# Defaults for bluez

# start bluetooth on boot?
# compatibility note: If this variable is not found bluetooth will
# start
BLUETOOTH_ENABLED=1

# This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
# you will have bluetooth functionality from your dongle instead of only HID.
# Note that not every bluetooth dongle is capable of switching back to HID
# mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
HID2HCI_ENABLED=1
HID2HCI_UNDO=1

James Schriver (dashua) wrote :

Peng,

Once you have the mouse connected Click the blue "i" in a circle under preferences.

Peng Deng (d6g) wrote :

dashua, thanks for your follow-up.

By "blue 'i'" , I suppose you meant the button in the middle, because I use a different icon theme, it is actually a "start". I clicked it to toggle the icon to the right of the device name on and off, but either way the connection won't re-establish.

My /etc/default/bluetooth looks exactly the same as yours. Would you mind posting other configuration files like /etc/bluetooth/hcid.conf, /etc/bluetooth/main.conf and /etc/bluetooth/input.conf? Thanks a lot.

James Schriver (dashua) wrote :

Peng,

/etc/bluetooth/main.conf :

# Defaults for bluez

[General]

# List of plugins that should not be loaded on bluetoothd startup
#DisablePlugins = network,input

# Default adaper name
# %h - substituted for hostname
# %d - substituted for adapter id
Name = %h-%d

# Default device class. Only the major and minor device class bits are
# considered
Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
DiscoverableTimeout = 0

# Use some other page timeout than the controller default one
# (16384 = 10 seconds)
PageTimeout = 8192

# Behaviour for Adapter.SetProperty("mode", "off")
# Possible values: "DevDown", "NoScan" (default)
OffMode = NoScan

# Discover scheduler interval used in Adapter.DiscoverDevices
# The value is in seconds. Defaults is 0 to use controller scheduler
DiscoverSchedulerInterval = 0

/etc/bluetooth/input.conf :

# Configuration file for the input service

# This section contains options which are not specific to any
# particular interface
[General]

# Set idle timeout (in minutes) before the connection will
# be disconnect (defaults to 0 for no timeout)
#IdleTimeout=30

The other files are not present.

James Schriver (dashua) wrote :
Peng Deng (d6g) wrote :

Thanks dashua, my config files look the same as yours, and I have tried re-installing all the bluetooth related packages but the problem still exists. But I noticed 2 things that may not be normal:

1. When I did "sudo dpkg-reconfigure bluez", I got several messages saying something like devices cannot be created in /dev/ due to read-only file system. Please see attached dpkg.txt

2. After reboot/suspend, I lost the bluetooth connection, but if at this point I open the bluetooth preferences dialog and change the visibility setting (either from Hidden to Always visible or vise versa), the connection establishes again. But no matter I keep this setting as Hidden or Always visible, after reboot/suspend, the connection gets lost again.
dmesg output is in the attached file dmesg.txt

Peng Deng (d6g) wrote :
Peng Deng (d6g) wrote :

Today after upgrade, the bluez-input is no longer in the repository, so I removed it. And this doesn't have any affect to the situation. Mouse still can get detected if I switched the visibility setting but not re-connect automatically. Therefore I guess the problem may not be related to bluez-input package.

mike (thefannings) wrote :

I have the same problem with Microsoft Intellimouse explorer for bluetooth.

Mike

shiversc (shiversc) wrote :

Same problem for me. My mouse "Microsoft Wireless Laser Mouse 8000" don't connect automatically after reboot!

William Stone III (wrs) wrote :

I can report the same behavior with slight variations.

The OS is Intrepid 64-bit. Installation was new rather than an upgrade from Hardy. It was installed yesterday and customized throughout the North American evening and during daylight hours today.

The computer is a Lenovo T61p laptop with built-in Bluetooth adapter. The mouse is a Logitech Travel Mouse correctly identified as "Bluetooth Travel Mouse" under Bluetooth Preferences.

This particular combination of hardware worked correctly under Hardy 32-bit for the two months it was installed after receiving the laptop from my employer. The mouse also worked with an old Gateway laptop with a dongle and with a Dell desktop with a different dongle from the same manufacturer.

Symptoms are extremely similar to others reported: the mouse does not reconnect following a reboot or power off of the mouse, requiring it to be deleted under Bluetooth Preferences and then re-discovered and paired.

The difference, however, is that while the utilities now report the mouse to be paired and it does correctly show under Bluetooth Preferences, mouse movement and button clicks are not being recognized by the OS. While Intrepid reports that it is connected, it behaves as though it is not.

Comparing config files mentioned in this thread show no differences between reported settings and mine.

Peng Deng (d6g) wrote :

I want to correct one part of my previous comment: when the mouse has
lost the connection, seems only switch from Hidden to Always visible
will help it to be detected again. The other way around is not
working. I noticed when it gets connected.

Can anyone of you who also has this problem try to switch the
Visibility Setting in Preference dialog to see if it helps?

Stephen Young (scy-stephen) wrote :

Switching from Hidden to Always visible causes my mouse to reconnect as well. The mouse is Logitech Bluetooth Laser Travel Mouse.

Hi All,

I just wanted to add a comment here. This bug was originally reported for a Broadcom 2046 bluetooth device with vendor and device id of 0x0a5c:0x2151 . As mentioned earlier, the patch for the Broadcom 2046 is already in both the Hardy and Intrepid kernel. If you are experiencing a similar issue but have a different device than what was originally reported you should open a new bug report as it will require a different fix than what was provided for this specific device. In that new report be sure to include the vendor and device id that you do have. You can also add a reference to this report from your new one. Thanks.

Peng Deng (d6g) wrote :

As suggested, a new report (bug #287265) has been opened since my device id is different (0a5c:201e) .

SingerWang (singer-singerwang) wrote :

I have a Microsoft Bluetooth Mouse 8000, and the following Bluetooth Adapter

Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

I pair the device and it works fine; however when I reboot the mouse doesn't work. I have the Bluetooth turned to 'Always visible' and it still doesn't work. I have to turn the power off/on on the mouse to get the computer to see it.

Primož Jerše (primskovich) wrote :

Actually, Device ID is mouse's (spelled correctly?) MAC address, kind of similar to network card's MAC address, meant to find the correct one in a sea of devices. Every device has different one.

I have Dell Inspiron 1525 and a Logitech V470 mouse, the combination of was also affected by this bug.

Switching visibilty to 'Always' on inital device connection made it reconnect on reboot. Worked for days now, I was happy. But since today's updates (2008-10-22) it doesn't work anymore. In fact, it doesn't even show on the device list in bluetooth preferences. Also, the preference screen freezes instantly when i open it and the wizard won't even find my mouse this time.

SingerWang (singer-singerwang) wrote :

I just did an full update; now it doesn't even pickup the mouse even if I turn off/on the mouse. I have to use the applet and click the connect button after turning off/on the mouse. This is driving me crazy.

Pete Graner (pgraner) wrote :

This requires more investigation and we are out of time for the 8.10 GA release. I'm marking the to the intrepid-updates milestone so we can get it in the first post GA update.

Changed in linux:
assignee: nobody → timg-tpi
milestone: none → intrepid-updates

I have a generic bluetooth mouse with same problem.
I installed bluez-compat so at least "hidd --search" and pressing the pairing button will get the mouse back.

Added back to /etc/default/bluetooth:
     HIDD_OPTIONS="--master -i 01:01:01:01:01:52 --server"

as worked in Hardy, but doesn't in Intrepid.

kszys (ksocha) wrote :

My MS Bluetooth Mouse 5000 also stoped working. Everything was fine until a reboot today. It no longer works. What is interesting, after removing and re-adding it to the bluetooth applet, it reports "successful device configuration". But it still does not work.

Togather with the problem of detecting a touchpad on my Dell E6400, Intrepid is becoming almost unusable :(

kszys.

Pconfig (thomas9999) wrote :

Does setting the Visibility setting to always visible help for anyone? It worked for me..

> Once you have the mouse connected Click the blue "i" in a circle under preferences.

What is that supposed to do? It toggles the blue 'info' icon in the device list, but there is no hint as to what that should achieve. I'd expect it to display info, but it doesn't.

> Does setting the Visibility setting to always visible help for anyone? It worked for me..

Yes! At least in combination with other things. Thanks.

Primož Jerše (primskovich) wrote :

Yes, i think it works too - i mean mouse reconnects now, just don't know what fixed it.

For those of you who doens't work. Try removing device and then before you readded it, move the visibility to always. Reboot and then change it back to hidden.

Long shot i know, but it's pretty painfull to do it manually after every reboot.

Peng Deng (d6g) wrote :

As Leann mentioned earlier, this bug was originally reported against the device with Id 0a5c:2151, if your bluetooth adapter has a different vendor Id, please file another bug report. There is already a report (Bug #285007) about the same issue with device 0a5c:201e, if you have the same device, maybe posting your comment there is a better solution. Or at least please include your bluetooth adapter id with your comment (using command: lsusb | grep -i bluetooth)

Jens Janssen (jayjay) wrote :

Here same problem with my device with ID 03f0:171d (HP Bluetooth Module (Broadcom) on HP 6715b Laptop).

Alex Karpenko (alexkarpenko) wrote :

My rocketfish bluetooth mouse also wouldn't reconnect on reboot on a clean installed Intrepid. Selecting "Always visible" fixed this problem. I did not install or change anything else.

André Colomb (acolomb) wrote :

Reported another adapter (USB ID 0a5c:2145 in a ThinkPad T400) in bug #292239.

Morten Højer (morten-alvor) wrote :

I'm experiencing exactly the same with my adapter and Targus bluetooth mouse. The adapter is reported as ID 0b05:b700 and it's apparently a broadcom BT-253 device. It sits in an ASUS eee 901.

First the mouse wouldn't reconnect at all. Then I followed the advice here to set bluez to "always visible" and reboot. This helped: My mouse now reconnects, but ONLY if I wait turning it on until everything's started. If I accidentally leave the mouse on during boot, there is no hope of getting it to work. Even if I restart /etc/init.d/bluetooth

Handssolow (handssolow) wrote :

With both avahi packages removed (avahi-daemon and avahi-autoipd) after reboots I'm getting a higher success connecting to my M/S Bluetooth 5000v1.0 mouse without having to trash and reinstall the mouse on my Acer Aspire One running 8.10 from a USB stick. Wifi working with Madwifi driver and Intrepid's driver disabled.

Does anyone else experience this?

use_linux (compu73rg33k) wrote :

I was experiencing this problem with 64 bit Intrepid on an Acer Aspire 9300 with a Microsoft Bluetooth Notebook Mouse 5000.

Turning the bluetooth to "always visible" fixed my problem of it not reconnecting after suspend/reboot. If I turn the mouse off and then back on, it takes about 15-20 seconds to reconnect and then it's fine. Thanks for the help.

Peng Deng (d6g) wrote :

With my installation and bluetooth mouse, it is actually not the
setting "visible" that helps the mouse get reconnected, but the action
of switching it from "hidden" to "visible". Every time my mouse loses
connection, I need to do such a switch in bluetooth prefs dialog.

niska (adelaii) wrote :

I have the same problem in intrepid with dell inspiron 1420N and logitech V470.
This doesn't just happen when rebooting but also after turning the mouse of and on, or
after it enters sleep mode if being left alone for a few minutes.

Vadim Tkachuk (vadim-tkachuk) wrote :

I have a Dell XPS1530 and using the Logitech V470 bluetooth mouse. I was experiencing the same problems. Toggling the "always visible" switch fixed the issue.

Jens Janssen (jayjay) wrote :

Same for me: Toggling to "Always visible" when pairing the bluetooth mouse solves the problem. After that i can switch back to "Hidden" without problems.

Muanis (muanis) wrote :

Same here.

Intrepid 8.10, changing visibility to Always Visible then pressing sync on mouse made it connect.

Cedric (c-vanfrachem) wrote :

Here is a workaround that worked for me ( who uses a Logitech Mouse.) But I think it will occur with ANY mouse !

I identified that "hciconfig" reported that hci0 interface was RUNNING but NOT "SCANNING"

I tried "sudo hciconfig hci0 pscan"

Then... it works until reboot.

So I inserted "hciconfig hci0 pscan" into /etc/init.d/bluetooth at the end of the "START) section" (just before the log_end_msg 0)

I guess the problem is that some option is not kept at reboot for hci module (or that I do not know how to specify this option in the appropriate file).

Anyway, now everythng works (mouse reconnects after reboot or after timeout).

Mats Taraldsvik (meastp) wrote :

The last couple of weeks, my bluetooth mouse has reconnected automatically, and it still does.

However, every time I stumble upon this other bug ( https://bugs.launchpad.net/bugs/294972 ), the mouse won't connect after a reboot. The easiest way to fix this for me, is turning the my hardware ( BT + Wireless ) switch off and on.

Dell D830
Logitech V470

saulwilliams (williams-saul) wrote :

hi,
my Dell bluetooth mouse and keyboard were both not connecting automatically following reboot.
I followed Cedric's fix:

"So I inserted "hciconfig hci0 pscan" into /etc/init.d/bluetooth at the end of the "START) section" (just before the log_end_msg 0)"

and now it connects automatically upon rebboting.

thanks Cedric !

saul

calimarno (calimarno) wrote :

Same problem here with a logitech bluetooth mouse on a ThinkPad 43p with Ubuntu Intrepid Ibex 8.10 up-to-date. None of the solutions above worked for me. After rebooting, hciconfig shows that the mouse (type USB ??) is UP and RUNNING...

I just got this bug, too. My Intrepid is up-to-date (-security and -updates); if this has been solved i think it should be placed in -updates, not in proposed.

manolo (mac-man2005) wrote :

I get:

   obex push file transfer unsupported

when trying to receive files from BT, using BT dongle on my ASUS, Intrepid installed. I have tried to receive files from an ACER with Windows Vista, a Nokia N70 mobile phone and also from another ACER using Intrepid, but no luck.

Also trying to receive files from the ACER laptop gives me the same error. No problem while sending files to other devices.

It seems it's a "receiving problem", at least in my case.

Jeff Sereno (jsereno) wrote :

I concur with Cedric's workaround fix - works great, however I notice that on reboot if the Bluetooth device (such as my mouse) already had a "connected" status, Intrepid won't RE-connect to that device until I power-cycle it, then Intrepid picks it up a few seconds later no issues and without needing to reboot again (if Cedric's fix is running). If I reboot and power-cycle my mouse before X starts, the mouse will be available as early as the login screen if I add Cedric's fix to my /etc/rc.local file.

manolo (mac-man2005) wrote :

Is it possible to adapt Cedris's workaround to my case?
To see my case please follow this link:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/249448/comments/56

or just take a look at the third from last post :)

Nathan Reckart (nreckart) wrote :

Cedric's fix worked for me as well, with a small tweak.

My Logitech Cordless MediaBoard Pro would not reconnect after the initial pairing.

I added 'hciconfig hci0 pscan' to /etc/rc.local and all is right with the world again upon reboot. The keyboard/mouse is available at the login screen. Adding it to /etc/init.d/bluetooth didn't work.

Thanks Cedric!

David Nadasi (macrophone) wrote :

Cedric's fix work very well on my VAIO VGN-FW21E with Intrepid and a Logitech laser mouse.

Thanx!!!

manolo (mac-man2005) wrote :

No help for my case?

Cedric's fix works beautifully for me too, although I put it into /etc/rc.local as others. I have HP Compaq 6720s and some Logitech Laser bluetooth mouse. Thanks a lot! I hope this will be fixed in future releases.

Mats Taraldsvik (meastp) wrote :

As I said earlier ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/249448/comments/52 ), my mouse only fails to reconnect.

When it does fail, this always work:

1. Turn off bluetooth mouse
2. Go to bluetooth preferences
3. Set to 'temporary available'
4. turn on bluetooth mouse, wait for it to reconnect
5. set back to 'always visible'

for me 'hciconfig hci0 pscan' didn't work - the tool reported hci0 to be busy, so preceding it with 'hciconfig hci0 restart' solved the problem

Roderick Drew (r-c-drew) wrote :

In Kubuntu and Xubuntu 9.04 (for both 32-bit and 64-bit PCs) I can get my bluetooth mouse and (apple) keyboard working - it being easiest to use the command sudo hidd --connect XX:XX:XX:XX:XX:XX (device MAC number) - though it generally takes several attempts. However, neither ever work on reboot (even after trying the 'hciconfig hci0 pscan' solution suggested here). For the keyboard I always have to remove the battery cover, reinsert it and hit the button on the RHS each time I reboot and so that it can be re-detected. After reboot in version 8.10 both mouse and keyboard always worked. My bluetooth dongle is by Cambridge Silicon Radio, ID 0a12.

Tim Gardner (timg-tpi) wrote :

Intrepid is no longer supported.

Changed in linux (Ubuntu Intrepid):
importance: Medium → Undecided
milestone: intrepid-updates → none
status: Confirmed → Won't Fix
Changed in linux (Ubuntu):
importance: Medium → Undecided
milestone: intrepid-updates → none
status: Confirmed → Won't Fix
Steve Murphy (murf-parsetree) wrote :

Hmm, looks like this is old as the hills!

I'm running on Ubuntu 13.10 (saucy?), 64 bit.

I've got an HP x4000b Bluetooth mouse.

I'm using an ASUS bluetooth dongle (hci0).

It would appear that the mouse loses its connection
if left sitting around long enough (not sure how long yet),
or if you power down the mouse and power it back up,
or if you reboot.

The hciconfig hci0 pscan doesn't make any difference. nor iscan, nor noscan.

At first, I discovered that if I get into the bluetooth system settings,
I can delete the hp bluetooth mouse, then create a new one , hit the connect
button under the mouse, then go with automatic pin settings, and its back
and running.

I also discovered, that while in in the disconnected state, I can move the mouse
around, and it will occasionally quickly come up as connected for a second or less,
and then lose the connection.

I then discovered that I can (with another mouse) go to the bluetooth setting, select
the hp bluetooth mouse, hit the connect button under the mouse, and then click on the
greyed out ON connection, and it will connect again.

Now, normally, the settings for the hp mouse say "Paired No".

I also have a targus bluetooth mouse, which goes thru batteries about once a week,
and the system has no problems with it. Turn it off, turn it on, it works. It also says
"Paired No".

Any ideas what it will take to get this mouse to reconnect properly?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.