Support for Macbook Air in applesmc

Bug #248238 reported by Henrik Rydberg
4
Affects Status Importance Assigned to Milestone
Mactel Support
Medium
Henrik Rydberg
Debian
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Pete Graner

Bug Description

Binary package hint: linux-image-2.6.24-19-generic

The applesmc module wrongly detects the Macbook Air as a macbook, which does
not have keyboard backlights. Also, the sensor set is wrong. A patch is
attached which

1) makes applesmc detect the macbook air

2) sets up a minimal set of sensors

The sensor set is not complete, and the accelerometer is turned off although present, but at least the keyboard backlight
is activated.

A patch against linux-next has been sent to the maintainer, but is awaiting action.

http://bugzilla.kernel.org/show_bug.cgi?id=10948

Revision history for this message
Henrik Rydberg (rydberg) wrote : pending with maintainer

This patch has been sent to the applesmc maintainer, but is still pending.

Revision history for this message
Nick Ellery (nick.ellery) wrote :

Confirming report, as a patch has been submitted.

Changed in linux:
status: New → Confirmed
Changed in mactel-support:
importance: Undecided → Medium
status: New → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
Revision history for this message
Pete Graner (pgraner) wrote :

Patch is in 2.6.26-5, and works as expected

Changed in linux:
status: Confirmed → Fix Committed
Changed in mactel-support:
status: Confirmed → In Progress
Revision history for this message
Henrik Rydberg (rydberg) wrote :

The v2.6.27-rc4-352-g2085d31 kernel still does not work for the Macbook Air, but this time for a simple reason: the DMI matcher list has the Macbook Air in the wrong place. A patch has been commited.

Changed in mactel-support:
assignee: nobody → rydberg
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in linux:
status: Fix Committed → In Progress
Revision history for this message
Henrik Rydberg (rydberg) wrote :

I am not sure what status the bug should have, given that a fix appeared in 2.6.26-5, which did not fully solve the problem. The following patch was sent to kernel-team a couple of days ago, and takes care of the rest of the problem.

Revision history for this message
Henrik Rydberg (rydberg) wrote :

I tested this again today on Ubuntu-2.6.27-3.4, and the problem remains, and the provided patch from 20080905 still applies. It is really a tiny tiny bug which only requires reordering of two list items. Maybe this one was held back by my tagging the bug incorrectly? Please apply, the original problem has had a solution since 20080713 :-)

Changed in linux:
status: In Progress → Fix Committed
Changed in linux:
status: Fix Committed → In Progress
Revision history for this message
Henrik Rydberg (rydberg) wrote :

As part of a larger patch set to applesmc, a patch for this problem is now in Andrew's -mm tree:

http://userweb.kernel.org/~akpm/mmotm/broken-out/hwmon-applesmc-add-support-for-macbook-air.patch

Changed in mactel-support:
status: In Progress → Fix Committed
Changed in linux:
status: In Progress → Fix Committed
Revision history for this message
Henrik Rydberg (rydberg) wrote :

Present in 2.6.27-7

Changed in mactel-support:
status: Fix Committed → Fix Released
Revision history for this message
Henrik Rydberg (rydberg) wrote :

Present in 2.6.27-7

Changed in linux:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in debian:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.