linux-headers package description refers to non-existent debian.README.gz

Bug #248214 reported by Reuben Thomas on 2008-07-13
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

linux-headers-2.6.24-19's description says: "Please read
/usr/share/doc/linux-headers-2.6.24-19/debian.README.gz for details", but there is no such file.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 13 21:10:36 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: linux-headers-2.6.24-19 2.6.24-19.34
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/sbin:/usr/sbin:/usr/local/epocemx/bin:/home/username/bin:/home/username/local/i686/bin:/home/username/local/bin:/home/username/.luarocks/bin:/home/username/Work/Adsensus/svn/nancy/trunk:/home/username/Work/Adsensus/svn/adsensus/trunk:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
SourcePackage: linux
Uname: Linux 2.6.24-19-generic i686

Reuben Thomas (rrt) wrote :
Changed in linux:
importance: Undecided → Wishlist
status: New → Triaged
importance: Wishlist → Low

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Reuben Thomas (rrt) wrote :

This bug is hardly something that requires my installing the package to test: you can verify it by (quick) inspection of the package description and list of files installed by the package.

Reuben Thomas (rrt) wrote :

OK, I checked and the bug is still present. The package descriptions of both linux-headers-2.6.27-1 and linux-headers-2.6.27-1-generic say:

"Please read /usr/share/doc/linux-headers-2.6.27-1/debian.README.gz for details."

This file is not installed by either package.

tags: added: kj-omit
Changed in linux (Ubuntu):
status: Triaged → Invalid
Reuben Thomas (rrt) wrote :

The bug report says that debian.README.gz is missing. The directory listing in #5 shows no debian.README.gz. (In any case, shouldn't it be called README.Debian.gz?)

Changed in linux (Ubuntu):
status: Invalid → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 248214

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: hardy
tags: added: bot-stop-nagging trusty

Confirmed in Trusty from Synaptic:
This is for sites that want the latest kernel headers. Please read /usr/share/doc/linux-headers-3.12.0-7/debian.README.gz for details.

At a terminal:
usr/share/doc/linux-headers-3.12.0-7$ dir
changelog.Debian.gz copyright

lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

Changed in linux (Ubuntu):
status: Incomplete → Triaged
summary: - Package description refers to non-existent file
+ linux-headers package description refers to non-existent
+ debian.README.gz
Reuben Thomas (rrt) wrote :

It's not so much that I'm unable to run the command, it's that it's pointless, as any human can see. Sorry, Automated Script!

lemasle lennaick (lennaick) wrote :

$ apt-cache policy linux-headers-3.13.0-65-generic linux-headers-3.13.0-65-generic:
  Installé : 3.13.0-65.106
  Candidat : 3.13.0-65.106
 Table de version :
 *** 3.13.0-65.106 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache show linux-headers-3.13.0-65-generic
Package: linux-headers-3.13.0-65-generic
Priority: optional
Section: devel
Installed-Size: 13119
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Source: linux
Version: 3.13.0-65.106
Provides: linux-headers, linux-headers-3.0
Depends: linux-headers-3.13.0-65, libc6 (>= 2.14)
Filename: pool/main/l/linux/linux-headers-3.13.0-65-generic_3.13.0-65.106_amd64.deb
Size: 700432
MD5sum: 614db704d1640ef60793168b9de24ef0
SHA1: 7121a09e5e9a69838ebfe8ba2d8a0539167129fa
SHA256: ee8b6ce1b853058e6f452cc273d380e71c6fcad0f1e59b948d8c14d33e493004
Description-en: Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
 This package provides kernel header files for version 3.13.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-3.13.0-65/debian.README.gz for details.
Description-md5: d41f4c88b55bc4123e3520c328c4e8e6
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

$ ls -la /usr/share/doc/linux-headers-3.13.0-65/debian.README.gz
ls: impossible d'accéder à /usr/share/doc/linux-headers-3.13.0-65/debian.README.gz: Aucun fichier ou dossier de ce type

$ ls -la /usr/share/doc/linux-headers-3.13.0-65/total 92
drwxr-xr-x 2 root root 4096 oct. 6 13:45 .
drwxr-xr-x 1924 root root 69632 oct. 17 14:42 ..
-rw-r--r-- 1 root root 10139 oct. 3 02:28 changelog.Debian.gz
-rw-r--r-- 1 root root 1292 oct. 3 00:11 copyright

$ zless /usr/share/doc/linux-headers-3.13.0-65/debian.README.gzgzip: /usr/share/doc/linux-headers-3.13.0-65/debian.README.gz: No such file or directory
/usr/share/doc/linux-headers-3.13.0-65/debian.README.gz: Aucun fichier ou dossier de ce type

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers