SiS 190/191 on ASUS P5SD2-VM dont detect link status / dont send traffic

Bug #247889 reported by Leandro Oliveira on 2008-07-12
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Bryan Wu

Bug Description

SRU Justification:

Impact: This bug causes SiS 190/191 on ASUS P5SD2-VM does not detect link status
and does not send traffic

Fix: This patch that is upstream since 2.6.28 (and is contained in Jaunty)

Testcase: Make sure that SiS 190/191 detects link status and sends traffic

---

I have a motherboard ASUS P5SD2-VM (E3464) with SIS968 chipset and SIS190/191 10/100 ethernet controler. Using ubuntu 8.04.1-server (kernel 2.6.24-9) this device is found by kernel but dont send trafic.

Clables and connections are checked and orange led indicating 100Mbps are on.

What to do? it´s a problem with some configuration or is a driver problem?

more information:

 uname -a
 Linux ubuntu 2.6.24-19-server #1 SMP Wed Jun 18 15:18:00 UTC 2008 i686 GNU/Linux

 modproble sis190 && dmes | tail -n 11
[ 259.833889] sis190: no version for "struct_module" found: kernel tainted.
[ 259.834785] sis190 Gigabit Ethernet driver 1.2 loaded.
[ 259.834823] ACPI: PCI Interrupt 0000:00:04.0[A] -> GSI 19 (level, low) -> IRQ 21
[ 259.834837] PCI: Setting latency timer of device 0000:00:04.0 to 64
[ 259.834846] 0000:00:04.0: Read MAC address from EEPROM
[ 259.834847] 0000:00:04.0: Error EEPROM read 0.
[ 259.834850] 0000:00:04.0: Read MAC address from APC.
[ 259.952632] 0000:00:04.0: Unknown PHY trans at address 0x1 phy->id[0]= 0x4d phy->id[1]=0xd021.
[ 261.310970] 0000:00:04.0: SiS 191 PCI Gigabit Ethernet adapter at f920ac00 (IRQ: 21), 00:1e:8c:a9:f9:9d
[ 261.310974] eth0: GMII mode.
[ 261.310977] eth0: Enabling Auto-negotiation.

 /sbin/ifconfig eth0
 eth0 Link encap:Ethernet HWaddr 00:1e:8c:a9:f9:9d
          inet addr:xxx.xxx.xxx.xxx Bcast:xxx.xxx.xxx.255 Mask:255.255.255.0
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:300 (300.0 B) TX bytes:0 (0.0 B)
          Interrupt:21 Base address:0xdead
note: pc recieves packets but dont send.

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Current message level: 0x00000037 (55)
        Link detected: no
note: Link detected: no

lshw -C network
  *-network:0
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:1e:8c:a9:f9:9d
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.2 duplex=full ip=xxx.xxx.xxx.xxx latency=0 link=no module=sis190 multicast=yes port=MII speed=100MB/s

mii-diag eth0 --force
Basic registers of MII PHY #0: ffff ffff ffff ffff ffff ffff ffff ffff.
  No MII transceiver present!.
 The autonegotiated capability is 03e0.
The autonegotiated media type is 100baseTx-FD.
 Basic mode control register 0xffff: Auto-negotiation enabled.
  Internal Collision-Test enabled!
  Restarted auto-negotiation in progress!
  Transceiver isolated from the MII!
  Transceiver powered down!
  Transceiver in loopback mode!
  Transceiver currently being reset!
 Basic mode status register 0xffff ... ffff.
   Link status: established.
 Remote fault detected!
   *** Link Jabber! ***
 Your link partner advertised ffff: Flow-control 100baseT4 100baseTx-FD 100baseTx 10baseT-FD 10baseT, w/ 802.3X flow control.
   End of basic transceiver information.

NixMan (kobusvdb) wrote :

Here is some more info that hopefully helps speedy resolution.

Got hold of a Mandriva 2008.0 DVD [2.6.22.9-1mdv-1-1mdv2008.0] and guess what : it has a problem with the SiS 771/671 graphics card but sees the SiS191 NIC no problem !!!

Connected to the internet via LAN router like a dream !!! Fortunately the latest Linux drivers for the m/b from the ASUS website sorted the display problem.

So, also having the source RPMs on the DVD, we thought our problems with Ubuntu would be solved !!! WROONNNGGG !!!

Using the sis190.c from the Mandriva DVD and compiling it on Ubuntu 8.04LTS makes ABSOLUTELY NO difference.

So we thought the problem could be in mii.ko, but also using the source from the DVD and compiling it on Ubuntu also makes NO difference.

So Ubuntu 8.04 LTS seems a lot more 'broken' than what meets the eye !!!

With ethtool, we interestingly also noted that under Mandriva the interface is indicated as PHYAD : 1 while under Ubuntu it's shown as PHYAD : 0.
Seems most likely that Ubuntu misidentifies and then tries to talk to a non-existent interface !!!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

pablomme (pablomme) wrote :

From somebody else's post at https://answers.launchpad.net/ubuntu/+question/38994 , I've attached a patch here that solves the problem, tested on another ASUS P5SD2-VM motherboard.

Latest 2.6.27 kernels dont solve the problem.

Hum.... applying that patch is easy.

Compiling the kernel, is another story on that flavour.

pablomme (pablomme) wrote :

If I understand correctly from an email notification I've received, Francois Romieu from the kernel bugzilla has committed the fix upstream.

It would be nice to see this patch in the initial Ubuntu Intrepid release on October the 30th. Would this be possible?

This is my current sis190.c file and it works.

I compiled my kernel with "fakeroot make-kpkg", had some difficult steps and I had to remove the ParaVirtualisation and GFS options but it works.

Hi Guys,

The patch referenced here has made it upstream. Unfortunately it is too late to squeeze this in prior to Intrepid's final release as the kernel is currently frozen. I've add an Intrepid nomination though and we'll try to get this in as an SRU - https://wiki.ubuntu.com/StableReleaseUpdates . I've pasted the upstream git commit id below for the kernel team to reference. Thanks.

ogasawara@yoji:~/linux-2.6$ git log 708f6e27c3f75166433b69174a8348308e55d073

commit 708f6e27c3f75166433b69174a8348308e55d073

Author: Francois Romieu <email address hidden>

Date: Mon Oct 20 23:37:55 2008 +0200

    sis190: add identifier for Atheros AR8021 PHY

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
pablomme (pablomme) wrote :

This sounds like a good case to bypass the freeze, since
(a) it's a one-liner,
(b) it's hardware-specific,
(c) these motherboards are fairly new -> number of people affected will increase substantially if not fixed, and
(d) it's been merged upstream.
However the criteria in https://wiki.ubuntu.com/StableReleaseUpdates seem to disagree...

Leann, thanks very much for making the case for this bugfix, whatever the outcome.

Changed in linux:
milestone: none → intrepid-updates
pablomme (pablomme) wrote :

Quick question: the patch committed upstream went into which kernel version (the x in 2.6.27.x)?

Another: I'm trying to see from http://kernel.ubuntu.com/git what changes are coming in the next intrepid-proposed kernel -- where does the proposed kernel come from? Is it ubuntu/ubuntu-intrepid.git?

pablomme (pablomme) wrote :

Answering myself: 2.6.28-rc1..

On Thu, Nov 27, 2008 at 02:16:11AM -0000, pablomme wrote:

> Another: I'm trying to see from http://kernel.ubuntu.com/git what
> changes are coming in the next intrepid-proposed kernel -- where does
> the proposed kernel come from? Is it ubuntu/ubuntu-intrepid.git?

Yes the master branch on that repository represents the currently
approved contents of the next -proposed kernel. Tags in that repository
give you the previous releases.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Who will care then?

Bryan Wu (cooloney) wrote :

Since Jaunty is 2.6.28, i think this issue was fixed in Jaunty release. And the patch is very simple for back-porting to Intrepid and Hardy. I will do this soon.

-Bryan

Changed in linux (Ubuntu Intrepid):
assignee: nobody → cooloney
status: Triaged → In Progress
Bryan Wu (cooloney) on 2009-04-28
Changed in linux (Ubuntu Intrepid):
status: In Progress → Fix Committed
Bryan Wu (cooloney) on 2009-04-28
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Stefan Bader (smb) on 2009-05-13
description: updated
Martin Pitt (pitti) on 2009-06-05
Changed in linux (Ubuntu):
milestone: intrepid-updates → none
Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Hardy):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Beattie (sbeattie) on 2009-06-16
tags: added: hw-specific
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-24.56

---------------
linux (2.6.24-24.56) hardy-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.24-24.54 with 2.6.24-24.55 security release applied

linux (2.6.24-24.54) hardy-proposed; urgency=low

  [Andy Whitcroft]

  * SAUCE: do not make sysdev links for processors which are not booted
    - LP: #295091

  [Brad Figg]

  * SAUCE: Add information to recognize Toshiba Satellite Pro M10 Alps Touchpad
    - LP: #330885
  * SAUCE: Add signatures to airprime driver to support newer Novatel devices
    - LP: #365291

  [Stefan Bader]

  * SAUCE: vgacon: Return the upper half of 512 character fonts
    - LP: #355057

  [Upstream Kernel Changes]

  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #341783, #212485
  * Input: atkbd - mark keyboard as disabled when suspending/unloading
    - LP: #213988
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619
  * sis190: add identifier for Atheros AR8021 PHY
    - LP: #247889
  * bluetooth hid: enable quirk handling for Apple Wireless Keyboards in
    2.6.24
    - LP: #227501
  * nfsd: move callback rpc_client creation into separate thread
    - LP: #253004
  * nfsd4: probe callback channel only once
    - LP: #253004

 -- Stefan Bader <email address hidden> Sat, 20 Jun 2009 00:14:36 +0200

Changed in linux (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-14.41

---------------
linux (2.6.27-14.41) intrepid-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: input: Blacklist digitizers from joydev.c"
    - LP: #300143

linux (2.6.27-14.40) intrepid-proposed; urgency=low

  [ Amit Kucheria ]

  * Disable DEVKMEM for all archs on Intrepid
    - LP: #354221
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Andy Isaacson ]

  * LIRC_PVR150: depends on VIDEO_IVTV
    - LP: #341477
  * SAUCE: FSAM7400: select CHECK_SIGNATURE
    - LP: #341712

  [ Andy Whitcroft ]

  * SAUCE: hotkey quirks for various Zepto Znote and Fujitsu Amilo laptops
    - LP: #330259
  * SAUCE: unusual devs: add an entry for the ScanLogic SL11R-IDE 0.78
    - LP: #336189

  [ Anton Veretenenko ]

  * SAUCE: sony-laptop: add support for Sony Vaio FW series function/media
    keys
    - LP: #307592

  [ Ayaz Abdulla ]

  * SAUCE: forcedeth: msi interrupt fix
    - LP: #288281

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Ike Panhc ]

  * squashfs: correct misspelling
    - LP: #322306
  * SAUCE: Fixing symbol name in HECI module
    - LP: #336549
  * Copy header files for various kernel media driver
    - LP: #322732

  [ Stefan Bader ]

  * SAUCE: vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * SAUCE: input: Blacklist digitizers from joydev.c
    - LP: #300143

  [ Upstream Kernel Changes ]

  * libata: make sure port is thawed when skipping resets
    - LP: #269652
  * x86-64: fix int $0x80 -ENOSYS return
    - LP: #339743
  * rt2x00: Fix race conditions in flag handling
    - LP: #258985
  * USB: cdc-acm: Add another conexant modem to the quirks
    - LP: #323829
  * Bluetooth: Add fine grained mem_flags usage to btusb driver
    - LP: #268502
  * Bluetooth: Handle bulk URBs in btusb driver from notify callback
    - LP: #268502
  * Bluetooth: Submit bulk URBs along with interrupt URBs
    - LP: #268502
  * hwmon: (abituguru3) Match partial DMI board name strings
    - LP: #298798
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619
  * sis190: add identifier for Atheros AR8021 PHY
    - LP: #247889
  * ath9k: implement IO serialization
    - LP: #373034
  * ath9k: AR9280 PCI devices must serialize IO as well
    - LP: #373034
  * acer-wmi: fix regression in backlight detection
    - LP: #333386

 -- Stefan Bader <email address hidden> Wed, 26 Aug 2009 11:48:11 +0200

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments