Ubuntu

Missing Force feedback support in kernel (CONFIG_HID_FF)

Reported by shaggy on 2008-07-09
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Intrepid
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Hi ubuntu kernel maintainers!

There is force feedback support in the linux kernel, lots of gamepads and wheels are supported. But the ubuntu kernel configuration excludes them. CONFIG_HID_FF ist not set.

Its a usefull feature, so please think about activating the feature and drivers in upcoming releases like intrepid.

regards, Sven

Changed in linux-meta:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist
status: New → Triaged
Changed in linux-meta:
importance: Wishlist → Medium

I agree with you. FF isn't work.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

shaggy (slimshaggy) wrote :

The 2.6.27 kernel does not solve this bug, since its configuration (config-2.6.27-2-generic) still has CONFIG_HID_FF not set.

This is my diff to the config file to solve the lack of force feedback support:

< # CONFIG_HID_FF is not set
---
> CONFIG_HID_FF=y
> CONFIG_HID_PID=y
> CONFIG_LOGITECH_FF=y
> CONFIG_LOGIRUMBLEPAD2_FF=y
> CONFIG_PANTHERLORD_FF=y
> CONFIG_THRUSTMASTER_FF=y
> CONFIG_ZEROPLUS_FF=y

shaggy (slimshaggy) wrote :

If there is any information needed to proceed with this bug, i'd be happy to help with it.

From my point of view this is a minor change with no risc of breaking something in the kernel. 4 days left until feature freeze. Time is running and i feel that its totally unnecessary to protract this to the next release.

BSA (b-s-a) wrote :

Intrepid is out, but CONFIG_HID_FF is not enabled, so kernel has not force feedback support.
Please enable it.

Steve Conklin (sconklin) on 2008-11-28
Changed in linux:
assignee: ubuntu-kernel-team → sconklin
status: Triaged → In Progress
Steve Conklin (sconklin) wrote :

I've added these options to a test kernel based on intrepid. The test kernel is located here:

http://people.ubuntu.com/~sconklin/246952/

Please test this and see if it resolves the problem.

Thanks!

Tschaka (stuff4tschaka) wrote :

i gave your test kernel a try, and force feedback works with my logitech rumblepad 2.
tested rumble with fftest (google for "fftest.c") and i could make my gamepad rumble with running ./fftest /dev/input/event3 as root and entering one of the numbers 0,4 and 5 there. would be nice to see this soon as default in ubuntu.

thanks for your effort!

Tim Gardner (timg-tpi) wrote :

Force feedback is experimental in 2.6.27, and as such, is not eligible for an SRU. It is, however, enabled by default in 2.6.28 (Jaunty).

Changed in linux-meta:
status: New → Invalid
Changed in linux:
status: New → Won't Fix
assignee: sconklin → nobody
status: In Progress → Fix Released
Changed in linux-meta:
status: New → Invalid
sergio (sergio-tarsiero) wrote :

Tim,

it seems that after the upgrade to jaunty, yet i can't use my logitech formula force ex force feedback. i tested it on some wine games. the wheel is correctly recognized, some games let me set ff on, but it doesn't work..

BSA (b-s-a) wrote :

sergio, please install ff-utils and test forcefeedback natively
please provide lsusb and evtest (may be need to compile from sources) output

sergio (sergio-tarsiero) wrote :

ask you pointed out, i've performed some tests you'll find in the attachment.
shortly, lsusb tells me i have the wheel in bus2, device2 (mapped in dev/input/js0).
force feedback has been mapped in /dev/input/event7. performing fftest i found some "invalid arguments". effectively, trying any tipe of effect, my wheel remains sadly inplace.

please help me...

BSA (b-s-a) wrote :

sergio, all looks fine.

This output:

Device /dev/input/event7 opened
Axes query:
Effects: Constant
Number of simultaneous effects: 16
Upload effects[0]: Invalid argument
Upload effects[2]: Invalid argument
Upload effects[3]: Invalid argument
Upload effects[4]: Invalid argument
Upload effects[5]: Invalid argument

Means that you have only constant effect, so you need test option number 1 only. But you try 2 and 3 which are not supported. Also you can run ffcfstress program which should change feedback on your wheel periodically.
Current kernel has no support for autocentering configuration for your wheel (and G25, which has same ID in legacy mode). In future versions it may be added. I send patch to kernel dev team soon.

sergio (sergio-tarsiero) wrote :

thank you.
as you wrote me, i tried option 1.
it tells me

---------------------
noi@noi-pc:~/Scrivania/ff-utils/ff-utils$ ./fftest /dev/input/event7
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Device /dev/input/event7 opened
Axes query:
Effects: Constant
Number of simultaneous effects: 16
Upload effects[0]: Invalid argument
Upload effects[2]: Invalid argument
Upload effects[3]: Invalid argument
Upload effects[4]: Invalid argument
Upload effects[5]: Invalid argument
Enter effect number, -1 to exit
1
Now Playing: Constant Force
Enter effect number, -1 to exit
2
Now Playing: Spring Condition
Enter effect number, -1 to exit
4
Now Playing: Strong Rumble
Enter effect number, -1 to exit
15
No such effect
Enter effect number, -1 to exit
9
No such effect
Enter effect number, -1 to exit
5
Now Playing: Weak Rumble
Enter effect number, -1 to exit

------

effectively, i expected to see ff effects on the wheel, but they don't appear at all.
the work perfectly on win.

what can be wrong?

BSA (b-s-a) wrote :

sergio
Current kernel driver for your wheel does not support autocentering manipulation. So you cannot see any effect from constant force (but if you run ffcstress, it is possible wheel changes centering force for one of sides). If you know how to recompile hid-logitech kernel module, then you can modify sources by hand (drivers/hid/hid-lgff.c): replacing line "{ 0x046d, 0xc294, ff_joystick }," by "{ 0x046d, 0xc294, ff_wheel },", then you need to recompile module hid-logitech.ko, unload old module and load new.
Kernel developers already apply my patch for this wheel, so next stable kernel (2.6.30, I think) will be has autocenetring for your wheel. Current kernel driver only supports autocenetring for Logitech MOMO Racing wheel.

quequotion (quequotion) wrote :

Is there a cohesive list of the gamepads/manufacturers supported by this module?
I have an Elcom PS2 controller adapter that supposedly provides rumble support in windows (I don't have a windows pc with games to test this on) but it gets no output in Ubuntu... The device has several other problems, mostly due to shoddy and cheap manufacturing, so I can't really tell if the problem is the hardware or the software.

Szymon Stasik (ciekawy) wrote :

I have the same problem with Formula Force EX as sergio - ff_test returns "invalid argument" for all effects but #1

I've tried 2.6.31.12 and 2.6.32.16 with same results. I've checked in the sources that line mentioned by BSA is already updated to ff_wheel

ASLok (fst-mail) wrote :

I have Genius Wheel 3 MT with force feedback, but ff dont working for me :( This problem in kernel settings, or with drivers, or with my configs?
I have this output:

[aslok@3r]2011.01.18-13:32:42:~$ lsusb | grep Rock
Bus 002 Device 025: ID 0583:b003 Padix Co., Ltd (Rockfire)
[aslok@3r]2011.01.18-13:32:54:~$ lsmod | egrep '^(joy|if|usbh)'
iforce 19840 0
joydev 11395 0
usbhid 42062 0
[aslok@3r]2011.01.18-13:32:55:~$ fftest /dev/input/event8
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Device /dev/input/event8 opened
Axes query:
Effects:
Number of simultaneous effects: 0
Upload effects[0]: Function not implemented
Upload effects[1]: Function not implemented
Upload effects[2]: Function not implemented
Upload effects[3]: Function not implemented
Upload effects[4]: Function not implemented
Upload effects[5]: Function not implemented
Enter effect number, -1 to exit
0
Now Playing: Sine vibration
Enter effect number, -1 to exit
-1
No such effect
[aslok@3r]2011.01.18-13:33:07:~$

BSA (b-s-a) wrote :

Please disconnect joystick, connect again. And post ouput of 'dmesg | tail -n10' command

ASLok (fst-mail) wrote :

Many thanks for your reply!!

[aslok@3r]2011.01.19-16:03:01:~$ dmesg | tail -n10
[77821.232836] AIF:PRIV connect attempt: IN=eth0 OUT= MAC= SRC=10.1.20.77 DST=10.1.20.255 LEN=201 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=UDP SPT=631 DPT=631 LEN=181
[77821.809990] usb 2-10: USB disconnect, address 7
[77828.951218] AIF:UNPRIV connect attempt: IN=eth0 OUT= MAC= SRC=10.1.20.77 DST=224.0.0.251 LEN=71 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=51
[77835.047199] AIF:UNPRIV connect attempt: IN=eth0 OUT= MAC=00:e0:4c:17:f3:e0:00:07:e9:0c:4e:e4:08:00 SRC=89.207.222.155 DST=10.1.20.77 LEN=52 TOS=0x00 PREC=0x00 TTL=53 ID=24246 DF PROTO=TCP SPT=45052 DPT=55629 WINDOW=5840 RES=0x00 SYN URGP=0

[77835.452601] usb 2-10: new low speed USB device using ohci_hcd and address 8
[77835.701135] input: Vibration,12-Button USB Wheel as /devices/pci0000:00/0000:00:02.0/usb2/2-10/2-10:1.0/input/input9
[77835.701269] generic-usb 0003:0583:B003.0004: input,hidraw2: USB HID v1.10 Joystick [Vibration,12-Button USB Wheel] on usb-0000:00:02.0-10/input0

[77838.956534] AIF:UNPRIV connect attempt: IN=eth0 OUT= MAC= SRC=10.1.20.77 DST=224.0.0.251 LEN=71 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=51
[77839.493146] AIF:PRIV connect attempt: IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:1e:8c:07:e2:84:08:00 SRC=10.1.20.67 DST=10.1.20.255 LEN=96 TOS=0x00 PREC=0x00 TTL=128 ID=7 PROTO=UDP SPT=137 DPT=137 LEN=76
[77839.493178] AIF:PRIV connect attempt: IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:1e:8c:07:e2:84:08:00 SRC=10.1.20.67 DST=10.1.20.255 LEN=96 TOS=0x00 PREC=0x00 TTL=128 ID=8 PROTO=UDP SPT=137 DPT=137 LEN=76
[aslok@3r]2011.01.19-16:03:02:~$

BSA (b-s-a) wrote :

please first query all eventN files in /dev/input/. May be you try test wrong device.

ASLok (fst-mail) wrote :

Today i have reboot, after reboot i did see this:

[aslok@3r]2011.01.20-09:46:33:~$ ls -Fal /dev/input/event*
crw-r----- 1 root root 13, 64 2011-01-20 01:09 /dev/input/event0
crw-r----- 1 root root 13, 65 2011-01-20 01:09 /dev/input/event1
crw-r----- 1 root root 13, 66 2011-01-20 01:09 /dev/input/event2
crw-r----- 1 root root 13, 67 2011-01-20 01:09 /dev/input/event3
crw-r----- 1 root root 13, 68 2011-01-20 01:09 /dev/input/event4
crw-r----- 1 root root 13, 69 2011-01-20 01:09 /dev/input/event5
crw-rw----+ 1 root root 13, 70 2011-01-20 01:09 /dev/input/event6
crw-r----- 1 root root 13, 71 2011-01-20 01:09 /dev/input/event7
crw-r----- 1 root root 13, 72 2011-01-20 01:09 /dev/input/event8
[aslok@3r]2011.01.20-09:53:42:~$ fftest /dev/input/event0
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Open device file: Permission denied
[aslok@3r]2011.01.20-09:53:49:~$ sudo !!
sudo fftest /dev/input/event0
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Device /dev/input/event0 opened
Axes query:
Effects:
Number of simultaneous effects: 0
Upload effects[0]: Function not implemented
Upload effects[1]: Function not implemented
Upload effects[2]: Function not implemented
Upload effects[3]: Function not implemented
Upload effects[4]: Function not implemented
Upload effects[5]: Function not implemented
Enter effect number, -1 to exit
0
Now Playing: Sine vibration
Enter effect number, -1 to exit
-1
No such effect
[aslok@3r]2011.01.20-09:54:30:~$ sudo fftest /dev/input/event1
[ ... ]
[aslok@3r]2011.01.20-09:54:49:~$ sudo fftest /dev/input/event8
[ ... ]
[aslok@3r]2011.01.20-09:59:25:~$ fftest /dev/input/event8
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Open device file: Permission denied
[aslok@3r]2011.01.20-10:04:20:~$

I did check event0 - event8, no diff (i use [ ... ] for reduce listing). 6 "Function not implemented" for all 9 events. For all 9 i check "Sine vibration", no feedback (

ASLok (fst-mail) wrote :

Tryed with zeroplus instead generic-usb, ff still not working ( In man for wheel i see need I-Force 2.0 if it can help..

Jan 21 02:37:06 3r kernel: [17182.032004] usb 2-10: USB disconnect, address 7
Jan 21 02:37:34 3r kernel: [17209.710055] usb 2-10: new low speed USB device using ohci_hcd and address 8
Jan 21 02:37:34 3r kernel: [17209.963134] input: Vibration,12-Button USB Wheel as /devices/pci0000:00/0000:00:02.0/usb2/2-10/2-10:1.0/input/input9
Jan 21 02:37:34 3r kernel: [17209.963283] zeroplus 0003:0583:B003.0004: input,hidraw2: USB HID v1.10 Joystick [Vibration,12-Button USB Wheel] on usb-0000:00:02.0-10/input0

ASLok (fst-mail) wrote :

Tryed with logitech driver, same ( I dont know, what to do next..

[241938.326994] usb 2-10: USB disconnect, address 8
[241943.372541] usb 2-10: new low speed USB device using ohci_hcd and address 9
[241943.623245] input: Vibration,12-Button USB Wheel as /devices/pci0000:00/0000:00:02.0/usb2/2-10/2-10:1.0/input/input10
[241943.623399] logitech 0003:0583:B003.0005: input,hidraw2: USB HID v1.10 Joystick [Vibration,12-Button USB Wheel] on usb-0000:00:02.0-10/input0
[241943.623404] logitech 0003:0583:B003.0005: not enough values in the field

I noticed, one moment.. Now pedals in nfsmw working correct, but before worked brake only, was the need to bind accelerator pedal to break and use button on wheel like break pedal. Now break and accelerator pedals working correct and i can to bind they both correct..

Omega-xis (nieknooijens) wrote :

haven't got it working either:
niek@niek-desktop:~$ dmesg | tail -n10
[ 33.962100] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 44.504043] eth0: no IPv6 routers present
[ 453.040121] usb 5-3: new full-speed USB device number 2 using ohci_hcd
[ 453.338753] Registered led device: xpad0
[ 453.338897] input: Generic X-Box pad as /devices/pci0000:00/0000:00:13.0/usb5/5-3/5-3:1.0/input/input13
[ 453.339148] usbcore: registered new interface driver xpad
[ 710.492156] usb 5-3: USB disconnect, device number 2
[ 714.776119] usb 5-3: new full-speed USB device number 3 using ohci_hcd
[ 714.953340] Registered led device: xpad1
[ 714.953472] input: Generic X-Box pad as /devices/pci0000:00/0000:00:13.0/usb5/5-3/5-3:1.0/input/input14
niek@niek-desktop:~$ sudo fftest
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Device /dev/input/event0 opened
Axes query:
Effects:
Number of simultaneous effects: 0
Upload effects[0]: Function not implemented
Upload effects[1]: Function not implemented
Upload effects[2]: Function not implemented
Upload effects[3]: Function not implemented
Upload effects[4]: Function not implemented
Upload effects[5]: Function not implemented
Enter effect number, -1 to exit
5
Now Playing: Weak Rumble
Enter effect number, -1 to exit
-1
No such effect

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers