Toshiba Tecra A9 (Nvidia) does not resume properly from hibernation with 2.6.24-19

Bug #241407 reported by Marc Tardif on 2008-06-19
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
nvidia-graphics-drivers-177 (Ubuntu)
Undecided
Unassigned

Bug Description

After installing the Hardy current image 20080617 on a Toshiba Tecra A9 (Nvidia), the laptop does not resume properly from hibernation. Instead of prompting for the password to unlock the computer, I get a vertically stretched Ubuntu logo at the bottom of the screen. The only way to recover from this problem seems to power off the machine and then boot normally again.

uname -a:
Linux ubuntu 2.6.24-19-generic #1 SMP Wed Jun 4 16:35:01 UTC 2008 i686 GNU/Linux

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

The same symptoms occur on a Dell XPS M1330. If the problem happens to be related to the graphics controller, the Toshiba has a nVidia Quadro NVS 130M (rev a1) and the Dell a nVidia GeForce 8400M GS (rev a1).

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

The Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . It contains the 2.6.27 Ubuntu kernel. It would be great if you could test and verify if this is still an issue. The status is being set to Incomplete until we receive further feedback. Thanks.

Changed in linux:
status: Triaged → Incomplete
John Woo (jmwoo2) wrote :

I have a Toshiba Tecra A9, with the Nvidia NVS 130M. I just loaded Ubuntu 8.10 Release candidate, and bringing back the video after suspending is still an issue. All I get is a blank screen. This is an issue for both the open source driver and the binary driver.

I can still SSH back into my laptop (from another computer on the LAN) after trying to resume the laptop. I was able to retrieve /var/log/messages and dmesg before and after the suspend, with and without the binary nvidia driver (4 files). I have attached these logs in the file logs.tar.gz. I have also attached a `sudo lspci -vvv` .

Do you guys have any debugging tools to fix suspend/video problems... or is it mostly just printk?

Charles Profitt (cprofitt) wrote :

For those asking people to test 8.10 instead of 8.04 - please remember that 8.04 is LTS. Lets not rush to tell people to go to a beta product instead of dealing with the issues on the LTS version.

Thanks PrivateVoid. I just wanted to add a note that current SRU (Stable Release Update) policy states that a bug must be fixed in the current development release before it can generally be considered for an SRU - https://wiki.ubuntu.com/StableReleaseUpdates . This is the reason why we'll ask for testing of the actively developed releases. Additionally, bugs must also meet a certain criteria in terms of severity and user impact to also qualify for SRU.

@jwoo, thanks for testing and the feedback. https://wiki.ubuntu.com/DebuggingKernelSuspend might provide some additional information. I did notice from your logs it looked like you used nvidia-glx-177. Just curious what happens if you try with nvidia-glx-173. Based on /usr/share/doc/nvidia-glx-17[3|7]/README.txt.gz both seem to claim to support your card.

John Woo (jmwoo2) wrote :

Leann,

I ran with nvidia-glx-173 with turning on /sys/power/pm_trace to 1. Upon trying to resume from suspend (to ram), the screen did not come back, nor did my Ethernet device. I was therefore unable to capture a dmesg after trying to resume from suspend.

I then got dmesg logs (before and after the suspend) for the open source driver and nvidia-glx-177 with turning /sys/power/pm-trace to 1.

For the open source driver, I didn't notice anything spectacular in the logs...

For the nvidia-glx-177 driver I get a nice stack trace, but knowing that the nvidia driver is binary only, there doesn't seem like much I can do. (See logs2.tar.gz: nvidia_177/dmesg_after_pm_trace_on). Looking at the end of this file, it looks like compiz.real was making a call to the nvidia driver. After realising this, I then disabled compiz (see logs: logs2.tar.gz: nvidia_177_compiz_off/dmesg_after_pm_trace_on_no_compiz). Even with disabling compiz, video does not seem to resume.

If there's any other data I can grab for you guys, please let me know.

Thanks!

Changed in linux:
status: Incomplete → Triaged

Hi jwoo,

The following from your nvidia 177 logs looks interesting as well:

Xorg[5470]: segfault at 0 ip b674b6f5 sp bfd9c9c0 error 6 in nvidia_drv.so[b6720000+475000]

What happens if you attempt to suspend from a tty:

Ctrl-Alt-F1
/etc/acpi/sleep.sh force

John Woo (jmwoo2) wrote :

Leann,

Wow, I didn't even see that line. Nice eyes.

Ok, with the nvidia-177 driver, I did :
  Ctrl-Alt-F1, got to a tty
  logged in
  set /sys/power/pm_trace to 1
  dmesg > dmesg_before_in_console (see logs3.tar.gz: nvidia_177_in_console/dmesg_before_in_console)
  Executed /etc/acpi/sleep.sh force

Waited about 4-5 minutes and video did not want to resume. I then ssh'ed back into the laptop (from another machine), and:
dmesg > dmesg_after_in_console (see logs3.tar.gz: nvidia_177_in_console/dmesg_after_in_console)

Marc Tardif (cr3) wrote :

The Toshiba Tecra A9 with Nvidia graphics controller seems to hibernate just fine with Intrepid. For your information, the recommended nvidia-177 driver is installed.

I was able to catch Marc on IRC and he confirmed that Suspend is working too. I examined both Marc and John's lspci files and it seems they have the exact same hardware. Marc did test from a fresh installation though.

John, does hibernate also work or fail for you as well? Can you also try burning a LiveCD of Intrepid that was released today - http://www.ubuntu.com/downloads and attempt to Suspend/Resume from the LiveCD?

John Woo (jmwoo2) wrote :

Leann,

Thanks for looking into this for me.

I did a fresh install of the (final) Ubuntu 8.10 and hibernate works for me (using the binary Nvidia 177 driver.. I did not try using 173 or the open source driver). Unfortunately suspend still does not work. :(

After installing (final) Ubuntu 8.10, I booted up a live session from the latest and greatest Ubuntu 8.10 CD and tried to do suspend/resume (as you suggested). Video did not come back upon trying to resume my laptop.

I did a diff with my lspci (lspci -vvnn) against Marc's, and it seems that Marc's laptop has an "Intel Corporation Turbo Memory Controller". This entry seems to be mysteriously missing from my laptop! I looked in my bios to see if there was anything I could turn on/off, but I didn't see anything that looked remotely close to a memory controller. I then upgraded my bios from 1.50 to 2.00, booted Ubuntu, tried suspend.. Still nothing.

I have attached a copy of my "sudo lspci -vvnn" (before and after flashing my bios). Apparently there was one line change under the status of one of the devices.. which seems negligible... I'm not exactly sure what to do at this point other than to call up Toshiba and ask them where my Intel Turbo Memory Controller is.. (heh, I doubt they'll know what I'm talking about). Any other suggestions?

Thanks,

John

Hi Marc and John,

Since you've both confirmed that Hibernation is no longer an issue with Intrepid and this bug report originally targeted the hibernation issue, I'm going to close this specific bug. However, I do recognize there still seems to be issues with suspend. Lets use bug 203251 to target the suspend issue. John, I'll migrate some of your specific logs and information you posted here to bug 203251. Thanks.

Changed in linux:
status: Triaged → Fix Released
Changed in nvidia-graphics-drivers-177:
status: New → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions