[Hardy] Kernel oops on AC<->DC

Bug #241229 reported by Yong Wang on 2008-06-19
8
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Stefan Bader
Hardy
Undecided
Unassigned

Bug Description

The ACPI BIOSes of some problematic machines, e.g. Toshiba Satellite L35, only export C1 when running on AC while the same machines support more than C1 when running on battery. This results in cpuidle_register_device not being called during system initialization when running on battery. However, cpuidle_enable_device will be called without cpuidle_register_device being called before when user switches from AC to DC and _CST changed notification occurs, thus the oops.

Upstream bug report can be found at http://bugzilla.kernel.org/show_bug.cgi?id=10394.

Changed in linux:
status: Unknown → Fix Released
Rui Boon (ruiboon) wrote :

Thanks for your bug report and the upstream link. This may be related to bug 207014 or bug 228375. This has already been committed to Linus' tree (commit dcb84f335bee9c9a7781cfc5d74492dccaf066d2), and should be out in 2.6.26.

Changed in linux:
status: New → Fix Committed
Yong Wang (yong-y-wang) wrote :

That I know and thanks for your reply. But the problem is that this fix is not in Hardy which is based on 2.6.24. I've backported the patch and sent to kernel-team mailinglist.

Stefan Bader (smb) wrote :

The request sent to kernel mailing list also includes the upstream commit 36a913586597cab1cd565e9bf348d037f0df955b which also would qualify for an SRU. I will pick the commits separately but tie them both to this bug report (since the occurrence is also quite similar).

Changed in linux:
assignee: nobody → stefan-bader-canonical
Stefan Bader (smb) wrote :

The modified patches have been committed to the hardy git as af7a9143bc401dadf55ffca48cbfd473f008a906 and 1d2480a8e95556905d57f40ab048aa51aed4263a.

Stefan Bader (smb) wrote :

SRU justification:

Impact: The ACPI BIOSes of some problematic machines, e.g. Toshiba Satellite L35, only export C1 when running on AC while the same machines support more than C1 when running on battery. This results in cpuidle_register_device not being called during system initialization when running on battery. However, cpuidle_enable_device will be called without cpuidle_register_device being called before when user switches from AC to DC and _CST changed notification occurs, thus the oops.

Fix: Available upstream as mentioned above.

Testcase: Boot in DC mode and then plug in power.

Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released

The above patches are already available and released for Intrepid. Changing status from Fix Committed to Fix Released.

Changed in linux:
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.