Ubuntu

ubuntu 8.04 fresh install crashes at boot time while loading usbHID

Reported by Gerard Sanromà on 2008-06-11
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Dell Inspiron 530 desktop computer with core 2 duo processor E6550.
I have installed 64 bits Ubuntu 8.04 correctly from live CD.
When doin normal boot the first time, system hangs while showing ubuntu logo and the orange bar moving one side to another.
In order to see what happens exactly I tried to boot in recovery mode and the system hangs immediately after displaying:

/build/buildd/linux-2.6.24/drivers/HID/usbHID/HID-Core.c: v2.6: USB HID Core Driver

Afterwards, the system remains indefinitely in this state while showing periodically further messages as:

[48.752700] ata3.00: qc timeout (cmd 0x27)
ata3.00: failed to read native max address (err_mask= 0x4)
ata3: failed to recover some devices, retrying in 5 secs

The system does not bring up any shell.

I tried to disable USB from bios and the system boots correctly (but mouse and keyboard don't work, obviously).

WORKAROUND: all_ide_generic

Joseph Sanromá (jsanroma) wrote :

I have 8.04 running complete with active USB adapter on Dell Optiflex Desktop dual core 32 bit Intel chip with no problems.
Intel 64b 6550 requires Intel EM64T-enabled BIOS to work properly according to warning from Intel.

Step back and try loading 32 bit version, the code for USB adapter shouldn't be all that different. The bios might be more gentle.

Dariel Dato-on (odd-rationale) wrote :

Thanks for your bug report and for your contribution to ubuntu. In order to determine if this issue is usplash related, would you boot your computer with usplash disabled and then shutdown to see if you can reproduce the issue? To disable usplash for a single boot, you can follow these steps :

1.Press Esc during Grub boot delay to access the boot menu.
2.Select your actual Ubuntu boot line and press "e" to edit it.
3.Select the "kernel" line and press "e" to edit it.
4.At the end of the line, remove "splash" and "quiet" and press "enter".
5.Type "b" to boot the custom boot line.

Gerard Sanromà (gsanroma) wrote :

Odd-rationale, I followed the steps you comment and the system behaves exactly the same.
To puntualize, I may say that I installed the system by, firstly starting ubuntu from livecd and then, launching the installation from desktop. The point is that the boot process from livecd also crashed bringing up a shell. I reached to start correctly from livecd by selecting the option 'acpi=off' from the start menu of the livecd (by pressing F6 for advanced options).
Therefore, it may be helpful to somehow include such an entry ('acpi=off') into the normal boot process of the fresh installed system.
I will report any findings on that line..

Gerard Sanromà (gsanroma) wrote :

I have somehow solved the problem by disabling acpi at boot time by adding the option acpi=off at the end of the kernel line in the grub menu.
It seems to be something about acpi.
I tried with the 32 bit version of ubuntu 8.04 as Joseph Sanroma suggested and I got exactly the same problem.. so it seems to be somehow architecture independent.

Gerard.

Gerard Sanromà (gsanroma) wrote :

I have found a better solution to my problem since it allows me to have acpi enabled.
I hope it helps to find the problem.
The fix is to add the option 'all_ide_generic' at the end of the kernel line.

Gerard.

Marius Kruger (amanica) wrote :

it seems that there is a workaround to this, so it might be fixable.

Changed in linux:
status: Incomplete → Confirmed

Gerard Sanromà, thank you for reporting this and helping make Ubuntu better. Hardy desktop reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue on a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: hardy needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers