JMicron card reader (152d:2339) in HP Pavilion 2035la doesn't support Memory Stick Pro (MSP)

Bug #237369 reported by Fabián Rodríguez on 2008-06-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.24

HP Pavilion 2000 series laptops (including thi 2035la model) include a single reader that supports the following formats [1]:
* Secure Digital (SD) Memory Card
* MultiMediaCard (MMC)
* Secure Digital Input/Output (SD I/O)
* Memory Stick (MS)
* Memory Stick Pro (MSP)
* xD-Picture Card (XD)
* xD-Picture Card (XD) Type M

This bug report is only for the Memory Stick Pro (MSP) card form factor, although Memory Stick (MS) may have the same issue. Kernel is 2.6.24-17.

When inserting an MSP card it is not recognized nor mounted automatically.

lsusb reports this:
Bus 005 Device 002: ID 152d:2339 JMicron Technology Corp. / JMicron USA Technology Corp.

Searching the Linux USB database doesn't return anything for this.

lsmod reports the following possibly related modules:
tifm_7xx1 8576 0
tifm_core 11012 2 tifm_sd,tifm_7xx1
mmc_core 51460 2 tifm_sd,sdhci

There are other similar reports of Memory Stick apparently being supported on a per-driver basis (see Bug #85862, Bug #48987, Bug #159951). This may or may not be duplicates, if anyone can help determine this I'll gladly mark them (or accept any such duplicate marking).

Although I am seeking resolution for this, I'd also like to know if there is any legal problem (patents, etc.) blocking this or if it is "just" that no one has gotten to it yet (which seems implied in the mentioned bug reports). Thanks for any insights on this.

I am filing this on behalf of an Ubuntu user that reported the issue in the #ubuntu-co channel (user: emerson), he'll most likely provide further output/testing as requested. dmesg output and maybe usbmon output would be nice. Anything else he could provide to help and see what is missing / wrong ?

--
[1] External media cards info comes from http://h10032.www1.hp.com/ctg/Manual/c00725689.pdf

description: updated
description: updated
gus (gustavo-varela) wrote :

Does the reader works for other formats ? Does those cards that you are trying to use really work (i.e. in other readers)?

Fabián Rodríguez (magicfab) wrote :

Yes, it works for other formats, and yes the card the initial reporter was using worked with Windows.

As for other readers, we don' t have those available. This report is *only* for the JMicron card reader (USB id 152d:2339).

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Henrik Daver (laederlappen) wrote :

I have the same problem with my JMicron card reader, running the 2.6.27 kernel. It works for smart media cards, but not for my memory stick pro duo. Any luck with solving the problem?

Hi Fabain,

Just curious if you've tested with Jaunty 9.04?

Changed in linux (Ubuntu):
status: New → Incomplete

I have tested it and still not working running kernel 2.6.28-11 using aspire one on UNR with Jmicron card reader

Hi rgchihanga,

If you could, please attach your lsusb output so we can confirm you indeed have the same hw. Also, it might be helpful to also confirm against the latest Karmic development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Thanks.

goniomdq (jose-goni) wrote :

Hello,
I have the same problem, but my reader is PCI. (my laptop is an HP dv5-1209)
It works with SD cards, which is the only one recognised as a card reader, the other ones are shown as system peripherals. I have tried with MSPro and XD cards and it doesn't work, that's when I noticed that the drivers for the other ones seamed not to be installed.
I'm gonna download the ISO release of the Karmic Ubuntu to try it out.
Attached is my lspci.
Thanks.

Gustavo Spadari (gspadari) wrote :

This happens to me as well.
Pavilion dv4-1413la.

Sean Snyders (sean-snyders) wrote :

I also have this issue on my Lenovo N500 as well. The card reader is a all-in-one type of reader that has only one slot to insert the card into.

SD cards work fine, but it does not work for normal Memory Stick (the old plain version). All cards work under windows and under different cards readers in linux.

Using 64bit Linux Mint Gloria, based on Ubuntu 9.04.

uname -a:
........ 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

lspci -nn:
02:00.0 System peripheral [0880]: JMicron Technologies, Inc. SD/MMC Host Controller [197b:2382]
02:00.2 SD Host controller [0805]: JMicron Technologies, Inc. Standard SD Host Controller [197b:2381]
02:00.3 System peripheral [0880]: JMicron Technologies, Inc. MS Host Controller [197b:2383]

lsusb:
Bus 002 Device 002: ID 04f2:b090 Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a5c:2150 Broadcom Corp.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Inserting and removing a SD card twice gives me the following messages. I've inserted a MS card in between these two events, and nothing shows up.
dmesg | tail -n 20:
[294814.924952] mmcblk0: mmc0:b368 1.91 GiB
[294814.925363] mmcblk0: p1
[294929.876234] mmc0: card b368 removed
[296325.768852] mmc0: new high speed SD card at address b368
[296325.769704] mmcblk0: mmc0:b368 1.91 GiB
[296325.769859] mmcblk0: p1
[296877.284158] mmc0: card b368 removed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments