Ubuntu

hisax isdn network broken

Reported by peterh on 2008-06-04
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Colin King

Bug Description

Binary package hint: linux-image-2.6.24-17-server

Please include http://lkml.org/lkml/2008/4/29/506 because
isdnutils-base failed to ifconfig ipppX.

cu Peter

bnomis (bmlaunchpad) wrote :

Same problem here with linux-image-2.6.24-19-generic; isdn networking does not work at all since ipppX interfaces can't be configured.

The patch mentioned above is part of the stable kernel series (included in 2.6.24.6) and helps for me.

Hi Guys,

Thanks for the reference to the upstream patch. Just for your information, the patch referenced is already in the upcoming Intrepid Ibex 8.10 Ubuntu kernel. If you'd like to test the latest Alpha for the upcoming Intrepid release, more information can be found at http://www.ubuntu.com/testing.

I've listed the upstream git commit id for this patch below. I'll also approve the Hardy nomination for the kernel team to consider backporting this patch. Thanks.

commit d2dcba612b357a4687843ad4f46629d219233fd7
Author: Paul Bolle <email address hidden>
Date: Sun Apr 13 22:44:20 2008 -0700

    [ISDN]: Do not validate ISDN net device address prior to interface-up

    Commit bada339 (Validate device addr prior to interface-up) caused a regression
    in the ISDN network code, see: http://bugzilla.kernel.org/show_bug.cgi?id=9923
    The trivial fix is to remove the pointer to eth_validate_addr() in the
    net_device struct in isdn_net_init().

    Signed-off-by: Paul Bolle <email address hidden>
    Signed-off-by: David S. Miller <email address hidden>

Changed in linux:
status: New → Fix Released
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Colin King (colin-king) on 2008-09-04
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Colin King (colin-king) wrote :

Hi,

I've added the patch and built the linux-kernel package - you can download the packages from my PPA at: https://launchpad.net/~colin-king/+archive

Add the following lines to your apt sources.list:

deb http://ppa.launchpad.net/colin-king/ubuntu hardy main
deb-src http://ppa.launchpad.net/colin-king/ubuntu hardy main

Then run the command:

sudo apt-get update

Alternatively, follow the instructions at: https://help.ubuntu.com/8.04/add-applications/C/extra-repositories-adding.html

If you can test this package and let me know if it works, then I can add this patch into the hardy as a Stable Release Update (SRU).

Thanks, Colin

peterh (peter-holik) wrote :

It's working for me

thanx Peter

Colin King (colin-king) wrote :

SRU justification:

Impact: ISDN networking does not work at all because ipppX interfaces
cannot be configured - c.f.
http://bugzilla.kernel.org/show_bug.cgi?id=9923

The patch attached is straight forward 1 line change in the form of an
upstream cherry pick of commit d2dcba612b357a4687843ad4f46629d219233fd7
to not validate the ISDN net device address prior to interface-up by
nullifying the pointer validate_addr.

Testcase: Without the patch, ISDN ipppX interfaces cannot be configured
and ISDN does not work. With the patch, ISDN now works.

Tested by user:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/237306/comments/4

Changed in linux:
milestone: none → ubuntu-8.04.2
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2008-11-14
Changed in linux:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
milestone: ubuntu-8.04.2 → none
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-11-14
Changed in linux:
milestone: none → ubuntu-8.04.2
Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

peterh (peter-holik) wrote :

linux-image-2.6.24-23-server_2.6.24-23.46_i386.deb

works for me

Launchpad Janitor (janitor) wrote :
Download full text (12.0 KiB)

This bug was fixed in the package linux - 2.6.24-23.46

---------------
linux (2.6.24-23.46) hardy-proposed; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated PREEMPT_RT support to rt21
    - LP: #302138

  [Amit Kucheria]

  * SAUCE: Update lpia patches from moblin tree
    - LP: #291457

  [Andy Whitcroft]

  * SAUCE: replace gfs2_bitfit with upstream version to prevent oops
    - LP: #276641

  [Colin Ian King]

  * isdn: Do not validate ISDN net device address prior to interface-up
    - LP: #237306
  * hwmon: (coretemp) Add Penryn CPU to coretemp
    - LP: #235119
  * USB: add support for Motorola ROKR Z6 cellphone in mass storage mode
    - LP: #263217
  * md: fix an occasional deadlock in raid5
    - LP: #208551

  [Stefan Bader]

  * SAUCE: buildenv: Show CVE entries in printchanges
  * SAUCE: buildenv: Send git-ubuntu-log informational message to stderr
  * Xen: dma: avoid unnecessarily SWIOTLB bounce buffering
    - LP: #247148
  * Update openvz patchset to apply to latest stable tree.
    - LP: #301634
  * XEN: Fix FTBS with stable updates
    - LP: #301634

  [Steve Conklin]

  * Add HID quirk for dual USB gamepad
    - LP: #140608

  [Tim Gardner]

  * Enable CONFIG_AX25_DAMA_SLAVE=y
    - LP: #257684
  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643

  [Upstream Kernel Changes]

  * Revert "[Bluetooth] Eliminate checks for impossible conditions in IRQ
    handler"
    - LP: #217659
  * KVM: VMX: Clear CR4.VMXE in hardware_disable
    - LP: #268981
  * iov_iter_advance() fix
    - LP: #231746
  * Fix off-by-one error in iov_iter_advance()
    - LP: #231746
  * USB: serial: ch341: New VID/PID for CH341 USB-serial
    - LP: #272485
  * x86: Fix 32-bit x86 MSI-X allocation leakage
    - LP: #273103
  * b43legacy: Fix failure in rate-adjustment mechanism
    - LP: #273143
  * x86: Reserve FIRST_DEVICE_VECTOR in used_vectors bitmap.
    - LP: #276334
  * openvz: merge missed fixes from vanilla 2.6.24 openvz branch
    - LP: #298059
  * openvz: some autofs related fixes
    - LP: #298059
  * openvz: fix ve stop deadlock after nfs connect
    - LP: #298059
  * openvz: fix netlink and rtnl inside container
    - LP: #298059
  * openvz: fix wrong size of ub0_percpu
    - LP: #298059
  * openvz: fix OOPS while stopping VE started before binfmt_misc.ko loaded
    - LP: #298059
  * x86-64: Fix "bytes left to copy" return value for copy_from_user()
  * NET: Fix race in dev_close(). (Bug 9750)
    - LP: #301608
  * IPV6: Fix IPsec datagram fragmentation
    - LP: #301608
  * IPV6: dst_entry leak in ip4ip6_err.
    - LP: #301608
  * IPV4: Remove IP_TOS setting privilege checks.
    - LP: #301608
  * IPCONFIG: The kernel gets no IP from some DHCP servers
    - LP: #301608
  * IPCOMP: Disable BH on output when using shared tfm
    - LP: #301608
  * IRQ_NOPROBE helper functions
    - LP: #301608
  * MIPS: Mark all but i8259 interrupts as no-probe.
    - LP: #301608
  * ub: fix up the conversion to sg_init_table()
    - LP: #301608
  * x86: adjust enable_NMI_through_LVT0()
    - LP: #301608
  * SCSI ips: handle scsi_add_host() failure, and other err cl...

Changed in linux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.