Connecting headset doesn't mute laptop speaker Acer 5920G

Bug #235607 reported by ajayambawat on 2008-05-28
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ubuntu Audio Team

Bug Description

When I am connecting the headset, the sound of the laptop speaker doesn't mute. At the same time I am getting sound in headset also.

Ubuntu Hardy 8.04
Kernel 2.6.24.17-generic

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

I hope the above information is sufficient.
Thanks

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested in the Reporting Sound Bugs section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments? Thanks in advance.

ajayambawat (ajayambawat) wrote :
Download full text (60.4 KiB)

ajay@ajay-laptop:~$ uname -a
Linux ajay-laptop 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

sudo lspci -vvnn
 Latency: 0
 Capabilities: [e0] Vendor Specific Information

00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 03) (prog-if 00 [Normal decode])
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
 I/O behind bridge: 00002000-00002fff
 Memory behind bridge: f0000000-f2ffffff
 Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
 Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR+ NoISA- VGA+ MAbort- >Reset- FastB2B-
 Capabilities: [88] Subsystem: Acer Incorporated [ALI] Unknown device [1025:0121]
 Capabilities: [80] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
  Address: fee0300c Data: 41c1
 Capabilities: [a0] Express Root Port (Slot+) IRQ 0
  Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
  Device: Latency L0s <64ns, L1 <1us
  Device: Errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
  Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
  Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
  Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 2
  Link: Latency L0s <256ns, L1 <4us
  Link: ASPM L0s L1 Enabled RCB 64 bytes CommClk+ ExtSynch-
  Link: Speed 2.5Gb/s, Width x16
  Slot: AtnBtn- PwrCtrl- MRL- AtnInd- PwrInd- HotPlug+ Surpise-
  Slot: Number 1, PowerLimit 75.000000
  Slot: Enabled AtnBtn- PwrFlt- MRL- PresDet- CmdCplt- HPIrq-
  Slot: AttnInd Off, PwrInd On, Power-
  Root: Correctable- Non-Fatal- Fatal- PME-

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03) (prog-if 00 [UHCI])
 Subsystem: Acer Incorporated [ALI] Unknown device [1025:0121]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 4: I/O ports at 1800 [size=32]

00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03) (prog-if 00 [UHCI])
 Subsystem: Acer Incorporated [ALI] Unknown device [1025:0121]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin B routed to IRQ 19
 Region 4: I/O ports at 1820 [size=32]

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03) (prog-if 20 [EHCI])
 Subsystem: Acer Incorporated [ALI] Unknown dev...

Changed in linux:
assignee: nobody → ubuntu-audio
importance: Undecided → Medium
status: Incomplete → Confirmed
nglnx (nglnx) wrote :

It unfortunately appears that this bug is not yet resolved. The Intrepid Ibex 8.10 Alpha2 is scheduled for release today. It will appear at the following when available: http://www.ubuntu.com/testing/intrepid/alpha2 . It contains the the actively developed 2.6.26 Ubuntu kernel. It would be great if you could test this upcoming release via a LiveCD and verify if the issue still exists. If so, please include the appropriate debugging information as outlined at https://wiki.ubuntu.com/DebuggingSoundProblems . Thanks in advance.

Changed in linux:
status: Confirmed → Incomplete
ajayambawat (ajayambawat) wrote :

Hi nglnx,

sorry for the late reply as I was out of town.
Checked all over the Ubuntu website as well as the net , couldn't get a live cd image.
Since the relese is still in alpha, I am not willing to install. Can you give me some link to the Live CD?

Thanks
Ajay

nglnx (nglnx) wrote :

As can be seen in the link provided above (http://www.ubuntu.com/testing/intrepid/alpha2), Alpha 2 does not include LiveCD images, only images with the Ubuntu alternate installer. Intrepid LiveCDs will be made available with Alpha 3.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jonas Windhager (jwindhager) wrote :

It seems to be that there is a solution for this problem on http://gentoo-wiki.com/Acer_Aspire_5920G#Sound, but I cannot try this in the next weeks because Im currently using another PC, maybe others can test it?

ajayambawat (ajayambawat) wrote :

Installed 2.6.27.2 on my Hardy and the headset jack is working perfect now.
But now the problem is with the Nvidia driver. After upgarding to 2.6.27.2 resolution got stuck at 800*600. Using "displayconfig-gtk" I got it
back to normal but for last 24 hr. I am struggling with Nvidia driver which doesn't work at all any more. Tried all the available one oldest to the latest 177.* but in vain ? Switching back to the 2.6.24.21 is also not helping. Any solution for that or only a clean re-install??

Thanks for the update. I'm going to mark this "Fix Released" for Intrepid. If you notice any regressions regarding this bug prior to Intrepid's final release, please reopen this by setting the status back to "New".

Regarding the Nvidia issues you are experiencing, care to open a new report? Thanks.

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers