Coretemp outdated / can't show 45nm core temps

Bug #235119 reported by therelic on 2008-05-27
22
Affects Status Importance Assigned to Milestone
lm-sensors
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Colin Ian King
lm-sensors-3 (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

Description: Ubuntu 8.04
Release: 8.04

The coretemp.c file in linux kernel 2.6.24 is outdated, the one in linux kernel 2.6.25 has the code lines to detect the model 17 cpus (intel 45nms q9300/q9450/etc.).

While the packaged lm-sensors' sensor-detect seems a bit dated, when I compiled and used the new one (3.0.2) it detected the q9300s cpu sensors.

Driver `coretemp' (should be inserted):
  Detects correctly:
  * Chip `Intel Core family thermal sensor' (confidence: 9)

When trying to use/load coretemp after this; "modprobe coretemp" - coretemp: Unknown CPU model 17

I believe this is the source of most of the lm-sensors outdated and not working problems with all the newer chips, since even if it were updated and worked to detect them, the coretemps module isn't up to date and therefore can't find the cpu sensors anyway.

Both the lm-sensors and the coretemp.c should be updated for the users running intel 45nm cpus.

ake sandgren (ake-sandgren) wrote :

Yes, please take the coretemp from 2.6.25 into Ubuntu 8.04.
We have a 672 node dual quadcore cluster with the model 17 cpus and we would REALLY like to have a working coretemp module.

ake sandgren (ake-sandgren) wrote :

Forgot to mention that we are running the 2.6.25 coretemp in our 2.6.24-16-server and 2.6.24-17-server Ubuntu Hardy kernels.
It works well.

Once again, please include it as soon as possible.

Christian Doczkal (thyrus) wrote :

I have a similar problem on an FSC E8410 Notebook. (with a T9300)
But when I try to insert coretemp i get a different message:

FATAL: Error inserting coretemp (/lib/modules/2.6.24-18-generic/kernel/drivers/hwmon/coretemp.ko): No such device

Is this the same error?
In the meantime, is there a way to get the new module compiled for the running kernel? I'd hate to mess around with building a custom kernel?

therelic (the-one-relic) wrote :

Yes that is the error when your cpu is up to date and core temp isn't.

Also noticed libsensors3 is seriously out dated, for kubuntu users, that file is locked to ksysguard and can't be gotten rid of for the more up to date
libsensors4.

Herbert V. Riedel (hvr) wrote :
Jimmy Angelakos (vyruss) wrote :

Ditto, I have the same issue with Core 2 Duo E8200 (45nm) and kernel 2.6.24-19 (Ubuntu 8.04.1)

Dave Rawks (drawks.) on 2008-06-27
Changed in linux:
status: New → Confirmed

Hi, I also have this same problem with macbook 4,1.

Christian Doczkal, you can see the message "coretemp: Unknown CPU model 17" in /var/log/messages after modprobe it.

Bart Verwilst (verwilst) wrote :

It's indeed a very small patch for a very nice feature ;) ( Running on a C2D 8400 here and no temp readings )

Matti Lindell (mlind) wrote :

The patch looks trivial and is hopefully included in next Hardy kernel. In intrepid's 2.6.26 kernel coretemp module loads properly and works. I have Core 2 Duo E8400.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Björn Torkelsson (torkel) wrote :

Leann,

Please, read the bugreports before sending your "automatically" request for people to test the new kernel release. Unless you are saying that hardy will jump to 2.6.27 as a supported kernel.

The report stated that the required version of coretemp was available in 2.6.25 and asked for a _backport_ of it to hardy, as it is a LTS release and thus very important for a lot of sites, which can/will not jump to intrepid.

Hi Bjorn,

I apologize for the noise. However, manually reading through thousands of kernel bug reports was not an option when we needed to immediately post a call for testing. It was bound to happen that the automated response would not read well with some reports, so for that I am sorry.

Now for the actual issue at hand. In order for the coretemp driver to even be considered for a Hardy SRU - a nomination must be opened and approved. I'll go ahead and do this. However, the final decision to backport with be left to the discretion of the kernel team and will need to qualify under the guidelines outlined at http://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
status: Confirmed → Fix Released

I'll also bring this to the attention of the kernel team as the patch does indeed look trivial. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Colin Ian King (colin-king) wrote :

Hi,

I've added the patch and built the linux-kernel package - you can download the packages from my PPA at: https://launchpad.net/~colin-king/+archive

Add the following lines to your apt sources.list:

deb http://ppa.launchpad.net/colin-king/ubuntu hardy main
deb-src http://ppa.launchpad.net/colin-king/ubuntu hardy main

Then run the command:

sudo apt-get update

Alternatively, follow the instructions at: https://help.ubuntu.com/8.04/add-applications/C/extra-repositories-adding.html

If you can test this package and let me know if it works, then I can add this patch into the hardy as a Stable Release Update (SRU).

Thanks, Colin

Matti Lindell (mlind) wrote :

Hi Colin, I installed 2.6.24-22.43cking4 -generic flavor from your PPA. I can confirm that coretemp module now loads properly and I'm able to proper temperature readings from a Intel 45nm CPU.

Thank you for your work.

therelic (the-one-relic) wrote :

Not sure what to do with that here, kernel build? Just by looking at the files, I can see one flaw with getting it to work. If the lm-sensors package hasn't been updated in the repository you would need to download 3.0.2 and run that one just to detect the core sensors for the 45nms. The current one in the repositories will not detect the new chips core temp sensors.

Colin Ian King (colin-king) wrote :

SRU justification:

Impact: Newer 45nm model 17 CPUs ("Penryn", such as Intel
q9300,q9450,Core 2 Due E8200,E800, etc) are not recognised by coretemp
driver.

The patch attached is straight forward upstream
cherry pick of commit ae770152c801f10a91e5e86597a39b5f9ccf2d0d from
2.6.25.

Testcase: Without the patch, the coretemp driver returns:
FATAL: Error inserting coretemp
(/lib/modules/2.6.24-xx-generic/kernel/drivers/hwmon/coretemp.ko): No
such device

With the patch, the driver recognises the CPU and loads.

Tested by user:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/235119/comments/15

Changed in linux:
status: In Progress → Fix Committed
Colin Ian King (colin-king) wrote :

therelic:

I've modified lm-sensors which should contain the appropriate fix - you can download the package from my PPA at: https://launchpad.net/~colin-king/+archive

Add the following lines to your apt sources.list:

deb http://ppa.launchpad.net/colin-king/ubuntu hardy main
deb-src http://ppa.launchpad.net/colin-king/ubuntu hardy main

Then run the command:

sudo apt-get update

Alternatively, follow the instructions at: https://help.ubuntu.com/8.04/add-applications/C/extra-repositories-adding.html

If you can test this package and let me know if it work with the kernel fix, then I will try and get this patch into the hardy as a Stable Release Update (SRU).

Thanks, Colin

therelic (the-one-relic) wrote :

Now sensors-detect sees the core sensors of the 45nm.

Bart Verwilst (verwilst) wrote :

Verified here! Install the new kernel removed my sound card and make my fglrx unusably slow, but at least the sensors work! ;)

Colin Ian King (colin-king) wrote :

For attention of lm-sensors maintainer:

Please find attached a debdiff for lm-sensors to enable sensing of 45nm cores. This patch has been tested in my PPA https://launchpad.net/~colin-king/+archive by therelic and Bart Verwilst. It would be good if we can get this into Hardy 8.04.2.

Thanks. Colin.

Changed in linux:
milestone: none → ubuntu-8.04.2
Changed in lmsensors:
assignee: nobody → ubuntu-core-dev
Daniel Holbach (dholbach) wrote :

Please use ubuntu-main-sponsors instead of ubuntu-core-dev.

Also it should probably be hardy-proposed instead of hardy in the debdiff. See https://wiki.ubuntu.com/StableReleaseUpdates for more info.

Changed in lmsensors:
assignee: ubuntu-core-dev → nobody
Colin Ian King (colin-king) wrote :

Trying again..

SRU justification:

Impact: Newer 45nm model 17 CPUs ("Penryn", such as Intel
q9300,q9450,Core 2 Due E8200,E800, etc) are not recognised by lm-sensors, specifically sensors-detect.

The debdiff attached allows sensors-detect to detect model 0x16 and 0x17 CPUs.

Testcase: Without the patch (and the kernel patch https://bugs.launchpad.net/ubuntu/+bug/235119/comments/17) , the sensors-detect will not detect these CPUs. With the patch, the CPUs are detected.

Tested by therelic and Bart Verwilst.

Changed in lmsensors:
assignee: nobody → colin-king
Shadowtester (shadowtester) wrote :

Is this kernal with the coretemp patch only for 32 bit or do you also have one for 64 bit Ubuntu 8.04 as well. I have a E8400 that is having the same problem.

Changed in lm-sensors-3:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.2
Richard Hull (rm-hull) wrote :

coretemp.c is out of date with respect to the Intel Atom chips - model 28 (0x1c) - modprobe coretemp reports an error similar to the first poster.

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 28
model name : Intel(R) Atom(TM) CPU N270 @ 1.60GHz
stepping : 2
cpu MHz : 800.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 xtpr lahf_lm
bogomips : 3191.95
clflush size : 64
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 28
model name : Intel(R) Atom(TM) CPU N270 @ 1.60GHz
stepping : 2
cpu MHz : 800.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon pebs bts pni monitor ds_cpl est tm2 ssse3 xtpr lahf_lm
bogomips : 3191.96
clflush size : 64
power management:

norwoods (norwoods) wrote :

does not seem to detect a q9550 when added to ubuntu studio 8.04.1

Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
therelic (the-one-relic) wrote :

Tried this on 64bit, but it does not work. The sensors-detect patch worked for detection but .ko still doesn't load. Looks like only a 32bit fix right now.

Bryce Harrington (bryce) on 2008-11-03
Changed in lm-sensors-3:
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

New hardy SRU fixes it harder, reopening.

Changed in linux:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Kernel which fixes this accepted into hardy-proposed, please test and give feedback here.

Changed in linux:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

lm-sensors-3 patch accepted into hardy-proposed as well, please test.

Colin, please fix this in jaunty as well, or if it is already, please close the task. Thanks!

Changed in lm-sensors-3:
status: New → Fix Released
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

this is purported to be fixed with lm-sensors 3.0.2 and above, which is present in intrepid and jaunty; marking as fixed.

Changed in lm-sensors-3:
status: New → Fix Released
therelic (the-one-relic) wrote :

Is it in the 8.04 LTS version, if not then there has been no fix for the problem at the 64bit versions of the LTS and therefore is not fixed. This being the case marking as fixed is in error.

Not sure if anyone has tested 64bit, I haven't had the time to rebuild a kernel to find out if the proposed changes would work. Haven't seen anyone else post about that either. Just making sure this is in the LTS since it will affect numerous computers that will be used with LTS version 8.04.

Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Lloyd Miller (millerlf) wrote :

still doesn't seem to work on 64 bit on intel q9450.

 # modprobe coretemp
FATAL: Error inserting coretemp (/lib/modules/2.6.24-22-generic/kernel/drivers/hwmon/coretemp.ko): No such device

Martin Pitt (pitti) wrote :

Lloyd, that's not the currently tested version. You need to upgade to hardy-proposed, which has the 2.6.24-23 kernel.

Lloyd Miller (millerlf) wrote :

ok, thanks, got hardy-proposed running and the coretemp works fine for me now on my q9450 on 64 bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lm-sensors-3 - 1:3.0.0-4ubuntu2

---------------
lm-sensors-3 (1:3.0.0-4ubuntu2) hardy-proposed; urgency=low

  * Add Intel model 0x16 and 0x17, LP: #235119

 -- <email address hidden> Tue, 09 Sep 2008 10:29:03 +0100

Changed in lm-sensors-3:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (12.0 KiB)

This bug was fixed in the package linux - 2.6.24-23.46

---------------
linux (2.6.24-23.46) hardy-proposed; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated PREEMPT_RT support to rt21
    - LP: #302138

  [Amit Kucheria]

  * SAUCE: Update lpia patches from moblin tree
    - LP: #291457

  [Andy Whitcroft]

  * SAUCE: replace gfs2_bitfit with upstream version to prevent oops
    - LP: #276641

  [Colin Ian King]

  * isdn: Do not validate ISDN net device address prior to interface-up
    - LP: #237306
  * hwmon: (coretemp) Add Penryn CPU to coretemp
    - LP: #235119
  * USB: add support for Motorola ROKR Z6 cellphone in mass storage mode
    - LP: #263217
  * md: fix an occasional deadlock in raid5
    - LP: #208551

  [Stefan Bader]

  * SAUCE: buildenv: Show CVE entries in printchanges
  * SAUCE: buildenv: Send git-ubuntu-log informational message to stderr
  * Xen: dma: avoid unnecessarily SWIOTLB bounce buffering
    - LP: #247148
  * Update openvz patchset to apply to latest stable tree.
    - LP: #301634
  * XEN: Fix FTBS with stable updates
    - LP: #301634

  [Steve Conklin]

  * Add HID quirk for dual USB gamepad
    - LP: #140608

  [Tim Gardner]

  * Enable CONFIG_AX25_DAMA_SLAVE=y
    - LP: #257684
  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643

  [Upstream Kernel Changes]

  * Revert "[Bluetooth] Eliminate checks for impossible conditions in IRQ
    handler"
    - LP: #217659
  * KVM: VMX: Clear CR4.VMXE in hardware_disable
    - LP: #268981
  * iov_iter_advance() fix
    - LP: #231746
  * Fix off-by-one error in iov_iter_advance()
    - LP: #231746
  * USB: serial: ch341: New VID/PID for CH341 USB-serial
    - LP: #272485
  * x86: Fix 32-bit x86 MSI-X allocation leakage
    - LP: #273103
  * b43legacy: Fix failure in rate-adjustment mechanism
    - LP: #273143
  * x86: Reserve FIRST_DEVICE_VECTOR in used_vectors bitmap.
    - LP: #276334
  * openvz: merge missed fixes from vanilla 2.6.24 openvz branch
    - LP: #298059
  * openvz: some autofs related fixes
    - LP: #298059
  * openvz: fix ve stop deadlock after nfs connect
    - LP: #298059
  * openvz: fix netlink and rtnl inside container
    - LP: #298059
  * openvz: fix wrong size of ub0_percpu
    - LP: #298059
  * openvz: fix OOPS while stopping VE started before binfmt_misc.ko loaded
    - LP: #298059
  * x86-64: Fix "bytes left to copy" return value for copy_from_user()
  * NET: Fix race in dev_close(). (Bug 9750)
    - LP: #301608
  * IPV6: Fix IPsec datagram fragmentation
    - LP: #301608
  * IPV6: dst_entry leak in ip4ip6_err.
    - LP: #301608
  * IPV4: Remove IP_TOS setting privilege checks.
    - LP: #301608
  * IPCONFIG: The kernel gets no IP from some DHCP servers
    - LP: #301608
  * IPCOMP: Disable BH on output when using shared tfm
    - LP: #301608
  * IRQ_NOPROBE helper functions
    - LP: #301608
  * MIPS: Mark all but i8259 interrupts as no-probe.
    - LP: #301608
  * ub: fix up the conversion to sg_init_table()
    - LP: #301608
  * x86: adjust enable_NMI_through_LVT0()
    - LP: #301608
  * SCSI ips: handle scsi_add_host() failure, and other err cl...

Changed in linux:
status: Fix Committed → Fix Released
Bigfoot77210 (bigfoot77210) wrote :

Hi, coretemp doesn't seems to work with Atom N270 processors.
However, I get it run by changing the line 419 of its source code from:
   (c->x86_model == 0x16) || (c->x86_model == 0x17) {
to
   (c->x86_model == 0x16) || (c->x86_model == 0x17) || (c->x86_model == 0x1C))) {

I attached my new coretemp source file and the changes.

I don't know how to use "git", I'm sorry. Here is what it would look like…

coretemp changesline 413
 for_each_online_cpu(i) {
  struct cpuinfo_x86 *c = &cpu_data(i);

−− /* check if family 6, models 0xe, 0xf, 0x16, 0x17 */
++ /* check if family 6, models 0xe, 0xf, 0x16, 0x17, 0x28 */
   if ((c->cpuid_level < 0) || (c->x86 != 0x6) ||
      !((c->x86_model == 0xe) || (c->x86_model == 0xf) ||
-- (c->x86_model == 0x16) || (c->x86_model == 0x17))) {
++ (c->x86_model == 0x16) || (c->x86_model == 0x17) || (c->x86_model == 0x28))) {

Steve Beattie (sbeattie) wrote :

Bigfoot77210: this bug has already been closed, please open a new bug against the linux package and attach your fix there. Thanks!

Changed in lmsensors:
assignee: Colin King (colin-king) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers