Jaunty Alpha 5, Hardy: Sound level low, poor sound quality on Macbook Pro

Bug #234165 reported by Helminthe on 2008-05-22
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Stregatto

Bug Description

One of the reasons for purchasing a Macbook has been its very good speakers, using OS X they sound louder than any other notebook I've owned, good bass, low noise. Using Ubuntu on the same system, I get a somewhat "metallic" distortion, and the maximum output level is way below the one on OS X. Alsa appears to work, pommed controls the Fn keys, but I only get 3 usable steps in the sound mixer (80,90 and 100%), below those it's almost muted.
Kernel 2.6.24-16-generic, all available updates installed.
lspci -v:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
        Subsystem: Apple Computer Inc. Unknown device 00a0
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at 9b500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0

Helminthe (helminthe) wrote :
Daniel T Chen (crimsun) wrote :

Please run the alsa-info.sh debugging script noted on the DebuggingSoundProblems wiki page, and attach the debugging output (in /tmp) to this bug.

Changed in alsa-driver:
assignee: nobody → crimsun
status: New → Incomplete
Helminthe (helminthe) wrote :

Sorry, didn't see that page, output attached. Thank you for your help.

Helminthe (helminthe) wrote :

FYI, I have just installed alsa-1.0.17rc2 (modules, firmware, lib, utils) and there is no improvement.

Helminthe (helminthe) wrote :

The report above is wrong, it seems, the output of alsa-info.sh shows
Driver version: 1.0.16
Library version: 1.0.17rc2
Utilities version: 1.0.17rc2

Modules install seemed to go OK though, is there something similar to /etc/default/linux-restricted-modules-common for alsa?

Helminthe (helminthe) wrote :

I have just noticed (simply didn't need this before) that the microphone is muted. I have played with alsamixer, kmix, artscontrol, krec, audacity - absolutely no sound input. I don't know how to debug this problem, everything in the interface of the applications tried suggests that the input channels are there and they are not muted.

Daniel T Chen (crimsun) wrote :

Many of your audio issues should be addressed in upstream alsa-kernel git. Will you try a git snapshot of alsa-driver, please?

Lennart Regebro (regebro-gmail) wrote :

It seems to me that the issue with low level and poor sound quality is because the third speaker of MacBooks aren't used. This is reported in this alsa-bug:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4086

I can confirm this bug for Ubuntu 9.04 Alpha 5 64-Bit with all updates as of today. There have been issues with Ubuntu and this MacBook Pro rev. 3 here in the past (eg one day after some update I couldn't get any sound any more at all), and sound quality has been low and max volume has been too low in the past. But now when I start the new 9.04 system the sound is even far worse than with 8.10. It's like rough and slightly crackling. No good at all.

Seems to me sound has been far better when I booted up the system for the first time. I haven't done any substantial changes on the system since then except for installing the proprietary Nvidia-180 driver (I would have tried the Nouveau open source driver but the installation routine did not offer to do so.)

Changed in linux:
status: Incomplete → Confirmed
Download full text (26.8 KiB)

:~$ cat /proc/asound/cards

tells me:

----
 0 [Intel ]: HDA-Intel - HDA Intel
                          HDA Intel at 0x9b500000 irq 20
----

bash utils_alsa-info.sh --no-upload (the wiki says you'd have to type "bash alsa-info.sh --no-upload" but this is obviously wrong) outputs a alsa-info.txt which says:

----
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.56
!!################################

!!Script ran on: Mon Mar 9 18:17:16 UTC 2009

!!Linux Distribution
!!------------------

Ubuntu jaunty (development branch) \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu jaunty (development branch)"

!!Kernel Information
!!------------------

Kernel release: 2.6.28-8-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: unknown
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.18rc3
Library version:
Utilities version: 1.0.18

!!Loaded ALSA modules
!!-------------------

snd_hda_intel

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x9b500000 irq 20

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:284b (rev 03)
 Subsystem: 106b:00a0

!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-usb-caiaq: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2

!!Loaded sound module options
!!--------------------------

!!Module: snd_hda_intel
bdl_pos_adj : 1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : 0
id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
model : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
position_fix : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
power_save : 0
power_save_controller : Y
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1...

David Murrell (david-murrell) wrote :

This is posted to the end alsa bug report, but I figure since I wrote it, then I should be able to post it where ever I like :)

On my Macbook 4,1, running a stock Ubuntu 8.10, kernel 2.6.27-11-generic, alsa version 1.0.17
The magic options bit that makes bass work on mine is a kernel option when inserting the snd_hda_intel module:

model=asus-a7m

The PCM level seems to control some(all, maybe) of the bass woofer. I'm not sure if all of the woofer is entirely all there though. Might be, would need to get two macbooks next to each other with the same piece of music to see. My hunch is that it isn't. Its more bassy than than the auto detected config, however.

David Murrell (david-murrell) wrote :

Argh, I'm a retard, and posted the above to the wrong bug report. Sorry about that. Still, that options tag might help on 9.04, haven't tested.

Sherry Howell (sherryhowell50) wrote :

This does work, but unfortunately it also disables the external speaker plug.

David Murrell (david-murrell) wrote :

Interesting - does it fix the sound quality issues though?

I did not try any "fix". I just want to confirm that the volume level is very low under Jaunty on a MacBook Pro 5,1 (with all output channels set to maximum of course).

Also, not to be forgotten is the *only-right-speaker* output issue. But this is another "bug" !?

Cheers, Nikos

Joel Duckworth (joel-jpd) wrote :

I have a Macbook 3,1 and can confirm that this is still an issue with Jaunty. Just a side note that you can get a bit more volume from the speakers by putting up the 'front' channel in the volume control. It's still really tinny though.

A patch has been released for ALSA 1.0.19 that fixes this issue.

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4086

See here for links to instructions of how to install this for testing.

https://help.ubuntu.com/community/MacBook3-1/Intrepid#Subwoofer%20fix

Now we need to push this fix for inclusion in 1.0.20 and Ubuntu 9.10.

Does the fix apply to MBP5,1?

Thanks, Nikos

If the sound chip is the same as in the Macbook 3/4, then yes. Otherwise probably not.

Helminthe, thank you for reporting this and helping make Ubuntu better. Hardy desktop reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue on a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: hardy jaunty kernel-sound needs-upstream-testing
Changed in linux (Ubuntu):
assignee: Daniel T Chen (crimsun) → nobody
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.