[intrepid] Ubuntu 8.10 will not boot Live on IBM ThinkPad A21p - CPU 1 soft lockup

Bug #231455 reported by Adam Honse on 2008-05-17
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

My older laptop (IBM ThinkPad A21p) ran perfectly well in Ubuntu 7.10. This laptop has an ATi Rage Mobility 128 M3 (16MB) graphics chip that uses the "ati" or "r128" driver. It has a 1600x1200, 15.4" LCD and a VGA output. When I got my 8.04 CD, I put it in and booted up to a horribly scrambled mess of a display. The screen was divided up into 3 sections and it was mostly unusable because you can't see anything. I took pictures of what happened and attached them to this report. I then rebooted and used "safe graphics mode", which allowed me to install it (low resolution, but it didn't scramble the display). After installing, I booted up to even more screen resolution errors, as the login screen doesn't show correctly (also pictured below) and it only detects 800x600 as the highest resolution (also pictured). When I attached a 1280x1024 CRT monitor to the VGA port, the laptop would allow me to select 1280x1024 as the maximum resolution and would display at that resolution on both the CRT and the built in LCD panel (but not at 1600x1200, only 1280x1024). I unplugged the VGA monitor, logged out, and logged back in and it is again stuck at 800x600.

Since 800x600 is practically unusable, this bug has forced me to use Windows XP on this computer, which I don't want to do. I like Ubuntu much better but with an unusable resolution it's practically useless. 8.04 worked fine on all of my other PC's (including my new HP dv9700t laptop), it only failed on my ThinkPad.

Adam Honse (calcprogrammer1) wrote :
Adam Honse (calcprogrammer1) wrote :

Ok, fixed it using the "Screens and Graphics" utility (unfortunately located in /usr/share/applications and removed from the System -> Applications menu where it should be...if you're going to hide the manual configuration, at least make an automatic system that actually WORKS...otherwise just let people use manual. Automatic is supposed to reduce the amount of configuration and searching people need to do, not increase it!)

rinconj (rincontek) wrote :

I have a few A21p and A22p and have encountered the same problem. I tried to run displayconfig-gtk, but it then asked me for the driver. Do I need to install other drivers? Can you tell me more details about
the procedures? I plan to have all 3 A21p/A22p running the same Ubuntu 8.04, but I'm still stuck with the first one.

peoitibble (peoitibble) wrote :

I also fixed it by using the "Screens and Graphics" utility.
I choosed the screen "LCD 1024 x 768" and the graphic card "vesa",
Now the A21p work good in the resolution 1024 x 768

Adam Honse (calcprogrammer1) wrote :

The A21p has a native resolution of 1600x1200...if you're only using 1024x768, you're really underusing the screen. Also, the A21p has an ATi Rage Mobility 128 M3 graphics card that is supported under the "ati" and "r128" drivers. You can get OpenGL acceleration by changing DefaultDepth to 16 instead of 24 (guess there's some kind of bug with 3d acceleration at 24 bit depth). Once you set the driver to ati, you can use Screens and Graphics to up the resolution to the native 1600x1200 and it'll work fine.

Adam Honse (calcprogrammer1) wrote :

GAAAAAH!!!!!!!!!! WHO MESSED UP 8.10??????? I install 8.10 hoping for a nice refresh, but instead I'm met with a horrible decision on the package management team to REMOVE SCREENS AND GRAPHICS!!!! Seriously, WTF! Not every monitor/graphics chip autodetects properly, we already determined that with 8.04. There's no reason to eliminate SaG just because most people are autodetected. Now those of us who were stuck using it to override the FAULTY autodetection are stuck...completely! Where can I get a .deb of SaG to fix my stupid computer?

GAH! It makes me mad when they eliminate perfectly useful applications for no apparent reason. This was a dumb move. Get Screens and Graphics back into the repos or get the autodetection routine to detect my 1600x1200 monitor as what is, not some pathetic 800x600 unusable resolution.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Socrates470BC (cdrummond) wrote :

Could not install Ubuntu 8.10 or 8.04 on my IBM Thinkpad A21p Laptop. The screen appears in three segments, I cannot see which options to select, or see how to fix this. My screen has a 1600x 1200 resolution. I also tried Centos 5.2, but this has the same problem. Even worse, I overwrote Windows 2000 and could not install Windows XP SP2 as it hung halfway through "installing drivers" with 35 minutes still to go!

If there is a solution to this , I would certainly like to see a speedy fix.

I have updated the thinkpad BIOS to 1.11 (The latest version).

The screen fills with messages like:
[258.772014] BUG: soft lockup - CPU #0 stuck for 61s!

Download full text (3.2 KiB)

Hello
There is a fix for your problem but you need to work a little without
seeing a correct screen.
* In the startup screen in Ubuntu you give User and Password (with a
corrupt screen)
* In the Ubuntu desktop screen you try to start a terminal window (It
is not easy with a corrupt screen)
* In the terminal you give the input: sudo nautilus
* Go to /usr/share/applications and start "Screen and Graphics" (
* In "Screen and Graphics" you choose graphic driver (vesa works good
for my A21p) and what screen you have (I use LCD)
* Now you have a correct screen and when you start the computer next
time the screen is correct.
Good luck
Per-Olof Thureson

3 dec 2008 kl. 10.41 skrev Socrates470BC:

>
> Could not install Ubuntu 8.10 or 8.04 on my IBM Thinkpad A21p
> Laptop. The screen appears in three segments, I cannot see which
> options to select, or see how to fix this. My screen has a 1600x
> 1200 resolution. I also tried Centos 5.2, but this has the same
> problem. Even worse, I overwrote Windows 2000 and could not
> install Windows XP SP2 as it hung halfway through "installing
> drivers" with 35 minutes still to go!
>
> If there is a solution to this , I would certainly like to see a
> speedy
> fix.
>
> I have updated the thinkpad BIOS to 1.11 (The latest version).
>
> The screen fills with messages like:
> [258.772014] BUG: soft lockup - CPU #0 stuck for 61s!
>
> --
> ThinkPad A21p - Screen Resolution Problems
> https://bugs.launchpad.net/bugs/231455
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xorg” source package in Ubuntu: Incomplete
>
> Bug description:
> My older laptop (IBM ThinkPad A21p) ran perfectly well in Ubuntu
> 7.10. This laptop has an ATi Rage Mobility 128 M3 (16MB) graphics
> chip that uses the "ati" or "r128" driver. It has a 1600x1200,
> 15.4" LCD and a VGA output. When I got my 8.04 CD, I put it in and
> booted up to a horribly scrambled mess of a display. The screen
> was divided up into 3 sections and it was mostly unusable because
> you can't see anything. I took pictures of what happened and
> attached them to this report. I then rebooted and used "safe
> graphics mode", which allowed me to install it (low resolution, but
> it didn't scramble the display). After installing, I booted up to
> even more screen resolution errors, as the login screen doesn't
> show correctly (also pictured below) and it only detects 800x600 as
> the highest resolution (also pictured). When I attached a
> 1280x1024 CRT monitor to the VGA port, the laptop would allow me to
> select 1280x1024 as the maximum resolution and would display at
> that resolution on both the CRT and the built in LCD panel (but not
> at 1600x1200, only 1280x1024). I unplugged the VGA monitor, logged
> out, and logged back in and it is again stuck at 800x600.
>
> Since 800x600 is practically unusable, this bug has forced me to
> use Windows XP on this computer, which I don't want to do. I like
> Ubuntu much better but with an unusable resolution it's practically
> useless. 8.04 worked fine on all of my other PC's (including my
> new HP...

Read more...

Hi,
Can you please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt.

Also can you let us know if the above workaround works please?

Thanks in advance.

Socrates470BC (cdrummond) wrote :

First: remember that 8.10 will not install at all because of the
[258.772014]BUG: soft lockup -CPU #0 stuck for 61s ! problem.

Second: although you may know all the ins and outs of this system, I was attracted to Ubunto because of ease of use. What appears to be required is not for novices.

Third: Even if I get 8.04.1 to install, would I then be unable to upgrade to 8.10 without having all of these problems return?

I have wasted two days trying to get this working, so unless there is going to be a patched version that fixes the problem, then I doubt whether Ubunto is going to work for me.

@Per:
Thanks Per, I did try to do everything as you described, but as you know it may not have gone exactly as you would expect. I ended up with my screen going completely white and not being able to see anything

@Teej:

I cannot get the O/S to work so operations like cut and paste, or print, or attach to post, or connect to internet are not possible.

Socrates: It seems you are having a different problem. This bug report is about an X display problem, you cannot boot which may relate to the kernel. Please find another bug.

CalcProgrammer: Can you provide the above logs for me please and let us know if the above workaround works for you

Thank you.

Could you please grab a copy of the latest 8.10 CD from http://www.ubuntu.com/getubuntu/download and try the Live environment?

If your screen resolution doesn't work right away, please execute these commands and upload the files created to this post using the Live environment.

sudo tar czf x11.tgz /etc/X11
glxinfo > glxinfo.log
lspci > lspci.log

Please give us these files and as much detail as you can to help us find out why there is an issue with your hardware.

Socrates470BC (cdrummond) wrote :

Note: I had to use 8.04.1 due to other problems with 8.10

I also had to $ cp glxinfo.log /media/DISKETTE before uploading the file to you

Socrates470BC (cdrummond) wrote :

lspci.log attached

I would appreciate getting this information from CalcProgrammer1 since he's the original reporter. We need this information using the 8.10 CD.

Can you also attach x11.tgz as requested above please
Thank you.

Socrates470BC (cdrummond) wrote :

@teej:

I have the problem described in this thread with 8.04.1

I have additional problems with 8.10 which prevents me using it at all.

OK no problem.
Socrates, can you then file another bug report for the booting problem for 8.10, as chances are the display problem was fixed for you in that version, but until we can get you booted we cannot verify that.
Also CalcProgrammer1, we need your info as you are the original reporter please as soon as possible as after 4 weeks at the most, bugs are marked Invalid, and without your info we cannot verify that the other users on this report are experiencing this problem from the same root cause.
Thankyou.

We need some accurate information. This bug report is passing the point of just Incomplete. I personally feel Invalid is an appropriate state for this since we don't have any accurate or relevant information per requests.

Socrates470BC (cdrummond) wrote :

x11.tgz attached

Socrates, can you please do as the Bug Control Team have asked and report your problem under another report, this is not the same problem with 8.10
Thank you.

Changed in xorg:
status: Incomplete → Invalid
Changed in xorg:
status: Invalid → Incomplete
Socrates470BC (cdrummond) wrote :

@Michael:

It appears that you are suggesting that the bug is invalid because you can't figure out the solution. The bug (not being able to view the screen properly) makes the system very difficult to operate and almost impossible to provide good diagnostic information, but please be assured that it very definitely is a bug. It is a bug of MAJOR proportions and you can either pretend that it does not exist and force potential users to proceed as if Ubuntu does not exist either, or you can fix the BUG.

In order to diagnose and fix this bug you are reliant on potential users to be both patient and persistant. As stated earlier, I have spent the past two days trying to work out the problems, that is a significant investment of my time. No doubt others who have reported this BUG have also invested heavily with their time.

In this repect, I very much appreciate the efforts of those who have found solutions that work for them and the people who are working on trying to fix the problem now.

What you don't know at the moment, is how many people just gave up and moved on.

I have uploaded several screen pictures to help everyone visualise the problem. You can find these pictures at the following URL's:

http://www.ratingsworld.co.uk/public/Ubuntu1s640x470.jpg
http://www.ratingsworld.co.uk/public/Ubuntu2s640x490.jpg
http://www.ratingsworld.co.uk/public/Ubuntu3s640x498.jpg

As you can see the sceen is split into 3 segments. The segments are non-contiguous. The cursor does not work in the left or right segments, and one has to try and manipulate the middle segment to bring into view the information required. Unfortunately you cannot always see what you need and spend much of the time working blind.

Socrates,
We are setting this now to your booting problem with Intrepid 8.10 as the original reporter has not got back to us.
Am I right that you cannot boot at all with 8.10 or is it the video 3 section issue?
For the 3 section issue, can you go to https://wiki.ubuntu.com/DebuggingCasper and follow the instructions there for us and attach each log file as a separate attachment please?

Thank you very much and good luck! :)

Socrates470BC (cdrummond) wrote :

I noted that canonical have a place in the UK.

Would it be helpful if I sent my PC to the UK office and let them se the problems first hand. This would allow them to check both problems with both 8.04.1 and 8.10 and then return the PC to me, hopefully with a working version of the Latest Ubunto.

Let's face it not everyone has problems and getting things to work on an old IBM Thinkpad A21p may not be a priority.

However, I do think that many people are looking to get some further use out of their older PC's and Laptops.

Socrates470BC (cdrummond) wrote :

Using Ubuntu 8.10, all I can get is the following is a bunch of error messages. See Picture at:

http://www.ratingsworld.co.uk/public/Ubuntu4.jpg

Adam Honse (calcprogrammer1) wrote :

Got my A21p running 8.10 fine, though I had to jump through quite a few hoops to fix it. First, I had to reinstall 8.04 (the original bug for this thread was under 8.04). It still had the issues, but I could use Screens And Graphics in 8.04 and got a working xorg.conf after using it. I then saved the xorg.conf to my flash drive and installed 8.10 again. 8.10 was stuck at 640x480 as usual, but pasting in the xorg.conf fixed it. I can post the xorg.conf if you want.

As for the three bars issue when using the Live CD, make sure you use Safe Graphics Mode (press F4 when booting I think), that works on the 8.04 and 8.10 CD's. I don't have time right now to test using a new CD, but maybe I can try this weekend if there is a new CD.

Confirming and Assigning to Kernel Team.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Confirmed
Richard Seguin (sectech) on 2008-12-04
Changed in linux:
importance: Undecided → Medium
Adam Honse (calcprogrammer1) wrote :

Here's my working xorg.conf for A21p (ATi Mobility Rage 128 M3, 1600x1200 LCD). It was made by Screens and Graphics in 8.04 but also works in 8.10, which I am using now.

Adam Honse (calcprogrammer1) wrote :

In response to Socrates470BC:

"Using Ubuntu 8.10, all I can get is the following is a bunch of error messages. See Picture at:

http://www.ratingsworld.co.uk/public/Ubuntu4.jpg"

What kind of networking card does your A21p have? They had a few different versions (all of which are miniPCI cards). Mine has the modem only (the Ethernet port is covered on mine). Since it's a NetworkManager error (seems to be anyways), see if your A21p has the combo card (both modem and Ethernet, easy to tell because you'll have a working Ethernet port on the back of your machine). Also, if you have any USB or PCMCIA network cards inserted, remove them (my Broadcom WiFi PCMCIA throws errors if the drivers aren't installed).

Adam Honse (calcprogrammer1) wrote :

Disregard the first xorg.conf, this one supports OpenGL acceleration (can only use 16 bit color if you want accelerated 3d though, so this one will only use 16 bit color).

Socrates470BC (cdrummond) wrote :

@CalcProgrammer:

Using installed version 8.04.1, I managed to copy your xorg.conf file.
I then shutdown the system and rebooted.
Screen now working fine on 8.04.1

I am not sure about updating to 8.10 until I can figure out what is going on.

Looking at the bottom of the laptop, there appears to be a lot of screws, and I am not too sure about taking the laptop apart.

Next step is to figure out how to get the Netgear PC Card working (WG511 v2).

I have the initial CD I got from netgear and can locate the WG511v2.INF file under the drivers/windowsxp directory on the cd.

I found this post: http://ubuntuforums.org/showthread.php?t=76804

I also read the help info (for Using Windows Wireless Drivers) but could not find a package called ndisgtk under
System -> Administration -> Synaptic Package manager.

The good news is that, thanks to you guys for sharing your knowledge, we have something that works and can build on.

Adam Honse (calcprogrammer1) wrote :

Just look at the back of your A21p. Is there a cover over the Ethernet port? If there is, you have the modem only card, if not, you have the full combo card.

8.04 and 8.10 both have Linux drivers (not having to use Windows ones) for most network cards (WiFi). Plug in your card and go to System-Administration-Hardware Drivers. Have it scan for drivers and it may find restricted drivers (often Broadcom for WiFi cards) that work with your card.

Socrates470BC (cdrummond) wrote :

@CalcProgrammer:

I have the full combo card.

System -> Administration -> Hardware Drivers

Window states: No proprietory drivers are in use on this system. (No options to perform a scan)

I did download ndiswrapper-1.53.tar.gz to my windows xp machine and I do have the WG511v2.INF file on the installation CD that came with the Netgear WG511v2 PC Card. Even if these files are of any use, I am not sure what to do with them. Not even sure what to do with the tar file.

If I can get the network card working and connect to the internet, I would be pretty happy.

Over the moon if I could then access files on the Ubuntu machine and copy them over to the windows PC's. Really setting up a shared drive or directory on the Unbunto Laptop would be perfect.

Adam Honse (calcprogrammer1) wrote :

Does the Ethernet part of the combo card work (can you connect if you plug your ThinkPad [running Ubuntu] into the network?) If it does, you can make a shared folder on your Ubuntu machine by right clicking a folder and sharing it. You can also access shared folders using Places -> Network.

What kind of card is the WG511v2? Can you only connect over WiFi (if the ThinkPad has internal Ethernet, you shouldn't need a wired PC card)? I have a Buffalo WLI-CB-G54S WiFi PC card that works fine in mine, also have a D-Link PC Card Ethernet (since mine doesn't have the combo card) which also works fine. What happens when you connect the PC card to your ThinkPad while it's running Ubuntu? Try restarting the machine, leaving the card in while it starts up, see if any drivers show up in the restricted thing.

Socrates470BC (cdrummond) wrote :

The ethernet part worked when windows 2000 was installed, but I have no wired ethernet connection available when using the laptop, only wireless.

I did an iwconfig, and got:

lo no wireless connections
eth0 no wireless connections
rfd0 no wireless connections

The WG511 is an 801.2b/g wireless PC card made by netgear

I think if I can untangle the tar file ndiswrapper-1.53.tar.gz which I downloaded to my windows PC, and install ndiswrapper, then I would be able to install the W511v2.INF file (the driver). Previous threads have suggested that the install package used to be on the Ubuntu release CD, but apparantly it is no longer there.

Adam Honse (calcprogrammer1) wrote :

Hmm...that may be more of an issue than I thought. The W511v2 apparently uses a Marvell chipset (never heard of them) and there may not be a native Linux driver. I know Broadcom and Intel chipsets work out of the box on Ubuntu (Broadcom's need to connect first to download drivers, but this is automatic). You may have to use the Ndiswrapper to get it right. You could try connecting to a wired Ethernet network (temporary, just disconnect your desktop or something) and doing an update using Update Manager, then trying out Hardware Drivers to see if it comes up with anything. If this doesn't work, you may be stuck using ndiswrapper. If all else fails, you can get a different PCMCIA WiFi card (they're cheap these days), preferably something Broadcom based or even better Intel if they make external ones.

Socrates470BC (cdrummond) wrote :

@CalcProgrammer:

Thanks for all of your help. I have a system than I can use with the open office application that will boot up in only a couple of minutes.

I can use Ubunto , but I will not be able to connect to anything via a wireless connection.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
@The Ubuntu Marketing effort and those wanting to promote the use of Ubuntu.

I used to install Unix on NCR Tower 32's and Xenix on intel 286 machines over 25 years ago and never did it take more than 3 or 4 hours to get everything working. I had intel 286 machines supporting up to 8 vt100/vt220 type terminals. Admittedly, we used to pay around $2,000 per operating system for each machine.

The past week has been very frustrating and if operating systems like Ubuntu want to make any real progress, then they need to work much harder to ensure new users are not faced with so many roadbloacks. But I said that back when Microsoft was a baby and the Unix community then were oblivious to the competition and any concept of user friendly interfaces. Unfortunately not much has changed.

After downloading ndiswrapper, finding out how to set the root password (http://ubuntuforums.org/showthread.php?t=954209&highlight=root+password), how to use tar to unzip ndiswrapper-1.53.tar.gz, and then following the instructions on what looked like a very promising wiki entry (http://wiki.linuxquestions.org/wiki/NDIS_Wrapper), I finally succumbed when the make command yielded a number of errors which prevented any further progress.

The inability to support many of the existing wireless network cards out there will obviously have an impact on the take up of operating systems like Ubuntu. There is a huge market out there for an operating system and applications that can make use of old computer hardware that no longer has sufficient horsepower to run modern day windows systems.

I am not going to purchase a new network card that has linux drivers as the cost of new system with windows vista will give me everything I want with up to date processors and applications. The market for Ubuntu is not really low cost, it is no cost. The time I have spent trying to get Ubuntu working would have paid for a new computer system.

Adam Honse (calcprogrammer1) wrote :

I agree with the no cost thing, though since I was in high school at the time I bought my A21p (used on eBay cause it was cheap and I wanted a laptop), I figured a $20 network card to get it all working was worth it. Hopefully a Marvell driver will come soon so you can use wireless on your laptop, drivers are always being released (8.10 finally made my ATi graphics work when it didn't on any older version) so just keep updating. I'd suggest moving to 8.10 if you can.

peoitibble (peoitibble) wrote :

I use a Netgear W511T WiFi card without any problem with my A21p. It worked out of the box without any modifications. Perhaps W511 is produced in several versions?. I thought it has a Atheros chip.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

LonghornDave (davefaver) wrote :

After a great experience with my old Thinkpad A21P and Ubuntu 7.10, the move to 8.10 was a disaster.

1) My router uses 64-bit WEP, and I could not connect.
     Networking was all messed up after the upgrade, and nothing would work.
     After a fresh install of 8.10, with no 64-bit WEP option
     My kid uses the his DS on the internet, so I must stay at 64-bit.

2) After the fresh install, I had the triple-screen problem with the video.
     Spent several hours trying to fix it. Eventually got VESA to work, but could not
     get the external display hot key to work.

3) Going back to 8.04 did not improve things.

4) Reinstalled 7.10, and everything is back to working great.

I use this laptop for boy scout activities. It's great because I don't worry much about it getting damaged.
I am teaching a class at a camp after Christmas, using a Powerpoint. I guess I'll just stay at 7.10 until
the laptop dies.

Berra (bereri) wrote :

Thanks to CalcProgrammer1, who posted a working xorg.conf-file, I can now for the first time in years make use of
my old IBM A21p. It works with the resolution it's made for (1600x1200) and it looks just great. Now there is no excuse
not to try out Linux/Ubuntu.
CalcProgrammer1 ... you are my hero!!! ;-)

Changed in linux:
status: Confirmed → Fix Released
Adam Honse (calcprogrammer1) wrote :

Bug persists in 9.04 despite Fix Released status. I booted the i386 ISO (from Ubuntu's torrent) and sure enough the messed up "split screen" error was still there. Using safe graphics mode I installed 9.04 but it only detects 800x600 (as it did in 8.10 before the status changed) and I still had to download my xorg.conf that I posted here to get the screen mode right. This bug is still a problem and has NOT been fixed in 9.04. The status needs to be reverted.

">>CalcProgrammer1

Bug persists in 9.04 despite Fix Released status. I booted the i386 ISO (from Ubuntu's torrent) and sure enough the messed up "split screen" error was still there. Using safe graphics mode I installed 9.04 but it only detects 800x600 (as it did in 8.10 before the status changed) and I still had to download my xorg.conf that I posted here to get the screen mode right. This bug is still a problem and has NOT been fixed in 9.04. The status needs to be reverted."

Confirmed here on IBM ThinkPad A22p, installing from 9.04 standard/advanced isos.
Using my desktop and managing to browse, copy and paste through the tri-splits, I saved Calc's xorg over mine, and after a reboot seems to be functioning just fine once changed to 16x12.

Not sure if this is helpful to anyone, of course, as Calc has done all the work here, but just wanted to put another voice in on the new j-j release still having this bug.

Posting again to note that I just used this config to attain a correct resolution on my a22p, in crunchbang, derived from 8.10ub..

Surprisingly, the split up screen only happens on startup prior to the fix, and is corrected at the login screen and further.

After applying the changes to xorg through sudo gedit, I have full resolution of this beautiful peice of kit, aswell as no more tri-screen garbage. :D

Thanks again!

mightbej (info-czinkota) wrote :

I tested it this morning with ubuntu 9.10. Still the same problem - splitted screen.
Still the same solution: copy the xorg.conf file to /etc/x11 restart gnome - its working again.

Thanks again.!

Thanks mightbej, and sorry no-one has got back to you all, I have been very busy. calcprogrammer, can you attach the xorg file, but attach it as a patch with the checkbox for it checked, this can be set Triaged, moved onto the xorg team, and hopefully implemented! Thank you.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
mightbej (info-czinkota) wrote :

The Screen is not splittet any more, but now it does flicker very often. Looks like a global refresh from the Window Manager.
I tried Ubuntu 9.04 again, this effekt does not happen there. So it seems to be 9.10 specific. Any explaination or a solution for this?

Thanks

mightbej, in Karmic please run apport-collect -p xorg 231455 and let it pull in the information. Thanks.

Adam Honse (calcprogrammer1) wrote :

Sorry for being late, I wasn't available this weekend. Here's the xorg.conf I posted before. I haven't had a chance to put 9.10 on my A21p yet but I will either this week or next weekend and then I can post how things went and methods I may have taken to get it working.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu version (10.10). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect <bug #>, and any other logs that are relevant for this particular issue.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers