SATA devices don't work with Asus M3N78-EH

Bug #231159 reported by Sense Egbert Hofstede on 2008-05-16
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I've just upgraded to a new motherboard. I went from an Asus M2NPV-VM to an Asus M3N78-EH with Geforece 8200 and nForce 720a or nForce 730a chipset. It has one IDE port supporting two IDE devices and six SATA ports supporting six SATA devices. Unfortunately the SATA devices don't work. When I tried to boot my system again it couldn't find the harddisk. It did detect it in some way at the boot(which I discovered after removing the splash and quiet boot options) but something times out, it retries after 5 seconds and times out again until it has repeated too often. At a LiveCD I do get booted in the DE, at my base install I get a BusyBox and the message that the /dev/{long UUID} can't be found.The UUID is from the SAYA harddisk. The sata harddisk is an Maxtor Diamondmax 17 SATA II with 160GB storage. I'm now attaching two tarballs, the first contains some error logs from the LiveCD, the second tarball contains some log files from the new install I made on an IDE harddisk. During the first logs I did have the SATA harddisk connected, during the second not.
I'm going to attach the output of dmidecode as soon as possible.

Sense Egbert Hofstede (sense) wrote :
Sense Egbert Hofstede (sense) wrote :
Sense Egbert Hofstede (sense) wrote :
Sense Egbert Hofstede (sense) wrote :

It gets a 'qc timeout' and tells me it can't IDENTIFY when it's '*Loading Hardware Drivers'. I hope this little bit of information can help you.

Sense Egbert Hofstede (sense) wrote :

It does work with OpenSolaris 5.1 and Windows XP SP2 so it's not a BIOS mistake.

Iulian Udrea (iulian) on 2008-05-25
Changed in linux:
importance: Undecided → High
status: New → Confirmed
Jarek (jarhuba) wrote :

Your bug looks similar to mine bug report:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/189987

Patch for this bug probably is committed to linux 2.6.26-rc8
I'm waiting for package with this kernel for testing.

Sense Egbert Hofstede (sense) wrote :

This bug is fixed now! At least it works with 2.6.24-20, which is in hardy-proposed now, I'm not sure when it started working, I just tried after I upgrade a clean install and swapped the old motherboard for this. SATA does work now, IDE doesn't.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jarek (jarhuba) wrote :

For my ABIT AN52 all is OK. I tested Intrepid Alpha5.

Sense Egbert Hofstede (sense) wrote :

I was wrong with PATA/IDE not working, it turned out my CD/DVD burner was broken. This is fixed in 2.6.24 and probably in 2.6.27 too, although I didn't test that.

Based on the above comments, I'll go ahead and close this report. Thanks.

Changed in linux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers