kill switch on with intel wifi 4965

Bug #230844 reported by Fernando Miguel on 2008-05-15
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Fernando Miguel

Bug Description

HI there.
I've bough a new laptop (an ASmobile S37S, asus barebone) that has an Intel 4965 ABGN.
I've search ubuntu foruns, lp, and googled all I could, but am unable to make the kill switch off, in order to turn the wifi on.
The card is well identified by the kernel, but there is no way to make it seen to NetworkManager, or even turning on the led.

Also when I tried to use ndiswrapper, it cause a back trace during the boot, and I was forced to use the LiveCD to uninstall it.

$ uname -a
Linux BluBUG 2.6.24-17-generic #1 SMP Thu May 1 13:57:17 UTC 2008 x86_64 GNU/Linux
$ sudo rmmod iwl4965
$ sudo modprobe iwl4965
$ sudo lspci | grep 4965
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

is this in anyway related?
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1209
[quote]
 ------- Comment #44 From Jack Malmostoso 2008-01-22 03:00:28 -------

I have installed 2.6.24-rc8 from the Debian trunk tree (http://wiki.debian.org/DebianKernel) and while leds do not work, the kill switch is now set to "0". It is still not possible
to toggle it but at least now
wireless works.
[/quote]

https://bugzilla.redhat.com/show_bug.cgi?id=240116#c4

Comment #4 From John W. Linville on 2007-05-15 14:58 EST
[quote]
Looks like iwl3945 is not polling SW-based RF kill switch. Please try this:
   echo 0 > /sys/class/net/wlan0/device/rf_kill
[/quote]

before this I need to remove and re-add the iwl4965 module

after the echo NetworkManager sees the wifi, but ifconfig doesn't.

I've installed boot chart to see if I could track down the problem. You can see the result here:
http://fileland.bugabundo.net/Linux/hardy-20080513-1.png

It seems that the Led turns of when X starts, so my guess is that some RC script is turning off the led and/or on the kill switch.

Any help is appreciated.

Thanks in advance.

description: updated
joenix (woutersj) wrote :

I have a Lenovo Thinkpad T61 with the same wireless network card. On 8.04 the card worked out of the box for me, except the indicator LED.

Hi Joenix.
Not mine, I've tried both 32 and 64 LiveCD, and even tried inetboot.

the Fn+F2 will not work neither will the wifi button.

after some messing around, and a few echos here and there, I finally was able to turn the kill switch off, and make NM see the WiFi card, and show up on iwconfig.
But still ifconfig didnt saw it, and I couldnt connect to anything.

With any other external USB dongle it works just fine.

with the new 2.6.26 kernel the leds are now OFF (they were always on with 2.6.24) and the buttons dont do anything again (for a time I could at least turn it on and off, after I did a few echos to the device)

soro2005 (soro) wrote :

I also have a S37S, and my wireless adaptar comes up in both Hardy 64 and Opensuse. Both the separate button and Fn+F2 kill the wireless adapter, but don't bring it up again. I can have the same effect by manually calling /etc/acpi/asus-wireless.sh (kills, but doesn't bring up again), so that I'm pretty sure that the problem is not with the wireless adapter, but with the acpi scripts.

The led's are a different issue. I can bring mine up by executing /etc/acpi/resume.d/60-asus-wireless-led.sh. Provided that the adapter is running, that is.

There are several other related bugs here and on the Debian bugtracker. I have tried to use the current acpi-support packages from sid to see whether the issue is solved upstream, but that borked it entirely.

I can, by the way, bring the wireless adapter back up again by resuming from suspension.

soro thank you so much for the extra input.
What kernel versions have you tried?
with 2.6.24.18 I was able to make my kill switch off, but the same method doesnt work with newer kernels.

:(

soro2005 (soro) wrote :

I am currently using 2.6.24-19 64 bit, but my wireless worked out of the box with the installation CD, the one from 32 bit, and with whatever kernel comes with the OpenSuse installer. Your problem may be a different one, but here, it is quite clearly not about the kernel, but about the acpi scripts that supposedly produce the hotkey actions. I can switch wireless off, but not on again.

Is there perhaps a setting in Bios you can change to boot the computer with wifi on?

Olá soro2005 e a todos.

On Tuesday 08 July 2008 14:03:40 soro2005 wrote:
>I can switch wireless off, but not on again.

With 2.6.24.18 I can turn it Off and On as I wish. but for that to work I had do and echo on the kill switch file.
Sorry I dont have the exact command with me...
But ifconfig never worked... only iwconfig

> Is there perhaps a setting in Bios you can change to boot the computer with wifi on?

If you have an S37S, you know that there is no option in the BIOS to change this.

--
BUGabundo :o)
(``-_-´´) http://Ubuntu.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net
ps. My emails tend to sound authority and aggressive. I'm sorry in advance. I'll try to be more assertive as time goes by...

i'm closing this, because after i took my laptop to the shop, and replace the wifi card, everything is fixed.
so it was hardware related.

Changed in linux:
assignee: nobody → bugabundo
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions