Ubuntu

system crash with hardy

Reported by zity on 2008-05-07
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.24

The system locks-up completely at random intervals.
The crash can be triggered by downloading mail with Thunderbird, but happens at any other activity after some random time.
No magic SysRq keys works, and there's nothing in the logs...

It's a 2.6.24-17-generic kernel, but the crash also happens with -16.
Everthing was fine with Gutsy on the same machine.

Booting with acpi=off makes the system work stable,
but acpi=noirq, acpi=ht, acpi=strict, noapic, nolapic, pci=noacpi don't help.

How to debug further ?

zity (zdevai) wrote :
zity (zdevai) wrote :
zity (zdevai) wrote :
zity (zdevai) wrote :

dmesg with acpi enabled

zity (zdevai) wrote :

dmesg with acpi=off

dreamstogo (hilary-bh-wright) wrote :

I am also experiencing this. Total lock up, nothing moves..

It seems to happen most frequently in Firefox when making a mouse click, either right, left or scroll. It doesn't happen if I don't touch the system.

The only way out is a system reset button. Then Ubuntu does a disk check, most often than not automatic fsck fails and I get sent to the console. Typing a fsck will fix the problems. Then you have to reboot.

This is TOTALLY unacceptable to a normal user.

To make matters worse, today I got a message saying that GDM could not be started. Again another reset to get the system back.

Guys, this has to be of a VERY HIGH priority!!!!!

Its getting to remind me of the good old windows blue screen days....

PS, I posted this also on 214108

Joe (fullmitten) wrote :

My bug, #227882 has been marked a duplicate of this one, so I will copy my latest findings over here.
I have an ATI 8500 video card. I get random hangs with Gutsy and Intrepid (though Intrepid is more stable).
If I disable DRI in xorg.conf, both Gutsy and Intrepid appear to be stable (over 8 hours of uptime with Intrepid vs. ~20 minutes). Of course, video performance suffers greatly. I'm watching Bug #141551, though that has to do with boots rather than run time hangs.
I see ziti has an ATI Radeon Mobility X600. Perhaps the Radeon driver is the cause?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Joe (fullmitten) wrote :

I got a hang after 58 minutes of uptime with the Intrepid Alpha 5 Live CD.
I installed openssh server and was able to get the logs and a screenshot of top running. After the hang, top reports that X takes up 97% of the CPU. Again, this post:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/141551/comments/14
describes something similar happening, but the original post is different.

Joe (fullmitten) wrote :

I think the problem my computer has is definitely the same as Bug #141551
Bryce Harrington's suggestion here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/141551/comments/39
works for me as reported here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/141551/comments/40

Thanks Joe. I'm going to go ahead an undup your original bug from this report and mark it as a duplicate of bug 141551 instead.

zity, since you are the original bug reporter, would you be able to test Intrepid to verify if this is still an issue? Thanks.

Changed in linux:
status: New → Incomplete
dreamstogo (hilary-bh-wright) wrote :

Hello, I reported above my experiences with hardy; I have now moved to Intrepid with the latest kernel 2.6.27.

I confirm the bug. I still get random system lockups. Three times today, same symptoms.

The third time it happened today something different did happen. No mouse clicks worked, yet the mouse cursor did continue to move for about 30 secs before also freezing.

Again, the only way out is to hard restart the system, then it does th disk checks and FSCK fails.

How can I help debug this?

Changed in linux:
status: Incomplete → New
zity (zdevai) wrote :

Just tried Intrepid, issue still exists with 2.6.27-7.
Can be triggered in various ways, e.g. hitting tab for bash auto-completion in a VT.
It's most probably not X related, as it also happens when X is not running.

Nothing in the logs, no led blinking, magic SysRq doesn't work.

zity (zdevai) wrote :

And found the reason: It's the pcspkr module.
Unloading it solves the hangs on the intrepid kernel. Not sure if it's the same issue as with the Hardy kernel, but
the symptoms are very similar.
Would be good to know what's the reason though.

There's also a related bug #146151 .

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
arielby (ariel-bys) wrote :

I got this bug with a Debian Lenny comp.

Reason: IDE connection "playing".

Reconnecting the IDEs fixes the "bug"

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Jeremy Foshee (jeremyfoshee) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/news/ubuntu-9.04-desktop . If the issue remains in Jaunty, Please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-2.6.28-11-generic 227806

If you could also test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine this issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

-JFo

Changed in linux (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-kernel-logs needs-upstream-testing
zity (zdevai) wrote :

As far as it concerns me, the bug is solved.
It was really hard to track down, but as mentioned above, the bug was in the pcspkr
and snd_pcsp modules, causing a hardlock on every system bell beep (bash auto-completion,
firefox search, thunderbird new mail, etc.).

The patch for snd_pcsp was already in 2.6.28, but the one for pcspkr only went into 2.6.29.
( http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=59bdb43769f2c3995badcd930d799451f5a39f76 )
(See also: http://bugzilla.kernel.org/show_bug.cgi?id=10347 )

So, Jaunty is still affected, workaround is to blacklist the pcspkr module.
Decide if you want to release a new kernel because of this, and feel free to
close this report.

Cheers,
zity

Keng-Yu Lin (lexical) on 2009-09-11
Changed in linux (Ubuntu):
status: Incomplete → Fix Released

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-16.57

---------------
linux (2.6.28-16.57) jaunty-proposed; urgency=low

  [ Leann Ogasawara ]

  * SAUCE: Enable speakers for Toshiba NB200 (Realtek ALC272)
    - LP: #438318
  * SAUCE: Toshiba NB200 (Realtek ALC272) mute speakers when headphones are
    plugged in
    - LP: #438318
  * SAUCE: Toshiba NB200 (Realtek ALC272) enable microphone
    - LP: #438318

linux (2.6.28-16.56) jaunty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * eCryptfs: Handle unrecognized tag 3 cipher codes
    - LP: #415252

  [ Zoltan Devai ]

  * Input: pcspkr - fix PIT lockup on some chipsets
    - LP: #227806
 -- Stefan Bader <email address hidden> Thu, 05 Nov 2009 12:01:41 +0100

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.