Ubuntu

Hardy: FN-up/down keys change brightness too rapidly on DELL XPS m1330

Reported by Zaar Hai on 2008-05-05
56
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Low
Unassigned

Bug Description

System: Kubuntu Hardy with latest updates. Dell XPS m1330 nVidia 8400M GS.
Problem: Adjusting brightness using Power Manager tray applet works fine. But when doing the same using FN-up/down keys, each key press adjusts brightness by about 50%. So, using the keys I have only three (instead of 8) brightness levels: 100%->47%->0% and back up: 0%->52%->100%.

Does it thinks that key is pressed many times when I press it just once?

Same bug here on Ubuntu Hardy

I can confirm this, seeing the same on my dell xps m1330.

Mike Basinger (mike.basinger) wrote :

Work around:
Add 'blacklist video' to /etc/modprobe.d/blacklist and reboot.

Zaar Hai (haizaar) wrote :

Workaround works great until kde power applet is loaded (and no brightness level reported). Then adjustment only works if I press keys once in several seconds, I.e. pressing FN-down three times in row has effect of only single press, (if I keep pressing, presses will only take effect once in several seconds), although brightness level is reported on screen.

Mario Limonciello (superm1) wrote :

Hm. So why do both hald-addon-dell AND the video kernel module allow brightness changing in the first place? That seems a bit backwards.

The same happens in Gnome (just in case).

Work around works in Gnome, I'm using a Dell XPS m1330 laptop.

Javier Jardón (jjardon) wrote :

I can confirm this bug.

I have a Dell XPS 1330 with intel x3100 integrated card and Ubuntu 8.04 instaled in it.

Javier Jardón (jjardon) wrote :
Javier Jardón (jjardon) wrote :
Javier Jardón (jjardon) wrote :
ethanay (ethan-y-us) wrote :

dell xps m1330 running Hardy (Gnome) w/latest

the last time i blacklisted the "video" module resulted in severe graphical corruption that did not revert after undoing the changes and rebooting. what does the "video" module do and is blacklisting it really a viable workaround?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

shivan (kingshivan) wrote :

using 2.6.27, the bug is still here

Guido Conaldi (guido-conaldi) wrote :

I am using Intrepid 64bit up-to-date, so with .27 kernel, on a dell xpm m1330. The bug is still there: using Fn keys to change brightness by 4 or more brightness levels at a time.

But this bug is there since ubuntu 7.10. More importantly, now blacklising video module do not work anymore as a workaround, as it cause crashes and make the menus unusable.

Ciso (cisoprogressivo) wrote :

I can confirm the problem with the workaround in Intrepid 8.10.
Crashes and unusable menus.

Guido Conaldi (guido-conaldi) wrote :

Two additions to my previous comment:

The original bug involved the nvidia nVidia 8400M GS chip, I am experiencing the bug on a Dell XPS 1330 with intel x3100 integrated card.

The blacklisting of the video module, which now is not working anymore as a temporary fix, was never an optimal solution because gnome-power-manager in ubuntu 8.04 was setting the the brightness levels when switching from ac to battery and vice versa often incorrectly.

In essence, brightness management on xps m1330 has been broken since ubuntu 7.10. If I can give more useful and specific output, just let me know. I am not and experienced bug reporter.

Ciso (cisoprogressivo) wrote :

The same as Guido said.
But i have nVidia 8400GS.
If someone need output, I'm here for any test.

Changed in linux:
importance: Undecided → Low
status: New → Confirmed
Changed in dell:
status: New → Confirmed
importance: Undecided → Low
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Ciso (cisoprogressivo) wrote :

Same problem here with Ubuntu 8.10 Beta.

Changed in linux:
status: Incomplete → Fix Released
Ciso (cisoprogressivo) wrote :

I see, that a fix has been release.
Will it be in Ubuntu 8.10?

Ciso (cisoprogressivo) wrote :

In Intrepid with the today update,
the brightness now change by 2 levels for pressing instead of 3 levels.

Changed in linux:
status: Fix Released → Confirmed
Guido Conaldi (guido-conaldi) wrote :

I can confirm that since latest updates two virtual backlight devices are created in /sys/devices/virtual/backlight. Both seems to be functional.

Would downgrading bios version potentially be a workaround?

hleong (excel28) wrote :

I have the same problem. In Ubuntu 8.04, it works with "blacklist video", but after upgrading to Ubuntu 8.10 with 2.6.27 kernel, I would get a black/blank screen when going into KDE.

Changed in linux:
status: Confirmed → Fix Released

I HAVE THE ANSWER!!! PLEASE READ AND COPY TO OTHER FORUMS! I have a Dell Laptop running Windows XP. Like most of you, the Fn + Down would dim the screen, however, Fn + Up would not brighten in. This is a bug that dell/intel cannot fix. There are patches that utilize linux, however, if you want the easiest way to fix the problem this is it: DOWNLOAD DARKADAPTED 2.3.4 BUILD 208. You can find it here: http://www.softpedia.com/progDownload/DarkAdapted-Download-5641.html This is the latest version, but if the link doesn't work, look for a newer version. This program fixes the bug and allows you to adjust all the video options from the same menu. You can email your thanks and praise to me at <email address hidden>

Andrzej Jarmoniuk (ajarmoniuk) wrote :

still not fixed in 11.10

Changed in somerville:
importance: Undecided → Low
status: New → Confirmed
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305644

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.