Ubuntu

Intel 3945ABG not working in Ubuntu 8.04 LTS

Reported by Craig Efrein on 2008-05-04
4
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Lenovo Y-310 and I am using the 8.04 Live CD

lspci
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

iwconfig
wlan0 IEEE 802.11g ESSID:"" Nickname:""
          Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwscan
wlan0 No scan results

lsmod
iwl3945 89844 0

Two problems, the WIFI LED does not light up at all, 2nd problem, I can't connect to my Netgear WIFI router. I normally use WEP 128 but even with that turned off, I still can't connect. I have tried getting support on the Live CD forum and no one there has the answer.

Maxwell Rain (maxwellrain) wrote :

What worked for me was the following :

- Installed the backports updates with the latets updated drivers
But after a day or so it appeared I couldn't find any networks (this error appeared random)

- Installed wicd instead of network-manager.
Again only helped temporarily

- Then I found the following sollution in BugZilla (http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1579):

Creating /etc/modprobe.d/iwl3945 with the following contents :
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1

Changed in linux:
status: Unknown → Fix Released

There hasn't been any recent activity in this bug report and we were wondering if this is still an issue? The Ubuntu kernel team is actively working on the upcoming Intrepid Ibex 8.10 release. If you could please test the latest Alpha release for Intrepid it would be much appreciated - http://www.ubuntu.com/testing . Please let us know your results. If the issue still exists, please also provide the appropriate debugging information as outlined at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance.

Changed in linux:
status: New → Incomplete

Hello,

Thank you for sending me the link to the Alpha release. I will certainly be more than happy to test. I have only ever submitted one bug report so I am not very familiar with testing and responding. Could you tell me who I should send my results to?

By the way, I did recently receive an email stating that the bug was fixed. I haven't had a chance to test yet since I just received the email yesterday.

Thanks,
Craig
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Tue, 26 Aug 2008 23:00:04 +0000
> Subject: [Bug 226411] Re: Intel 3945ABG not working in Ubuntu 8.04 LTS
>
> There hasn't been any recent activity in this bug report and we were
> wondering if this is still an issue? The Ubuntu kernel team is actively
> working on the upcoming Intrepid Ibex 8.10 release. If you could please
> test the latest Alpha release for Intrepid it would be much appreciated
> - http://www.ubuntu.com/testing . Please let us know your results. If
> the issue still exists, please also provide the appropriate debugging
> information as outlined at https://wiki.ubuntu.com/KernelTeamBugPolicies
> . Thanks in advance.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> Intel 3945ABG not working in Ubuntu 8.04 LTS
> https://bugs.launchpad.net/bugs/226411
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” source package in Ubuntu: Incomplete
>
> Bug description:
> I have a Lenovo Y-310 and I am using the 8.04 Live CD
>
> lspci
> 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
>
> iwconfig
> wlan0 IEEE 802.11g ESSID:"" Nickname:""
> Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
> Tx-Power=27 dBm
> Retry min limit:7 RTS thr:off Fragment thr=2346 B
> Power Management:off
> Link Quality:0 Signal level:0 Noise level:0
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> iwscan
> wlan0 No scan results
>
> lsmod
> iwl3945 89844 0
>
>
> Two problems, the WIFI LED does not light up at all, 2nd problem, I can't connect to my Netgear WIFI router. I normally use WEP 128 but even with that turned off, I still can't connect. I have tried getting support on the Live CD forum and no one there has the answer.

Hi Craig,

Please just post any test results/feedback here to this bug report. We'll be notified of any updates you make to this report. Also, it looks like the upstream bug was marked Fix Released because of comment 15 - http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1579#c15 . Also, we'll be putting out a call for testing a newer kernel in the next day or so. As a result, you may want to wait to test this latest kernel. We'll be sure to update this report with the announcement. Thanks.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Craig Efrein (cjefrein) wrote :

I attempted to run the Live CD Linux 8.10 Alpha 4 on the same machine, Lenovo Y310 that started this bug report. I don't know what happened exactly, but the screen was completely blank from the minute I chose Try Ubuntu from the Live CD boot screen. Please let me know what I can do to provide proper feedback for the screen problems I know appear to be having.

I believe that this is my graphics setup:
lspci
    00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Hi Craig,

Can you retest with the Alpha5 release that just came out a few hours ago - http://www.ubuntu.com/testing. It has the newer 2.6.27 kernel. Thanks.

Craig Efrein (cjefrein) wrote :

Hello again Leann,

I have begun downloading and I will let you know soon how it goes. Is there any sort of feedback, logs, output I can provide you during my testing?

Craig
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Fri, 5 Sep 2008 22:26:31 +0000
> Subject: [Bug 226411] Re: Intel 3945ABG not working in Ubuntu 8.04 LTS
>
> Hi Craig,
>
> Can you retest with the Alpha5 release that just came out a few hours
> ago - http://www.ubuntu.com/testing. It has the newer 2.6.27 kernel.
> Thanks.
>
> --
> Intel 3945ABG not working in Ubuntu 8.04 LTS
> https://bugs.launchpad.net/bugs/226411
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” source package in Ubuntu: Incomplete
>
> Bug description:
> I have a Lenovo Y-310 and I am using the 8.04 Live CD
>
> lspci
> 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
>
> iwconfig
> wlan0 IEEE 802.11g ESSID:"" Nickname:""
> Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
> Tx-Power=27 dBm
> Retry min limit:7 RTS thr:off Fragment thr=2346 B
> Power Management:off
> Link Quality:0 Signal level:0 Noise level:0
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> iwscan
> wlan0 No scan results
>
> lsmod
> iwl3945 89844 0
>
>
> Two problems, the WIFI LED does not light up at all, 2nd problem, I can't connect to my Netgear WIFI router. I normally use WEP 128 but even with that turned off, I still can't connect. I have tried getting support on the Live CD forum and no one there has the answer.

Hi Craig,

Sorry for the delayed response. Did you see any improvement with the Alpha5 release? Also, just an fyi, Alpha6 came out last week if you still saw issues with Alph5. Definitely let us know your results.

Regarding logs/info you can provide if you still are having issues, take a look at https://wiki.ubuntu.com/KernelTeamBugPolicies which describes the typical log files the kernel team usually requests. Thanks.

Craig Efrein (cjefrein) wrote :
Download full text (3.3 KiB)

Hello Leann,

Yes I am having an issue with PPP, I sent a question to Ubuntu's forums: https://answers.launchpad.net/ubuntu/+question/45815. Essentially, using my Samsung Z230, I am no longer able to browse or ping. I can resolve DNS names but in spite of my efforts, I can not visit any pages. I am however able to connect using my Virtual Windows 2003 server within Ubuntu so I know the phone works and that connections are possible.

On a separate issue, my WEP key has to be reentered every time I connect. I tried manually adding it to /etc/interfaces but no luck. Also, I can not deactivate or activate WIFI with the FN +F5 key. I can however using the network-manager icon or via the kill switch on this computer. Finally, partimage won't backup my ntfs drive. This is important because in order to move onto 8.10, I had to move my .virtualbox and .mozilla-thunderbird to my Western Digital 250. They are now available in my home drive using symbolic links. I can use TAR in the mean time but I prefer partimage.

Other than that, the WIFI support is excellent for me. Under 7.10, I continually lost my connection and was forced to reboot to get it back. Under 8.10, I stay connected.

If you could help me first with the PPP issue, I would sincerely appreciate it. I must connect to work and having to use windows to do so, even virtual is very cumbersome.

Thank you,
Craig
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Tue, 23 Sep 2008 00:07:28 +0000
> Subject: [Bug 226411] Re: Intel 3945ABG not working in Ubuntu 8.04 LTS
>
> Hi Craig,
>
> Sorry for the delayed response. Did you see any improvement with the
> Alpha5 release? Also, just an fyi, Alpha6 came out last week if you
> still saw issues with Alph5. Definitely let us know your results.
>
> Regarding logs/info you can provide if you still are having issues, take
> a look at https://wiki.ubuntu.com/KernelTeamBugPolicies which describes
> the typical log files the kernel team usually requests. Thanks.
>
> --
> Intel 3945ABG not working in Ubuntu 8.04 LTS
> https://bugs.launchpad.net/bugs/226411
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” source package in Ubuntu: Incomplete
>
> Bug description:
> I have a Lenovo Y-310 and I am using the 8.04 Live CD
>
> lspci
> 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
>
> iwconfig
> wlan0 IEEE 802.11g ESSID:"" Nickname:""
> Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
> Tx-Power=27 dBm
> Retry min limit:7 RTS thr:off Fragment thr=2346 B
> Power Management:off
> Link Quality:0 Signal level:0 Noise level:0
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> iwscan
> wlan0 No scan results
>
> lsmod
> iwl3945 89844 0
>
>
> Two problems, the WIFI LED does not light up at all, 2nd problem, I can't connect to my Netgear WIFI route...

Read more...

Hi Craig,

I'm going to mark this particular bug as "Fix Released" as you've commented you are able to stay connected with 8.10.

Regarding the other issues you are seeing, it's best if you would open a separate bug report for each. It's helpful to the developers if reports target one specific issue. The hotkey issue you are seeing I have already seen similar reports - bug 267682, but they look like they are using different hardware.

As for your PPP question, I probably won't be much help as I'm not very knowledgeable regarding that type of issue.

Thanks.

Changed in linux:
status: Incomplete → Fix Released
Craig Efrein (cjefrein) wrote :

Hello again Leann,

Thank you for your help. I did make progress with my PPP issue. If you do know of someone though who could help out. I tried the forum but so far the responses have been too simplistic.

I can now ping and resolve addresses. Skype works, VPN works, thunderbird can access POP3. Its just good ole firefox that's saying no way no how.

This is important to me because I'm expected to connect anywhere from anywhere. Any chance you could send me in the right direction?

Craig

----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Tue, 23 Sep 2008 17:28:06 +0000
> Subject: [Bug 226411] Re: Intel 3945ABG not working in Ubuntu 8.04 LTS
>
> Hi Craig,
>
> I'm going to mark this particular bug as "Fix Released" as you've
> commented you are able to stay connected with 8.10.
>
> Regarding the other issues you are seeing, it's best if you would open a
> separate bug report for each. It's helpful to the developers if reports
> target one specific issue. The hotkey issue you are seeing I have
> already seen similar reports - bug 267682, but they look like they are
> using different hardware.
>
> As for your PPP question, I probably won't be much help as I'm not very
> knowledgeable regarding that type of issue.
>
> Thanks.
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Fix Released
>
> --
> Intel 3945ABG not working in Ubuntu 8.04 LTS
> https://bugs.launchpad.net/bugs/226411
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” source package in Ubuntu: Fix Released
>
> Bug description:
> I have a Lenovo Y-310 and I am using the 8.04 Live CD
>
> lspci
> 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
>
> iwconfig
> wlan0 IEEE 802.11g ESSID:"" Nickname:""
> Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
> Tx-Power=27 dBm
> Retry min limit:7 RTS thr:off Fragment thr=2346 B
> Power Management:off
> Link Quality:0 Signal level:0 Noise level:0
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> iwscan
> wlan0 No scan results
>
> lsmod
> iwl3945 89844 0
>
>
> Two problems, the WIFI LED does not light up at all, 2nd problem, I can't connect to my Netgear WIFI router. I normally use WEP 128 but even with that turned off, I still can't connect. I have tried getting support on the Live CD forum and no one there has the answer.

komputes (komputes) wrote :

I would also like to confirm that iwl3945 v 1.2.20 (included in Hardy) either does not connect or has an extremely slow internet connection. Testing this in the new development version of Ubuntu - iwl3945 v 1.2.26ks (included in Intrepid) this no longer seems to be an issue. I recommend bringing this fix into Hardy.

Changed in linux:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.