Ubuntu

ISAPNP grabbing I/O region reserved for PCI device on 2.6.12 (regression from 2.6.10)

Reported by Jose Manuel Martinez Carrion on 2005-09-26
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

The Kernel 2.6.12.x don't work with RLT-8139/8139C/8139C+ network interface

Ben Collins (ben-collins) wrote :

Could you be more specific about what doesn't work, and how? Is there some error
message you are refering to? I know that breezy kernel works with 8139, because
I have this type of card in atleast one machine.

Pardon is my first one bug :)

Then when I start with kernel 2.6.12 Ubuntu does not recognize my card of
network, I can't connect to internet, but with the 2.6.10 it uses it perfectly.
Neither with the Live Eval it recognizes my card or, so I do not believe that it
is that I need algun package.

If you want that I sends some .log to you...

P.D. My English is very bad, this I have been translated automatically, pardons
for that reason

A greeting

Matt Zimmerman (mdz) wrote :

Send us the output from:

lspci
lspci -n
lsmod
dmesg

When I boot with kernel 2.6.12 I can't conect to internet, Ubuntu only encounter
a modem that I don't have. In the device manager i can see my RTL-8319, but it
don't work

Download full text (20.8 KiB)

root@sauron:/home/jose # lspci
0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] System
 Controller (rev 25)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP Bri
dge (rev 01)
0000:00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-756 [Viper] ISA (rev 0 1)
0000:00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-756 [Viper] IDE (re
v 07)
0000:00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-756 [Viper] ACPI (rev 03)
0000:00:07.4 USB Controller: Advanced Micro Devices [AMD] AMD-756 [Viper] USB (r
ev 06)
0000:00:08.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capt
ure (rev 11)
0000:00:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (r
ev 11)
0000:00:09.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04)
0000:00:0a.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:0a.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:0a.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:0a.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
0000:00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C
/8139C+ (rev 10)
0000:01:05.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX
100 DDR/200 DDR] (rev b2)

root@sauron:/home/jose # lspci -n
0000:00:00.0 0600: 1022:7006 (rev 25)
0000:00:01.0 0604: 1022:7007 (rev 01)
0000:00:07.0 0601: 1022:7408 (rev 01)
0000:00:07.1 0101: 1022:7409 (rev 07)
0000:00:07.3 0680: 1022:740b (rev 03)
0000:00:07.4 0c03: 1022:740c (rev 06)
0000:00:08.0 0400: 109e:036e (rev 11)
0000:00:08.1 0480: 109e:0878 (rev 11)
0000:00:09.0 0401: 1274:5880 (rev 04)
0000:00:0a.0 0c03: 10b9:5237 (rev 03)
0000:00:0a.1 0c03: 10b9:5237 (rev 03)
0000:00:0a.2 0c03: 10b9:5237 (rev 03)
0000:00:0a.3 0c03: 10b9:5239 (rev 01)
0000:00:0c.0 0200: 10ec:8139 (rev 10)
0000:01:05.0 0300: 10de:0111 (rev b2)

root@sauron:/home/jose # lsmod
Module Size Used by
ipv6 217408 6
binfmt_misc 10888 1
rfcomm 34972 0
l2cap 22404 5 rfcomm
bluetooth 43012 4 rfcomm,l2cap
cpufreq_powersave 1920 0
cpufreq_stats 5124 0
cpufreq_userspace 4444 0
cpufreq_ondemand 5916 0
cpufreq_conservative 6820 0
freq_table 4484 1 cpufreq_stats
tc1100_wmi 6916 0
video 16004 0
battery 9604 0
container 4608 0
i2c_acpi_ec 5760 0
fan 4740 0
button 6672 0
pcc_acpi 11392 0
sony_acpi 5516 0
thermal 13192 0
processor 23100 1 thermal
ac 4996 0
dev_acpi 11396 0
hotkey 9508 0
af_packet 20232 0
floppy 52692 0
pcspkr 3652 0
rtc 11832 0
usblp 11776 0
snd_ens1371 22240 1
gameport 14472 1 snd_ens1371
snd_rawmidi 22816 1 snd_ens1371
snd_seq_device 8204 1 snd_rawmidi
snd_ac97_codec 72188 1 snd_ens...

Ben Collins (ben-collins) wrote :

Odd, 8139cp recognized the card, and correctly notes that it isn't an 8139cp, so
drop to let 8139too handle it. However, 8139too doesn't seem to be picking it up.

Can you do:

sudo rmmod 8139too
sudo rmmod 8139cp
sudo modprobe 8139too
ifconfig -a

Send the output to all those commands please.

Matt Zimmerman (mdz) wrote :

(In reply to comment #4)
> When I boot with kernel 2.6.12 I can't conect to internet

But you can when you use a different kernel? which one?

>> When I boot with kernel 2.6.12 I can't conect to internet
>
>But you can when you use a different kernel? which one?

Excuse me, my English is very bad...

I use kernel 2.6.10 to conect internet, kernel 2.6.12 don't conect, my net card
not run with him...

The output to all commands:

root@sauron:/home/jose # rmmod 8139too
root@sauron:/home/jose # rmmod 8139cp
root@sauron:/home/jose # modprobe 8139too
root@sauron:/home/jose # ifconfig -a
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:447 errors:0 dropped:0 overruns:0 frame:0
          TX packets:447 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:112618 (109.9 KiB) TX bytes:112618 (109.9 KiB)

sit0 Link encap:IPv6-in-IPv4
          NOARP MTU:1480 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Very thank for help me...

Ben Collins (ben-collins) wrote :

Man, I totally missed the error in dmesg from 8139too (was expecting it to come
after the 8139cp driver messages).

Here's the relevant parts:

8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt 0000:00:0c.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
PCI: Unable to reserve I/O region #1:100@de00 for device 0000:00:0c.0
Trying to free nonexistent resource <0000de00-0000deff>
Trying to free nonexistent resource <efffff00-efffffff>
8139too: probe of 0000:00:0c.0 failed with error -16

Can you send me the output of lspci -vvn? Also try booting with the acpi=off option.

Download full text (8.7 KiB)

root@sauron:/home/jose # lspci -vvn
0000:00:00.0 0600: 1022:7006 (rev 25)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
        Latency: 120
        Region 0: Memory at e8000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at eddfd000 (32-bit, prefetchable) [size=4K]
        Region 2: I/O ports at da00 [disabled] [size=4]
        Capabilities: [a0] AGP version 1.0
                Status: RQ=16 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans-
64bit- FW- AGP3- Rate=x1,x2
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP+ GART64- 64bit- FW- Rate=x1

0000:00:01.0 0604: 1022:7007 (rev 01)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 120
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: ede00000-efefffff
        Prefetchable memory behind bridge: d5c00000-e5cfffff
        BridgeCtl: Parity- SERR+ NoISA- VGA+ MAbort- >Reset- FastB2B-

0000:00:07.0 0601: 1022:7408 (rev 01)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

0000:00:07.1 0101: 1022:7409 (rev 07) (prog-if 8a [Master SecP PriP])
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Region 4: I/O ports at f000 [size=16]

0000:00:07.3 0680: 1022:740b (rev 03)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-

0000:00:07.4 0c03: 1022:740c (rev 06) (prog-if 10)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 16 (20000ns max), Cache Line Size: 0x08 (32 bytes)
        Interrupt: pin D routed to IRQ 5
        Region 0: Memory at effcf000 (32-bit, non-prefetchable) [size=4K]

0000:00:08.0 0400: 109e:036e (rev 11)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (4000ns min, 10000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at eddfe000 (32-bit, prefetchable) [size=4K]
        Capabilities: [44] Vital Product Data
        Capabilities: [4c] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: ...

Read more...

Ben Collins (ben-collins) wrote :

Ok, can you now send me the lspci -vvn with the working 2.6.10 kernel? Please
use the "Create a New Attachment" link, instead of pasting directly in a comment.

Also, under the 2.6.12 kernel, please attach the output of "cat /proc/ioports"
and "cat /proc/iomem".

Created an attachment (id=4116)
lspci -vvn with 2.6.10 kernel and "cat" with 2.6.12

Well, sorry for delay,here this what you requested to me, I hope that it helps
you.

Ben Collins (ben-collins) wrote :

I need /proc/ioports and /proc/iomem for 2.6.12 kernel, not 2.6.10, thanks.

Created an attachment (id=4138)
the good file

well, it mistakes when putting the labels, here this the good file

Ben Collins (ben-collins) wrote :

Ok, this is the part I was looking at:

de00-deff : 0000:00:0c.0
  de00-de03 : motherboard
    de00-de03 : pnp 00:00

That first memory range (de00-deff) is the I/O memory reserved for the 8139
device, and it is the showing the right PCI ID. However, the first 4 bytes are
actually being used by motherboard/pnp? Not sure why that is.

Can you send me /proc/ioports from 2.6.10 please?

Ben Collins (ben-collins) wrote :

Try booting with noisapnp option, please. Looking back at the dmesg, PNP surely
reserves this area, which it shouldn't.

I have a problem, even says "permission denied" like root... If I execute with
"sh /proc/ioports" I obtain the following thing

root@sauron:/home/jose # sh /proc/ioports
/proc/ioports: line 1: 0000-001f: command not found
/proc/ioports: line 2: 0020-0021: command not found
/proc/ioports: line 3: 0040-0043: command not found
/proc/ioports: line 4: 0050-0053: command not found
/proc/ioports: line 5: 0060-006f: command not found
/proc/ioports: line 6: 0070-0077: command not found
/proc/ioports: line 7: 0080-008f: command not found
/proc/ioports: line 8: 00a0-00a1: command not found
/proc/ioports: line 9: 00c0-00df: command not found
/proc/ioports: line 10: 00f0-00ff: command not found
/proc/ioports: line 11: 0170-0177: command not found
/proc/ioports: line 12: 01f0-01f7: command not found
/proc/ioports: line 13: 02f8-02ff: command not found
/proc/ioports: line 14: 0376-0376: command not found
/proc/ioports: line 15: 0378-037a: command not found
/proc/ioports: line 16: 037b-037f: command not found
/proc/ioports: line 17: 03c0-03df: command not found
/proc/ioports: line 18: 03f6-03f6: command not found
/proc/ioports: line 19: 03f8-03ff: command not found
/proc/ioports: line 20: 0778-077a: command not found
/proc/ioports: line 21: 0cf8-0cff: command not found
/proc/ioports: line 22: 5000-507f: command not found
/proc/ioports: line 23: 5000-5003: command not found
/proc/ioports: line 24: 5004-5005: command not found
/proc/ioports: line 25: 5008-500b: command not found
/proc/ioports: line 26: 5010-5015: command not found
/proc/ioports: line 27: 5020-5023: command not found
/proc/ioports: line 28: 5080-50ff: command not found
/proc/ioports: line 29: 50e0-50ef: command not found
/proc/ioports: line 30: c000-cfff: command not found
/proc/ioports: line 31: da00-da03: command not found
/proc/ioports: line 32: da00-da00: command not found
/proc/ioports: line 33: dc00-dc3f: command not found
/proc/ioports: line 34: dc00-dc3f: command not found
/proc/ioports: line 35: de00-deff: command not found
/proc/ioports: line 36: de00-deff: command not found
/proc/ioports: line 37: f000-f00f: command not found
/proc/ioports: line 38: f000-f007: command not found
/proc/ioports: line 39: f008-f00f: command not found
root@sauron:/home/jose #

this is not good, right?

Created an attachment (id=4141)
dmesg output whit noisapnp

Wiht "noisapnp" it follows without working. The dmesg output is in archive.

I feel it, tomorrow I must go to me was days, return the next Monday, I will
not be able to continue sending information until then.

A greeting and thank you very much.

Ben Collins (ben-collins) wrote :

Please use cat, not sh, in order to get /proc/ioports.

Ben Collins (ben-collins) wrote :

Please also send me the dmesg from 2.6.10 aswell. Thanks for getting me all this
info. Hopefully we will get a fix soon.

Created an attachment (id=4142)
ioports 2.6.10

well, this is the output

Created an attachment (id=4143)
dmesg of 2.6.10

thanks to you for your dedication, I hope that it is not thus (because already
you have fixed it :) ), but if Monday you need more information, you do not
doubt in sending a message to me.

A greeting and luck

Ben Collins (ben-collins) wrote :

Since noisapnp alone didn't do it, try all these options together:

noisapnp pnpacpi=off

If that doesn't work, also try:

noisapnp pnpacpi=off pnpbios=off

Send dmesg for each of those boots (working or not).

Thanks

Created an attachment (id=4324)
dmesg 2 kernel 2.6.12-9-386

good, already I am of return, I send here to you what you requested to me

Created an attachment (id=4325)
dmesg kernel 2.6.12-9-386

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

hello, I am glad to have the news yours... is sufficient whereupon it
installs Dapper's 2.6.15-7 kernel or I need to update in addition some
other package?

P.D. Pardon, I have sent you east message to your mail by error...

A greeting and thanks for your aid

I have proven to update single kernel, but it requests to me to update more
packages, so it will hope to that it leaves livecd

A greeting

Created an attachment (id=5351)
Dmesg of Dapper kernel 2.6.15

hello, I have proven as you requested Dapper to me, but follows the same
problem, recognizes the network card but I cannot use it...

I send the exit to you of dmesg with kernel of Dapper

Ben Collins (ben-collins) wrote :

Part of the dmesg is missing. Can you send "cat /proc/ioports" aswell.

We need to try disabling all of pnp, so let's try all of these boot options
together:

noisapnp pnpacpi=off pnpbios=off

Thanks

Created an attachment (id=5629)
Ioports without pnp

Hello, it pardons that it has not answered to you before, but that there am
been very, very is occupied...

I have proven what you said to me, to start with the options of noisapnp,
pnpacpi=off and pnpbios=off, but it follows without working, does not detect
the network card.

I send the exit to you of "cat/proc/ioports" and "dmesg"

A greeting.

Created an attachment (id=5630)
dmesg without pnp

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

williamts99 (williamts99) wrote :

This bug still remains for Intrepid Ibex.

williamts99 (williamts99) wrote :

I would like to correct my above statement, as I tested in Intrepid there was a connector failure. And the network card is working for me in Intrepid.

Jef (ofthelit) wrote :

Just tested with a live cd of Ubuntu 8.10 and the network card still doesn't work.
The green led lights up when a cable is plugged in (like hardy).
Also, the interface is called "pan0", while it was "eth0" in Hardy Heron.

Kangarooo Jānis (kangarooo) wrote :

This bug also affects me.
I just installed ubuntu 9.10 and automaticly its not connecting. Its thinking thinking and then not connecting.

Heres
lspci
lspci -v
lspci -v| grep Ethernet

Jeremy Foshee (jeremyfoshee) wrote :

Unassigned from Ben Collins. Marked Won't Fix for kernel source for Dapper. I need one of the people experiencing this currently to provide us with 'apport-collect -p linux 22575' from the most recent kernel possible. I prefer this be from the Lucid Alpha 3 and/or the most current mainline build of the kernel.

I'd like to get this in front of the Kernel team soon.

Thanks in advance,

-JFo

Changed in linux-source-2.6.15 (Ubuntu):
status: New → Won't Fix
Changed in linux (Ubuntu):
assignee: Ben Collins (ben-collins) → nobody
status: Confirmed → Incomplete
Neil Perry (nperry) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!

Changed in linux (Ubuntu):
status: Incomplete → Invalid

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jef 1139 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'V8235'/'VIA 8235 with ALC650E at 0xdc00, irq 22'
   Mixer name : 'Realtek ALC650E'
   Components : 'AC97a:414c4722'
   Controls : 57
   Simple ctrls : 36
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=8fbf1408-bee5-4de1-a445-6a6ac5a3538e
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MSI MS-6712
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=2f9e689a-9ad1-464e-ae0c-2e7446bf3ff8 ro quiet splash
ProcEnviron:
 LANG=nl_BE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.32
Reproducible: No
RfKill:

Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/02/01
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Version 07.00T
dmi.board.name: MS-6712
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: Uknown Chassis Manufacture
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrVersion07.00T:bd04/02/01:svnMSI:pnMS-6712:pvr1.0:rvnMSI:rnMS-6712:rvr1.0:cvnUknownChassisManufacture:ct3:cvrVersion1.00:
dmi.product.name: MS-6712
dmi.product.version: 1.0
dmi.sys.vendor: MSI

tags: added: apport-collected

apport information

apport information

apport information

Jef (ofthelit) wrote : BootDmesg.txt

apport information

apport information

apport information

apport information

apport information

Jef (ofthelit) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

Jef (ofthelit) wrote : UdevDb.txt

apport information

Jef (ofthelit) wrote : UdevLog.txt

apport information

apport information

Jef (ofthelit) wrote :

I have two of these cards. They were used by a friend in an old Pentium serving as router. It ran Red Hat and was replaced by a wireless router when it didn't boot. I think the hard disk had errors.

The PC which generated the report had another working network card when running the test. When I plugged in the network cable, no LEDs gave light, while the other same card did light up (used in my first comment). If you want, I can test that one too if you think this one might be broken. However, I don't have it available now. Let me know.

Changed in linux (Ubuntu):
status: Invalid → New
tags: added: kj-triage
Jeremy Foshee (jeremyfoshee) wrote :

Jef Van den Brandt,
      That sounds worthwhile if you don't mind testing the other card.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: New → Incomplete
Jef (ofthelit) wrote :

The other card doesn't light up either.
I think I confused it with another card I bought shortly after that. It wouldn't establish a connection, but the lights were on. Got replaced, still the same, removed the network applet, configured it manually and it worked.

I tested the second card with the same kernel and a kernel from mainline. The resulting files are both attached.

Jef (ofthelit) on 2010-06-28
Changed in linux (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
status: New → Triaged

Jose Manuel Martinez Carrion, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-kernel-logs needs-upstream-testing
removed: apport-collected linux
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.