Ubuntu 8.04 server kernel / Xen enabled / Nvidia problem

Bug #224340 reported by CO82 on 2008-04-29
54
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Jared Sutton

Bug Description

I'm running 8.04 server kernel and tried to install NVidia drivers. It fails due to enabled Xen support in version 8.04's kernel. See conversation with nvidia's support here:

http://www.nvnews.net/vbulletin/showthread.php?t=112102

As you can see it is not a problem of the driver or the driver's setup. Xen is definitely enabled in 8.04 server kernel while it wasn't in Ubuntu server 7.10 where everything works fine.

Kind regards,

Chris

CO82 (orth-kris) wrote :

I don't think that this report is a duplicate of #107814 because I did NOT install any Xen features or a Xen kernel. This is the standard 8.04 server kernel. Is Xen integrated in Ubuntu 8.04 Server edition by default?

awe (redhorse-nospam-2006) wrote :

Same probleme here.

Need server kernel because of ram size, but (as posted by CO82) xen modules are configured, so the nv installer fails.

Bug in kernel config?

awe (redhorse-nospam-2006) wrote :

Chris,

KVM ist ubuntus choice for virtualization (and its working great).
I thought xen is removed .... does not look like. Lets see what the maintainers say ...

I am not happy with buying a GPU for 280 EUR and can not use it.
Opinion would be to build your own kernel (works) ... but then i dont need LTS :(

So please, Ubuntu stuff .... check this asap.

Kind regards

AWE

Xyverz (xyverz) wrote :

I am also having the same problem. I installed the server kernel so I could use all 8gb of RAM in my system, but the nvidia module build failed. It gave the Xen kernel error.

`dpkg -l|grep -i xen` returns zero results.

--X...

Xyverz (xyverz) wrote :

Also wanted to add, I don't believe this is a duplicate, especially not of the ticket listed in previous comments. I *have* installed the linux-restricted-modules after I installed the server kernel.

mannheim (kronheim) wrote :

The source package for linux in Ubuntu 8.04 for i386 has the following line in the file ./debian/confi/i386/config.server:

    CONFIG_XEN=y

The corresponding config file for amd64 does not have this line. I don't know anything about this: maybe it is intentional and not a bug. But it means that the server flavor kernel on the i386 architecture is recognized as a xen kernel (but not on the amd64 architecture). This is why the nvidia binary installer refuses to install on the server kernel in i386.

This is certainly not a duplicate.

Xyverz (xyverz) wrote :

How do we get the devs to change the status of this bug?

CO82 (orth-kris) wrote :

I've just sent an email to <email address hidden>. I hope they will change the status soon.

CO82 (orth-kris) wrote :

Hm, that did not work :-) Message was rejected... Anyone knows who or how to contact to remove that duplicate tag?

Jared Sutton (jpsutton) wrote :

This bug is not a duplicate of the one listed (so I un-marked it as such). Except for the use of the term "Xen" in both bugs, they are completely unrelated.

Here's the gist of the bug:
1. There is a linux-image-xen package that is specifically designed for use with Xen.
2. The linux-image-server should not have Xen support in it.
3. Many people are using the linux-image-server kernel because it has PAE support and therefore can address > 4GB memory
4. Some people prefer to use the nvidia package from nvidia.com instead of the linux-restricted-modules + nvidia-glx packages (the nvidia.com package is faster for me).
5. The inclusion of Xen support in the linux-image-server kernel prevents the nvidia installer from building the module.

So, the solution is to remove the unnecessary Xen support from linux-image-server.

Jared Sutton (jpsutton) wrote :

The bug is specific to the linux-image-server package build from the listed source package. The Xen support should be removed in a future release.

Xyverz (xyverz) wrote :

Thanks Jared. :-)

Jared Sutton (jpsutton) on 2008-05-12
Changed in linux:
status: New → Confirmed
richdemars (richdemars) wrote :

I am also seeing the same issue. Is there an ETA on the release of a new compiled server kernel package without the XEN support or is there good step by step instructions on how to recompile the server kernel with all supporting packages our self?

Xyverz (xyverz) wrote :

With the release of the 2.6.24-18-server kernel, this is no longer an issue. I was able to install the kernel, install the restricted modules, and have my nvidia goodness again.

--X...

richdemars (richdemars) wrote :

I installed the new 2.6.24-18-server kernel and still have issues with getting composite rendering to work with it.

Xyverz (xyverz) wrote :

Composite rendering works just fine for me. That would more likely be an X configuration issue, and not a kernel / driver issue.

CO82 (orth-kris) wrote :

still no change? btw: last automatic update destroyed my running 7.10 server system (updates included new kernel and new x server...). time to say goodbye, perhaps next version will run better, but for me only in a vm.. i dont want to install a new system every 3 months or spend hours to revert everything.

regards,
chris

Jared Sutton (jpsutton) wrote :

I upgraded to the latest server kernel a few days ago. The Xen support is still enabled, so this bug is not fixed (and hence, nVidia driver failed to install from the nVidia.com package). I'm running off the Generic kernel at the moment so that I can get the nVidia driver to actually install.

I'm also wondering if the maintainer of the kernel packages is aware of this bug report. I know the people in charge of things like this are busy, but this should be a trivial and obvious fix.

Xyverz (xyverz) wrote :

Yeah, I had problems as well. I had gotten it working with the provided packages, but then it broke again.

I just ditched 32-bit and went back to 64-bit. No more problems.

Tested w/Intrepid alpha and found the same thing - Xen enabled by default in desktop and server packages.

Jared Sutton (jpsutton) wrote :

3vi1,

When you said "desktop and server packages," where you refering to the generic and server packages? If so, then the problem has actually gotten worse, as the generic kernel has not been a problem up till now.

Jared Sutton (jpsutton) wrote :

Ubuntu kernel team seems to be the ones to look at this.

Changed in linux:
assignee: nobody → ubuntu-kernel-team

I'm chiming in with the exact same problem. 8.4 server 32-bit version.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jared Sutton (jpsutton) wrote :

This bug is still present in the linux-2.6.27-1 package from Intrepid (installed on Hardy). The nvidia driver package from nvidia.com refuses to install since Xen support is enabled in the kernel config. To stay afloat, I'm currently running 2.6.27-server with the restricted-modules package and nvidia-glx-177. It seems to be running well so far.

Changed in linux:
importance: Undecided → Medium
status: Confirmed → Triaged
dan_linder (dan-linder) wrote :

*bump*

Any update on this? Last night I upgraded from 8.04 to 8.10 and I'm running into this issue too.

I'm running kernel linux-image-2.6.27-4-generic and trying to install NVIDIA-Linux-x86_64-177.70-pkg2.run.

Dan

Rich (cuda-rich) wrote :

This should be higher priority. It's not about GUI bling on servers - the 4GB restriction is huge. Also without the nvidia drivers developers like me can't develop or run CUDA apps. IMHO Ibex is not ready until there's a non-Xen kernel option.
-Rich

Erica Peterson (probabilistic) wrote :

Same problem here - I just upgraded to 8.10 and can't install the nvidia driver package. I'm running linux-image-2.6.27-7-generic and trying to install NVIDIA-Linux-x86_64-173.14.09-pkg2.run.

Erica Peterson (probabilistic) wrote :

Hmmm. I had booted into low-graphics mode after failing to manually install the nvidia driver, when the third-party drivers icon appeared in my taskbar. It offered me two proprietary nvidia drivers to install - I chose the recommended one (version 177) and it works perfectly. This is the same tool as going through the menus: System -> Administration -> Hardware Drivers. I've always had to manually install the nvidia driver in the past, so I hadn't tried the hardware drivers tool this time - glad to see it works! Thanks, ubuntu!

On Sun, Nov 2, 2008 at 11:15 AM, Erica <email address hidden> wrote:

> Hmmm. I had booted into low-graphics mode after failing to manually
> install the nvidia driver, when the third-party drivers icon appeared in
> my taskbar. It offered me two proprietary nvidia drivers to install - I
> chose the recommended one (version 177) and it works perfectly. This is
> the same tool as going through the menus: System -> Administration ->
> Hardware Drivers. I've always had to manually install the nvidia driver
> in the past, so I hadn't tried the hardware drivers tool this time -
> glad to see it works! Thanks, ubuntu!
>

This works well for most people, but I have a system with two NVidia
graphics cards, one which uses the 177 driver, and another which needs the
96 driver. With the Ubuntu drivers way, I can't get both to run at once -
the packages are exclusive of each other.

If I could use a non-Xen kernel, I could then get the 177 and 96 drivers
from NVidia and install them myself.

Dan

--
"Quis custodiet ipsos custodes?" (Who can watch the watchmen?) -- from the
Satires of Juvenal
"I do not fear computers, I fear the lack of them." -- Isaac Asimov (Author)
** *** ***** ******* *********** *************

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Keng-Yu Lin (lexical) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/news/ubuntu-9.04-desktop . Please let us know your results.

If the issue remains while still running Jaunty, please run the following command which will automatically gather and attach updated debug information:

apport-collect -p linux-image-2.6.28-11-generic <bug #>

Thanks in advance.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Jim Lieb (lieb) wrote :

This bug report was marked as Incomplete a while ago and has not had any feedback to provide the requested information. As a result this bug is being closed. Please reopen if this is still an issue in the latest Karmic 9.10 Alpha release http://cdimage.ubuntu.com/releases/karmic/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers