Ubuntu

MemStick problem with card_reader (tifm)

Reported by mastrboy on 2008-04-26
64
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When inserting a MemStick card in my laptops card reader (Laptop being HP NC6320), nothing really happens, output from dmesg is only:
tifm_core: MemoryStick card detected in socket 0:0

I can not mount it manually either, but i found a fix on a blog:
http://swehrmann.blogspot.com/2008/04/memorystick-support-unter-ubuntu-hardy.html

After applying this fix, my card now automounts and shows up on the desktop.

The work around for this issue extracted from the blog:
svn co -r155 http://svn.berlios.de/svnroot/repos/tifmxx/trunk/driver/
cd driver/
wget http://www.tu-chemnitz.de/~sweh/tifm_ms.patch
patch -p0 < tifm_ms.patch
make
sudo make install

Output from dmesg after patch:
[ 3267.243300] tifm_ms tifm_ms0:0: executing TPC b008, 6c17
[ 3267.243311] tifm_ms tifm_ms0:0: data event: fifo_status 8, host_status 4020, flags 0
[ 3267.243314] tifm_ms tifm_ms0:0: fifo data transfer, 8, 0
[ 3267.243325] tifm_ms tifm_ms0:0: fifo data transfer, 0 remaining
[ 3267.243342] tifm_ms tifm_ms0:0: host event: host_status 1020, flags 2
[ 3267.243350] tifm_ms tifm_ms0:0: TPC complete
[ 3267.243357] tifm_ms tifm_ms0:0: executing TPC e001, 6c17......
...........

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

To get your fix included in Ubuntu, it would help if you tried transforming it into a debdiff (http://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff) and submit it for review (http://wiki.ubuntu.com/SponsorshipProcess). If you prefer somebody else to do that, that's fine - please just indicate if you're available to do that.

BTW, this is fixed in kernel 2.6.25 but not backported to Ubuntu yet.

Regards

mastrboy (mastrboy) wrote :

It would be alot quicker of somebody other than me submitted the deb-diff, for me to do that i first have to learn it, and i really don't have time to do so in atleast 2 weeks.

BandD (swords-into-plowshares) wrote :

Thank you! I can confirm this bug in Hardy. But this patch works wonders!

Sap (trauby-2006) wrote :

Works like a charm :) .

N.B. : The "wget" link has changed. I referred to the blog mentioned by the OP and the link is : wget http://www.sw83.de/misc/tifm_ms.patch

:)

Too bad these instructions don't work with Intrepid.
Apparently kernel 2.6.26 doesn't like tifm_ms.
Tried to checkout latest revision and compile patch-less with no luck whatsoever.

Gustavo Niemeyer (niemeyer) wrote :

FWIW, a friend just told me he's being affected by this same bug.

getaceres (getaceres) wrote :

I have a Sony Vaio FE31Z with Intrepid and I can't mount the memory stick (I couldn't mount it with any previous Ubuntu version also).

I get the following message:
Aug 20 23:45:37 ubuntu-vaio klogd: [ 1187.114327] tifm_core: MemoryStick card detected in socket 0:0

But nothing else happens.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

getaceres (getaceres) wrote :

I've tested the 2.6.27 kernel and the issue is not resolved. The memory stick is not mounted.

Jo (jo-r) wrote :

This fix also worked for me.
Sony Vaio PCG-9W4M
2.6.24

getaceres (getaceres) wrote :

Is it possible to include the aforementioned fix in the default ubuntu packages? It seems that the upstream kernel is not going to fix it.

mikes (mikevas) wrote :

Any news about this? Is the tifm_ms module going to be included in 8.10? It seems that it is currently missing.

Niklas Hagman (blinkiz) wrote :

Using Ubuntu 8.10 (intrepid, 2008-11-02) and having the same problem. Solution posted is not working in intrepid. Have searched the net for a solution but couldn't find any..
Other memory cards works fine under intrepid. Have Zepto Znote 6224w.

David Horat (david-horat) wrote :

Using Ubuntu 8.10 (final version) I am having the same problem. Other memory cards work fine. My notebook is: Sony Vaio VGN-TX1 (3 years old already).

The modules provided at http://svn.berlios.de/svnroot/repos/tifmxx/trunk/driver/ don`t compile with the new kernel.

Regards,
David

Changed in linux:
status: Unknown → Confirmed
Aidan Fitzpatrick (afit) wrote :

With an in-built Sony VGN-SZ3XWP it didn't work in 8.10, and doesn't work in 9.04, which just says:

"tifm_core: MemoryStick card detected in socket 0:0"

This is very similar to #48987 and #159951.

sentvid (sentvid) wrote :

Hi,

tifm_ms.ko is not in the modules directory in jaunty, where as I suppose it has to be there in "/lib/modules/2.6.28-11-generic/kernel/drivers/memstick/host"

as per http://linux.sourcearchive.com/documentation/2.6.28-2.2/tifm__ms_8c-source.html

May be there is some problem this driver got missed out.

Please help

Alwin Garside (yogarine) wrote :

Using Jaunty beta, and Memory Stick still doesn't work out of the box. Output of lspci -vv attached.

$ uname -a
Linux vaio 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

Alwin Garside (yogarine) wrote :
Glauco (glauco-hass) wrote :

Nothing yet? There's no way to get memstick to be mounted. The patch once worked with Hardy doesnt compile in Jaunty with latest updates.

pulpo88 (zymurgent) wrote :

Memory stick works in Jaunty. But you have to build the module - it's part of the kernel source tree now but Ubuntu has it disabled.

Hopefully they'll include this module in the next release.

See my comments to bug 159951.

Alwin Garside (yogarine) wrote :

Seems to have been fixed in Karmic, marking this as such. Correct me if I'm wrong.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Gargoulf (pasquiernoterdaeme) wrote :

Nothing happens when I insert XD card under ubuntu 10.04.
However, "dmesg" produces:
tifm_core: SmartMedia/xD card detected in socket 0:0

when removing the card, dmesg adds:
tifm0 : demand removing card from socket 0:0

lspci reckognises the reader:
03:01.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

I tried the patch given here but it failed at the make. Anyway, the problem is NOT corrected in ubuntu 10.04.
If anyone has been able to mount XD card on ubuntu 10.04, please let me know.

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.