acx_111 pcmcia not working

Bug #22195 reported by Matthew East on 2005-09-21
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ben Collins

Bug Description

My acx_111 pcmcia wifi card is not working out of the box. I put it in and it
appears in network-admin, but when I go to configure it, it has not picked up
any of the numerous AP's nearby. No light has come on on the card, from which I
deduce that the firmware isn't loaded. I'm attaching dmesg

The card is a DLINK DWL-G650+ and shows up as wlan0

thanks, Matt

Matthew East (mdke) wrote :

Created an attachment (id=3954)
dmesg, as promised

Matthew East (mdke) wrote :

FWIW I've tried putting the firmware from the card's CD in /lib/hotplug/firmware
and naming it:

1. FwRadio16.bin (original name)
2. RADIO16.BIN
3. TIACX111.BIN

In cases 1 and 3, dmesg is the same as the uploaded attachment. In case 2, it
tells me this:

[4303572.930000] FATAL: firmware upload: data parts at offset 60252 don't match
(0xf884c6a5 vs. 0x00000000)! I/O timing issues or defective memory, with
DWL-xx0+? Makefile: ACX_IO_WIDTH=16 should help. Please report!
[4303572.930000] acx_write_fw (radio): 0, acx_validate_fw: 1
[4303572.930000] radio firmware upload attempt #5 FAILED, retrying...
[4303573.950000] Trying to issue a command to the ACX100 but the Command
Register is not IDLE (6860h)
[4303573.950000] acx111_init_packet_templates: Init max packet templates
[4303573.971000] Trying to issue a command to the ACX100 but the Command
Register is not IDLE (6860h)
[4303573.971000] acx111_init_packet_templates: packet template configuration FAILED
[4303573.971000] Danger Will Robinson, MAC did not come back
[4303573.971000] ACPI: PCI interrupt for device 0000:05:00.0 disabled
[4303573.982000] acx_probe_pci: TI acx_pci.o: Ver 0.2.0pre8 loading FAILED
[4303573.982000] acx_pci: probe of 0000:05:00.0 failed with error -5

Matt Zimmerman (mdz) wrote :

(In reply to comment #2)
> FWIW I've tried putting the firmware from the card's CD in /lib/hotplug/firmware
> and naming it:
>
> 1. FwRadio16.bin (original name)
> 2. RADIO16.BIN
> 3. TIACX111.BIN

Does the firmware actually differ from the firmware we supply in
/lib/hotplug/firmware by default? It's already there under those names, so
you've probably clobbered the packaged versions (reinstall
linux-restricted-modules to fix it)

Étienne BERSAC (bersace) wrote :

the version 0.3 of the driver have a very good support of acx1XX chipset (for
many D-Link, NetGear WG311v2, etc.).

Matthew East (mdke) wrote :

(In reply to comment #3)
> (In reply to comment #2)
> > FWIW I've tried putting the firmware from the card's CD in /lib/hotplug/firmware
> > and naming it:
> >
> > 1. FwRadio16.bin (original name)
> > 2. RADIO16.BIN
> > 3. TIACX111.BIN
>
> Does the firmware actually differ from the firmware we supply in
> /lib/hotplug/firmware by default? It's already there under those names, so
> you've probably clobbered the packaged versions (reinstall
> linux-restricted-modules to fix it)

Just to be clear: this problem was occurring BEFORE I copyed the firmware to the
hotplug directory from the CD. I don't think Ubuntu is shipping the firmware for
this particular card. AFAICS it is NOT there under those names: I can see
RADIO15* but not RADIO16*. In any case, even with the firmware copied to the
directory, the card is not working.

Matt

Matthew East (mdke) wrote :

this card is not working in dapper either. I can see it in ifconfig -a, but no
light is on on the card, and it shows no sign of detecting any networks.

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-8 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

Frantisek Fuka (fuxoft) wrote :

My USRobotics 5410 (which worked perfectly out of the box with Breezy) does not work with Dapper at all (I installed it today from scratch and applied all upgrades using LAN). I found the solution <a href=http://www.ubuntuforums.org/showthread.php?p=860917&posted=1#post860917>here</a>. - The problem was with firmware, it had to be downgraded! (Note I am talking about native support, not ndiswrapper.)

Ben Collins (ben-collins) wrote :

Please read /lib/firmware/`uname -r`/acx/readme.txt

This will tell you how to provide the right information.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.