[hardy] Kernel panic with Zydas wifi and kernel 2.6.24

Bug #220013 reported by Luke Plant on 2008-04-20
48
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.24

Upgraded to Hardy today, and never had the following problem in Gutsy:

After a connection attempt is made using my wireless USB Zydas dongle, if the connection fails, the system freezes and the keyboard LEDs start flashing - a hard reset is then necessary. I have not been able to find anything in kern.log indicating a kernel panic - I will try to get the crash to occur when I'm looking at a console.

If I am lucky and the connection attempt is successful, it works fine.

Kernel:
 package: linux-image-2.6.24-16-386
 version: 2.6.24-16.30

Kernel module used: zd1211rw

Dongle info:

Bus 005 Device 002: ID 0ace:1215 ZyDAS WLA-54L WiFi

Luke Plant (spookylukey) wrote :

I've got a backtrace at a text console:
-----------------------

Call Trace:
[<c01274dc>] run_timer_softirq+0x9c/0x1c0
[<c013a0a2>] tick_program_event+0x32/0x60
[<c0134c65>] hrtimer_interrupt+0x185/0x1c0
[<c013a260>] tick_sched_timer+0x0/0x190
[<c0123f42>] __do_softirq+0x52/0xa0
[<c0123fd5>] do_softirq+0x45/0x50
[<c011155e>] smp_apic_timer_interrupt+0x3e/0x80
[<c010a193>] sched_clock+0x13/0x40
[<c01051b8>] apic_timer_interrupt+0x28/0x30
[<c0116542>] native_safe_halt+0x2/0x10
[<c010261c>] cpu_idle+0x1c/0x70
[<c03fab05>] start_kernel+0x245/0x2d0
[<c03fa370>] unknown_bootoption+0x0/0x1e0
===============
Code: 34 24 74 10 eb 25 8b 43 14 89 da 83 e0 fe 39 f0 75 19 89 cb 89 f0 e8 74 fe ff ff 39 fb 8b 0b 75 e5 83 c4 0c 89 e8 5b 5e 5f 5d c3 <0f> 0b eb fe 83 ec 0c 89 74 24 04 89 c6 89 7c 24 08 89 d7 89 1c

EIP: [<c012737c>] cascade+0x6c/0x70 SS:ESP 0068:c03f9f20
Kernel panic - not syncing: Fatal exception in interrupt.

-----------------------------

There were also what appeared to be timestamps at the beginning of each line. However, I didn't include these, as they were different each time, and it took me 3 attempts to get the full trace. This was because after a few minutes, the following started to scroll up the screen (along with some other occasional things which I could not catch):

  zd1211rw 5-4:1.0: Could not allocate skb

Since I had to write down the backtrace on paper by hand, I had to try again. The 3rd time, I managed to get the 'Code' bit at the end. This time, the backtrace was identical to the above apart from it missed out the line with 'sched_clock'. I don't know if that makes a difference to the interpretation of the 'Code' section or not.

Thanks.

Hi Luke,

Care to also attach your full dmesg output for the kernel team to reference. Also the output of "sudo lspci -vvnn" might not hurt. Just for future reference, if you happen to have a digital camera, you could also just take a photo of your monitor when the stack trace is being dumped and then just attach the photo here. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Luke Plant (spookylukey) wrote :

After rebooting, there was nothing in dmesg logs about this, or any system logs, otherwise I would have included it. (And yes, a digital camera would have been handy!).

I've attached the lspci output, which doesn't mention the wifi AFAICS, presumably because it is a USB wifi. Also attached "lsusb -v" output.

Luke Plant (spookylukey) wrote :

Hi Luke,

Just to see if it makes a difference, care to test the Intrepid Ibex 8.10 kernel? It was most recently rebased with the upstream 2.6.25 kernel and is currently available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following:

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command:

sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. After you've finished testing you can remove the kernel- ppa.list file and run 'sudo apt-get update' once more to restore your system. Please let us know your results. Thanks.

Luke Plant (spookylukey) wrote :

Thanks so much for looking at this bug, it's much appreciated.

I've installed the 2.6.25 kernel (I had to install linux-ubuntu-modules-2.6.25-1-386 too, otherwise I got dmesg errors "Could not load firmware file zd1211/zd1211b_ub. Error number -2", and a useless wifi).

So far, all seems good. I have at least twice *definitely* managed to trigger the situation that was causing panics before (attempting and failing to connect to a network), and there have been no kernel panics. Bug #120622 is also fixed (I reported on that bug too).

Using this kernel permanently is a bit awkward, due to the lack of nvidia modules. Before, I was using 2.6.22 (with Hardy), which meant having to downgrade nvidia-glx-new to version 100.14.19+2.6.22.4-14.10 from Gutsy. This in turn meant downgrading xorg (aptitude sorted this out for me).

I guess I could now upgrade nvidia-glx-new and xorg to Intrepid, with some apt-pinning jiggery-pokery to stop me getting the whole lot. Would that work?

Thanks.

Luke Plant (spookylukey) wrote :

To answer my own question: no, that won't currently work, since linux-image-2.6.25 is not yet in the Intrepid archive (it's still at 2.6.24)

Hi Luke,

Thanks for testing and the feedback. The Intrepid kernel definitely sounds promising here. As you know we're still in the early stages for the Intrepid kernel so it may be a few weeks before it actually hits the archives. But for now I'll go ahead and mark this fix released against Intrepid. Obviously if you notice any regressions feel free to reopen this (ie set the Intrepid task from "Fix Released" to "New").

It might be nice to try and narrow down the patch which will resolve the panics on the Hardy kernel. We could then possibly try to get it in the Hardy 8.04.1 point release. However, isolating the fix would require performing a git bisect and doing some kernel builds. This is not something we expect bug reporters to know how to do. But if you're feeling adventurous, the following links may help:

http://www.kernel.org/doc/local/git-quick.html#bisect
https://wiki.ubuntu.com/KernelCustomBuild

There are a few things to note however. When performing the git bisect you will have to switch the meanings of "good" and "bad" as the bisection is looking for the patch which caused a regression rather than the patch which provides a fix. Also, you can get the git tree for the Intrepid kernel by doing:

git clone git://kernel.ubuntu.com/ubuntu/ubuntu-intrepid.git

Again, doing the above this completely voluntary on your part. Thanks :)

Changed in linux:
status: Triaged → Fix Released
status: New → Incomplete
Luke Plant (spookylukey) wrote :

FYI, I'm very unlikely to attempt the above in the month, and after that I probably won't be using my Zydas wifi (I'll probably by using a wired internet connection). So don't hold your breath on this one!

Steven Weller (suweller) wrote :

Hi,

I have more or less the same problem. The system hangs if a connection is lost in an unpredictible way. This I found out when I had to unplug my wifi-modem/router.
My modem is a linksys WAG325N

Since this hangs my system and I have to do a hard reset dmesg doesn't show anything of value.

I don't know how to correctly perform a bisection so I won't be much help aside from being able to conclude this isn't system or router specific.

chourmovs (chourmovs) wrote :

i've got exactly the same problem using zydas wifi for my bluestork dongle

To answer to Leann about git bisection test ?
This could be very very painfull since kernel panic is not systematic and depend on connection ( about 1 upon 3 for me)

Do i have the ability to try another driver to get more stability ?

Skull (stefan-kull) wrote :

The following similar bug reports seems to pointing at the same symptoms when using Wireless-LAN...
List of symptoms:
    * Screen and mouse become frozen
    * Caps Lock LED BLINKING
    * Scroll Lock LED BLINKING
    * ...only way out is to reboot by unplugging batteries and power adapter.
    * My notebook is OK as long as I use the built in cable-LAN adapter.

List of earlier reported bugs with similar symptoms

Bug #205653: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/205653
                        "Hardy beta - laptop randomly freezes with caps & scroll lock led's blinking"

Bug #194650: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/194650
                        "computer locks up using rt61pci"

Bug #216421: https://bugs.launchpad.net/ubuntu/+bug/216421
                        "Wireless-LAN will freeze both screen & mouse pointer"

Bug #152102: https://bugs.launchpad.net/ubuntu/+bug/152102
                        "Belkin F5D6001 Freezing Ubuntu 7.10 RC1"

I looks to me (an advanced user, but not an software developer) that this is an OLD and serious bug/issue...
...please ;-( could someone look into this issue?

  * Severity: High => Makes system hang/crash
  * Impact: High => I can NOT use wlan at all!

svasie (svasie) wrote :

I can completely confirm this bug. System hangs randomly on wifi connect.

lsusb:
Bus 002 Device 003: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi

Please, keep this bug in mind. High severity and high impact as remarked by Skull.

Christophe Olinger (olingerc) wrote :

Just installed intrepid alpha 2.

No zydas still. Can£t load firmware. Will wait for alpha 3 and try again.

Russ Tokuyama (russtoku) wrote :

I have the same problem with thing hanging and requiring a reboot.
I'm using Hardy with 2.6.24-19-generic and a Belkin FD7050 v4xxx.
Hangs when using Wicd or Network Manager to connect to the wireless.
The scroll and caps lock lights end up flashing on the PS/2 keyboard.
Things were working very nicely under Gutsy.

dmesg:
[ 46.531006] zd1211rw 3-5:1.0: eth1
[ 46.531080] usbcore: registered new interface driver zd1211rw
[ 47.724834] zd1211rw 3-5:1.0: firmware version 4725
[ 47.764793] zd1211rw 3-5:1.0: zd1211b chip 050d:705c v4810 high 00-17-3f AL2230_RF pa0 g--NS

lsusb:
Bus 003 Device 002: ID 050d:705c Belkin Components

lsmod:
zd1211rw 56964 0
ieee80211softmac 30976 1 zd1211rw
ieee80211 35528 2 zd1211rw,ieee80211softmac
usbcore 146028 4 zd1211rw,ehci_hcd,ohci_hcd

Thanks!

karkoma (norbertlaplana) wrote :

Excuse me, I don't understand English very well and I'm new here.

I have the same problem in Ubuntu. I have to do a hard reset when I connect my zydas USB wireless.

There isn't any solution for this problem?

thanks.

chourmovs (chourmovs) wrote :

The only way for the moment is to dist-upgrade to intrepid IBEX
I did that and i'm very happy with this alpha version

karkoma (norbertlaplana) wrote :

But it is an alpha version.... I had problems (fortunately now resolved) in Hardy heron and I installed it when Heron was stable.

Anybody goes to resolve the problem on Hardy Heron, in a near future?

Id2ndR (id2ndr) wrote :

I can confirm the bug on hardy. It does not happen regularly so it was difficult to diagnose. I've just seen that it freeze the screen went NM-applet show you are connected (after the 2 green bubbles). (My keyboard doesn't have led so I haven't seen caps locks blinking).

lsusb
0ace:1211 ZyDAS 802.11b/g USB2 WiFi

Does Incomplete status mean that this bug will not be corrected in hardy ?

Alwin Garside (yogarine) wrote :

This bug also affects me on 2.6.24-19-generic with my usb 0ACE:1215 ZyDAS WLA-54L WiFi. However, it only occurs when I'm using network-manager. When I just apt-get remove network-manager and configure my wireless connection manually (with dhcp) in /etc/networking/interface my computer won't crash. (Fortunatly I don't roam arround with this box.)

However, from time to time my USB WiFi somehow disconnects or resets (I mean the USB part, not the WiFi part). This is where with Network Manager installed my computer would usually crash. In dmesg it shows up like this:

[33077.260001] hub 2-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
[33077.260020] usb 2-1: USB disconnect, address 2
[33077.270924] zd1211rw 2-1:1.0: error ioread32(CR_REG1): -22
[33077.434633] usb 2-1: new full speed USB device using uhci_hcd and address 3
[33077.602972] usb 2-1: configuration #1 chosen from 1 choice
[33077.722273] usb 2-1: reset full speed USB device using uhci_hcd and address 3
[33077.905861] zd1211rw 2-1:1.0: eth1
[33086.671105] hub 2-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
[33086.671123] usb 2-1: USB disconnect, address 3
[33086.810886] usb 2-1: new full speed USB device using uhci_hcd and address 4
[33086.978990] usb 2-1: configuration #1 chosen from 1 choice
[33087.154498] usb 2-1: reset full speed USB device using uhci_hcd and address 4
[33087.312838] zd1211rw 2-1:1.0: eth1

Whenever this happens, my WiFi connection goes down, but I just restart the networking services and everything works fine. So there might be some problem in network-manager too?

Has anyone else here tried uninstalling network-manager and configuring their devices manually?

I will reinstall network-manager now and see if I can get some sort of log output that can help pinpointing this problem.

Alwin Garside (yogarine) wrote :
Alwin Garside (yogarine) wrote :

ok, so I installed network-manager and after an hour my PC crashed, here's the syslog for the session. My PC crashed at Aug 24 10:11.

chourmovs (chourmovs) wrote :

Before i dist-upgrade the problem occured with konnection manager, wicd or mad wifi
It's a problem with linux old kernel and not with ubuntu implementation, the only way is to disr upgrade to a newer kernel by testing intrepid

I can say that everything work for me with intrepid and faster than in hardy

Alwin Garside (yogarine) wrote :

Yeah but what I don't get is why it only crashes when using network-manager... There might be something wrong with the way network-manager handles things.

karkoma (norbertlaplana) wrote :

I confirm Alwin's post. It only crash when using network-manager. I remove it from my system and I connect the wireless through terminal commands.

I prefer this solution than update to a new ubuntu distribution that is in the alpha version.

See you, and thanks for all!

Russ Tokuyama (russtoku) wrote :

I removed the Network Manager applet and didn't use the System -> Admin -> Network (network-admin). Then I run configured /etc/network/interfaces to bring up the wireless interface. This worked for a little while and hung my system. My guess is that it's something with the kernel and drivers. Anyway, another data point.

Russ Tokuyama (russtoku) wrote :

I'm updated to 2.6.24-21-generic and now my Belkin FD7050 v4xxx wireless doesn't hang; no blinking keyboard lights. All appears stable. I'm still not using Network Manager; just System -> Administration -> Network (network-admin). Thanks!

Russ Tokuyama (russtoku) wrote :

Oops! I spoke too soon. This goodness only lasted 1:40 hours before things hung and the keyboard lights were blinking. I had left an apt-get running when things hung. Hopefully, things improve since Hardy is LTS.

eccoh (rastamokshha) wrote :

Hello everyone

here same bug with usb key wireless ZyDAS WLA-54L WiFi
sometimes freeze at starting
or when i connect the key....

i'mon kubuntu hardy and kernel 2.6.24.21
and i get the bug since kubuntu feisty

hope intrepid update will fix it

eccoh ha scritto:
> Hello everyone
>
> here same bug with usb key wireless ZyDAS WLA-54L WiFi
> sometimes freeze at starting
> or when i connect the key....
>
> i'mon kubuntu hardy and kernel 2.6.24.21
> and i get the bug since kubuntu feisty
>
> hope intrepid update will fix it
>
>
yes Intrepid, in my case, solved the bug (with 2.6.27.7-generic kernel)
I have exactly the same usb adapter (ZyDAS WLA-54L WiFi )

Hi

eccoh (rastamokshha) wrote :

for me looks like it's ok now with intrepid release candidate (64bit)
tried it yesterday
and for the moment i get now freeze
great ;)

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Antoine Amarilli (a3nm) wrote :

I can still reproduce this bug in Hardy... the computer often freezes when trying to connect to a Wifi network.

frapell (frapell) wrote :

I'm suddenly experiencing this problem.
When pluggin in my EUSSO Wirless-G USB Adapter[0] (using zd1211rw driver) my system sometimes (and sometimes not) gets a hard freeze. Until yesterday things where working great, it was today that i'm having this problem, and i didn't do any update of any package.
Here's all the information i can get from /var/log/messages:

Feb 4 08:57:38 jenny kernel: [ 3043.472050] usb 3-1: new high speed USB device using ehci_hcd and address 4
Feb 4 08:57:38 jenny kernel: [ 3043.607861] usb 3-1: configuration #1 chosen from 1 choice
Feb 4 08:57:38 jenny kernel: [ 3043.821440] cfg80211: Using static regulatory domain info
Feb 4 08:57:38 jenny kernel: [ 3043.821454] cfg80211: Regulatory domain: US
Feb 4 08:57:38 jenny kernel: [ 3043.821461] ^I(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Feb 4 08:57:38 jenny kernel: [ 3043.821469] ^I(2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821476] ^I(5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821483] ^I(5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821490] ^I(5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821497] ^I(5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821504] ^I(5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
Feb 4 08:57:38 jenny kernel: [ 3043.821512] cfg80211: Calling CRDA for country: US
Feb 4 08:57:38 jenny kernel: [ 3044.068134] usb 3-1: reset high speed USB device using ehci_hcd and address 4
Feb 4 08:57:39 jenny kernel: [ 3044.346274] zd1211rw 3-1:1.0: phy0
Feb 4 08:57:39 jenny kernel: [ 3044.346352] usbcore: registered new interface driver zd1211rw
Feb 4 08:57:43 jenny kernel: [ 3048.436389] firmware: requesting zd1211/zd1211b_ub
Feb 4 08:57:43 jenny kernel: [ 3048.497759] firmware: requesting zd1211/zd1211b_uphr
Feb 4 08:57:43 jenny kernel: [ 3048.552271] zd1211rw 3-1:1.0: firmware version 4725
Feb 4 08:57:43 jenny kernel: [ 3048.594974] zd1211rw 3-1:1.0: zd1211b chip 0ace:1215 v4810 high 00-02-72 AL2230_RF pa0 g--NS
Feb 4 08:57:43 jenny kernel: [ 3048.597947] cfg80211: Calling CRDA for country: DE

After this, the system is completely frozen, all i get is a blinking Caps Lock and i have to shut down holding the power button for like 5 secs or so.

[0] - http://www.eusso.com/Models/Wireless/UGL2454-U2Z/UGL2454-U2Z.htm

Barry Klein (blklein) wrote :

I am trying to use a Dlink DWA-110 wireless G usb modem (ID 07d1:3c07) on Hardy, kernel 2.6.2-.24.53 generic

The modem is not recognised when plugged in (it uses rt73usb)
Even after manual 'modprobe rt73usb', the wlan device is not created. (NOTE: this command loads the modules whether the modem is plugged in or not).

After loading linux-backports-modules-hardy-generic, the modules load when the modem is plugged in and wireless works as expected, but when the modem is unplugged, the kernel panics.

The kernel panic can be triggered with the command "modprobe -r rt73usb"

Barry Klein (blklein) wrote :

I am attaching a digital camera screenshot of the panic.

Julian Wiedmann (jwiedmann) wrote :

This release has reached end-of-life [0].

[0] https://wiki.ubuntu.com/Releases

Changed in linux (Ubuntu Hardy):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers