random freezes on Ubuntu Hardy Heron

Bug #219345 reported by mathieu levernieux on 2008-04-18
20
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

since I have updated my Ubuntu Gutsy Gibbon to Ubuntu Hardy Heron, my system freezes ramdomly, so I haven't neither mouse nor keyboard... I must restart my computer with the power button.

My configuration :
Ubuntu Hardy Heron
desktop environnement : Xfce 4
kernel 2.6.24-16 (I had this with the 2.6.24-15 kernel too)
proc amd athlon XP 2000+ 1.6 Ghz
RAM 512 MB
Graphic card Nvidia Geforce 4 420 Go
my PC is a laptop...

Thank you

Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
+ Does ctrl+alt+f1 take you to a console?
+ Does ctrl+alt+backspace restart X?

Thanks.

ctrl+alt+F1 and ctrl+alt+backspace don't work... When it freezes, I have no keyboard at all.

Sergio Barjola (sbarjola) wrote :

Could you attach the following files ?

+ /var/log/syslog
+ /var/log/Xorg.0.log
+ ~/.xsession-errors
+ output of lspci -vvnn

Thanks in advance.

the syslog

the Xorg.0.log

the xsession-errors

and the output of lspci -vvnn

Sergio Barjola (sbarjola) wrote :

hi there, is this still this issue happening with the last updates ?

Hi, yes, I had a freeze yesterday. But now I use Emesene and not amsn, and I have less freezes. But these freeze can be made by my hard disk drive no ? I don't know if the logs I posted could tell that...

Aswarp (aswarp2002) wrote :

I have this problem as well which by the way I would tag as critical and has IMHO very bad effect on Hardy's perceived image of stability. I don't even get a BSOD, just... nothing.
I am running KUbuntu Hardy Heron with Compiz, NVIDIA latest official driver (GeForce 6600) on a 8 GB partition. It seems that the freezing problem started happening around the time when I run low on disk space, but not quite sure. The I freed up some space by removing already installed packages within Synaptic. But the systems continues to freeze randomly. The screen keeps showing what it has got but the mouse does not move nor can I use the keyboard. Trying to get a console access with Ctrl+Alt+F# does not work either, obviously. So I must do a hard reboot EVERY time.

It seems that the system stays for longer time before freezing if I perform a "free -m" periodically, every five minutes or so, but I never know when the system is going to get frozen and I keep bleedin'...
What can I do?

Aswarp (aswarp2002) wrote :

The syslog is attached

Aswarp (aswarp2002) wrote :

The Xorg0.0log is attached

Aswarp (aswarp2002) wrote :

The .xsession-errors hidden file is attached

Aswarp (aswarp2002) wrote :

The lspci -vvnn command output is attached

Aswarp (aswarp2002) wrote :

I could reproduce the frozing when playing a lengthy HD vídeo online, for instance at www.vimeo.com.
Hoever, not always. If I use "free -m" just before watching the video, KUbuntu does not always freeze.
Oh, and it got hanged up in different situations as well... it seems to me that this bug is somehow related to a low memory/swap/disk space circumstance.
Any clue/patch/fix for this?

Sergio Barjola (sbarjola) wrote :

I'm associating this bug with linux package.

Aswarp (aswarp2002) wrote :

It is just a theory but I think that the freezing of the Operating System could be somehow related to microprocessor, harddisks, memory or motherboard overheating.
If that was the case, the term "freezing" would be completely inaacurate (I a m trying to find my sense of humour about it however it is not funny at all when you have been working heavily and Hardy gets harder...)

kiev1 (sys-sys-admin) wrote :

No, I checked is not malfunction hardware, it is occurs in many-many cases

kiev1 (sys-sys-admin) wrote :

For today the unique output is to replace sata hdd on usual ata ide hdd
At me this kernel-bug is not shown the second month at use ata ide hdd

Roy Kimbrell (roy-kimbrell) wrote :

Please see Bug #230541. I reported this a couple of weeks ago. The problem started in Hardy - it would freeze (no keyboard, caps-lock key did not function - that is, the caps-lock led did not light). I encountered this problem when attaching a Wacom tablet (usb). However, in working with it and Justin Dugger (the Ubuntu Wacom guy), I discovered the system would freeze with ANY usb device - disk drive, tablet, and so on. I believe the problem is in the usb device driver. There's additional data with bug #230541 - dmesg file, logs, etc.

Roy

Aswarp (aswarp2002) wrote :

I have a USB harddrive, webcam and a Genius drawing tablet, but none of them were configured yet to work in KUbuntu. And it still keeps freezing from time to time. Now, if I stop Compiz and run KWin instead, the systems looks somehow more stable.

Aldo Latino (aldolat) wrote :

I use regularly Ubuntu from Breezy Badger and I never had a problem. Since I use (either upgrading or fresh installing) Hardy Heron my system freezes: the keyboard and the mouse are useless, so I have to make a hard-reset (damaging my filesystem).

The problem is not related to high temperature, because the system freezes also when I turn it on and the hardware is cold. The problem occurs randomly: I am not able to find the reason, because it happens in different situations; it's not reproducible for me now.

If I downgrade to Gutsy all works fine; if I use Debian Etch or Windows XP all is ok. Only in Hardy I have these problem.

Here my system: Pentium 4 1.7 GHz, 1 GB RAM, power unit of 450 W, video card Ati AIW 9800SE (either with open drivers or fglrx), two 120 e 160 GB hard disks, DVD burner, audio SoundBlaster Audigy Platinum EX, network card Realtek, a multiple card reader on slot PCI, a wacom tablet intuos 9x12 USB.

Aldo Latino (aldolat) wrote :

I add that the freezes occur from 3-4 to 7-8 times a day!

Aswarp (aswarp2002) wrote :

I updated the kernel and xserver-xorg (en dof june released version) and have not had this problem again. Oh, yes, my X graphical desktop stopped working but I fixed it by reinstalling the nvidia drivers. There is a thorougher explanation of what I did afterwards in the following link.
Now I can watch videos from different sources, even all at once, and Hardy does not freeze anymore (but I am not very sure why).
http://alfonsoycia.blogspot.com/2008/06/nuevo-software-en-hardy-heron.html

Aldo Latino (aldolat) wrote :

I found a trick in this post [1] on ubuntu forums suggesting to add this values to kernel boot options line in /boot/grub/menu.lst:

highres=off nohz=off irqpoll

I added this values and from yesterday until now none freeze occurred (remember: I had many freezes in one day). The system appears very very stable. I tried to stress it up but I was not able to cause one hang-up.
May this issue be related to the tickless kernel option?

I will inform you if this is really effective on my machine.

[1] http://ubuntuforums.org/showthread.php?p=4963984#post4963984

Aldo Latino (aldolat) wrote :

Two days ago, as you know, I added some variables to the kernel boot options (see previous comment). After nearly 48 hours of continuous job, my PC has worked perfectly, without any freeze, and it's now very stable. Is the problem now identified?

kiev1 (sys-sys-admin) wrote :

I have added these options, but the given bug has not disappeared (((

Aswarp (aswarp2002) wrote :

The options (as I remember) went something like: lowres=on.
This means that the higher screen resolution graphical modes are disabled. That is not what I would call a solution...

GmGasTer (gmgarbellotto) wrote :

Same problem of freeze for me. It happens NOT randomly, but when I connect my usb wi-fi
It freezes, then two lights start to blink on my laptop (one is "caps-lock", the other one... no idea what's that light :-D )

EVERYTIME I turn on my pc, I have to disconnect my usb wi-fi, then log in, then connect it and pray... Sometimes I have to do it 7-8 times before it works!!!

Sometimes it gives the same problem randomly.

I have latest ubuntu version, fully upgraded...

Sergio Barjola (sbarjola) wrote :

GmGasTer, your problem seems another bug. "caps-lock" blinking is related with kernel crash.
Please, add a new bug report including the following files, according with the kernel team policies:

- uname -a > uname-a.log
- cat /proc/version_signature > version.log
- dmesg > dmesg.log
- sudo lspci -vvnn > lspci-vvnn.log

Thanks in advance.

GmGasTer (gmgarbellotto) wrote :

Ah, ok, sorry I thought it was a similar bug... I'll do as you suggested...

Thanks! And again, sorry I'm new to ubuntu ;)

Changed in linux:
status: Incomplete → New
Aldo Latino (aldolat) wrote :

An update regarding my freezes.

I wrote above [1] about a possible workaround.
This workaround isn't the solution to my problem.

Here my update.
I have a USB ports multiplier, connected to a PCI slot. This device also has an external unit that brings 7 ports in front of the PC (3 USB, 1 SD, 1 Compact Flash, and so on). The external unit is connected to the internal part via a usual USB connector. If I disconnect the external unit - leaving the PCI card connected and fully functional into the PC - the freezes disappear.
In this moment I am not using the options for kernel booting which I have indicated above [2].

Perhaps the problem is related to USB in any way?

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/219345/comments/27
[2] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/219345/comments/26

Aldo Latino (aldolat) wrote :

A friend of mine has two laptop. One of these has an integrated multiple SD card reader and *only this* laptop has many freezes.
He asked me how he could disable that card reader. He want to verify if this piece of hardware could be the origin of these freezes.

Can you tell me how to disable an integrated card reader in a laptop?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Aswarp (aswarp2002) wrote :

I am running the 2.6.24-19-generic kernel and the problem seems to be gone for good...
Oh, and by the way I reclaced the 300W power supply with a 400W one.

Aswarp (aswarp2002) wrote :

I am running the 2.6.24-19-generic kernel and the problem seems to be gone for good...
Oh, and by the way I replaced the 300W power supply with a 400W one.

Per the last comment I'm tentatively marking this "Fix Released" for Hardy. Mathieu, since you are the original bug reporter, if this is not resolved for you please set the status back to "New". Thanks.

Changed in linux:
status: New → Fix Released
Roy Kimbrell (roy-kimbrell) wrote :

Just installed the latest updates to Hardy on a Sony Vaio VGN-A270P. The problem with USB devices continues. I have a 250G drive connected via USB. I attempted to copy about 100G to that drive. It ran for 10 or 20 minutes then the OS locked up as it had before. The fixes, if any, in the newest Ubuntu updates did not fix the problem.

Uname -a reports....
Linux sony-vaio 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

Roy Kimbrell (roy-kimbrell) wrote :

With Ubuntu 9.04 this problem appears to have been fixed. USB devices on my Sony VGN-A270P work well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.