Hard drives recognizing issues (P5W-DH with Intel 82801GR/GH Sata Controller)

Bug #219312 reported by Yann SLADEK on 2008-04-18
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

I'd like to report a bug using the new kernel 2.6.24-16 after an upgrade from Ubuntu Gutsy (last ubuntu kernel 2.6.22).
When I tried to boot up on Ubuntu (386 or generic either), I get the messages printed below.

I'd like to say that I've already got that sort of issues regarding upgrade from Feisty to Gutsy. I had to unplug my DVD-writer to boot properly.
Now, I'm able to boot with that DVD writer but got messages complaining about ATA (see dmesg attached)

I found a lot of bugs regarding this issue but no real fix to apply.
Don't hesitate to ask me for further information

My configuration :

Asus P5W-DH
Seagate HDD SATA2 ST3320620AS
WD HDD SATA2 WDC WD2500KS-00MJB0

dmesg problems :

 42.029888] ahci 0000:00:1f.2: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl SATA mode
[ 42.029891] ahci 0000:00:1f.2: flags: 64bit ncq led clo pio slum part
[ 42.029895] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[ 42.030045] scsi0 : ahci
[ 42.030159] scsi1 : ahci
[ 42.030927] scsi2 : ahci
[ 42.031006] scsi3 : ahci
[ 42.031029] ata1: SATA max UDMA/133 abar m1024@0xfebfb800 port 0xfebfb900 irq 219
[ 42.031031] ata2: SATA max UDMA/133 irq_stat 0x00400040, connection status changed irq 219
[ 42.031033] ata3: SATA max UDMA/133 abar m1024@0xfebfb800 port 0xfebfba00 irq 219
[ 42.031035] ata4: SATA max UDMA/133 abar m1024@0xfebfb800 port 0xfebfba80 irq 219
[...]
[ 42.505023] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 42.552256] ata1.00: ATA-7: ST3320620AS, 3.AAK, max UDMA/133
[ 42.552258] ata1.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 31/32)
[ 42.610461] ata1.00: configured for UDMA/133
[ 43.487236] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 73.433023] ata2.00: qc timeout (cmd 0xec)
[ 73.433029] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x5)
[ 73.433031] ata2: failed to recover some devices, retrying in 5 secs
[ 83.935003] ata2: port is slow to respond, please be patient (Status 0x80)
[ 88.461808] ata2: COMRESET failed (errno=-16)
[ 89.160549] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 89.160616] ata2.00: ATA-6: Config Disk, RGL10364, max UDMA/133
[ 89.160618] ata2.00: 640 sectors, multi 1: LBA
[ 89.160622] ata2.00: device is on DMA blacklist, disabling DMA
[ 89.160693] ata2.00: configured for PIO4
[ 89.471981] ata3: SATA link down (SStatus 0 SControl 300)
[ 89.947121] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 90.105746] ata4.00: ATAPI: HL-DT-ST DVDRAM GSA-H62N, CL00, max UDMA/100
[ 90.261657] ata4.00: configured for UDMA/100

Yann SLADEK (yann-sladek) wrote :
Yann SLADEK (yann-sladek) wrote :
description: updated
description: updated
guenthert (guenthert) wrote :

I just ran into what looks the very same issue: the SATA drives here worked fine in 2.6.22, but aren't found in 2.6.24-16-generic. The kernel spits out messages of the form (transcription - I can't get to it otherwise):
--8<--
[ 56.463297] SCSI subsystem initialized
[ 56.477843] ACPI: PCI Interrupt 0000:00:12.0[A] -> GSI 21 (level, low) -> IRQ 21
[ 56.478127] ahci 0000:00:12.0: controller can't do 64bit DMA, forcing 32bit
[ 56.478178] ahci 0000:00:12.0: controller can't do PMP, turning off CAP_PMP
[...]
[ 57.480373] ahci 0000:00:12.0: AHCI 0001.0100 32 slots 4 ports 3Gbps 0xf impl SATA mode
[ 57.480427] ahci 0000:00:12.0: flags: ncq sntf ilck pm led clo pio slum part
[ 57.481394] scsi0 : ahci
[ 57.481710] scsi1 : ahci
[ 57.481873] scsi2 : ahci
[ 57.482040] scsi3 : ahci
[ 57.955539] ata1: SATA link up 1.5Gbps (SStatus 113 SControl 300)
[ 87.904552] ata1.00: qc timeout (cmd 0xec)
[ 87.904608] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[ 87.904653] ata1: failed to recover some devices, retrying in 5 secs
-->8--

Linux 2.6.22-14-generic recognizes the (300GB Seagate) disks as
--8<--
ahci 0000:00:12.0: flags: ncq ilck pm led clo pmp pio slum part
ata1.00: ATA-7: ST3320620AS, 3.AAE, max UDMA/133
ata1.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 31/32)
-->8--
(can't get detailled information right, now as I'm in the middle of a botched 7.10->8.04 upgrade :-/

Yann SLADEK (yann-sladek) wrote :

Hi,

I don't know if you have any clues to fixed this issue but I've spent my entire week end on it so I'm able to give you some kind of help.

To have a system fully bootable and working, you need to modify the IDE options in the BIOS.
So go into BIOS -> IDE Configuration > Mode : Enlarge (don't know exactly but not Compatible or IDE) and SATA+P-ATA

Then you need to add 2 options in grub to get it booting correctly.
Add irqpoll and noprobe=ata4

Now my system is booting properly and working great, my disks are well recognized

FYI, I sent an email in the IDE/ATA team kernel developement but no answer (it seems that I'm not the only one). I crossposted them because this bug should have been fixed into the 2.6.23-rc2
I tried with a 2.6.25 and it wasn't working no longer too so I think this bug is still present

On Mon, 2008-04-21 at 23:41 +0000, Yann SLADEK wrote:

> Hi,
>
> I don't know if you have any clues to fixed this issue but I've spent my
> entire week end on it so I'm able to give you some kind of help.
>
> To have a system fully bootable and working, you need to modify the IDE options in the BIOS.
> So go into BIOS -> IDE Configuration > Mode : Enlarge (don't know exactly but not Compatible or IDE) and SATA+P-ATA
>
> Then you need to add 2 options in grub to get it booting correctly.
> Add irqpoll and noprobe=ata4
>
> Now my system is booting properly and working great, my disks are well
> recognized
>
> FYI, I sent an email in the IDE/ATA team kernel developement but no answer (it seems that I'm not the only one). I crossposted them because this bug should have been fixed into the 2.6.23-rc2
> I tried with a 2.6.25 and it wasn't working no longer too so I think this bug is still present
>

Thanks for sharing your findings. However on the system under my desk
(Motherboard: ASUS M2R32-MVP with ATI SB600 SATA interface, CPU: Athlon
64 X2 4600+) changing the mode in which the SATA controller operates
from "Native" to "AHCI" or even "RAID" didn't help; neither did the
kernel command line option 'irqpoll'.

For now, I'm running Ubuntu 8.04 (beta) with the old kernel, i.e.
2.6.22-14. Seems to work reasonably well.

best regards
    Guenther

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-source-2.6.24:
status: New → Invalid
guenthert (guenthert) wrote :

Uh, invalid?

I guess, what makes this defect 'invalid' is, that it is believed to be an interrupt routing issue caused by the BIOS, see http://www.gossamer-threads.com/lists/linux/kernel/879808 , but I might be wrong.

I see, if I can get the diagnostics of this system and send them to interested parties before I attempt to upgrade the BIOS of the system under investigation.

guenthert (guenthert) wrote :

Meanwhile I found that the kernel (2.6.24-16) finds the SATA drive, if the command line option "pci=nomsi" is provided. This works for me (I'll check later, if a BIOS upgrade helps too).

Kevin_b_er (ktbvz2) wrote :

This might be a duplicate of 190492, but the error mask is different for Yann SLADEK and the same for guenthert.

Yann SLADEK (yann-sladek) wrote :

Hi,

yes, as you said, it might be a duplicate of 190492 but as I said, I'm running a working mode, which means I choosed options in the BIOS making kernel working by adding parameters.

I get pretty same messages when running IDE Configuration in BIOS with AHCI. But adding parameters doesn't solve anything so I switched to the IDE Enlarge mode (or advanced mode, my BIOS is in french)

Meanwhile, I think we can mark my bug as a duplicate.

Shane Huang (shane-huang) wrote :

Yann:

Can you add this patch:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a878539ef994787c447a98c2e3ba0fe3dad984ec
to see whether it can fix your bug?

This patch is already in kernel 2.6.25, if it can fix your bug,
Ubuntu guys please add it to Ubuntu 8.04.

Thanks

guenthert (guenthert) wrote :

On Fri, 2008-04-25 at 00:59 +0000, Shane Huang wrote:

> Yann:
>
> Can you add this patch:
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a878539ef994787c447a98c2e3ba0fe3dad984ec
> to see whether it can fix your bug?
>
> This patch is already in kernel 2.6.25, if it can fix your bug,
> Ubuntu guys please add it to Ubuntu 8.04.
>
>
> Thanks
>

Yann or Guenther? These seem to be two different, albeit related cases.
Mine can be circumvented with the "pci=nomsi" option, while Yann
reported success with the "irqpoll" option.

Guenther

guenthert (guenthert) wrote :

On Fri, 2008-04-25 at 00:59 +0000, Shane Huang wrote:

> Yann:
>
> Can you add this patch:
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a878539ef994787c447a98c2e3ba0fe3dad984ec
> to see whether it can fix your bug?
>
> This patch is already in kernel 2.6.25, if it can fix your bug,
> Ubuntu guys please add it to Ubuntu 8.04.
>
>
> Thanks
>

Yann or Guenther? These seem to be two different, albeit related cases.
Mine can be circumvented with the "pci=nomsi" option, while Yann
reported success with the "irqpoll" option.

Guenther

Shane Huang (shane-huang) wrote :

Oh, my mistake, Yann is using Intel's platform, please ignore my comment above.

But the above git commit can be added to Ubuntu kernel to fix another bug.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Yann SLADEK (yann-sladek) wrote :

This problem is solved by using new kernel into intrepid alpha 5.
I just got a message at the shut down : ata4 : SRST Failed (-4)
Everything else is just fine

Thanks for the update. Marking this "Fix Released" for Intrepid.

Changed in linux:
status: Triaged → Fix Released
feld (felderado) wrote :

I'm still having this issue with a Tyan S2895 motherboard. I'm running Ibex with latest updates.

I have not tried irqpoll, noprobe=ataX, or pci=nomsi as grub options yet. I also have not changed any BIOS settings yet either.

This problem only came to exist when I upgraded to Ibex from Hardy in September. I can give any information you need.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers