VirtualBox - Can't install hardy server as guest - inappropriate kernel error

Bug #216784 reported by Neil Wilson on 2008-04-13
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
virtualbox-ose (Ubuntu)
Medium
Unassigned

Bug Description

Trying to install Hardy 8.04 Beta Server i386 as a guest into a Gutsy 7.10 Host VirtualBox system

Package is 1.5.0-dfsg2-1ubuntu3

On reboot the kernel reports:

"This kernel requires the following features not present on the CPU:
0:6
Unable to boot - please use a kernel appropriate for your CPU."

Think that is something to do with PAE.

Whatever it is it is confusing the Gutsy emulator!

Daniel Hahler (blueyed) wrote :

I can confirm this for linux-openvz (Hardy guest on Hardy host).

Changed in linux:
importance: Undecided → Medium
status: New → Triaged
Daniel Hahler (blueyed) on 2008-04-17
Changed in virtualbox-ose:
importance: Undecided → Medium
status: New → Triaged
Blair Zajac (blair) wrote :

I got the exact same error using the Hardy RC server build inside Parallels 3.0 build 5584.

The install proceeded fine then upon the first reboot, it failed.

Blair Zajac (blair) wrote :

I installed Hardy i386 using the alternative ISO into Parallels and that worked.

I was able to get the Ubunutu server install to boot by going into a shell (alt-F2)
at the end of the install and 'chroot /target bash' and apt-get linux-image-generic
and removing the server kernel.

Falk Pauser (falk-pauser) wrote :

same error here when using hardy (alternate) as host to install hardy-server (stable) into virtualbox (1.5.6_OSE)

rrambo (robert-rambo) wrote :

same error here, hardy host with hardy-server guest... no problems with qemu or vmware, just virtualbox.

Antonio Pérez Pérez (aperez) wrote :

I've had the same error, but making some tests I've found that with just enabling the PAE option and the VT extensions option (even if you don't have them) on the VM settings solves this.

I don't quite understand why is this behaviour... but it works for me.

jsgaarde (jakob-simon-gaarde) wrote :

Solution:
boot from the ubuntu-server CD and choose "Rescue a broken system" from the boot menu.

Start a shell exchange the kernel

apt-get update
apt-get install linux-generic
apt-get remove linux-server

This may not be the perfect solution, but it works.

/ Jakob

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Niels Egberts (nielsegberts) wrote :

The virtualbox version in Intrepid Ibex has PAE support. Under advanced settings check the box and you are up and running :-)

Changed in virtualbox-ose:
status: Triaged → Fix Released
Changed in linux:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers