Ubuntu

rtl8187 link quality poor

Reported by u-foka on 2008-04-11
354
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Medium
Seth Forshee
Nominated for Lucid by Rogerio Luz Coelho
Maverick
Medium
Seth Forshee

Bug Description

Binary package hint: linux-source-2.6.24

Hy!

I have a notebook with an integrated rtl8187 based wifi.
Now I switched to hardy, and I hoping if my wifi now works without ndiswrapper, because the driver is now in the mainline kernel...
But my problem is still exists :S The link quality of the wifi connection is very poor... I mean, the driver reports the real connection srenght, but my connection LAGGS if I move away from my ap only about 4-5 meters, then if I ping the ap, I got 50% packet loss, and at about 8 meters, my connection unusable, when the driver reports 60% connection srenght... I'm sure my wifi works, because I tested it on window$ and with ndiswrapper, and with they, I got good results, but with ndiswrapper, other problems exists :S

Thanks for your help!
...and sorry because my baad English!

$ lsb_release -rd
Description: Ubuntu hardy (development branch)
Release: 8.04

$ apt-cache policy linux-image-2.6.24-15-generic
linux-image-2.6.24-15-generic:
  Installed: 2.6.24-15.27
  Candidate: 2.6.24-15.27
  Version table:
 *** 2.6.24-15.27 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Kenny Millington (kmdm) wrote :

I just experienced this and the following command helped:-

$ sudo iwconfig wlan0 rate 11M

Could be worth a shot.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

u-foka (ufooka) wrote :

Hy!

I will test the new kernel with my corrent installation if you think it produces a reasonable result!
But maybe I can install intrepid alpha5 on an usb drive as soon as it's released :)

Mike Beatty (mikelbt) wrote :

I'm having the same trouble with the latest Kernel in Intrepid. I have had the card working with ndiswrapper but the new native driver doesn't work.

Hélio Nunes (dedalu-dedalu) wrote :

Same here with Intrepid (2.6.27-7-generic #1 SMP Fri Oct 24 06:40:41 UTC 2008 x86_64 GNU/Linux). I experience very low signals and about 20%-50% packet loss unless I am in the very same room with the access point...

Freemor (freemor) wrote :

I can confirm this problem.
uname -a
Linux flaptop 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

link quality is tragically low even when I sit the laptop right beside tha access point. Was working 95% o.k. in 8.04.1 (small problem with dropped connections under heavy load but that was easy to deal with)

the my wireless is now mostly 95% broken because the range is about 10 feet.

using cat /proc/net/wireless shows

Inter-| sta-| Quality | Discarded packets | Missed | WE
 face | tus | link level noise | nwid crypt frag retry misc | beacon | 22
 wlan0: 0000 19. 65 13 0 0 0 0 0 0

as you can see the noise level is seriously high which it wasn't before upgrading and I can tell from other laptops that the high noise value is a false reading of some sort. (I'm fairly rural.. not a lot of interference)

Please set this to high priority. And definitely strongly warn people before they upgrade as this will render any laptop with a built-in rtl8187 (which are many) nearly useless for mobile use. And it wil be a big shock to people coming from the stable environment of Hardy.

if you need me to post more info let me know

Hélio Nunes (dedalu-dedalu) wrote :

If I use unison from my desktop to sync with a cifs share on my laptop I do not loose the connection but my laptop do not listen the router anymore. Pinging is going ok (no packet loss next to the access point) and suddenly "ping: sendmsg: No buffer space avaliable" or "Destination Host Unreachable".

Wireless is useless and no priority or response from any developer...

Freemor (freemor) wrote :

Just an update.. After some more testing it seems that although I am having a false high noise level causing a false low link quality it seems that I am not suffering the dropped connections and lost packets others are reporting.

The false high noise level/low link quality is concerning however so I still feel that the problems with the RTL8187 should be noted in the release notes until this is resolved.

kernel-janitor (kernel-janitor) wrote :

Hi ufooka,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 215802

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=154ca56f-0b23-43b3-be52-e01b5f4abcb6
MachineType: Gateway MT6706
Package: linux-image-2.6.28-13-generic 2.6.28-13.45
PackageArchitecture: i386
ProcCmdLine: root=UUID=53ebff02-57e1-4e43-85c8-4745a359d401 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_CA.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-13.45-generic
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev powerdev sambashare scanner vboxusers video

Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :
Freemor (freemor) wrote :

The problem persists in Jaunty. Misreported Signal level and low range.

I did a apport-collect -p linux-image-`uname -r` 215802 as per kernel-janitors request. I can not provide the same on newer kernels or Karmic as this is a mission critical machine. the problem as severe enough to have me move to a wired connection (luckily in my case the machine lives in the same room as the router).

If I can be of further assistance let me know. if no one can offer info from Karmic or a newer kernel I may be able to boot from the karmic live CD late one night and see if the problem is still alive in Karmic and if so get the apport-collect output for you. If I can generate further meaningful info without having to jump out of Jaunty I'd be glad to do so.

regards,
Freemor

@freemor, thanks for testing and the feedback for Jaunty.

u-foka, since you are the original bug reporter, would you be able to test and confirm with the latest Karmic and upstream Mainline kernel? Thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
tags: removed: needs-kernel-logs

I used to experience this bug, however somewhere along the way with the kernel updates it was fixed for me. I was getting 14%, but now I get 85% in Karmic and there are no slowdowns. As far as I am concerned this bug is no longer...

u-foka (ufooka) wrote :

Hy there!

Sorry because the lateness!

Now I'm home, and I will test it soon. And will report the results.

Thanks for assistance!

u-foka (ufooka) wrote :

Hy! ... and sorry again!

But it's really interesting, and I wanted to post only if I compleatly sure about that!

I mage many tests, and I found that the driver in the new kernel works better on one router, and works as poor on router two as router one works with the old driver...

So with jaunty kernel:
router one (especially a dlink ap DWL-2100AP with an ubuntu machine as router) has good link quality
router two (a linksys wrv-200) has baad link quality
And with karmic, router one is poor and two has good link quality!

So finally I can't confirm it that the new driver is better than the old one! But it surely works some different way ;)
I will try to test it on more routers, but unfortunatelly I have a new note now, and that one is used by my father...

So it may take some time but I'l be back!

Hélio Nunes (dedalu-dedalu) wrote :
Download full text (3.3 KiB)

System monitor's connection graph looks more solid in Karmic than in Jaunty, with smaller gaps. But I am feeling lower transfer rates on local network. Its only a feeling, I did not measure it before updating, sorry. Now, for large files, on the same room, I get an average of 2MB/s receiving and 1MB/s sending. Is it ok?

Some data:

1) indoors, same room, 2 meters away

wlan0 IEEE 802.11bg ESSID:"casinha"
          Mode:Managed Frequency:2.462 GHz Access Point: 00:13:46:11:08:68
          Bit Rate=36 Mb/s Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:E540-ECB2-633E-4859-B587-BB96-5906-4B30-05B4-0F1C-B3BF-40DA-34B4-67A8-F724-3E17 [2]
          Power Management:off
          Link Quality=70/70 Signal level=-19 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Bit rate setting is auto, but it does not go 54Mb/s. If I force it I have connection issues. My signal level deviates between -22 and -17 dBm. No packet loss:

PING roteador.localdomain (192.168.0.1) 56(84) bytes of data.
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=1 ttl=127 time=1.73 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=2 ttl=127 time=2.96 ms
...
^C
--- roteador.localdomain ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9015ms
rtt min/avg/max/mdev = 1.146/1.728/2.968/0.559 ms

2) indoors, 2 walls, 10 meters away (I couldn't connect from this same spot with Jaunty.)

wlan0 IEEE 802.11bg ESSID:"casinha"
          Mode:Managed Frequency:2.462 GHz Access Point: 00:13:46:11:08:68
          Bit Rate=18 Mb/s Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:E540-ECB2-633E-4859-B587-BB96-5906-4B30-05B4-0F1C-B3BF-40DA-34B4-67A8-F724-3E17 [2]
          Power Management:off
          Link Quality=67/70 Signal level=-43 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Bit rate is adapting to signal level, with deviates from -43 to -42 dBm. But I get packet loss:

PING roteador.localdomain (192.168.0.1) 56(84) bytes of data.
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=1 ttl=127 time=1.53 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=2 ttl=127 time=1.70 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=3 ttl=127 time=1.46 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=5 ttl=127 time=1.58 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=6 ttl=127 time=1.61 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=7 ttl=127 time=2.18 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=8 ttl=127 time=7.75 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=9 ttl=127 time=2.32 ms
64 bytes from roteador.localdomain (192.168.0.1): icmp_seq=10 ttl=127 time=1.53 ms
^C
--- roteador.localdomain ping statistics ---
10 packets transmitted, 9 received, 10% packet loss, time 9017ms
rtt min/avg/max/mdev = 1.461/2.411/7.757/1.912...

Read more...

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SIS966 [HDA SIS966], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SIS966 [HDA SIS966], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jean 1384 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SIS966'/'HDA SIS966 at 0xb0100000 irq 18'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,10190000,00100101'
   Controls : 17
   Simple ctrls : 11
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=a5c1e648-8936-452c-98cd-6dba9484bf95
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
 Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: DIXONSXP DIXONSXP
Package: linux-image-2.6.31-16-generic 2.6.31-16.53
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-16-generic root=UUID=615d8439-f60d-4b6f-be68-f053e6bde3ec ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-16-generic N/A
 linux-firmware 1.25
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1439): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1439): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1497): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1510): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 06/16/2008
dmi.bios.vendor: OEM
dmi.bios.version: 1.12
dmi.board.asset.tag: Tag 12345
dmi.board.name: N/A
dmi.board.vendor: DIXONSXP
dmi.board.version: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: DIXONSXP
dmi.modalias: dmi:bvnOEM:bvr1.12:bd06/16/2008:svnDIXONSXP:pnDIXONSXP:pvr:rvnDIXONSXP:rnN/A:rvrN/A:cvnDIXONSXP:ct10:cvr:
dmi.product.name: DIXONSXP
dmi.sys.vendor: DIXONSXP

tags: added: apport-collected
Nick Howden (24doeway) wrote :

Seeing similar symptoms of intermittent connectivity with Karmic (9.10) using an RTL8187B device.

I've uploaded the apport and if I can provide any additional info happy to help.

Nick

Hi!

Same problem here, with Ubuntu 10.04.
My signal is strong (98 ~ 100%), however in about 8 meter the connection is lost and is totally impossible to connect again. I try unsucessfully many versions of Windows Drivers to RTL8187B with ndiswrapper. Please guys, don't let me back to windows!

I have exact same problems as Fernando J. Cordeiro has.

Richard Mosse (mosser) wrote :

Same here in Lucid 10.04 signal is reported as 80-90% but is very week,
it keeps dropping and is too slow to use,I briefly tried it beside the router and it worked fine.
please not windows!, does anybody know a possible workaround to boost the signal I tried :
sudo iwconfig wlan0 rate 11M but no luck, help!!

I have the same issue, wi-fi is only useable if I get closer than 2-3 meters from the antena. Farther form that it just isn´t able to connect.

Using the Ubuntu 10.4 64bit here, but Debian 5.0.4, Debian Testing , OpenSUSE 11.2 and Mandriva 2010.0 all have the same problems (best seems Mandriva).

And guess what?? Windows 7 64bit gives AWESOME reception ... witch of course is the cherry on my I-hate-this-damn-chip sunday ;)

*** Have been in contact with the guys at Linux-wireless (kernel devel list) and had to stop the test they were trying to diagnose the problem. Seems the USB stick that uses rtl8187b works fine, the problem is the onboard chip. Anyone have this experience?

The guys at Linux-wireless asked me to do a MMIO trace on the drivers, but I had no time (needs kernel config), if anyone has the time or the will reply to this and I will try to explain how that works.

*** Have tryied e-mailing the guys at Realtek, didn´t get a response for now.

Rogerio Luz Coelho

Punit Rathod (punitrathod) wrote :

I have a Netgear WG111v3 (RTL8187B) card. I have the same problems.

I have also tried the following with no real gains:
1. Ubuntu 9.10 with all kernel upgrades
2. Ubuntu 10.04 with all kernel upgrades (2.6.32-22-generic) and with 2.6.34 kernel from Ubuntu kernel mainline (http://kernel.ubuntu.com/~kernel-ppa/mainline/)
3. Backtrack 4 cd

If I use "iwconfig wlanX rate auto", then the rate for the interface hovers around 1M most of the time. On manually forcing a higher rate (i.e., above 24M) the connection automatically drops periodically.

Search for the term "No probe response" in the syslog.txt file attached. These are the time instances when the connection drops and reconnects.

The distance from the Laptop to the Router is less than 5 meters and there is line of sight. There is no obstacle (wooden partition or a wall) causing the signal to drop.

The card works fine with stable connection in Windows XP. Using ndiswrapper with windows xp inf+sys files in Ubuntu 10.04 (2.6.32-22) also works fine. But, the native drivers in the kernel do not work properly.

I can run some additional tests or traces to provide more insight into what might be going wrong with the driver.

I'll attach my iwconfig and lsusb files in the subsequent posts.

Punit Rathod (punitrathod) wrote :
Punit Rathod (punitrathod) wrote :

@ Punit:

Punit do a dmesg | grep -e wlan

You will see that there is a "wlan4: deauthenticating from 00:19:5b:ba:3f:6d by local choice (reason=3)"

this local choise (reason=3) is exacly what happens to me when I can´t connect or when losing connection.

*** While messing with my rate control, seems that 11M is the best setup available (iwonfig wlan0 rate 11M)

Rogerio

@Rogerio:
Yes, I noticed that rate 11M was quite stable for me too.

* You mentioned about some MIMO traces. Can you give some more details or
give some pointers. I can give it a try.

Download full text (4.8 KiB)

Excerpt from a Linux-wireless discussion (this is Linux kernel developer's list for wireless interfaces)

They asked me to do some tests: the major one was MMIO tracing the driver:

> You need to enable MMIO tracing support in your kernel config, and
> recompile your kernel (assuming it is not enabled already - distros
> usually disable the entire tracing framework by default). Then:
> -Mount debugfs to /debug. (Usually it is mounted by default, but some
> distros like to mount it @ /sys/kernel/debug instead - remount it to
> /debug.)
> -"echo mmiotrace > /debug/tracing/current_tracer"
> -"cat /debug/tracing/trace_pipe > trace.txt &" - at this point, tracing begins.
> -Load r8187b and connect.
> -"echo "Driver loaded!" > /debug/tracing/trace_marker"
> -"echo nop

Ok here are some news:

1) The rtl8187b problem is a know bug in Ubuntu since forever - bug
#215802
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/215802

2) Tryied the Realtek driver found in:
http://ubuntuforums.org/showthread.php?t=1446894
(rtl8187B_linux_26.1056.1112.2009.release.tar.gz )

- as seno said here on the list in 14-05-2010 17:20:02

It installs a module called r8187b, witch I managed to use ONCE, after
it installed, then after it disconnected it would not connect again, and
after I rebooted there was no more wi-fi interface (!!!) ifconfig and
iwconfig confirm that my wi-fi card (wlan0) is nowhere to be found

5) Rate seems weird on this card. If I define the rate with
"iwconfig wlan0 rate 11M" it gives the best download speed, even if I
rase this to 24M or 54M I get at least a 40% difference, same if I lower
the rate.
Maybe what Hin-Tak Leung (2010-04-03) said about the Minstrel algorithm?
Could we try to install both Minstrel and older algorithms side by side
and make a comparison? from what I read here:

http://wireless.kernel.org/en/developers/Documentation/mac80211/RateControl/minstrel
"Further, it means that the 1 Mbps rate (which typically has a high
probability of successful transmission) will not be used in preference
to the 11 Mbps rate."

But my rate is always a defaulted 1Mb/s on bootup. I put it to 11M
manually and the connection improves dramatically

4) Ran the mmiotrace on the rtl8187 driver, it all seems gibberish to
me ;)

one while it was at 1m from the router giving me top speed (same as
Win7): trace1.txt:

VERSION 20070824
PCIDEV 0000 10390671 0 d0000000 0 0 0 0 0 0 8000000 0 0 0 0 0 0
agpgart-sis
PCIDEV 0008 10390003 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
PCIDEV 0010 10390968 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
PCIDEV 0015 10395513 10 1f0 3f6 170 376 1081 0 0 8 0 8 0 10 0 0 pata_sis
PCIDEV 0018 10397001 14 d8404000 0 0 0 0 0 0 1000 0 0 0 0 0 0 ohci_hcd
PCIDEV 0019 10397001 15 d8405000 0 0 0 0 0 0 1000 0 0 0 0 0 0 ohci_hcd
PCIDEV 001b 10397002 16 d8406000 0 0 0 0 0 0 1000 0 0 0 0 0 0 ehci_hcd
PCIDEV 0020 10390191 13 d8407000 1001 0 0 0 0 0 80 80 0 0 0 0 0 sis190
PCIDEV 0028 10391183 11 10c9 10bd 10c1 10b9 10a1 0 0 8 4 8 4 10 0 0
sata_sis
PCIDEV 0030 1039000a 18 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport
PCIDEV 0038 1039000a 19 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport
PCIDEV 0078 10397502 12 d8400000 0 0 0 0 0 0 4000 0 0 0 0 0 0 HDA Intel
PCIDEV 00f8 1...

Read more...

Also having this problem, with a Alfa 54G USB stick on Ubuntu 10.04 (Karmic)

Bus 001 Device 005: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

The connection becomes very slow after a while (due to packet loss). I'm now trying the rate 'workaround'
After re-associating to the network, everything is fine again, for a while. The time after which the problem occurs seems to depend on the network load.

Two years after the first report and no exist any solution?

Regards
Nacho

tags: added: iso-testing

Now the wireless rtl8187b adapter seems for now a dead end, the linux-wireless people can´t seem to get interested in this bug, seems it is a hit-miss situation as one of the devs has the chip working pleasently in his box, the latest post was something in the way of "well mine works so I can´t write code to fix something that works".

In Aug/2010 another kernel dev has aparently seen the problem and is as I write this trying some test on the driver.

Oh well, we will wait and see. In the Ubuntu bug tracker the problem is still open and persists on many people´s machines.

By the way just have a search in Ubuntu bugs : Realtek wireless has a lot of bugs tracking, the most of them relate to #567016 , but I couldn´t mark that one as a duplicate of this thread, so I will try the other way around to see if we can get everybody in the same page.

FYI seems the .32-generic-proposed kernel fixed some issues and a lot of people are reporting success (but if seems they are in a different chipset than 8187b) have not tested yet, but worth a try.

Rogerio

oh forgot the link to the kernel-wireless discution group:

http://www.spinics.net/lists/linux-wireless/msg54219.html

if anyone sees a way to help please join that group / thread

Rogerio - CoolRabbit

Ok have just added this as a DUPLICATE of bug #567016 ...

Please update your links acordingly as the bug #567016 seems to have more kernel devs involved !!

Rogerio

People, exist a driver from Realtek, the same fix the problems of quality signal, lost connection, no connection, etc. Here the fix.

The post is in spanish, so, you can translate with google translator.

http://www.techdays.com.ar/2010/10/12/instalar-wifi-realtek-8187b-en-ubuntu/

Regards.
Nacho

I upload the driver from realtek.

Download and follow the instruction from the readme file.

Realtek 8187B

I forgot, use sudo for install.

good luck

So ... here is an update:

1st - Nacho's driver does not work at all for my 10.04 64bit box ... it is hit and miss on the compile, but I lose my wlan0 interface, it's jsut gone !!

here is the e-mail I got from Realtek about their support for 64bit

[code]

de Jerry-RealtekFAE <...@realtek.com>
para Rogerio Luz Coelho <luz.rogerio@...>
cc wlanfae <...realtek.com>
data 28 de fevereiro de 2010 22:45
assunto Re: 8187b for linux 64bits

Dear Sir/Madam

Thanks for your e-mail.
The RTL8187B Linux driver just only support 32bit os.

Best Regards
Jerry

[/code]

The GREAT NEWS is that there is a Brasilian developer in the kernel-wireless list that seems to have fixed the problem:

I am actually using the 8187b card with a Ubuntu 10.04 box 64 bit about 30 meters from the router, and conection is as good it seems as with Win7 ...

Will test more of this connection so it can be patched in the kernel, but it will take a HUGE TIME to come down to a kernel compiled for Ubuntu, my advice is getting the patch, apllying it to the source of the driver and recompiling the driver against your running kernel ...

Will ask him if I can post it here, as soon as he responds will post it and maybe some 2.6.32-25 kernel packages with it already installed

Rogerio

Changed in linux:
status: New → Confirmed

New update :)

Suspend / Resume works great with the new patch and wicd :))

tags: added: patch
Sundaram Ramaswamy (legends2k) wrote :

Oh can't wait to get it! Please do ask the developer to share it here :)

Vince McIntyre (vmcintyr) wrote :

I think the patch is discussed here:
  https://patchwork.kernel.org/patch/139191/
and
  http://www.spinics.net/lists/linux-wireless/msg58213.html

See also later discussion of a further series of patches for this hardware
  http://www.spinics.net/lists/linux-wireless/msg58361.html

@Vince

Yes I am in this discussion...

TO ALL WHO MAY CONCERN : THE FIX IS BELOW:

1) Download the patch or copy and paste it from http://www.spinics.net/lists/linux-wireless/msg58213.html (as said earlier by Vince)

2) save it as a .patch file (fix.patch is the upload)

3) aply the patch

4) build the driver (try this link if you don't know how http://wireless.kernel.org/en/users/Download#Building_and_installing )

5) reboot

If people are insterested I have a semi-custom kernel package built with the patched driver, it's a 64bit preempt , but I can post it somewhere.

Rogerio

The patch that initialy fixes this bug for me:

Seth Forshee (sforshee) on 2011-01-12
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Seth Forshee (sforshee) wrote :

I've uploaded test kernel packages with this fix applied to http://people.canonical.com/~sforshee/lp215802/. Please let me know whether or not these packages fix this issue. Note that I've included packages for lucid and maverick, so you'll need to select the versions that correspond to your kernel version.

Seth Forshee (sforshee) on 2011-01-12
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Vince McIntyre (vmcintyr) wrote :

I tested this device:

$ sudo lsusb -d 0846:4260
Bus 001 Device 004: ID 0846:4260 NetGear, Inc. WG111(v3) 54 Mbps Wireless [RealTek RTL8187B]
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x0846 NetGear, Inc.
  idProduct 0x4260 WG111(v3) 54 Mbps Wireless [RealTek RTL8187B]
  bcdDevice 2.00
  iManufacturer 1 Manufacturer_NETGEAR
  iProduct 2 NETGEAR WG111v3
  iSerial 3 <redacted>
  bNumConfigurations 1

against:
 * ubuntu 2.6.32-26-generic
 * http://people.canonical.com/~sforshee/lp215802/linux-image-2.6.32-28-generic_2.6.32-28.55+LP215802v1_i386.deb (md5sum 3578ab4e4757ea2c5f53b3d43fa75c78).

With 2.6.32-26-generic, the device fell over after about an hour, with
  Jan 15 00:25:14 ubuntu kernel: [279647.500012] No probe response from AP <redacted> after 500ms, disconnecting.

The signal strength was pretty good, -38db, link quality 70/70.

With the test kernel, the device has been solidly up for nearly 24h. Signal strength similar, -38db +/- a few db, quality 65/70.

Looks like this fixes it for me.

Vince McIntyre (vmcintyr) wrote :

With the patched kernel iwconfig reports a bit rate of 36Mbit/s. Non-optimal tests (rsync over ssh within the wireless LAN) showed a real throughput of at least 2.7Mbit/s, ie well over 1Mbit/s.

u-foka (ufooka) wrote :

Hy!

Thanks for the fix :)
By the way, I already have a new note, and the one with this wifi chip is currently used by my father... I'l test it as soon as I can, but it can't be a quick run :(

Seth Forshee (sforshee) wrote :

@Vince, thanks for testing!

@u-foka, no problem.

If anyone affected by this problem is able to test against the 2.6.35 (i.e. maverick) kernel I posted, I'd appreciate getting some verification against that kernel as well.

Andy Whitcroft (apw) wrote :

The patch in question has hit mainline in v2.6.38 and therefore will be in the next Natty kernel (once it is stable enough to upload). Moving Fix Committed for Natty, Maverick testing is still required as per Seth's last comment.

Changed in linux (Ubuntu Maverick):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
filip (bandit-s-fw) wrote :

On maverick i have had no disconnects anymore so far and also the speed of the network has increased after installing the kernel.
However i have also installed the wl backport 2.6.36 previously and is still installed. But i see even then an improvement.
With only the wl backport i still got the disconnects.

Seth Forshee (sforshee) wrote :

@filip:

Thanks for testing. Just to confirm, you were testing with the 2.6.35 kernel packages I posted?

I should be able to tell which rtl8187 driver is being used if you'll provide the output from running 'modprobe --show-depends rtl8187' in a terminal on your machine.

filip (bandit-s-fw) wrote :

Yes, i have installed your kernel builds (maverick) from post #67 but with the backport wireless package of the .36 kernel.
It is not my computer so i can't run it now. But as soon as i can i will report the output.
If you want i can remove the backport package to see.

Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux - 2.6.38-1.27

---------------
linux (2.6.38-1.27) natty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: AUFS -- update aufs-update to track new locations of headers
  * ubuntu: AUFS -- update to c5021514085a5d96364e096dbd34cadb2251abfd
  * SAUCE: ensure root is ready before running usermodehelpers in it
  * correct the Vcs linkage to point to natty
  * rebase to linux tip e78bf5e6cbe837daa6ab628a5f679548742994d3
  * [Config] update configs following rebase
    e78bf5e6cbe837daa6ab628a5f679548742994d3
  * SAUCE: Yama: follow changes to generic_permission
  * ubuntu: compcache -- follow changes to bd_claim/bd_release
  * ubuntu: iscsitarget -- follow changes to open_bdev_exclusive
  * ubuntu: ndiswrapper -- fix interaction between __packed and packed
  * ubuntu: AUFS -- update to 806051bcbeec27748aae2b7957726a4e63ff308e
  * update package version to match payload version
  * rebase to e6f597a1425b5af64917be3448b29e2d5a585ac8
  * rebase to v2.6.38-rc1
  * [Config] updateconfigs following rebase to v2.6.38-rc1
  * SAUCE: x86 fix up jiffies/jiffies_64 handling
  * rebase to linus tip 2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] updateconfigs following rebase to
    2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] disable CONFIG_TRANSPARENT_HUGEPAGE to fix i386 boot crashes
  * ubuntu: AUFS -- suppress benign plink warning messages
    - LP: #621195
  * [Config] CONFIG_NR_CPUS=256 for amd64 -server flavour
  * rebase to v2.6.38-rc2
  * rebase to mainline d315777b32a4696feb86f2a0c9e9f39c94683649
  * rebase to c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] update configs following rebase to
    c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] disable CONFIG_AD7152 to fix FTBS on armel versatile
  * [Config] disable CONFIG_AD7150 to fix FTBS on armel versatile
  * [Config] disable CONFIG_RTL8192CE to fix FTBS on armel omap
  * [Config] disable CONFIG_MANTIS_CORE to fix FTBS on armel versatile

  [ Kees Cook ]

  * SAUCE: kernel: make /proc/kallsyms mode 400 to reduce ease of attacking

  [ Stefan Bader ]

  * Temporarily disable RODATA for virtual i386
    - LP: #699828

  [ Tim Gardner ]

  * [Config] CONFIG_NLS_DEFAULT=utf8
    - LP: #683690
  * [Config] CONFIG_HIBERNATION=n
  * update bnx2 firmware files in d-i/firmware/nic-modules

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
  * packaging: make System.map mode 0600
  * thinkpad_acpi: Always report scancodes for hotkeys
    - LP: #702407
  * sched: tg->se->load should be initialised to tg->shares
  * Input: sysrq -- ensure sysrq_enabled and __sysrq_enabled are consistent
  * brcm80211: include linux/slab.h for kfree
  * pch_dma: add include/slab.h for kfree
  * i2c-eg20t: include linux/slab.h for kfree
  * gpio/ml_ioh_gpio: include linux/slab.h for kfree
  * tty: include linux/slab.h for kfree
  * winbond: include linux/delay.h for mdelay et al

  [ Upstream Kernel Changes ]

  * mark the start of v2.6.38 versioning
  * rebase v2.6.37 to v2.6.38-rc2 + c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
    - LP: #689886
    - LP: #702125
    - LP: #608775
    - LP: #215802
...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
filip (bandit-s-fw) wrote :

@ Seth Forshee

uname --all
Linux carine-laptop 2.6.35-25-generic #43+LP215802v1 SMP Wed Jan 12 04:25:36 UTC 2011 i686 GNU/Linux

~$ modprobe --show-depends rtl8187
insmod /lib/modules/2.6.35-25-generic/kernel/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/2.6.35-25-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.35-25-generic/kernel/drivers/leds/led-class.ko
insmod /lib/modules/2.6.35-25-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.35-25-generic/kernel/drivers/net/wireless/rtl818x/rtl8187.ko

I've also removed the backport wireless package. So now i am back to stock edititon.

Mode:Managed Frequency:2.437 GHz Access Point: ereased
          Bit Rate=36 Mb/s Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=70/70 Signal level=-9 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 When there is no page loading in the browser the bit rate is 1 mb/s.
I see that the bit rate increases when browsing like above shows.
At the moment i don't see any regressions. Only a good improvement.

Seth Forshee (sforshee) wrote :

Thanks, filip.

It sounds like there should be a new backport wireless package for both lucid and maverick once the 2.6.38 kernel gets released, so I'll probably let this fix come in via that route to avoid any potential for regression.

Changed in linux:
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Maverick):
status: Incomplete → In Progress
Seth Forshee (sforshee) wrote :

The upstream fix for this bug was contained in v2.6.38-rc1.

Changed in linux:
status: Fix Committed → Fix Released
vygiz (vygiz) wrote :

With LAN connection:

ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

>uname --all
Linux vygiz-pc2 2.6.32-30-generic #59-Ubuntu SMP Tue Mar 1 21:30:46 UTC 2011 x86_64 GNU/Linux

Seth Forshee (sforshee) wrote :

@vygiz: This bug should be fixed in the next backports wireless release, which should be happening soon.

vygiz (vygiz) wrote :

Mine is not wireless, it is a WIRED connection. Will it still be fixed?

Also I grabbed the currently available 2.6.38 kernel but it has the same problems.

Seth Forshee (sforshee) wrote :

@vygiz: Ah, sorry, I didn't read closely enough. If you're having problems with the wired connection then it is off-topic for this bug. You should file a new bug for your issue.

Seth Forshee (sforshee) wrote :

linux-backports-modules-2.6.35 2.6.35-28.20 contains compat-wireless from 2.6.38 and is available in maverick-proposed. Please test to verify that this issue has been fixed.

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
removed: needs-upstream-testing
Seth Forshee (sforshee) wrote :

The fix for this issue in Maverick has been released in linux-backports-modules-2.6.35 2.6.35-28.20.

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Mike (joke99) wrote :

Hi, i have ubuntu 11.04, all updates, wifi chipset rtl8187B, kernel 2.6.38-10, and still have ping up and slow speed (~1 mbit/s) when download something.
In windows its works fine.
Can someone help me with it?
Thanks, and sorry my bad english.

laptop:~$ uname -a
Linux mike-laptop 2.6.38-10-generic #44-Ubuntu SMP Thu Jun 2 21:32:22 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

laptop:~$ modprobe --show-depends rtl8187
insmod /lib/modules/2.6.38-10-generic/updates/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/2.6.38-10-generic/updates/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.38-10-generic/updates/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.38-10-generic/updates/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko

laptop:~$ sudo lsusb -d 0bda:8187
Bus 001 Device 004: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

Seth Forshee (sforshee) wrote :

@Mike: You are probably experiencing a different problem since the fix that's already in natty has been confirmed to fix the issue reported here. Please run 'ubuntu-bug linux' in a terminal to open a new bug for your issue. Thanks!

Bertrand (berts-beersite) wrote :

@Seth and @Mike: I think I am suffering from the same issue. Typically very low speeds (often even capped at 80kb/s).

Though newer version of (K)ubuntu

~$ modprobe --show-depends rtl8187
insmod /lib/modules/3.0.0-15-generic/kernel/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/3.0.0-15-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.0.0-15-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.0.0-15-generic/kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko

~$ lsusb -d 0bda:8187
Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

~$ uname -a
Linux beertop 3.0.0-15-generic #24-Ubuntu SMP Mon Dec 12 15:25:25 UTC 2011 i686 i686 i386 GNU/Linux

Mike (joke99) wrote :

Hi, Bertrand,
Yes, its the same issue, and I have open a new bug for this:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/802902
Thanks

Smolag (smolag) wrote :

I'm on Ubuntu 12.04 beta 2, kernel 3.2.0-22-generic-pae, i386. I can see improvements since last stable releases but still I experience slow network and network outage. At least it doesn't drop connection any more. I really would like to see my AWUS036H card working as fast and stable as in Windows.

Smolag (smolag) wrote :

OK, so the connection drops every time I try to create a report using apport-collect; apport-collect -p linux 215802 to be exact. After I used apport-collect the connection started dropping approximately every 20 seconds.

To post a comment you must log in.