Ubuntu

Ubuntu Can't Mount LiveFS CDs Burned on Vista

Reported by jlparise on 2008-04-08
56
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
Wishlist
Unassigned

Bug Description

System: Ubuntu Gutsy Gibbon

Updated to all the latest updates.

Problem: Every time a friend gives me a data CD burned on Windows Vista, Ubuntu can't mount it. From Gnome I simply get a pop up stating it cannot be mounted. See attached screenshot. From the command line I get the following:

jon@jon-laptop-ubuntu:/media$ mount cdrom0
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

dmesg output is attached.

The last 2 lines seem to pertain to the problem they read:

[ 597.412000] UDF-fs: No fileset found
[ 597.544000] Unable to identify CD-ROM format.

I have no idea what so is, it doesn't seem to be a valid command.

This has happened to me with 3 CDs, each one was burned was burned using Windows Vista's built in burning feature. I can verify that the CD's contain data since I was able to read them with a Windows XP machine and get the files.

I'm not sure what other information would be helpful so please let me know.

thanks,

Jon

jlparise (jlparise) wrote :
jlparise (jlparise) wrote :

I tried to mount it a few times, here is the full dmesg output.

doorknob60 (doorknob60) wrote :

It's because Microsoft made their own proprietary file system for burning CDs...typical. Tell him to change the option to Mastered instead of Live File System, or use a different burning program. More info: http://windowshelp.microsoft.com/Windows/en-US/Help/b47eb51a-ea6d-4d97-97b0-2d07a59316981033.mspx

jlparise (jlparise) wrote :

I figured it's an issue with Microsoft, the reason I reported it is that people are going to continue to try to distribute Vista Cds. It is going to be the dominant platform regardless of how terrible it is sadly. So it would be wise for Ubuntu to be able to read the discs.

I know it is not Ubuntu's fault, but the average person doesn't know that. They will blame it on Ubuntu when it doesn't work.

Also, my friend does not have another burning program, nor does she want to purchase one.

Brian Murray (brian-murray) wrote :

I was able to recreate this bug report by burning a LiveFS formatted CD in Windows Vista and then trying to mount it using Hardy Heron with kernel version '2.6.24-19-generic'. It seems that there is no kernel support for this particular filesystem at this point in time.

David Youngs (canonicaladmin) wrote :

Yes - I'm having exactly the same problem here. Interestingly, I think the problem also affects Windows 2000 and Apple OS-X.

See also:
http://conradc.wordpress.com/2008/04/28/cannot-read-cd-or-dvd-from-windows-vista/
http://digg.com/microsoft/Burning_Issues_With_Vista
http://windowshelp.microsoft.com/Windows/en-US/Help/2af64e60-60aa-4d79-ab6c-3a5db5806cbe1033.mspx#section_3

The only way I can get these CDs to read on Ubuntu is by installing WinXP within VMWare or similar - which whilst it proves there is no problem with the CD/DVD drive, is not viable for most people.

The problem is I've previously sent a number of CDs back to people saying "sorry, I think your CD might be damaged because it's not reading on my Linux PC which usually reads everything...". I suspect this conversation is being repeated daily around the planet given the number of people trying to use Ubuntu et al alongside Vista machines. Whilst we can try and tell people to burn using 'non-default' options on Vista, I'm sceptical about the number of Vista users who'll actually be able to do this (let alone remember to do it consistently).

Strangest of all, it's possible that the problem might actually be related to Microsoft actually implementing an existing *standard* - UDF2.50. Shocking I know - (and slightly embarrassing if for us Linux fan-boys if we hasn't caught up with mainstream support for an open standard 18 months after Vista was released.) On the otherhand, it could be that MicroSoft have hacked UDF2.50 around and their implementation is broken. Any ideas? I'm having a look at http://sourceforge.net/projects/linux-udf/

Brian Murray (brian-murray) wrote :

Using kernel version 2.6.26-3-generic from Intrepid Ibex I was able to successfully mount a LiveFS formatted CD (by Windows Vista) with it.

Brian Murray (brian-murray) wrote :

I'm setting the status of this bug to Fix Released as this is now possible with the latest Ubuntu kernel. We will check with the kernel team to see if it is possible to get this fix included in Hardy Heron though.

Changed in linux:
status: Confirmed → Fix Released

Hi Guys,

It sounds like the kernel team will consider backporting this for a Hardy SRU. I'm just adding the possible git commit id to consider backporting for the kernel team. Thanks.

commit bfb257a5981af805a9394f00f75d3d9f7b611cc0
Author: Jan Kara <email address hidden>
Date: Tue Apr 8 20:37:21 2008 +0200

    udf: Add read-only support for 2.50 UDF media

    This patch implements parsing of metadata partitions and reading of Metadata
    File thus allowing to read UDF 2.50 media. Error resilience is implemented
    through accessing the Metadata Mirror File in case the data the Metadata File
    cannot be read. The patch is based on the original patch by Sebastian Manciulea
    <email address hidden> and Mircea Fedoreanu <email address hidden>.

    Signed-off-by: Sebastian Manciulea <email address hidden>
    Signed-off-by: Mircea Fedoreanu <email address hidden>
    Signed-off-by: Jan Kara <email address hidden>

David Youngs (canonicaladmin) wrote :

Sounds great - but (after several hours of trying) it still doesn't want to work here.

I've downloaded Intrepid Ibex from: http://cdimage.ubuntu.com/releases/intrepid/alpha-1/ It came with a slightly older kernel, so I updated (using standard repositories / usual method) and the kernel now reports: "Linux ubuntu 2.6.26-3-generic #1 SMP Wed Jul 2 21:54:36 UTC 2008 x86_64 GNU/Linux"

The dmseg output when I try to load a UDF 2.50 formated CD from Vista still reads:
[ 2276.836315] end_request: I/O error, dev sr0, sector 29508
[ 2277.000290] end_request: I/O error, dev sr0, sector 29504
[ 2277.200290] end_request: I/O error, dev sr0, sector 29500
[ 2277.600293] end_request: I/O error, dev sr0, sector 29508
[ 2277.600293] udf: udf_read_inode(ino 7377) failed !bh
[ 2277.856293] end_request: I/O error, dev sr0, sector 29508
[ 2277.856293] udf: udf_read_inode(ino 7377) failed !bh
[ 2277.856293] UDF-fs: No partition found (1)
[ 2278.412285] ISOFS: Unable to identify CD-ROM format.

I've tried multiple CDs - just in case of physical media errors. If I select 'Mastered CD' when burning in Windows Vista, the disc reads fine. But every type of LiveCD still fails I've tried different drives. I've tried different versions of Vista. It still resolutely refuses me.

I've also tried UDF 2.01 - which is the default CD format that most Vista users are going to be burning on. This also fails 100% of the time for me - but with a slightly different error message:
[ 2573.620375] UDF-fs: No VRS found
[ 2573.660589] UDF-fs: No VRS found
[ 2573.721194] ISOFS: Unable to identify CD-ROM format.
[ 2574.041861] ISOFS: Unable to identify CD-ROM format.
[ 2574.051774] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[ 2618.894201] usb 3-4: USB disconnect, address 4
[ 2855.737382] end_request: I/O error, dev sr0, sector 11420
[ 2855.880659] end_request: I/O error, dev sr0, sector 11416
[ 2856.048658] end_request: I/O error, dev sr0, sector 11412
[ 2856.380660] end_request: I/O error, dev sr0, sector 11420
[ 2856.380660] udf: udf_read_inode(ino 2855) failed !bh
[ 2856.612662] end_request: I/O error, dev sr0, sector 11420
[ 2856.612662] udf: udf_read_inode(ino 2855) failed !bh
[ 2856.612662] UDF-fs: No partition found (1)
[ 2856.760647] ISOFS: Unable to identify CD-ROM format.

(NB: there's a pen drive being connected and disconnected a few times - that's being used to copy log files across to my PC).

I attach a zip file with the last 25 lines of dmesg output after trying each of the different UDF CD formats.

Any advice / assistance would be very gratefully received.

Hi David,

I noticed the following bug report, bug 106910, which seems to describe a similar if not a duplicate issue reported here. One of the comments described being able to successfully mount CD-RW and DVD-RW burned in windows. I'm curious if you'd be willing to test their solution and let us know your results:

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/106910/comments/21

Thanks in advance.

Bruno Léon (bruno-leon) wrote :

Hi,

trying to mount an UDF CD burnt using Vista I ended up on this topic.
I tried the solution presented in the above link and IT DID NOT fix the pb.
The pb is the same on Hardy/Intrepid.

dmesg gives this:
[ 3370.099441] udf: udf_read_inode(ino 232162) failed !bh
[ 3370.099455] UDF-fs: No partition found (1)
[ 3385.891240] attempt to access beyond end of device

Hope somebody will find a solution.

Brian Murray (brian-murray) wrote :

I was unable to recreate this bug using kernel version 2.6.27-14-generic on my laptop. What specific kernel version are you using? You can check via 'cat /proc/version_signature' in a terminal.

Bartek Celary (karaphka) wrote :

I am having this issue:

[ 8918.239680] udf: udf_read_inode(ino 2261816) failed !bh
[ 8918.295588] udf: udf_read_inode(ino 2261816) failed !bh
[ 8918.296719] UDF-fs: No partition found (1)
[ 8918.640338] ISOFS: Unable to identify CD-ROM format.
[ 9059.516487] udf: udf_read_inode(ino 2261816) failed !bh
[ 9059.572378] udf: udf_read_inode(ino 2261816) failed !bh
[ 9059.573521] UDF-fs: No partition found (1)
[ 9691.859452] udf: udf_read_inode(ino 2261816) failed !bh
[ 9691.915201] udf: udf_read_inode(ino 2261816) failed !bh
[ 9691.916285] UDF-fs: No partition found (1)

My kernel: Ubuntu 2.6.27-11.27-generic

I tried the solution mentioned above and also no go.

The medium that causes the error is a DVD-RW written in Vista. The DVD-RW was formatted and the files were dropped, then the session was closed (via drive's context menu end session (or similar) option).

Also tried to copy via Virtualbox Windows XP and it worked OK, so the medium is readable. The DVD was not written to before.

Konstantin Mikhaylov (jtraub) wrote :

I have a bucnh of DVDs which were burnt with Nero under Windows XP several years ago. All of them are reading perfectly in Windows environment (XP and Vista). But i can not get them mounted on Ubuntu 8.10

here is information

xxx@xxxx:~$ sudo mount /dev/scd0 /media/cdrom0 -t udf
mount: блочное устройство /dev/scd0 защищен от записи, монтируется только для чтения
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       В некоторых случаях полезная информация может быть
       найдена в syslog - попробуйте dmesg | tail или что-то
       в этом роде
xxx@xxxx:~$ dmesg | tail
[255454.994234] UDP: bad checksum. From 208.65.91.105:1024 to 192.168.1.147:55201 ulen 111
[255732.381231] attempt to access beyond end of device
[255732.381236] sr0: rw=0, want=68, limit=4
[255732.390257] attempt to access beyond end of device
[255732.390262] sr0: rw=0, want=1028, limit=4
[255732.390269] attempt to access beyond end of device
[255732.390272] sr0: rw=0, want=2052, limit=4
[255732.390276] UDF-fs: No partition found (1)

Going to test with VirtualBox

komputes (komputes) wrote :

Brian, I am in doubt that this is "Fix Released". Maybe "Fixed Partially". I have a CD-RW that is not recognizable in Linux. This is a CD-RW with photos on it, which I wrote in Vista in a very particular manner*. The CD-RW burned with Vista's file manager using the "LiveFS" (Microsoft's implementation of UDF 2.5)

If your attempt to reproduce my issue please be sure to insert CD-RW media into the Vista Machine and try both of these methods, comparing the outcome:

Tests:
*1) add files, remove some files, eject disc, insert disc, add more files, eject disk, insert disc into intrepid machine
2) add files, eject disk, insert disc into intrepid machine

Outcomes:
1) ISOFS: Unable to identify CD-ROM format.
2) UDF 2.5 CD-RW is read correctly

Please let me know if you can reproduce this Brian. If so can you please re-open this bug and create an upstream bug at bugzilla.kernel.org.

Also this:
http://bugzilla.kernel.org/show_bug.cgi?id=3300
Jan Kara speaks of a patch that was added to 2.6.26 to add support UDF 2.50. I fear this patch may be incomplete/buggy.

This is a old issue I believe it is to do with the Live FS  that is the default burning level on Vista. I have now choose a different level other then the default Vista and it seems to work.

That is the solution for now, maybe the Vista LiveFS is a  pripority to the Vista Operation System.

Thanks
Brian

--- On Thu, 3/26/09, David Bensimon <email address hidden> wrote:
From: David Bensimon <email address hidden>
Subject: [Bug 213696] Re: Ubuntu Can't Mount LiveFS CDs Burned on Vista
To: <email address hidden>
Received: Thursday, March 26, 2009, 8:13 PM

Brian, I am in doubt that this is "Fix Released". Maybe "Fixed
Partially". I have a CD-RW that is not recognizable in Linux. This is a
CD-RW with photos on it, which I wrote in Vista in a very particular
manner*. The CD-RW burned with Vista's file manager using the
"LiveFS"
(Microsoft's implementation of UDF 2.5)

If your attempt to reproduce my issue please be sure to insert CD-RW
media into the Vista Machine and try both of these methods, comparing
the outcome:

Tests:
*1) add files, remove some files, eject disc, insert disc, add more files,
eject disk, insert disc into intrepid machine
2) add files, eject disk, insert disc into intrepid machine

Outcomes:
1) ISOFS: Unable to identify CD-ROM format.
2) UDF 2.5 CD-RW is read correctly

Please let me know if you can reproduce this Brian. If so can you please
re-open this bug and create an upstream bug at bugzilla.kernel.org.

Also this:
http://bugzilla.kernel.org/show_bug.cgi?id=3300
Jan Kara speaks of a patch that was added to 2.6.26 to add support UDF 2.50. I
fear this patch may be incomplete/buggy.

--
Ubuntu Can't Mount LiveFS CDs Burned on Vista
https://bugs.launchpad.net/bugs/213696
You received this bug notification because you are a direct subscriber
of a duplicate bug.

      __________________________________________________________________
Looking for the perfect gift? Give the gift of Flickr!

http://www.flickr.com/gift/

komputes (komputes) wrote :

I have been unsuccessful in trying to reproduce this issue for the past hour.
I still have a disc which I previously burned in Vista, which can't be read in Ubuntu.
If someone confirms that they are still having an issue reading/writing multiple sessions on the Windows LiveFS I will look into this a little further.

Vladimir Hidalgo (vlad88sv) wrote :

[ 130.787177] UDF-fs: Partition marked readonly; forcing readonly mount
[ 130.899170] UDF-fs: No fileset found

Still an issue in Karmic =(
~$ uname -a
Linux ubuntu 2.6.31-10-generic #34-Ubuntu SMP Wed Sep 16 00:23:19 UTC 2009 i686 GNU/Linux

BavarianPH (bavarianph) wrote :
Download full text (118.8 KiB)

Bug # 567154 is related to this bug.

Still an issue in Lucid LTS

Linux phh 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux.

I also tested a Lucid LTS (Apr 29 UTC 2010) installed on a clean, empty hdd.

I also experimented with different fstab configurations to no avail.

Still no Vista advanced, internal burnt CD/DVD support in Lucid LTS!

In bug # 567154 I have attached terminal output to 3 tests:

1.) Vista advanced, internal burnt DVD+R containing data/media.
2.) Blank DVD+R.
3.) Actual Vista Install DVD-ROM

I will repeat these tests here:

First: a DVD+R containing data/media, burnt by Vista advanced, internal burner (readable in a Vista SP2 PC):

phh@phh:~$ ls -la /media/
total 20
drwxr-xr-x 5 root root 4096 2010-05-10 18:32 .
drwxr-xr-x 26 root root 4096 2010-05-12 16:26 ..
lrwxrwxrwx 1 root root 7 2010-03-21 05:33 floppy -> floppy0
drwxr-xr-x 2 root root 4096 2010-03-21 05:33 floppy0
drwxrwx--- 9 phh disk 4096 2010-05-08 22:42 sdb1
drwxr-xr-x 3 root root 4096 2010-05-02 15:40 sdc1

phh@phh:~$ sudo mount -l
[sudo] password for phh:
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
none on /var/lib/ureadahead/debugfs type debugfs (rw,relatime)
/dev/sdb1 on /media/sdb1 type ext4 (rw,nosuid,nodev)
/dev/sdc1 on /media/sdc1 type ext4 (rw,nosuid,nodev) [Ubuntu]
gvfs-fuse-daemon on /home/phh/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=phh)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

dmesg
[ 8555.821594] end_request: I/O error, dev sr0, sector 120
[ 8555.824788] sr 4:0:1:0: [sr0] Unhandled sense code
[ 8555.824792] sr 4:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 8555.824798] sr 4:0:1:0: [sr0] Sense Key : Medium Error [current]
[ 8555.824805] sr 4:0:1:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 8555.824812] sr 4:0:1:0: [sr0] CDB: Read(10): 28 00 00 00 00 1e 00 00 02 00
[ 8555.824829] end_request: I/O error, dev sr0, sector 120
[ 8555.828850] sr 4:0:1:0: [sr0] Unhandled sense code
[ 8555.828854] sr 4:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 8555.828860] sr 4:0:1:0: [sr0] Sense Key : Medium Error [current]
[ 8555.828867] sr 4:0:1:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 8555.828875] sr 4:0:1:0: [sr0] CDB: Read(10): 28 00 00 00 00 1e 00 00 02 00
[ 8555.828891] end_request: I/O error, dev sr0, sector 120
[ 8555.832083] sr 4:0:1:0: [sr0] Unhandled sense code
[ 8555.832088] sr 4:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 8555.832094] sr 4:0:1:0: [sr0] Sense Key : Medium Error [current]
[ 8555.832101] sr 4:0:1:0: [sr0] Add. Sense: L-EC uncorre...

Jovaro (bug-jovaro) wrote :

I am also having trouble mounting DVD's burned in Vista with LiveFS, both in Karmic and in Lucid. So I am marking this bug as confirmed instead of fix released.

I think the importance should be increased as well, since Ubuntu just should be able to read DVD's burned in Vista.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
jhellen (jukka-hellen) wrote :

Found this fix from 2007 in the ubuntuforums. Just move the udf parameter in the fstab like this:

BEFORE:
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
AFTER:
/dev/scd0 /media/cdrom0 iso9660,udf user,noauto,exec,utf8 0 0

This worked for me :)

Mger Zero (mgerzero) wrote :

Check bug 44233, read the recent post.
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/44233

The temp fix may work for you.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.