Problem with IDE DVD-RW on VIA controler with pata_via module

Bug #213639 reported by Leszek on 2008-04-07
64
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
High
Unassigned
Nominated for Hardy by giboulet

Bug Description

Binary package hint: linux-image-2.6.24

My IDE DVD-RW drive (NEC-Optiarc AD-7173A) worked without problems in Gutsy. It worked with kernel module via82cxxx for VIA controler on my M/B (was seen as /dev/hdc) in 2.6.22 kernel from Gutsy. I've made upgrade to Hardy Beta 3 days ago. In Hardy Beta with kernel 2.6.24-15 (linux-image-2.6.24-15-generic) there is no via82cxxx kernel module - it has been replaced with pata_via module. This new module recognizes my DVD drive and apps generally see it (as /dev/sr0) but I cannot do anything usefull with it - Audio-CDs don't work anymore, DVDs cannot by played, burning apps stop burning after few sectors. I nailed down this problem to pata_via module - I've blacklisted it and copied via82cxxx kernel module from latest kernel with it (2.6.24-12). Now everything works as expected and as it was in Gutsy.

So don't include pata_via in default kernel in Hardy - stay with well working and reliable via82cxxx kernel module. It worked for all people and it's too soon to switch to libATA drivers for some chipsets since these drivers have problems.

Leszek (bigl-aff) wrote :

BTW my M/B i Asus A7V880 with Athlon XP 2800+. Here is detailed dmesg from my PC.

description: updated
Leszek (bigl-aff) on 2008-04-07
description: updated
Leszek (bigl-aff) on 2008-04-08
description: updated
megalo (alex-menger) wrote :

I can confirm this with linux-image-2.6.24-16-generic. The vanilla beta release (sans updates) worked fine, but now my whole system freezes whenever I try to access a CD or DVD. Seems to be the pata modules -- I have a similar issue (though not that severe) on another machine with the same chipset running openSUSE 10.3. Coincidentally, 10.3 was the first release that came with the pata modules.

One must love Linux.This is the year of the desktop!

Get a Mac. Seriously.

Thanks for the report Leszek. Seems this is a result of bug 181561. I'll reassign to the kernel team. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged
giboulet (gvuidel) wrote :
Download full text (3.1 KiB)

I have the same bug with pata_amd module.
After upgrade my Gutsy to Hardy RC the devices changes from hdx to sdx and my DVD RW (ASUS DRW-1608P3S) became unusable. Impossible to read a CD or DVD.
In dmesg :
[ 29.104185] pata_amd 0000:00:09.0: version 0.3.10
[ 29.104274] PCI: Setting latency timer of device 0000:00:09.0 to 64
[ 29.105408] scsi0 : pata_amd
[ 29.106175] scsi1 : pata_amd
[ 29.107533] ata1: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
[ 29.107537] ata2: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
[ 29.276189] ata1.00: ATA-7: HDS728080PLAT20, PF2OA21B, max UDMA/133
[ 29.276194] ata1.00: 160836480 sectors, multi 16: LBA48
[ 29.300095] ata1.00: configured for UDMA/133
[ 29.620040] ata2.00: ATAPI: ASUS DRW-1608P3S, 1.24, max UDMA/66
[ 29.671662] usb 1-2: new low speed USB device using ohci_hcd and address 3
[ 29.791954] ata2.00: configured for UDMA/66
[ 29.792097] scsi 0:0:0:0: Direct-Access ATA HDS728080PLAT20 PF2O PQ: 0 ANSI: 5
[ 29.798662] scsi 1:0:0:0: CD-ROM ASUS DRW-1608P3S 1.24 PQ: 0 ANSI: 5
[ 29.817518] Driver 'sd' needs updating - please use bus_type methods
[ 29.817626] sd 0:0:0:0: [sda] 160836480 512-byte hardware sectors (82348 MB)
[ 29.817644] sd 0:0:0:0: [sda] Write Protect is off
[ 29.817647] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 29.817671] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 29.817727] sd 0:0:0:0: [sda] 160836480 512-byte hardware sectors (82348 MB)
[ 29.817739] sd 0:0:0:0: [sda] Write Protect is off
[ 29.817742] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 29.817762] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 29.817767] sda:<4>Driver 'sr' needs updating - please use bus_type methods
[ 29.829683] sda1 sda2 < sda5 > sda3
[ 29.852122] sd 0:0:0:0: [sda] Attached SCSI disk
[ 29.859371] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 29.859395] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 29.884688] usb 1-2: configuration #1 chosen from 1 choice
[ 29.888383] sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray
[ 29.888392] Uniform CD-ROM driver Revision: 3.20
[ 29.888457] sr 1:0:0:0: Attached scsi CD-ROM sr0

And when i try to read a DVD :
Apr 23 10:14:53 lion kernel: [ 5035.278597] end_request: I/O error, dev sr0, sector 1391324
Apr 23 10:14:53 lion kernel: [ 5035.308557] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 23 10:14:53 lion kernel: [ 5035.308567] sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current]
Apr 23 10:14:53 lion kernel: [ 5035.308572] sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA
/32)
Apr 23 10:14:53 lion kernel: [ 5035.308579] end_request: I/O error, dev sr0, sector 1391320
Apr 23 10:14:53 lion kernel: [ 5035.345547] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 23 10:14:53 lion kernel: [ 5035.345558] sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current]
Apr 23 10:14:53 lion kernel: [ 5035.345563] sr 1:0:0:0: [sr0] Add. Sense: Logical unit communication C...

Read more...

Leszek (bigl-aff) wrote :

So take amd74xx.ko module from linux-image-2.6.24-12 package, put it into /lib/modules/2.6.24-16-generic/kernel/drivers/ide/pci/ and add "blacklist pata_amd" to /etc/modprobe.d/blacklist file. Reboot and you'll have old config - working one! :)

PS. If you don't find linux-image-2.6.24-12 package (latest is linux-image-2.6.24-16 and all older seem to be removed from all archives in preparation for Hardy release) I can put it here (whole or only IDE modules).

giboulet (gvuidel) wrote :

I did not find older version with the module amd74xx.ko
If you can put it here, I will test it
My arch is i386
Thanks

Leszek (bigl-aff) wrote :

OK - I'll put it here in the evening. Luckly I've saved whole linux-image-2.6.24-12 package on HDD so will extract both modules (only AMD & VIA has been migrated to PATA) for everyone to use.

Leszek (bigl-aff) wrote :

So here are modules from linux-image-2.6.24-12 package and detailed instruction what to do:

0. unzip ide-modules.zip

1. sudo cp via82cxxx.ko amd74xx.ko /lib/modules/2.6.24-16-generic/kernel/drivers/ide/pci/

2. sudo depmod -a

3. sudo vi /etc/modprobe.d/blacklist-local

4. add 2 following lines:

blacklist pata_via
blacklist pata_amd

5. sudo update-initramfs -u

6. sudo reboot

I hope it helps everyone with such problems.

giboulet (gvuidel) wrote :

Now my DVD works !
Thanks Leszek !

Leszek (bigl-aff) wrote :

Previous modules don't work with latest Hardy kernel (2.6.24-17) so here are new modules for this kernel compiled by myself from official Ubuntu kernel source.

slayer (antoniochiaravalloti) wrote :

i confirm this bug.

here's my detailed bug report: https://bugs.launchpad.net/ubuntu/+bug/222547

so the only way to fix is changing those modules?

Leszek (bigl-aff) wrote :

It seems so. Official kernel from version 2.6.24-13 moved to newer PATA modules. It seems that they work correctly for some people (for example take a look at bug 181561 - it was the reason to swich to PATA modules) but sadly these modules don't work for others (including us). It seems as some kind of deadlock and I'm really interested how it will be fixed in Hardy.

slayer (antoniochiaravalloti) wrote :

We've got a problem here. I think those modules you posted (that work great with ubuntu 32 bit) don't work with the 64 bit version. What are we gonna do now?

Leszek (bigl-aff) wrote :

Just recompile linux-image for your platform and extract modules from DEB package. But naturally it's still woraround and I'm waiting for official solution to this problem.

slayer (antoniochiaravalloti) wrote :

i am sorry, but i don't think to be able doing what you suggested me. would you please give me a little howto? thank you very much ;)

  • unnamed Edit (428 bytes, text/html; charset=ISO-8859-1)

>
> i am sorry, but i don't think to be able doing what you suggested me.
> would you please give me a little howto? thank you very much ;)

Use the power of Google! :) "ubuntu kernel compiling" should be you magic
words. ;)

pdevries (pdevries) wrote :

I have essentially the same bug. In this case, my hard drive requires the via82cxxx module (at bootup) in order to enable dma. Without dma, the whole OS is almost too slow to use.

Leszek's workaround using his modules compiled for 2.6.24-17 works for me.

Spohl (bernfresse) wrote :

Is it possible that depmod -a only takes the loaded kernel. For example the newest doesnt work, I boot an old one, and try to put those modules in the new one. Is depmod -a correct then?

Frederik Kriewitz (freddy436) wrote :

You're right depmod -a only cares about the loaded kernel.

But you can do that manually (it's probably the easiest way), you just need to add two lines to /lib/modules/2.6.24-17-generic/modules.dep:

/lib/modules/2.6.24-17-generic/kernel/drivers/ide/pci/via82cxxx.ko: /lib/modules/2.6.24-17-generic/kernel/drivers/ide/ide-core.ko
/lib/modules/2.6.24-17-generic/kernel/drivers/ide/pci/amd74xx.ko: /lib/modules/2.6.24-17-generic/kernel/drivers/ide/ide-core.ko

You probably want to use the -k option of update-initramfs too

slayer (antoniochiaravalloti) wrote :

any news about the "6 4bit" version of Hardy? I can't find the 2.6.24-12 64 bit image so i can't extract anything... please let me know something about it :(

slayer (antoniochiaravalloti) wrote :

new kernel version - 2.6.24-18 / modules not working anymore...

Leszek (bigl-aff) wrote :

Modules for 2.6.24-17 work for me also in 2.6.24-18. Just put them into /lib/modules/2.6.24-18-generic/kernel/drivers/ide/pci/ , do "sudo depmod -a" and reboot.

BTW sorry but I've no 64-bit machine to make modules for it. Just build kernel on such machine ( use point 9 from https://help.ubuntu.com/community/Kernel/Compile as a guide how to do it) and then get these 2 modules from final linux-image DEB file.

Leszek (bigl-aff) wrote :

Sorry for bad info - naturally use point 8 from howto to build kernel!!! :)

And IMHO simplest way to extract modules from DEB file is to use "mc" - just hit enter on DEB file and you will see it's contents and you can copy files from it (just like with ZIP archives).

slayer (antoniochiaravalloti) wrote :

ok, thank you for the info! should i build 2.6.24-12 image or 2.6.24-18 ?

Leszek (bigl-aff) wrote :
  • unnamed Edit (123 bytes, text/html; charset=ISO-8859-1)

If you want modules working with 2.6.24-18 you should build 2.6.24-18.
Modules from 2.6.24-12 worked only up to 2.6.24-16.

slayer (antoniochiaravalloti) wrote :

attempt #1 failed - modules produced but not working... maybe i should try compiling using both processors together ( export CONCURRENCY_LEVEL=3 ). I will let you know...

slayer (antoniochiaravalloti) wrote :

which options did you use for recompiling (further than enabling the amd and via modules?) did yo ukeep pata_via and sata_via?

Leszek (bigl-aff) wrote :
  • unnamed Edit (192 bytes, text/html; charset=ISO-8859-1)

I copied original config file from /boot directory and just enabled these 2
modules. All other options doesn't matter since finally you take only these
2 modules from compiled kernel.

Sergey Sychev (nightguest) wrote :

Hi. I have same problem with libata.. and i fix this bug by changing 40-wire cable to 80-wire.
In Leszek dmesg log i found this:

[ 32.644068] hdc: Optiarc DVD RW AD-7173A, ATAPI CD/DVD-ROM drive
[ 32.644102] hdc: host max PIO5 wanted PIO255(auto-tune) selected PIO4
!!!! [ 32.644276] hdc: host side 80-wire cable detection failed, limiting max speed to UDMA33

try - maybe help

Leszek (bigl-aff) wrote :
  • unnamed Edit (227 bytes, text/html; charset=ISO-8859-1)

So your drive works OK with new modules when you connect it with 80-wire
cable? Or it works OK with old modules?

I ask because this warning makes no difference for me - I've it with old
modules and they work OK.

slayer (antoniochiaravalloti) wrote :

nothing to do... i noticed, however, that my modules are 17 kb each, while yours are about 170 kb. do you think that's because you produced your modules with the kernel debugging? i don't think this can interfere!

I'm quite giving up hardy...

slayer (antoniochiaravalloti) wrote :

GREAT NEWS !!!

I thought my ide cable could have been 40-wire instead of 80-wire. IT WAS!! NOW I GOT A 80-WIRE CABLE AND EVERYTHING WORKS GREAT WITH THE STANDARD (NEW) MODULES !!!

I tried four different cables, the amazing thing is that they all were 40-wire, I can't believe it!!!

The bug is now solved for me, thanks to everybody!

p.s. the only way to discover if your ide cable is 40-wire or 80-wire is that the 80-wire cable has got coloured pins (blue-mother board , gray-slave and black-master)

More suggestions:

I suggest not to use cable select, but to set your hd to master (if it is master) and connect it to the black pin of the cable, os slave and connect it to the gray pin.

I suggest, moreover, to set manually the speed of the hard disk (in my case ultra dma 6) and the PIO mode (4 to me). Who knows, maybe the bug affects via chipsets when they work in auto mode...

Leszek (bigl-aff) wrote :
  • unnamed Edit (171 bytes, text/html; charset=ISO-8859-1)

I never enabled debugging. Maybe it was enabled by default in generic kernel
but I didn't enabled it. I just enabled 2 modules and did standard make-kpkg
command.

slayer (antoniochiaravalloti) wrote :

kernel debugging is enabled by default, you should disable it in order to produce lighter modules (but the functionality is the same, that's only debug info for develpoers). That's however what i found.

Have you tried with a new 80-wire cable? :)))

Leszek (bigl-aff) wrote :
  • unnamed Edit (537 bytes, text/html; charset=ISO-8859-1)

>
> Have you tried with a new 80-wire cable? :)))

Yes and now my drive works with new modules. :)

I haven't tested it 100% with all things (reading various CDs & DVDs) but
abolutely there is a big difference - previously reading stopped after few
sectors and now whole DVD worked without problems. So it seems to be
solution. :)

Alessio Igor Bogani (abogani) wrote :

@Leszek,

Could you test kernel available on http://kernel.ubuntu.com/~abogani/bug228624/ and report if it is solve this bug (using 40 wire cable)?

Thanks!

Leszek (bigl-aff) wrote :

I hope I'll do it today evening. Stay tuned. :)

2008/7/23 Alessio Igor Bogani <email address hidden>:

> @Leszek,
>
> Could you test kernel available on
> http://kernel.ubuntu.com/~abogani/bug228624/<http://kernel.ubuntu.com/%7Eabogani/bug228624/>and report if it is solve
> this bug (using 40 wire cable)?
>
> Thanks!
>

Changed in linux:
assignee: ubuntu-kernel-team → abogani
status: Triaged → Incomplete
rusart (ruslan-levitskiy) wrote :

On the 2.6.24-19 modules from 2.6.24-16 didn't work. Has anybody compiled modules for 2.6.24-19-generic kernel?

Alessio Igor Bogani (abogani) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the comments #37. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
FlagMan (flagman) wrote :

Not trying to offend, but I just wasted a few days running into mysterious freezes.
Switching to the old IDE via82cxxx driver fixes this.

May I suggest blacklisting pata_via and including via82cxxx ?
It would save people with VIA controller a lot of trouble!

I am willing to test, the problem is easily reproducible,
but the kernel in comment 36 does not even boot.

For more information about my setup have a look at my
upstream bugreport:
http://bugzilla.kernel.org/show_bug.cgi?id=11426

Changed in linux:
status: Invalid → New
Leszek (bigl-aff) wrote :

I can confirm that kernel provided by Alessio in comment 37 doesn't boot at all on my PC. After selecting it from GRUB I see only "Starting up ..." and that's all.

Leszek (bigl-aff) wrote :

BTW modules from 2.6.24-17 kernel work in latest Hardy kernel. So if you don't want to compile them yourself just use these compiled by me:

Changed in linux:
assignee: abogani → ubuntu-kernel-team
Changed in linux:
status: Unknown → Confirmed
FlagMan (flagman) wrote :

Mmm.
I think these _may_ be two separate issues after all.
(in both cases, switching back to old IDE is a workaround)

1. Quite a few comments mention "cannot use/read/write" issues, and that using an 80-wire-cable is a second workaround.

2. megalo (comment #2) and me are experiencing freezes of the whole system!

I would be interested in getting some "me too" for the second case.
Anybody??!

moret (contato-launchpad) wrote :

I want to register that I lost three DVDs to this same error, used Leszek workaround (with the modules from comment 42) and my DVD is back to normal now. I'm using kernel 2.6.24-19, IDE LG DVDRW 40 pins, so I can also confirm that this behaviour is still present on this kernel version.

BTW, thanks Leszek!

Alessio Igor Bogani (abogani) wrote :

Leszek, since you are the original bug reporter, can you comment if this is still an issue for you with the Beta release for Intrepid - http://www.ubuntu.com/testing/intrepid/beta . You should be able to test with a LiveCD. Thanks.

Leszek (bigl-aff) wrote :

I've tested it with Interpid Beta LiveCD and it worked - I could access my HDD. So I decided to do upgrade to Interpid on my PC. And sadly Interpid doesn't boot at all on my PS. So problem is not with VIA controller at all but with / on this controller. I've compiled needed modules for Interpid kernel (2.6.27-7) - whole IDE section is disabled so I needed not only module for VIA but also whole IDE stack. After compiling it and putting all modules where they should be ( /lib/modules/2.6.27-7-generic/kernel/drivers/ide/ ) I'e done all standard things described by me before (in comment #8) and it didn't worked. Maybe since I was in earlier kernel from Hardy (since new one doesn't boot)? But after this I've installed updated kernel (from Interpid RC) and I don't know what exactly helped from postinst script, but now my PC boots with Interpid kernel (2.6.27-7). You can find attached all modules needed - it's "ide" dir, which should be put in /lib/modules/2.6.27-7-generic/kernel/drivers/ to make it work. Then reinstall latest kernel package (this option is available in synaptic in context menu fr selected package).

Leszek (bigl-aff) wrote :

Here is also dmesg from boot:

Hi Leszek,

It's interesting that you noted the Intrepid Beta LiveCD worked but then after upgrading you were unable to boot. Can you comment what the boot failure was with the 2.6.27-7.14 kernel? For example, if you booted with the 'quiet' and 'splash' options removed was there anything dumped to the screen?

Changed in linux:
status: New → Incomplete
Leszek (bigl-aff) wrote :

In recovery mode everything worked until mounting root filesystem. VIA
controller was discovered (if I remember correctly) but HDD attached to it
was not discovered. If it's so important I can do it once again - I only
need to move all IDE modules somewhere else out of /lib/modules.

Hi Leszek,

If you wouldn't mind moving the IDE stack and then recreating the boot issue that would be great. Would you also be able to take a picture of your screen which captures the messages of the boot failing? That would be the most helpful. Thanks.

Leszek (bigl-aff) wrote :

Sorry for wrong information about this error - my VIA controller works with Interpid! :-)

I've forgotten that I've blacklisted pata_via module for Hardy kernel. After removing pata_via from blacklist (and IDE modules from /lib/modules/2.6.27-7-generic/) and re-installing latest linux-image from Interpid everything works as expected. :-)

PsychoChimp (kavi-89) wrote :

I installed Intrepid Ibex (8.10) on my Sony Vaio FR102 (uses a VIA chipset) but I still got constant freezing/lock-ups...
After blacklisting the pata drivers and using the most recent modules that Leszek posted (thanks mate!) it finally seems to be working fine.

What happens when there is a new release/kernel? Will I need new modules or will the most recent one posted continue to work?

Can we not have an option to use the old modules in a future release as I'm sure this issue will affect many people with VIA chipsets...

Thanks

Leszek (bigl-aff) wrote :

>
> What happens when there is a new release/kernel? Will I need new modules
> or will the most recent one posted continue to work?

They may work if you move them into correct subdir in /lib/modules (if new
kernel will be different than 2.6.27-7-generic). If not you need to compile
new modules.

tarosk (taro) wrote :

Seems that this problem makes Ubuntu not installable on some configuration. Any boot time workarrounds?

see bug https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/253321

Hi Leszek,

Thanks for the update. Since you are the original bug reporter I'm going to mark this "Fix Released". For anyone who is still experiencing issues, it would be best for you to open a new bug report specific to the hardware that you have. The reason I say this is because it will be much easier for the for the kernel team to examine that new report rather than having to sift through the multiple comments posted here (many of which no longer apply since Leszek confirmed this is resolved). In your new report it would be great if you would provide the general debugging information outlined at https://wiki.ubuntu.com/KernelTeamBugPolicies . Also feel free to reference this report in your new one. Thanks again and we appreciate your help and feedback.

Changed in linux:
status: Incomplete → Fix Released

I also forgot to add that you may want to try with the "all_generic_ide" boot parameter to see if it helps as a temporary workaround. Thanks.

Montblanc (montblanc) wrote :

I can't switch back to old ide drivers. I've got a pata_ali module, which refers to i2c_ali15x3, i2c_ali1535 and i2c_core. I need old alim15x3.ko module, but I can't find it. Can someone tell me where to find it and how to compile it? I'm using kernel 2.6.27-10-generic.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

@Leszek, could you explain how to install the driver in Jaunty? The reason I ask is because someone mentioned to me that the same directory/location to put the driver is different. To read the original response, see http://linux.ittoolbox.com/groups/technical-functional/ubuntu-l/pata_via-ide-dvdrw-on-via-controller-in-jaunty-3402498
Thanks!
Shannon VanWagner

Maybe creating directories similar to Hardy will help? I cannot say anything
else since it worked for me already in Intrepid and since then I've changed
my hardware so now have no environment to test things.

Naturally you can compile and install your own kernel with disabled PATA
modues and enabled old ones - it's always a solution.

2010/4/5 Shannon VanWagner <email address hidden>

> @Leszek, could you explain how to install the driver in Jaunty? The reason
> I ask is because someone mentioned to me that the same directory/location to
> put the driver is different. To read the original response, see
> http://linux.ittoolbox.com/groups/technical-functional/ubuntu-l/pata_via-ide-dvdrw-on-via-controller-in-jaunty-3402498
> Thanks!
> Shannon VanWagner
>
> --
> Problem with IDE DVD-RW on VIA controler with pata_via module
> https://bugs.launchpad.net/bugs/213639
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in linux:
importance: Unknown → High
Changed in linux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.