iwl3945 fill logs with: RX non-WEP frame, but expected encryption

Bug #213594 reported by Schefti on 2008-04-07
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Intel Linux Wireless
Undecided
yi-zhu-intel
linux (Ubuntu)
Medium
Unassigned
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 8.04 + iwl3945 + wpa2

I use wireless network (using iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.0 and WPA2), it's running perfectly - only the logs have thousends of entries like:

Apr 6 10:06:44 ds002 kernel: [ 244.361823] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:44 ds002 kernel: [ 244.361830] wmaster0: RX non-WEP frame, but expected encryption
Apr 6 10:06:44 ds002 kernel: [ 244.419312] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:44 ds002 kernel: [ 244.419320] wmaster0: RX non-WEP frame, but expected encryption
Apr 6 10:06:45 ds002 kernel: [ 244.473110] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:45 ds002 kernel: [ 244.473118] wmaster0: RX non-WEP frame, but expected encryption
Apr 6 10:06:45 ds002 kernel: [ 244.526515] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:45 ds002 kernel: [ 244.582788] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:45 ds002 kernel: [ 244.582796] wmaster0: RX non-WEP frame, but expected encryption
Apr 6 10:06:46 ds002 kernel: [ 244.639320] wlan0: RX non-WEP frame, but expected encryption
Apr 6 10:06:46 ds002 kernel: [ 244.639328] wmaster0: RX non-WEP frame, but expected encryption
Apr 6 10:06:46 ds002 kernel: [ 244.693890] wlan0: RX non-WEP frame, but expected encryption

I tried to find something about this, but nothing help.
Installation and configuration the wireless connection using wpa2 was easily, but this problem fills my logs up to 40 MB a day!

thanks

Ubuntu 8.04 + iwl3945 (with linux-backports-modules-hardy) + all updates

iwl3945 works but only with version 1.2.25 (the one backported). 1.2.0 (the one in stock kernel) never connects in any combination of wep/wpa/wpa2, hidden/not-hidden essid, or without security. Also 1.2.0 fails to enable the wifi led indicator.

with both drivers i get my logs filled with:

Apr 8 08:15:27 pablo-laptop kernel: [ 386.806138] wlan0: RX non-WEP frame, but expected encryption
Apr 8 08:15:27 pablo-laptop kernel: [ 386.806148] wmaster0: RX non-WEP frame, but expected encryption

There is also a bug report here: http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1614

It seems to be a problem with WPN824 routers, but as i told to intellinuxwireless guys i used the same router with the old ipw3945 driver without any problems.

Can you add the old driver as an optional restricted module? ipw3945 is by far less problematic and also support better card status and traffic notification.

Schefti (dischef) wrote :

Thank you for information,

I looked for another driver but older drivers seemed to be not compatible with actual Kernel (2.6.24-12-generic). So I tried the newest driver but same problem.
I'm using WPN824 too. I can't understand why the router should be the problem, the connection is running perfectly. While the kernel makes the messages I think it's a problem with kernel.

What can I do to stop the messages? Can I set a filter for kernelmessages to stop it?
I don't know how to use an older driver as optional restricted module, because I'm a new user of linux/ubuntu.

Thank's

Schefti

You can filter your log messages changing your syslog configuration (/etc/syslog.conf)
More info with syslog.conf(5) (man 5 syslog.conf)

If i recall correctly you need to change the options for:
 - /var/log/syslog
 - /var/log/messages
 - /var/log/debug
 - /var/log/kern.log

Another options is to use sysctl to change how the kernel itself log stuff, the configuraton
for systcl is in /etc/sysctl.conf, and there is a man page for it too. sysctl.conf(5)

The parameter you need to change is kernel.printk you can find information about it at:
 - http://www.de-brauwer.be/wiki/wikka.php?wakka=printk
 - http://www.linuxjournal.com/article/2365

the first is specifically about printk and related paramaters, the second is a good
explanation about what sysctl is for (read it first :P)

I dont think the router is the problem, i have one since a long time without any problems,
and before updating to hardy everything used to work flawless. But it seems this bug
is triggered by it.

About the restricted module thing, that part of the message was not for you, sorry.
I hope when someone of the ubuntu kernel team read this thread, he/she follow my
humble recomendation. :P

Regards.
blo

Schefti (dischef) wrote :

I changed the value für printk to 0 0 0 0 and to 8 8 8 8 - nothing happens - the logs full with that messages.
By editing syslog.conf I get no change.

I hope you can give me another workaround to solve this problem.
Or can you give me more infos for what I have to do, because I'm new to linux.
At moment I think that's the last problem I have.

thanks

That's weird, kernel.printk should be able to solve this (i think) ... it dont work for me either. :(
So i change my syslog to ignore kernel messages with debug level.
Attached is my syslog.conf file as an example.

It seems this will be fixed soon: http://ubuntuforums.org/showthread.php?t=693099

Øyvind Stegard (oyvinst) wrote :

Having the very same problem with iwl3945 drivers and a WPN824v2 Netgear access point (w/up-to-date firmware). ipw3945 worked fine against the same access point, and it gave me some indication of traffic as well. With the new Intel wireless drivers, my WiFi-led is completely dead (Thinkpad Z61m). I hope the kernel message silencing patch is included as an update in Ubuntu Hardy.

Cleber Santz (clebersantz) wrote :

Same here, using Hardy Heron Linux 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

Wireless Card info:

product: PRO/Wireless 3945ABG Network Connection
vendor: Intel Corporation
bus info: pci@0000:02:00.0
logical name: wmaster0
version: 02
serial: 00:18:de:a3:db:1b
width: 32 bits
clock: 33MHz
capabilities:
 Power Management,
 Message Signalled Interrupts,
 PCI Express,
 bus mastering,
 PCI capabilities listing,
 Logical interface,
 ethernet,
 Physical interface,
 Wireless-LAN
configuration:
 broadcast: yes
 driver: iwl3945
 latency: 0
 module: iwl3945
 multicast: yes
 wireless: IEEE 802.11g

Sten During (yappo) wrote :

LG T1 Express Dual
Intel 3945 ABG
Kubuntu 8.04

Error-data as above.
This is a router-dependent bug.

I get these messages while connecting to a Netgear Mimo router, but
I do NOT see them when connected to a Sitecom router.

Specific model-versions not as interesting as the fact that changing
router, but keeping WEP-setup EXACTLY the same between routers,
changes the behaviour.

There are many issues with this card, mostly because the new driver is not complete,
and the ubuntu kernel guys removed the old one :(

To get it work properly you need to do some changes in your system:

  - install linux-backports-modules-hardy package
  this enable the wifi led indicator, but only for enable/disable, there is no traffic
  indicator (led blinking) yet.

  - disable kernel.debug messages in syslog.conf
  there is an example in an previous post, or check syslog.conf(5)

Simon Gibbs (simon-gibbs) wrote :

I'm observing this with Hardy Heron using a Net Gear "WPN802 v2" and a Samsung Q70 laptop. I have all the updates.

Daniel T Chen (crimsun) on 2008-12-10
Changed in linux-meta:
status: New → Invalid
Changed in intellinuxwireless:
status: New → Invalid
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: linux-backports-modules-2.6.24 (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 213594

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu14
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sarthk 1942 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc300000 irq 47'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,17aa3867,00100001 HDA:11c11040,11c10001,00100200'
   Controls : 21
   Simple ctrls : 12
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=77ef9901-e9ed-42e1-9281-c89dd5153a09
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: LENOVO 0769AB2
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-32-generic-pae root=UUID=5ac432f1-22dc-4cde-b965-dc7c4507fbb6 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic-pae 3.2.30
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: Daemon not responding.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-32-generic-pae N/A
 linux-backports-modules-3.2.0-32-generic-pae N/A
 linux-firmware 1.79.1
Tags: precise running-unity
Uname: Linux 3.2.0-32-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/21/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 68ET31WW
dmi.board.name: IEL10
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr68ET31WW:bd12/21/2007:svnLENOVO:pn0769AB2:pvr3000N200:rvnLENOVO:rnIEL10:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 0769AB2
dmi.product.version: 3000 N200
dmi.sys.vendor: LENOVO

tags: added: apport-collected precise running-unity

apport information

apport information

apport information

s p (sarthorks) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

s p (sarthorks) wrote : IwConfig.txt

apport information

s p (sarthorks) wrote : Lspci.txt

apport information

s p (sarthorks) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

s p (sarthorks) wrote : RfKill.txt

apport information

s p (sarthorks) wrote : UdevDb.txt

apport information

s p (sarthorks) wrote : UdevLog.txt

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Schefti, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: hardy needs-kernel-logs needs-upstream-testing
removed: apport-collected precise running-unity
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.