[hardy] several Fn-Keys stop working after loading kernel on Samsung Q45 laptop

Bug #212790 reported by pittipatti on 2008-04-06
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by pittipatti
hal-info (Ubuntu)
Medium
Unassigned
Nominated for Hardy by pittipatti
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by pittipatti

Bug Description

Hardware:
  - Samsung Notebook Q45-Aura T7100 Duke (the one with intel graphics GM965)

After loading the kernel several Fn-keys stop doing their job.
In bios-screen or grub they work fine.

When presssing these keys I get "Use 'setkeycodes xxx ...' to make it known" messages in syslog.

These are in particular:
- Fn-up-arrow: e008 (brightness up)
- Fn-down-arrow: e009 (brightness down)
- Fn-F2: e003 (display battery capacity)
- Fn-F4: e002 (toggle internal/external display)
- Fn-F5: e004 (toggle lcd-baklight)
- Fn-F7: e031 (cutom-app: samsung magic-doctor)
- Fn-F8: e033 (toggle processor speed)
- Fn-F9: e006 (toggle WLAN pysicaly)

The following keys don't work but show xev-events:
- Fn-F3: euro-symbol
- Fn-F12: scroll-lock
- Fn (single press and release): show context-menu

Daniel Hahler (blueyed) wrote :

Are the keypress events logged to /var/log/acpid?
Does acpi_listen display anything, when pressing the key(s)?

pittipatti (pittipatti) wrote :

No the keys don't produce acpi-events.
Instead they produce scancodes that are not recognized by the userspace (see http://people.freedesktop.org/~hughsient/quirk/quirk-keymap-scancodes.html)

There are two possible solutions:
1. add some lines to the file "samsung.hk" of the package "hotkey-setup" but this seems to be deprecated
2. make the scancodes known using "hal" by adding them to hal-fdi-file "30-keymap-misc.fdi" which is already done upstream (21hour ago ;-) ) according to http://gitweb.freedesktop.org/?p=hal-info.git;a=blob;f=fdi/information/10freedesktop/30-keymap-misc.fdi

I think the second one would be the better solution, which might be integrated automatically with the next hal-info-merge.

Daniel Hahler (blueyed) wrote :

Thanks for providing this information. I suspect you've tested it?

I'm assigning the bug from hal to hal-info and will invalidate the other bug tasks.

Changed in hal:
importance: Undecided → Medium
status: New → Triaged
Changed in acpi-support:
status: New → Invalid
Changed in linux:
status: New → Invalid
Mika Fischer (zoop) wrote :

I tried applying this patch manually and now the Battery hotkey works, the others now show up via 'lshal -m' but do nothing. So there is more needed for a fix than this patch.

Stas (stasic) wrote :

I have the same trouble on my Samsung R25 laptop.

Don't work Fn+Up and Fn+Down (brightness up , brightness down)
Other shortcuts using "Fn" works great.

On the hardy beta, brightness works good, after installing the final release it's dead.

P.S. sorry for my english

Martin Pitt (pitti) on 2008-10-02
Changed in hal-info:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081001-0ubuntu1

---------------
hal-info (20081001-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot with updated hardware data.
    - Add Lyra TH1100A music player. (LP: #213636)
    - Add Sony Walkman NWD-B105. (LP: #231470)
    - Add Samsung Q45 special keys. (LP: #212790)
  * Grabbed a bunch of Nokia/LG mobile modem FDIs contributed in Launchpad,
    cleaned them up, committed them upstream, add them as
    debian/patches/00upstream_mobile_modems.patch for now.
    (LP: #257045, #257725, #258197, #259041, #268482, #274952)
  * Drop 03_latitude_xt_tablet_keys.patch, upstream now.

 -- Martin Pitt <email address hidden> Thu, 02 Oct 2008 20:27:57 +0200

Changed in hal-info:
status: Fix Committed → Fix Released
Seraphimdom (seraphimdom) wrote :

I've already have hal-info 20081001 installed, but still can't get those particular key worked.

MarkS (mark-marksyms) wrote :

This appears to affect the Samsung X65 as well.

Fn-F2 (batt status)
Fn-F3 (Euro symbol)
Fn-F4 (Switch display output)
Fn-F7 (samsung magic doctor)
Fn-F8 (CPU speed)

Nothing appears in dmesg about unknown keycodes, nothing in /var/log/acpid and nothing reported as X events in xev. Is there anything I can do to work out what these keys are doing as they don't seem to be recognised by anything?

Others seem to work fine, standby, backlight, mute, wireless control, keypad lockout, numlock, scroll lock, volume, home and numeric keypad functions.

The brightness keys Fn-(Up/Down) do work but only on the console or using the NV video driver, this is a known bug with the NVidia drivers I believe.

Francesco Mosca (fmosca) wrote :

Samsung q45+intel gm965: brightness controls behaves badly: both ways (up or down) it gets stuck repeating first fn-keypress, quickly bringing all brightness up (or down).

With a totally darked screen the only way to bring it back i found is to press once fn+up, switch to a console outside of X and switch back. Other fn-keys doesn't work at all.

Tom K. C. Chiu (tomchiukc) wrote :

It's now 2009, but my Samsung R20 still cannot use the Fn+Up and Fn+Dn. I am using Ubuntu Studio 8.04 updated to the latest version.

Is there anything I can do to contribute to solve to this problem?

brotherquintus (gkoefner) wrote :

I can confirm this bug on my Samsung P560 laptop, using ubuntu 8.10

i have the same symptoms as pittipatti.

brotherquintus (gkoefner) wrote :

When using setkeycodes to set the keys, the keys work but the keyboard is stuck (more specifically it seems to think the Fn key stays pressed) when i restart X server it works again, until I use one of the broken Fn keys.

brotherquintus (gkoefner) wrote :

If any of you have the same problem as me I found a kernel patch ( http://bugzilla.kernel.org/show_bug.cgi?id=12021 ) which forces keyrelease events for certain keys.
The only problem is that it is for the NC10, I modified it to suit my keys.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.