Sound on ICH6 not working

Bug #211912 reported by Jaap Haitsma
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running 2.6.24-15 kernel

lspci | grep Audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

lsmod output also attached.

If I play audio, pavumeter (VU meter for pulse audio) shows that audio is playing but I don't here anything. In gnome-volume-control I also see my ICH6 audio device. I just don't have audio. Audio worked some kernel versions ago

Revision history for this message
Jaap Haitsma (jaap) wrote :
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi,

Does this issue still exist with the latest 2.6.24-19 kernel for Hardy. If so, care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. If the issue still exists, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Revision history for this message
oz457 (kurt-skynet) wrote :

Hello Leann,

I have the latest kernel and use the following soundcard:
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
It seems recognized. When booting at the log in screen, I hear the welcome sound. After logging in, no way to make the sound card work. I have done every possible thing to make the sound work, but it has been unsuccesful.
I post you all seperate attachements to this mail:

Revision history for this message
oz457 (kurt-skynet) wrote :
Revision history for this message
oz457 (kurt-skynet) wrote :
Revision history for this message
oz457 (kurt-skynet) wrote :

The strange thing about this bug is that the sounds actually works at the startup but stops working once logged in.
Maybe this will be able to help you to find the bug.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
oz457 (kurt-skynet) wrote :

Hello Lean,

Sorry for being slow in the response. I have now upgraded to the above kernel, and I can't believe my eyes! It resolved the problem! I don't know what you have done to this new kernel, but I have sound, and network through the native network card.
I just still can't use the wireless native network card, but as I need high network speeds for the disk sharing, I don't mind.

Thanks so much. If anybody has a problem with their sound card on the Aspire Acer 1692 WLMi, just mail me and I will send you all necessary information regarding the configuration settings.

Kind regards.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for testing oz457.

Jaap, since you are the original bug reporter, can you confirm this is resolved with Intrepid? Thanks.

Revision history for this message
Jaap Haitsma (jaap) wrote :

I'm not running Intrepid, but it's fixed in Hardy Heron

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Setting this to "Fix Released".

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers