[Hardy] [regression] ehci_hcd.ko breaks suspend-to-ram

Bug #211572 reported by Petr Dlouhý
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

When I am using kernel 2.6.24-13 or 2.6.24-14 on my Asus A6L, the resume from STR is not working anymore. The computer goes to suspend normally, but after waking it up, the screen remains blank (the backlight is turned on), and the kernel is not responding - sysrq is not working, and mouse is not shining. It works fine with kernel 2.6.24-12 (I have them installed all, so it is not caused by other packages in Ubuntu).
The problem is identified to be the ehci_hcd.ko module, after unloading it normal suspend-to-ram behavior is restored.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Petr,

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* sudo lspci -vvnn > lspci-vvnn.log

Also, can you attach your dmesg output (dmesg > dmesg.log) after an attempted suspend/resume cycle as outlined here: https://wiki.ubuntu.com/DebuggingKernelSuspend .

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

(but the problem was alredy present on kernel 2.6.24-13)

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

Of course, here it is.
(but the problem was alredy present on kernel 2.6.24-13)

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

Here is lspci, the dmesg will take me little more time.

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

Here is dmesg.

I tried to unload some modules from kernel before suspending, and I find out, that the problem is in ehci_hcd module (after unloading this and only this module, the resume works again).

Changed in linux:
status: Incomplete → New
Revision history for this message
Karl Martin (klein-km) wrote :

I can confirm this bug on a Thinkpad T61 8889-2BG with Hardy 2.6.24-15. On resume, the backlinght turns on but nothing more happens. With 2.6.24-12 resume worked fine although, sometimes, instead of the password dialog a white screen was displayed.
After removing ehci_hcd resume worked again in 2.6.24-15 (many thanks for the hint). Unfortunately, blacklisting this module in acpi-support did not help as Hardy does not use this file. Does anybody know where I can blacklist this module in Hardy?

Revision history for this message
Karl Martin (klein-km) wrote :
Revision history for this message
Karl Martin (klein-km) wrote :
Revision history for this message
Karl Martin (klein-km) wrote :
Changed in linux:
status: New → Confirmed
Revision history for this message
Fabian Neumann (fneumann) wrote :

@Karl Martin

AFAIK Hardy replaces (to some extend) acpi-support with pm-utils. You might use pm-utils config files to blacklist ehci_hcd. See http://en.opensuse.org/Pm-utils#Configuration

I've got a T61 myself -- but cannot really confirm this bug. I can confirm the blank screen after resuming with kernel -12, though.

Revision history for this message
Karl Martin (klein-km) wrote :

@Fabian Neumann

Thank you very much for the information. I just found out that resume is working fine when nothing is connected to the usb ports. However, if I connect my hub with mouse, keyboard and dvd burner to the usb port resume does not work anymore. Even with these devices connected resume was working fine in 2.6.24-12.

Unfortunately, kernel version 2.6.24-15 does not solve the other bug mentioned above displaying sometimes a white screen instead of the password dialog after resuming. I am wondering whether this bug is related to the nvidia driver or to X. Do you have a NVIDIA card too?

Revision history for this message
Fabian Neumann (fneumann) wrote :

Yes, I think this is a bug in the binary nvidia driver. Just search for "ubuntu nvidia blank screen". Cannot name a bug, there're probably many of them...

But I mixed some things up. Resume works for me, but quick-user-switching gives me a blank screen. Haven't tested it on all kernel configurations, as I don't need it that often.

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

No, I have intel card. It seems to me, tha this bug is issue only of the ehci_hcd module.

Revision history for this message
Karl Martin (klein-km) wrote :

I think that the bug reported initially in this thread is caused by the ehci_hcd module.

The other bug that I mentioned seams to be different from the one mentioned by Fabian Neumann. I do not see a black screen after resume but a white screen where the mouse pointer is correctly displayed and can be moved. However, the screen is otherwise completely white and no password dialog is displayed. I can then enter the password blindly and after that the desktop is shown correctly. As the mouse pointer is shown correctly on the white screen I am not sure that this bug is related to the nvidia driver. Perhaps there is a problem with the initialization of X.

Revision history for this message
Gregor Burger (burger-gregor) wrote :

hi i can confirm this bug on a clevo m72r. the workaround unloading the ehci_hcd module works too for me.

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

With 2.6.24-16 is it still broken.

Revision history for this message
Daryl (daryl-ball) wrote :

confirm that this is still broken in 2.6.24-16

Revision history for this message
Alex (alexstrabala-deactivatedaccount) wrote :

USB ports not working after resume on Dell Inspiron E1705/9400 with 2.6.24-16.

version.log:
Ubuntu 2.6.24-16.30-generic

Revision history for this message
Alex (alexstrabala-deactivatedaccount) wrote :

Fix mentioned by Fabian Neumann seems to work. http://en.opensuse.org/Pm-utils#Configuration

sudo nano /etc/pm/config.d/config

SUSPEND_MODULES="button ehci_hcd"

Reboot, and it seems to work pretty well.

Revision history for this message
c_t (chefturner) wrote :

I can confirm this bug with Ubuntu 2.6.24-16.30-generic on a Samsung X20 laptop. The workaround mentioned, i.e. putting the line

SUSPEND_MODULES="ehci_hcd"

in some file in /etc/pm/config.d/ works, however only when suspending using the kde-guidance-powermanager applet. It doesn't work when pressing the sleep button. Probably the sleepbutton-event is still handled by the old scripts in /etc/acpi ?!?

Revision history for this message
Alex (loxal) wrote : Re: [Hardy] [regresion] [SOLUTION] resume from suspend (to ram) is not working with kernel 2.6.24-13 - 2.6.24-16

Same kernel, same problem on my Lenovo 3000 V200 notebook.

c_t: "putting the line SUSPEND_MODULES="ehci_hcd" in some file in /etc/pm/config.d/ works"

Yep, works fine for me :)

I would suggest a file name like "/etc/pm/config.d/WORKAROUND" to remove this file later manually. Here my one-liner solution:

sudo echo SUSPEND_MODULES=\"ehci_hcd\" > /etc/pm/config.d/WORKAROUND

Revision history for this message
c_t (chefturner) wrote : Re: [Hardy] [regresion] resume from suspend (to ram) is not working with kernel 2.6.24-13 and 2.6.24-14

I don't know why but since today's upgrade suspend/resume works fine for me even *without* removing the ehci_hcd module... Although it doesn't seem like linux-image has been upgraded today :/... Can anybody confirm that suspend is working again?

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

It is still broken for me (2.6.16). Had you some usb devices plugged-in before suspending?

Revision history for this message
c_t (chefturner) wrote :

I even suspended my laptop using
$ echo mem > /sys/power/state
(so no pm-utils or other stuff should interfere) and all my usb devices (keyboard, mouse, external hd) are working perfectly (before and after suspend). I have no idea why this is... I have no files in /etc/pm/ at all and MODULES="" in /etc/default/acpi-support .

$ cat /proc/version_signature
Ubuntu 2.6.24-16.30-generic

Revision history for this message
DaveAbrahams (boostpro) wrote :

When I have USB devices plugged into my IBM Advanced Mini Dock, it breaks suspend unless I have ehci_hcd in MODULES. However, if I do add ehci_hcd to MODULES, the USB ports on my dock become unavailable forevermore after a suspend.

Revision history for this message
c_t (chefturner) wrote :

Ok, it's broken again for me too. I can't explain, why it worked for some days, but since upgrading to 8.04 final and rebooting ehci_hcd must be blacklisted again in order to get usb devices working after resume.

$ cat /proc/version_signature
Ubuntu 2.6.24-16.30-generic

Revision history for this message
Erik Andrén (erik-andren) wrote :

I can confirm this bug on a Clevo M720R, C2D 2.4 GHz, Intel 965GMA onboard graphics.

description: updated
Revision history for this message
DaveAbrahams (boostpro) wrote :

I may have just been getting lucky with the unload of ehci_hcd, because resume just failed again with USB devices plugged into my dock.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
reagle (joseph.reagle) wrote :

The 'SUSPEND_MODULES="ehci_hcd"' works well for me unless I'm running a virtual machine. So as part of my suspend I need to suspend all of them as well first.

Revision history for this message
Alex (loxal) wrote :

The behavior have not changed with 2.6.24-17-generic :( The workaround is still necessary.

Revision history for this message
tomaszr (tomasz-rosinski) wrote :

i confirm this problem

using solution from Alex Strabala (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/211572/comments/19)
everything works perfect

Revision history for this message
Zaar Hai (haizaar) wrote :

Confirming the problem. System Dell XPS m1330 Nvidia 8400M GS. 2.6.24-16-generic.
Suspend worked OK, but there was no USB after resume.
Proposed fix (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/211572/comments/19) worked fine.

Revision history for this message
tully (tuly-seznam) wrote :

Confirming the problem.

this is working for me:
http://ubuntuforums.org/showthread.php?t=782782

hp nx6125
cat /proc/version_signature
Ubuntu 2.6.24-16.30-generic

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

I updated to Intrepid, and it seems to be fixed in "kernel 2.6.26-1.5".

Revision history for this message
Nick B. (futurepilot) wrote :

Still present in 2.6.24-19. If anything is plugged into my USB hub, the resume from suspend process hangs at a blank screen with a blinking cursor and does not respond. As others have mentioned unloading ehci_hcd before suspending fixes the problem.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Petr, thanks for testing Intrepid and the feedback. I'm going to mark this "Fix Released" against Intrepid. I'll open a nomination for a Hardy stable release update, but the likelyhood of a SRU ( https://wiki.ubuntu.com/StableReleaseUpdate ) at this point it not very high I don't think. Thanks.

Changed in linux:
status: Triaged → Fix Released
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Angus Turnbull (angus-twinhelix) wrote :

This problem also affects my Toshiba Tecra M3. Suspend/resume worked under Gutsy but fails with all release Hardy kernels and the current Intrepid kernel. They would resume to a blank screen without accepting any input necessitating a hard reboot.

Adding this to /etc/pm/config.d/config:

SUSPEND_MODULES="ehci_hcd"

fixes the problem. LSPCI output is attached. /proc/version_signature is "Ubuntu 2.6.27-7.16-generic"

I found this out using the pm_trace function, the relevant portion of dmesg output is:

[ 1.851860] Magic number: 0:250:259
[ 1.851865] hash matches /build/buildd/linux-2.6.27/drivers/base/power/main.c:350
[ 1.851884] tty ttyx1: hash matches
[ 1.851958] pci 0000:00:1d.7: hash matches
[ 1.852017] rtc_cmos 00:08: setting system clock to 2068-04-03 03:15:29 UTC (3100648529)

I presume this bug is the correct place to file the issue, if anyone wants to report under Intrepid please do so :).

Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Petr Dlouhý (petr-dlouhy) wrote :

The bug doesn't appear any more (in fact, for long time now). Feel free to open it again, if somebody is experiencing it.

Changed in linux (Ubuntu Hardy):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers