cdrom-detect fails for HP DL145 in hardy beta

Bug #210200 reported by Nick Moffitt on 2008-04-01
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Colin Ian King

Bug Description

When installing on an HP DL145 system, the installer boots but then reports that it cannot detect the CD-ROM drive. It offers me the option of installing drivers from a diskette.

I believe that the install has been tested successfully on this model via PXE, but it does not work from CD.

Nick Moffitt (nick-moffitt) wrote :

This problem also appears with the 8.04 i386 image. (Both of these are the server image)

Mathias Gug (mathiaz) on 2008-04-03
Changed in cdrom-detect:
milestone: none → ubuntu-8.04
Chris Jones (cmsj) wrote :

current amd64 daily alternate can not detect any block devices on this machine at all. It should find a PATA CDROM and an LSI SAS raid controller.
beta amd64 *desktop* does see the LSI card

Colin Watson (cjwatson) wrote :

Debugging this with Chris Jones, we've established that the desktop CD can't see the CD drive either, which strongly suggests it's a kernel bug. Help?

Chris Jones (cmsj) wrote :

syslog from the installer

Chris Jones (cmsj) wrote :
Chris Jones (cmsj) wrote :
Chris Jones (cmsj) wrote :
Colin Ian King (colin-king) wrote :

I believe the SCSI storage controller [0100]: LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS [1000:0054] (rev 01) requires mptsas.ko to be loaded - is this actually installed? This driver supports the SAS1068 (id 0x0054).

Chris Jones (cmsj) wrote :

syslog from 6.06.2 installer (server)

Chris Jones (cmsj) wrote :

The dapper.2 installer is able to detect the CD drive, possibly by use of an older IDE driver (in that it shows up as hda). See attached syslog

Chris Jones (cmsj) wrote :

Colin: The SAS card may be a red-herring - presumably it would load such drivers after finding the CD?

Colin Ian King (colin-king) wrote :

Hi Chris,

The problem is reported in the following lines of the kernel message log:

Apr 8 14:53:44 kernel: [ 79.439665] ata1: port is slow to respond, please be patient (Status 0x80)
Apr 8 14:53:44 kernel: [ 84.248978] ata1: SRST failed (errno=-16)

If possible try going into you BIOS and turning off AHCI on the SATA controller - not sure if all BIOS configs will allow this, but it's worth a try.

Chris Jones (cmsj) wrote :

The BIOS has an option to switch the SATA controller from presenting as SATA to PATA. This makes no apparent difference to the installer, which still fails to detect the CD drive.

Chris Jones (cmsj) wrote :

A 7.10 alternate amd64 CD shows exactly the same SRST error, so it seems that we've never been installable on this hardware, so this is not a regression.

Changed in linux:
assignee: nobody → colin-king
status: New → In Progress
ewb (ewb) wrote :

I have a similar (perhaps identical) problem with the 8.04 beta alternate i386 iso installing to an ASUS P5E board with an intel e3110 (xeon) dual-core CPU, 8G of DDR2 ram, 2 SATA hard drives and 1 Sony DVD-RW IDE (PATA) drive. BIOS setup was initially AHCI but I also tried the available IDE/Enhanced and IDE/Compatible options to no avail. Still get "No common CD-ROM Drive Detected." I also bumped the CD boot timeout from 15s to 30s in the BIOS without any effect (not surprising, since it boots from the ISO disk just fine).

This is an intel X38/ICH9R based board. There is also an eSATA controller, but I am not using it.

I have previously installed on this machine from the 7.10 alternate amd64 iso and I am now installing from the 7.10 alternate i386 iso (and am past the cdrom detect stage), so this appears to be a problem specific to the 8.04 beta iso. I have not tried the 8.04 beta AMD64 iso, nor any "standard" (non-alternate) iso, nor any server iso.

Problems like this were discussed extensively back in 2005, eg Debian bug 342359 and seemed to be attributed to a problem in ata_piix. Since the 7.10 ISO works, I am now assuming that is not the current issue here, but maybe I am wrong and it has re-appeared.

Colin Ian King (colin-king) wrote :

Hi Chris,

Can you possibly give me the output of lspci -vvnn (and if you can lshw) for the 6.06.2 installer on the same hardware. This will help me see what is different from 6.06.2 and Hardy.

I believe that the HL-DT-STDVD-ROM GDR=8087N ATAPI drive is connected to the broadcom IDE controller - but it's hard to tell. Is it possible to see where the drive is connected on this machine to verify my assumption?

Thanks

Colin

Colin Ian King (colin-king) wrote :

Chris,

It appears that the problem maybe with the pata_serverworks driver, the following https://bugzilla.redhat.com/show_bug.cgi?id=379771 shows there is some sort of issue with it for CD-ROM drives. There was a suggestion to use libata.pata_dma=1, but I am unsure if this will work around the problem - especially if this cannot be passed down to the module from a LiveCD boot.

I think this may have to wait unti an upstream fix appears.

Colin

Colin Ian King (colin-king) wrote :

One boot option worth trying is:

generic.all_generic_ide=1

Not sure if that will solve the problem, but it's worth a spin.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Colin Ian King (colin-king) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/news/ubuntu-9.04-desktop . Please let us know your results. Thanks.

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Colin Ian King (colin-king) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.