Add support for Dell BT Wireless 370 & 410

Bug #209715 reported by Tim Gardner on 2008-03-31
20
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner

Bug Description

Dell Bluetooth Wireless 370 device needs special handling for the SCO protocol. Add it to the blacklist.

Related branches

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-14.24

---------------
linux (2.6.24-14.24) hardy; urgency=low

  [Amit Kucheria]

  * LPIA: Update from moblin
  * LPIA: Fix reboot problem after S3/S4
  * LPIA: Integrate latest Dabney thermal patches
  * LPIA: Change-umd_dbg-debug-level-to-KERN_INFO
  * LPIA: Compile modules into kernel to save on boot time
  * LPIA: lots of Dabney CONFIG options dissapeared
  * LPIA: Purge nonexistent config options

  [Jay Chetty]

  * UBUNTU:USBC:Integrated USBC 2.0.0.32L.0009

  [Misha Zhilin]

  * USB: ehci: handle large bulk URBs correctly (again)
    - LP: #204857

  [Tim Gardner]

  * frame buffer regression - screen blank except for blinking cursor after
    fbcon vtswitch
    - LP: #201591
  * Blacklist Bluetooth Dell Wireless 370 for SCO MTU
    - LP: #209715
  * Set CONFIG_FAIR_CGROUP_SCHED for server flavours.
    - LP: #188226
  * Add DMI IO_DELAY support.
    - LP: #200057

 -- Tim Gardner <email address hidden> Mon, 31 Mar 2008 11:19:49 -0600

Changed in linux:
status: Fix Committed → Fix Released
Mario Limonciello (superm1) wrote :

Additionally,

The newer versions of the firmware shipping on this device will bring it up in a HID/UHE dongle mode. The device needs to be switched to HCI mode upon boot, so the attached debdiff to bluez-utils will handle this.

Changed in dell:
status: New → Confirmed
Changed in bluez-utils:
status: New → In Progress
Mario Limonciello (superm1) wrote :

Turns out this also works for the 410, so here is an updated patch with the 410 as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.26-0ubuntu5

---------------
bluez-utils (3.26-0ubuntu5) hardy; urgency=low

  * Add 007_dell_bluetooth to enable HID->HCI
    switching on Dell 370 & 410 BT controllers. (LP: #209715)

 -- Mario Limonciello <email address hidden> Fri, 04 Apr 2008 13:34:15 -0500

Changed in bluez-utils:
status: In Progress → Fix Released
Changed in dell:
status: Confirmed → Fix Released
aryan (aryandeep123) on 2009-07-12
Changed in dell:
assignee: nobody → aryan (aryandeep123)
mesplamax (masi-nqn06) wrote :

Hey, I have a dell studio 1555 and i wondered if any of you could you help me configuring my Dell bluetooth 370 in Ubuntu Karmic kernel 2.6.32-020632-generic? I can't get it working, and, as I'm a linux noob, I don't have the slightest clue in how to apply the patches mentioned before.Thanks

Jerone Young (jerone) wrote :

@mesplamax
               The bluetooth 370 does work under 10.04 & 9.10 without issue. Not sure about the kernel you are using though. That isn't an offical Ubuntu kernel.

                Check that the rfkill isn't set . Run command (from terminal) "rfkill list" . If it is hard or softblocked press the kill switch hot key. Also check the bios .. and test to see if testing the rfkill not to control bluetooth helps.

Changed in somerville:
assignee: nobody → aryan (aryandeep123)
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305673

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers