Sound did work in 2.6.24-5 but not in 2.6.24-7 till 2.6.32-16

Bug #209047 reported by Tijmen Ruizendaal (timing) on 2008-03-30
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ubuntu Audio Development Team
Nominated for Lucid by Tijmen Ruizendaal (timing)

Bug Description

Sound did work in 2.6.24-5 but not in 2.6.24-7 till 2.6.24-12. I don't have any newer kernels yet. I can still boot the -5 kernel, then sound is working. When booting to the other kernels, I hear some clicks out of my speakers or headphone. The speaker-test application isn't playing any sound in -7 till -12.

The output from ./alsa-info.sh is on http://pastebin.ca/962832
Or below:

!!################################
!!ALSA Information Script v 0.4.41
!!################################

!!Script ran on: Sun Mar 30 03:17:13 CEST 2008

!!Linux Distribution
!!------------------

Ubuntu hardy (development branch) \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

!!Kernel Information
!!------------------

Kernel release: 2.6.24-12-generic
Operating System: GNU/Linux
Architecture: i686
Processor: unknown
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.16
Library version:
Utilities version: 1.0.15

!!Loaded ALSA modules
!!-------------------

snd_hda_intel

!!Soundcards recognised by ALSA
!!-----------------------------

 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xff63c000 irq 22

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 02)
 Subsystem: 1179:ff40

!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-usx2y: index=-2
snd-usb-caiaq: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388

!!Loaded sound module options
!!--------------------------

!!Module: snd_hda_intel
enable : Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : 0
id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
index : -1,-1,-1,-1,-1,-1,-1,-1
model : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
position_fix : 0,0,0,0,0,0,0,0
power_save : 0
power_save_controller : Y
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1
single_cmd : N

!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Analog Devices AD1986A
Address: 0
Vendor Id: 0x11d41986
Subsystem Id: 0x1179ff40
Revision Id: 0x100500
No Modem Function Group found
Default PCM:
    rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Default Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Default Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
GPIO: io=0, o=1, i=0, unsolicited=0, wake=0
Node 0x02 [Audio Output] wcaps 0x30311: Stereo Digital
  Converter: stream=6, channel=0
  Digital:
  Digital category: 0x0
  PCM:
    rates [0x60]: 44100 48000
    bits [0x2]: 16
    formats [0x5]: PCM AC3
  Delay: 3 samples
  Connection: 2
     0x01* 0x06
Node 0x03 [Audio Output] wcaps 0x44d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x11 0x11]
  Converter: stream=0, channel=0
  Power: setting=D0, actual=D0
  Processing caps: benign=1, ncoeff=70
Node 0x04 [Audio Output] wcaps 0x40d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Converter: stream=4, channel=0
  Power: setting=D0, actual=D0
Node 0x05 [Audio Output] wcaps 0x40d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Converter: stream=0, channel=0
  Power: setting=D0, actual=D0
Node 0x06 [Audio Input] wcaps 0x100511: Stereo
  Converter: stream=1, channel=4
  PCM:
    rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
    bits [0x6]: 16 20
    formats [0x1]: PCM
  Power: setting=D0, actual=D0
  Connection: 1
     0x12
Node 0x07 [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 8
     0x03 0x09 0x13 0x14 0x15 0x16 0x17 0x18
Node 0x08 [Audio Mixer] wcaps 0x200100: Mono
  Connection: 1
     0x07
Node 0x09 [Audio Mixer] wcaps 0x20010e: Mono Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals: [0x80] [0x80]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals: [0x80]
  Connection: 2
     0x04 0x05
Node 0x0a [Audio Selector] wcaps 0x300101: Stereo
  Connection: 3
     0x07* 0x04 0x05
Node 0x0b [Audio Selector] wcaps 0x300101: Stereo
  Connection: 2
     0x07* 0x04
Node 0x0c [Audio Selector] wcaps 0x300101: Stereo
  Connection: 2
     0x04* 0x07
Node 0x0d [Audio Selector] wcaps 0x300101: Stereo
  Connection: 2
     0x05* 0x08
Node 0x0e [Audio Selector] wcaps 0x300100: Mono
  Connection: 2
     0x08* 0x11
Node 0x0f [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-Out vals: [0x00 0x00]
  Connection: 8
     0x1f* 0x20 0x1d 0x1d 0x27 0x28 0x29 0x2a
Node 0x10 [Audio Selector] wcaps 0x300101: Stereo
  Connection: 3
     0x20* 0x1c 0x1f
Node 0x11 [Audio Selector] wcaps 0x300941: Stereo R/L
  Connection: 2
     0x0f* 0x2b
  Processing caps: benign=1, ncoeff=0
Node 0x12 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Connection: 8
     0x11* 0x22 0x00 0x21 0x10 0x07 0x08 0x23
Node 0x13 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Connection: 1
     0x11
Node 0x14 [Audio Selector] wcaps 0x30010c: Mono Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80]
  Connection: 1
     0x23
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Connection: 1
     0x22
Node 0x16 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Connection: 1
     0x21
Node 0x17 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Connection: 1
     0x10
Node 0x18 [Audio Selector] wcaps 0x30010c: Mono Amp-Out
  Amp-Out caps: ofs=0x0f, nsteps=0x0f, stepsize=0x0b, mute=1
  Amp-Out vals: [0x8f]
  Connection: 2
     0x19* 0x24
Node 0x19 [Beep Generator Widget] wcaps 0x700000: Mono
Node 0x1a [Pin Complex] wcaps 0x400185: Stereo Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x11 0x11]
  Pincap 0x081f: OUT HP Detect Trigger ImpSense
  Pin Default 0x0121401f: [Jack] HP Out at Ext Rear
    Conn = 1/8, Color = Green
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0xc0: OUT HP
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0a
Node 0x1b [Pin Complex] wcaps 0x400185: Stereo Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x11 0x11]
  Pincap 0x081001f: OUT HP EAPD Detect Trigger ImpSense
  EAPD 0x0:
  Pin Default 0x9117f110: [Fixed] Speaker at Int Rear
    Conn = Analog, Color = Other
    DefAssociation = 0x1, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0b
Node 0x1c [Pin Complex] wcaps 0x400185: Stereo Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Pincap 0x0837: IN OUT Detect Trigger ImpSense
  Pin Default 0x410110f0: [N/A] Line Out at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0c
Node 0x1d [Pin Complex] wcaps 0x400985: Stereo Amp-Out R/L
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80 0x80]
  Pincap 0x081737: IN OUT Detect Trigger ImpSense
    Vref caps: HIZ 50 GRD 80
  Pin Default 0x41a1912e: [N/A] Mic at Ext Rear
    Conn = 1/8, Color = Pink
    DefAssociation = 0x2, Sequence = 0xe
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x0d
Node 0x1e [Pin Complex] wcaps 0x400104: Mono Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80]
  Pincap 0x0810: OUT
  Pin Default 0x411711f0: [N/A] Speaker at Ext Rear
    Conn = Analog, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x0e
Node 0x1f [Pin Complex] wcaps 0x400081: Stereo
  Pincap 0x081727: IN Detect Trigger ImpSense
    Vref caps: HIZ 50 GRD 80
  Pin Default 0x02a19020: [Jack] Mic at Ext Front
    Conn = 1/8, Color = Pink
    DefAssociation = 0x2, Sequence = 0x0
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=00, enabled=0
Node 0x20 [Pin Complex] wcaps 0x400081: Stereo
  Pincap 0x081727: IN Detect Trigger ImpSense
    Vref caps: HIZ 50 GRD 80
  Pin Default 0x418130f0: [N/A] Line In at Ext Rear
    Conn = 1/8, Color = Blue
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
Node 0x21 [Pin Complex] wcaps 0x400081: Stereo
  Pincap 0x0827: IN Detect Trigger ImpSense
  Pin Default 0x5993e1f0: [N/A] Aux at Int ATAPI
    Conn = ATAPI, Color = White
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
  Unsolicited: tag=00, enabled=0
Node 0x22 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0820: IN
  Pin Default 0x5933112e: [N/A] CD at Int ATAPI
    Conn = ATAPI, Color = Black
    DefAssociation = 0x2, Sequence = 0xe
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
Node 0x23 [Pin Complex] wcaps 0x400000: Mono
  Pincap 0x0820: IN
  Pin Default 0x59b370f0: [N/A] Telephony at Int ATAPI
    Conn = ATAPI, Color = Yellow
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x20: IN
Node 0x24 [Pin Complex] wcaps 0x400000: Mono
  Pincap 0x0820: IN
  Pin Default 0x93f711f0: [Fixed] Other at Int Left
    Conn = Analog, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
Node 0x25 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x0810: OUT
  Pin Default 0x4145f1a0: [N/A] SPDIF Out at Ext Rear
    Conn = Optical, Color = Other
    DefAssociation = 0xa, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x02
Node 0x26 [Power Widget] wcaps 0x500500: Mono
  Power: setting=D0, actual=D0
  Connection: 8
     0x07* 0x08 0x13 0x14 0x15 0x16 0x17 0x18
Node 0x27 [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 2
     0x1f 0x1d
Node 0x28 [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 2
     0x1f 0x20
Node 0x29 [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 2
     0x1d 0x20
Node 0x2a [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 3
     0x1f 0x1d 0x20
Node 0x2b [Audio Mixer] wcaps 0x200100: Mono
  Connection: 1
     0x0f
Codec: Generic 11c1 ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x11790001
Revision Id: 0x100200
Modem Function Group: 0x1
--endcollapse--

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 0 2008-03-30 03:07 /dev/snd/controlC0
crw-rw---- 1 root audio 116, 4 2008-03-30 03:07 /dev/snd/hwC0D0
crw-rw---- 1 root audio 116, 5 2008-03-30 03:07 /dev/snd/hwC0D1
crw-rw---- 1 root audio 116, 24 2008-03-30 03:07 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 16 2008-03-30 03:08 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 1 2008-03-30 03:07 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 2008-03-30 03:07 /dev/snd/timer

!!Aplay/Arecord output
!!------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Intel]

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 17 [55%] [-21.00dB] [on]
  Front Right: Playback 17 [55%] [-21.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 17 [55%] [-9.00dB] [on]
  Front Right: Playback 17 [55%] [-9.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Internal Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]

!!Alsactl output
!!-------------

--startcollapse--
state.Intel {
 control.1 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 31'
  iface MIXER
  name 'Master Playback Volume'
  value.0 17
  value.1 17
 }
 control.2 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 2
  iface MIXER
  name 'Master Playback Switch'
  value.0 true
  value.1 true
 }
 control.3 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 31'
  iface MIXER
  name 'PCM Playback Volume'
  value.0 17
  value.1 17
 }
 control.4 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 2
  iface MIXER
  name 'PCM Playback Switch'
  value.0 true
  value.1 true
 }
 control.5 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 31'
  iface MIXER
  name 'Internal Mic Playback Volume'
  value.0 0
  value.1 0
 }
 control.6 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 2
  iface MIXER
  name 'Internal Mic Playback Switch'
  value.0 false
  value.1 false
 }
 control.7 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 31'
  iface MIXER
  name 'Mic Playback Volume'
  value.0 0
  value.1 0
 }
 control.8 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 2
  iface MIXER
  name 'Mic Playback Switch'
  value.0 false
  value.1 false
 }
 control.9 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 3'
  iface MIXER
  name 'Mic Boost'
  value.0 0
  value.1 0
 }
 control.10 {
  comment.access 'read write'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 15'
  iface MIXER
  name 'Capture Volume'
  value.0 0
  value.1 0
 }
 control.11 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 2
  iface MIXER
  name 'Capture Switch'
  value.0 false
  value.1 false
 }
 control.12 {
  comment.access 'read write'
  comment.type ENUMERATED
  comment.count 1
  comment.item.0 Mic
  comment.item.1 'Internal Mic'
  comment.item.2 Mix
  iface MIXER
  name 'Capture Source'
  value Mic
 }
 control.13 {
  comment.access 'read write'
  comment.type BOOLEAN
  comment.count 1
  iface MIXER
  name 'External Amplifier'
  value true
 }
 control.14 {
  comment.access 'read write user'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 120'
  comment.tlv '0000000100000008fffff44800000032'
  iface MIXER
  name 'Digital Capture Volume'
  value.0 60
  value.1 60
 }
}
--endcollapse--

!!All Loaded Modules
!!------------------

Module
i915
drm
af_packet
rfcomm
l2cap
bluetooth
acpi_cpufreq
cpufreq_conservative
cpufreq_stats
cpufreq_powersave
cpufreq_ondemand
cpufreq_userspace
freq_table
sbs
container
sbshc
dock
ipv6
ppp_generic
slhc
iptable_filter
ip_tables
x_tables
nls_iso8859_1
nls_cp437
vfat
fat
parport_pc
lp
parport
joydev
pcmcia
snd_hda_intel
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_page_alloc
snd_hwdep
ath_pci
wlan
ath_hal
snd_seq_dummy
battery
ac
video
output
snd_seq_oss
snd_seq_midi
snd_rawmidi
snd_seq_midi_event
asus_laptop
button
led_class
snd_seq
serio_raw
snd_timer
snd_seq_device
psmouse
yenta_socket
rsrc_nonstatic
pcmcia_core
snd
intel_agp
agpgart
iTCO_wdt
iTCO_vendor_support
shpchp
soundcore
pci_hotplug
evdev
pcspkr
ext3
jbd
mbcache
sg
sr_mod
sd_mod
cdrom
ata_piix
8139cp
pata_acpi
ata_generic
8139too
mii
ehci_hcd
libata
scsi_mod
uhci_hcd
usbcore
thermal
processor
fan
fbcon
tileblit
font
bitblit
softcursor
fuse

This seems to be fixed upstream. I hope thix fix can be added to linux-ubuntu-modules-2.6.24

Hi,

Still not fixed in 2.6.24-14-generic.
new ./alsa-info.sh output: http://pastebin.ca/969740

Tijmen, what is the specific fix from upstream that fixes this? Is there a link you could provide?

Greg,
Someone from the #alsa IRC channel helped me during kernel version -12. He said he made a change which was supposed to fix my problem.
Yesterday, I was unable to find the bug in the bugtracker upstream. I still have no sound.

Thanks for replying :-)

I have kernel version 2.6.24-16 now. Still no sound. If I boot to the -5 version I'm still able to enjoy music.

And about the 'fix'. There has never been a bug in their buglist. Just someone who said: 'I fixed it'. But I haven't had any results yet. And no one seems to know if this fix is in ubuntu already. I checked the changelog already, couldn't find anything.

Apparently, on Feb 23, Daniel T. Chen said "I think the patch_analog updates broke it" and "I'll try to update alsa-source today for it" in #alsa.

Daniel T Chen (crimsun) wrote :

Please run `sudo /etc/init.d/alsa-utils reset'.

tijmen@pruim:~$ uname -a
Linux pruim 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux
tijmen@pruim:~$ sudo /etc/init.d/alsa-utils reset
[sudo] password for tijmen:
 * Resetting ALSA... [ OK ]
tijmen@pruim:~$

So that seems OK. Still no sound tho.

OK, I updated to Intrepid. I'm currently at kernel: 2.6.26-2.
Still no sound. Can someone please pick this up? Thanks

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Okay, I updated my Intrepid, sound is still not working with 2.6.27-1. It didn't work with 2.6.26 either.

This is the follow-up bug report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/262736

Thank you very much!

Changed in linux:
status: Incomplete → New
Daniel T Chen (crimsun) wrote :

Please test a daily-live image tomorrow (to ensure that you're using 2.6.27-7).

Changed in linux:
assignee: nobody → ubuntu-audio
status: New → Incomplete

uname -a: Linux pruim 2.6.27-7-generic #1 SMP Fri Oct 10 03:55:24 UTC 2008 i686 GNU/Linux

Sound still not working.

Just watched a YouTube video with my external soundcard. Then I sent the sound with pulseaudio to my built in card. Looks like there is some progress tho, during silent parts I hear a small bit of noise. When someone talks in a video I hear more noise and a bit of the person talking. very unclear though. Earlier it was just 'tick krrgt tick'.

What i forgot to mention:

The sound on my external soundcard works excellent.
The description of the noise and such is about the internal card.
I can switch easily between both cards.

Tijmen,

You may want to also test the latest pre-release for Jaunty since that's what is being actively developed at the moment - http://cdimage.ubuntu.com/daily-live/current/ .

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Triaged

An update on this issue. I just did a fresh install with the 9.04 beta. Sound is still not working. I still hear some 'krrrt tick tick' stuff.

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody

Really, when is someone going to fix this? How hard can it be to check the differences between 2.6.24-5 and 2.6.24-7 and roll back the changes made for the soundcard I have? I'm not a kernel or alsa hacker so I have no idea where to start. Is there someone I should contact directly to fix this?

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Audio Development Team (ubuntu-audio-dev)
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete

Two years later, this bug is still not fixed. I just updated to lucid with no improvements.

Why is no-one looking at the changes between: 2.6.24-5 and 2.6.24-7 ? That's the moment when the error was 'implemented' in ubuntu.

Changed in linux (Ubuntu):
status: Incomplete → New
summary: - Sound did work in 2.6.24-5 but not in 2.6.24-7 till 2.6.24-16
+ Sound did work in 2.6.24-5 but not in 2.6.24-7 till 2.6.32-16
madbiologist (me-again) wrote :

If this is not working in the latest Lucid kernel (2.6.32-22), there is a workaround for your AD1986A mixer/codec in bug #308872 which should help. It seems to be applicable to Lucid, given the similar comment in the opening description of bug #524948.

Leo (leorolla) wrote :

Could you test madbiologist's suggestion and then set this report back to New? Thank you.

Changed in linux (Ubuntu):
status: New → Incomplete

After an update a few days ago, it works again. I didn't make any changes to settings, just did some updates once in a while. Bug can be closed.

Leo (leorolla) on 2010-06-18
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers