Kernel oops (2.6.24-12) while booting with battery inserted

Bug #207014 reported by Sam Lin on 2008-03-26
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Stefan Bader

Bug Description

Binary package hint: acpi-modules-2.6.24-12-386-di

I encountered kernel oops (Ubuntu 2.6.24-12) while booting with battery inserted.
Some workaround are acpi=off, avoiding loading battery.ko or putting battery away.

Any idea ?

dmesg and dsdt as attachments.

Sam Lin (itrs-lin) wrote :
Sam Lin (itrs-lin) wrote :
Sam Lin (itrs-lin) wrote :

such opps didn't happen on 2.4.26-3 kernel

Sam Lin (itrs-lin) wrote :

typing error: such oops didn't happen on 2.6.24-3

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged
Stefan Bader (smb) wrote :

Though removing the use of the battery module seems to help, could you try whether booting with the battery but without the netconsoles does work? The stack backtrace rather points to net/atm.

This issue is reported and resolved.

http://bugzilla.kernel.org/show_bug.cgi?id=10339

Stefan Bader 提到:
> Though removing the use of the battery module seems to help, could you
> try whether booting with the battery but without the netconsoles does
> work? The stack backtrace rather points to net/atm.
>
>

Stefan Bader (smb) on 2008-04-03
Changed in linux:
assignee: ubuntu-kernel-team → stefan-bader-canonical
status: Triaged → In Progress
Stefan Bader (smb) wrote :

The first patch from upstream (that should fix the Oops) has been applied. However the second one ( commit id: b8a1bdb14940946fcf0438a6337b2a6c54294fb8) wasn't, since the kernel currently is frozen and it doesn't fix the immediate problem.

Changed in linux:
status: In Progress → Fix Committed
Stefan Bader (smb) on 2008-04-03
Changed in linux:
milestone: none → ubuntu-8.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-15.26

---------------
linux (2.6.24-15.26) hardy; urgency=low

  [Colin Ian King]

  * airprime.c supports more devices
    - LP: #208250

  [Kees Cook]

  * AppArmor: get latest batch of upstream fixes into Hardy (svn 1160)

  [Stefan Bader]

  * ACPI: fix boot oops regression in kernel
    - LP: #207014

  [Tim Gardner]

  * Enable CGROUPS for non x86/x86_64 arches, all flavours.
   - LP: #188226

 -- Tim Gardner <email address hidden> Thu, 03 Apr 2008 07:00:29 -0600

Changed in linux:
status: Fix Committed → Fix Released
juan22 (juanfra-rojas) wrote :

The problem persist on kernel 2.6.24.18

This problem kernel cofirmed in:
http://bugzilla.kernel.org/show_bug.cgi?id=10394

Please consider this patch in future kernel. The patch corrects this problem.

I am Using old kernel 2.6.22 work fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.