Mute/mic LEDs no function on ProBook 440/460 G11

Bug #2067669 reported by Andy Chi
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Fix Committed
Critical
Dirk Su
linux (Ubuntu)
New
Undecided
Unassigned
Jammy
Invalid
Undecided
Unassigned
Mantic
Invalid
Undecided
Unassigned
Noble
Fix Committed
Undecided
Andy Chi
linux-oem-6.5 (Ubuntu)
Invalid
Undecided
Andy Chi
Jammy
Fix Committed
Medium
Andy Chi
Mantic
Won't Fix
Medium
Andy Chi
Noble
Won't Fix
Medium
Andy Chi

Bug Description

[Impact]
The mic mute/audio mute LEDS are not work on HP ProBook 440/460 G11

[Fix]
It needs the specific quirk for the hardware layout.
Thus, add the quirks to make it works.

[Test]
After applying the quirk, the audio/mic mute LEDs are working good.

[Where problems could occur]
If HP ships the different system boards design with the same subsystem ID of audio codec which is using different GPIO pins (different layout), then the quirk will not work (LEDs will not work when muting audio-output or microphone).

Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu Jammy):
assignee: nobody → Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu):
assignee: nobody → Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu Jammy):
status: New → Confirmed
Changed in linux-oem-6.5 (Ubuntu Mantic):
status: New → Won't Fix
Changed in linux-oem-6.5 (Ubuntu Noble):
status: New → Won't Fix
Changed in linux-oem-6.5 (Ubuntu Mantic):
assignee: nobody → Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu Noble):
assignee: nobody → Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu Jammy):
importance: Undecided → Medium
Changed in linux-oem-6.5 (Ubuntu Mantic):
importance: Undecided → Medium
Changed in linux-oem-6.5 (Ubuntu Noble):
importance: Undecided → Medium
Andy Chi (andch)
tags: added: oem-priority originate-from-2066823 stella
Andy Chi (andch)
Changed in oem-priority:
assignee: nobody → Andy Chi (andch)
importance: Undecided → Critical
status: New → Confirmed
LEE KUAN-YING (kyyc0426)
Changed in linux (Ubuntu Jammy):
status: New → Invalid
Changed in linux (Ubuntu Mantic):
status: New → Invalid
Changed in linux (Ubuntu Noble):
status: New → Confirmed
assignee: nobody → Andy Chi (andch)
Changed in linux-oem-6.5 (Ubuntu):
status: New → Invalid
LEE KUAN-YING (kyyc0426)
Changed in linux-oem-6.5 (Ubuntu Jammy):
status: Confirmed → Fix Committed
Revision history for this message
Andy Chi (andch) wrote :
Changed in oem-priority:
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Noble):
status: Confirmed → Fix Committed
Andy Chi (andch)
Changed in oem-priority:
assignee: Andy Chi (andch) → Dirk Su (dirksu)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-6.5/6.5.0-1025.26 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-jammy-linux-oem-6.5' to 'verification-done-jammy-linux-oem-6.5'. If the problem still exists, change the tag 'verification-needed-jammy-linux-oem-6.5' to 'verification-failed-jammy-linux-oem-6.5'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: kernel-spammed-jammy-linux-oem-6.5-v2 verification-needed-jammy-linux-oem-6.5
Revision history for this message
Andy Chi (andch) wrote :

Enable proposed2 and install linux-oem-6.5/6.5.0-1025.26 on the target machine, mic/speaker mute leds work as expected.

tags: added: verification-done-jammy-linux-oem-6.5
removed: verification-needed-jammy-linux-oem-6.5
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.