Ubuntu

Warning during boot: WARNING: Error inserting padlock_sha (/lib/modules/2.6.24/12-generic/kernel/drivers/crypto/padlock-sha-.ko): No such device

Reported by Adna rim on 2008-03-24
142
This bug affects 22 people
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Unassigned
linux (Debian)
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
since hardy I'm getting the following error while booting:

[63.686712] padlock: VIA Padlock Hash Engine not detected.
modprobe: WARNING: Error inserting padlock_sha (/lib/modules/2.6.24/12-generic/kernel/drivers/crypto/padlock-sha-.ko): No such device

I'm using dm_crypt and luks and although there is this warning the encrypted filesystem is working well.

The same error is reported here by an user of the serverkernel:
 * http://ubuntuforums.org/showthread.php?p=4567140

Is this warning fixable?

It's also reproduceable from the console:
[19:56:48]bash:~$ uname -r
2.6.24-12-generic
[19:56:54]bash:~$ sudo modprobe sha256
[sudo] password for adnarim:
WARNING: Error inserting padlock_sha (/lib/modules/2.6.24-12-generic/kernel/drivers/crypto/padlock-sha.ko): No such device

Adna rim (adnarim) on 2008-03-24
description: updated
MountainX (dave-mountain) wrote :

Yes, I can confirm this bug.

Mike Rushton (leftyfb) wrote :

Confirmed

Ubuntu Hardy 8.04 beta
swap and /home encrypted. I receive this error after entering the first passphrase for swap to be mounted. The error comes up, then onto prompting for the /home passphrase.

Just curious if you've tried blacklisting the module.

Changed in linux:
status: New → Incomplete
Mike Rushton (leftyfb) wrote :

Should blacklisting be something everyone with an encrypted filesystem installation be doing by default? If this is not needed, then it should be blacklisted by default.

Workaround:
alias sha256 to sha256_generic

padlock-sha is for using the crypto-chip on via epia boards

The problem is:
padlock-sha is aliased to sha256 in hardy.

Adna rim (adnarim) wrote :

Hi Sven,
could you please specifiy what you mean with aliasing the module? Just renaming it?

greets

Add the line:
alias sha256 sha256_generic
to /etc/modprobe.d/aliases
This leads to the old (pre-hardy) behaviour, where sha256 is an alias for sha256_generic and not for padlock-sha
In Gutsy, sha256 was an alias for sha256_generic

Blacklisting (as well as assigning sha256 alias to sha256_generic) works

Changed in linux:
status: Incomplete → Confirmed
MountainX (dave-mountain) wrote :

What are the security implications of this issue (if we don't alias as described above)? Is it likely that this will be fixed in Hardy soon anyway?

In case one wonders why I'm asking these questions, I have been curious since I started using Hardy about what happens when I implement a work-around for a bug that is later fixed -- potentially in a way that is not compatible with my workaround. That's a question related to the bigger picture. I plan to stay with this same installation of Hardy as I move forward, but I am collecting (implementing) various bug fixes as I use it. (Sorry to get off topic a bit.)

It's not a bug - it's a feature.

Honestly, it just tries to load the module for hardware encryption support of a VIA Epia - so users of a VIA Epia will have hardware acceleration for encryption out of the box.
For everyone else, it will fail loading and no harm is done.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Johan Kröckel (jnkl) wrote :

But when this happens, ubuntu doesnt show the bootsplash anymore. So, cant say thats a harm, but its a bug anyway.

Johan Kröckel (jnkl) wrote :

Excuse me:
This happend to me (or I just recognized it) because I tried to setup a swapfile for hibernation and instead of setting "resume=/dev/sda2" as a kernel boot option mine was "resume=/swapfile". So, you can ignore my contribution.

tubby gweilo (tubbygweilo) wrote :

I am using 8.04 with lvm and fully encrypted hard disk on two machines and every now and then both error in the way described by the first poster.

errno (gav-lca) wrote :

Yes, I can confirm this bug too. Aliasing module helps.

Sergio Zanchetta (primes2h) wrote :

I confirm it with kernel 2.6.24-19-generic

fwfw (fewfew) wrote :

I'm using Ubuntu 8.04 with kernel 2.6.24-19-generic and fully encrypted hard disk without LVM. For me none of the two workarounds worked!

llimaa (llimaa) wrote :

Still no solution ? I even tried to delete the module and without success. :/
I never had a Ubuntu version without issues!

mzanfardino (mzanfardino) wrote :

I have thoroughly read this thread in an effort to find a solution to this issue for my machine as well. I have discovered something that it probably obvious to most but clearly wasn't to me. If you are intent on aliasing sha265 to something like sha256_generic, but sure you do not blacklist both sha256 and sha256_generic! This is a sure way to lock you our of your encrypted partitions.

Fortunately I did not encrypt my root partition (something I highly recommend you don't do!) and was able to de-blacklist sha256. This seemed to fix my issue with not being able to decrypt the partition.

llimaa (llimaa) wrote :

And again the bug was fixed in Debian, sometimes i wonder why I'm still using Ubuntu...
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464673

Changed in linux:
status: Unknown → Fix Released

The Debain report comments this was fixed in cryptsetup=2:1.0.6-1

The current version of cryptsetup for the upcoming Intrepid Ibex release is 2:1.0.6-2ubuntu7 so it would seem this should be resolved for Intrepid Ibex 8.10. Regardless I've reassigned this to the cryptsetup package. If anyone can test and confirm this is resolved in Intrepid that would be great - http://www.ubuntu.com/testing .

Changed in linux:
assignee: ubuntu-kernel-team → nobody
importance: Medium → Undecided
status: Triaged → New
Reinhard Tartler (siretart) wrote :

when comparing the current ubuntu and debian package, I don't see any releavant changes in debian/initramfs/cryptroot-script .

I'm therefore closing this bug.

Changed in cryptsetup:
status: New → Fix Released
llimaa (llimaa) wrote :

Just because you don't see any relevant changes, does not mean that this bug don't exist anymore. Sorry but people using 8.04 don't care for fixes in 8.10 Alpha, they want it to be fixed in 8.04. Specially since its LTS.

You can't tell somebody to upgrade the whole system to an alpha stage OS Version because of a bug, That's not the right way.

sadfub (sadfub) wrote :

I confirm this bug on Ubuntu 8.04. It has all worked since I made recently some updates then I got this error message during boot. This bug seemed to be reintroduced someway (regression)! Hoping that the alias workaround will fix this.

kbish (kbish) wrote :

I confirm this bug on Ubuntu 8.10. I got error messages during boot. It's not fixed :( . Also I can't find any workaround.

bloo (bloo) wrote :

Making a clean install (I haven't tried with an upgrade, sorry) solved the problem for me (it happened in Hardy but seems to be solved in Intrepid, at least in my machine, I use Intrepid 32 bits).

The only thing is that the graphical bootsplash turns to text mode just after entering my passphrase, as it did in Hardy hwne the padlock error appeared. I don't really know if it this is related in any way.

Andreas Olsson (andol) on 2009-01-21
Changed in linux:
status: New → Confirmed
starslights (starslights) wrote :

Hello,

I run on kubuntu Karmic 9.10 64 bits, 2.6.31-10-generic

modprobe FATAL: Error inserting padlock_sha (/lib/modules/2.6.31-10-generic/kernel/drivers/crypto/padlock-sha.ko): No such device

Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: starslights 4192 F...m mplayer
 /dev/snd/controlC0: starslights 2779 F.... kmix
                      starslights 4192 F.... mplayer
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 41
   Simple ctrls : 23
DistroRelease: Ubuntu 9.10
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=d70651d4-6f58-4736-adea-3321aeeab5ee ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_CH.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-10-generic N/A
 linux-firmware 1.19
RfKill:

Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/26/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1611
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1611:bd11/26/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

tags: added: apport-collected
Subu Krishnamoorthy (madank) wrote :

I see the same problem as starslights. I run karmic 2.6.31-11-generic.

neferty (roman-semko) wrote :

Same here after today's "beta" updates. :-/

tags: added: iso-testing
simovaris (sercet) wrote :

Same problem here as #27.

It seldomly boots normally though. I'm running i386 karmic with latest updates.

Raubvogel (raubvogel) wrote :

I too am experiencing it with a fresh install of 10.04 LTS:

modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-23-server/kernel/drivers/crypto/padlock-sha.ko): No such device

lbz (lbz) wrote :

Same problem as #48 on 10.04 LTS server 32-bit.

Jan Groenewald (jan-aims) wrote :

Confirmed on lucid 64bit server

0 root@oystercatcher:/var/log#cat daemon.log|grep sha
Aug 23 16:52:12 oystercatcher modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-24-server/kernel/drivers/crypto/padlock-sha.ko): No such device
Sep 1 08:34:56 oystercatcher modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-24-server/kernel/drivers/crypto/padlock-sha.ko): No such device
Sep 20 10:29:07 oystercatcher modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-24-server/kernel/drivers/crypto/padlock-sha.ko): No such device
Oct 4 11:57:26 oystercatcher modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-24-server/kernel/drivers/crypto/padlock-sha.ko): No such device
Oct 4 12:33:17 oystercatcher modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-24-server/kernel/drivers/crypto/padlock-sha.ko): No such device
0 root@oystercatcher:/var/log#uname -a
Linux oystercatcher 2.6.32-24-server #43-Ubuntu SMP Thu Sep 16 16:05:42 UTC 2010 x86_64 GNU/Linux
0 root@oystercatcher:/var/log#lsb_release -d
Description: Ubuntu 10.04.1 LTS
0 root@oystercatcher:/var/log#lsmod|grep sha
sha1_generic 2231 7
0 root@oystercatcher:/var/log#grep sha /etc/drbd.d/r0.res
                verify-alg sha1;
                data-integrity-alg sha1;

poloshiao (poloshiao) wrote :

I got the error message "modprobe: FATAL: Error inserting padlock_sha ..."
since I installed ubuntu 10.04 LTS recently.
I resolved this problem after I read #33 ( the URL as below )
and applied it to my /etc/crypttab.
I found out there was a line "...swap,cipher=..." in my /etc/crypttab.
I just added a space between "swap," and "cipher" so that it looked
like this "...swap, cipher=..." in my /etc/crypttab.
The error message disappeared after I rebooted !

Thank for Message #33 by Alexander Mader
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568008#33

I have the same error when using 2.6.32-6-server. The server doesn't boot. No need to say that this is a complete disaster.

James Cuzella (trinitronx) wrote :

Just installed 10.10 Maverick Meerkat on a Lenovo ThinkPad T410, and am getting this too:

modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.35-24-generic/kernel/drivers/crypto/padlock-sha.ko)

Aliasing sha256 to sha256_generic did not work. Blacklisting padlock-sha did though.

Jeremy Foshee (jeremyfoshee) wrote :

James / Wayne,
    Apologies for the delay on this issue. As this bug was filed originally in 2008, would you mind opening a new bug for me? I'd like to get the relevant logging from each of you on your respective environments. That would also enable me to close out this old bug as the original reporter has likely resolved this issue or at the very least worked around it.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Joao Mendes (badseed-pt) wrote :

Hi,

I'm having the same in 11.04 (64bit)

modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.38-9-generic/kernel/drivers/crypto/padlock-sha.ko): No such device

Thanks,
João Mendes

lambengolmor (nicola-feltrin) wrote :

Jeremy Foshee wrote:
>would you mind opening a new bug for me

Has someone opened the new bug yet? I am experiencing this bug too and I'd like to know the correct place to report.

PS: anyway I'm using ubuntu 11.04 32 bit (2.6.38-8-generic), it boots fine and everything seems to work (with the exception of the modprobe message at boot time)

Joao Mendes (badseed-pt) wrote :

Hi,
Just opened the bug for Jeremy

Bug #779912

Thanks,
João Mendes

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.