sound stopped working

Bug #206087 reported by Joerg Beyer
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Sound worked for a few hours (less than a day) after the upgrade to hardy, then suddenly
stopped completly. The strange thing is, that I am not aware, that I changed anything around this time.

> lsb_release -rd
Description: Ubuntu hardy (development branch)
Release: 8.04

> apt-cache policy pulseaudio
pulseaudio:
  Installed: 0.9.9-1ubuntu2
  Candidate: 0.9.9-1ubuntu2
  Version table:
 *** 0.9.9-1ubuntu2 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

>lspci | grep audio
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)

> lsmod | grep snd
snd_usb_audio 81024 1
snd_usb_lib 17920 1 snd_usb_audio
snd_hwdep 10244 1 snd_usb_audio
snd_intel8x0 34972 3
snd_ac97_codec 100644 1 snd_intel8x0
ac97_bus 3200 1 snd_ac97_codec
snd_pcm_oss 44672 0
snd_mixer_oss 17664 1 snd_pcm_oss
snd_pcm 80388 4 snd_usb_audio,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_mpu401 9640 0
snd_mpu401_uart 9600 1 snd_mpu401
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 3 snd_usb_lib,snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24324 2 snd_pcm,snd_seq
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54660 22 snd_usb_audio,snd_hwdep,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8800 1 snd
snd_page_alloc 11400 2 snd_intel8x0,snd_pcm
usbcore 138632 8 snd_usb_audio,snd_usb_lib,gspca,usb_storage,libusual,ehci_hcd,ohci_hcd

> ls -l /dev/shm/
insgesamt 232
-r-------- 1 joerg joerg 2097176 2008-03-24 16:21 pulse-shm-2264702867
-r-------- 1 joerg joerg 2097176 2008-03-24 17:24 pulse-shm-400211903

> ps uax | grep pulse
joerg 8602 0.0 0.5 35284 5368 ? Sl 16:21 0:01 /usr/bin/pulseaudio --log-target=syslog
joerg 8607 0.0 0.2 5680 2248 ? S 16:21 0:00 /usr/lib/pulseaudio/pulse/gconf-helper

any more infos I could give?

Revision history for this message
Hanusz leszek (leszek-skynet) wrote :

Did the problem appeared after reboot ?
What kernel are you using ? (uname -a)

Revision history for this message
Joerg Beyer (j-beyer) wrote :

no, the problem did not appear after a reboot, but persists over reboots.
I watched a small movie from my camcorder with totem (sound was OK), stopped watching and wanted
to watch the same movie with vlc, but sound failed since that moment - no idea what the cause might be.

kernel is Linux phb 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

Revision history for this message
Joerg Beyer (j-beyer) wrote :

when I play a testsound, e.g. with
paplay test.wav
(file test.wav says: test.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 22050 Hz)
, then pavumeter shows "moving" signal levels, but I still can hear nothing.

Is there a way to follow the processes and find where the sound is supressed?

Revision history for this message
Joerg Beyer (j-beyer) wrote :

I just rebooted with an old knoppix cd to make sure, that this computer still could do audio output: it worked out of the box, but still no sound within hardy.

could anybody suggest how to debug the pulseaudio chain or reconfigure it from scratch?

Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

Thanks for reporting this bug.

Please follow the instructions under "Reporting Sound Bugs - Automatic Sound Information Collection" on this page to produce a file containing all relevant debugging information: https://wiki.ubuntu.com/DebuggingSoundProblems. Then attach the output file here.

Thanks!

Revision history for this message
Joerg Beyer (j-beyer) wrote :

sound works again for me - something (maybe totem or vlc) set the volume of "IEC958P" undetected to 0.

Is stays valid, that debugging the sound chain isn't easy.

Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

Closing this bug as per the reporter's last comment.

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers