Ubuntu

USB port disabled by hup (EMI? re enabling)

Reported by Antti Luoma on 2008-03-21
32
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Tim Gardner
mythtv (Ubuntu)
Medium
Unassigned
yelp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: yelp

Description: Ubuntu hardy (development branch)
Release: 8.04 (amd64)
Mainboard is based on amd690G chipset.

I have been trying to get my SUB DBV-tuner to work, I have consulted v4l-dvb-users list and drivers are compiled ok and TV-usb-card is initialized correctly.

But when i issue a scan i get these strange usb disconnects / reconnect errors in syslog:

[ 2079.556854] dib0700: firmware started successfully.
[ 2079.757650] dvb-usb: found a 'Pinnacle PCTV 72e DVB-T' in warm state.
[ 2079.757709] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 2079.757850] DVB: registering new adapter (Pinnacle PCTV 72e DVB-T)
[ 2079.982150] dvb_register_frontend
[ 2079.982158] DVB: registering frontend 0 (DiBcom 7000PC)...
[ 2080.165536] DiB0070: successfully identified
[ 2080.165546] dvb-usb: Pinnacle PCTV 72e DVB-T successfully initialized and connected.
[ 2164.220052] dvb_frontend_open
[ 2164.220058] dvb_frontend_start
[ 2164.220474] dvb_frontend_ioctl
[ 2164.220477] dvb_frontend_thread
[ 2164.220479] DVB: initialising frontend 0 (DiBcom 7000PC)...
[ 2164.236503] dvb_frontend_ioctl
[ 2164.236509] dvb_frontend_add_event
[ 2164.236055] dvb_frontend_swzigzag_autotune: drift:0 inversion:0 auto_step:0 auto_sub_step:0 started_auto_step:0
[ 2164.316402] dvb_frontend_ioctl

 // I think THIS is the cause of the problem
[ 2164.504843] hub 6-3:1.0: port 7 disabled by hub (EMI?), re-enabling...
[ 2164.504890] usb 6-3.7: USB disconnect, address 4

[ 2164.505094] dvb_unregister_frontend
[ 2164.505096] dvb_frontend_stop
[ 2170.886982] dvb-usb: error while stopping stream.
[ 2170.887011] dvb_frontend_release
[ 2170.887343] dvb-usb: Pinnacle PCTV 72e DVB-T successfully deinitialized and disconnected.
[ 2170.916174] usb 6-3.7: new high speed USB device using ehci_hcd and address 5
[ 2170.953302] usb 6-3.7: configuration #1 chosen from 1 choice
[ 2170.953464] dvb-usb: found a 'Pinnacle PCTV 72e DVB-T' in warm state.
[ 2170.953503] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 2170.953617] DVB: registering new adapter (Pinnacle PCTV 72e DVB-T)

I already tried to disable usb autosusbend with good no results (find some issues related to this with google):
put this in rc.local:
echo -1 > /sys/module/usbcore/parameters/autosuspend
sleep 1
/usr/sbin/lsusb

Is this is a kernel bug?

ProblemType: Bug
Architecture: amd64
Date: Fri Mar 21 23:59:33 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.22.0-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.24-12-generic x86_64

Antti Luoma (anluoma) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for your comments. This does not appear to be a bug report as such. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. http://launchpad.net/support

Changed in yelp:
importance: Undecided → Low
status: New → Invalid
Antti Luoma (anluoma) wrote :

Hi,

I do really think this is a BUG. USB shouldn't disconnect/reconnect devices when they are used. Same issues are reported for kernels berore (not using this usb-dvb stick but other hardware. See for example https://bugs.launchpad.net/linux/+bug/102659

I might have even debugged this myself, but haven't done any kernel debugging before, and guessing it takes time to set things up and I haven't got that now.

dh (dcharvey) wrote :
Download full text (3.2 KiB)

I get the same behaviour on my HP nx6125 laptop with both a nova-t and nova-t diversity stick. Either attempting to scan for, or watch dvb channels results in the following:

 MT2060: successfully identified (IF1 = 1220)
[ 589.459712] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:13.2/usb3/3-8/input/input16
[ 589.470534] dvb-usb: schedule remote query interval to 150 msecs.
[ 589.470540] dvb-usb: Hauppauge Nova-T Stick successfully initialized and connected.
[ 606.300175] hub 3-0:1.0: port 8 disabled by hub (EMI?), re-enabling...
[ 606.300181] usb 3-8: USB disconnect, address 11
[ 606.312990] mt2060 I2C write failed
[ 608.563167] mt2060 I2C write failed
[ 608.563243] mt2060 I2C write failed (len=2)
[ 608.563246] mt2060 I2C write failed (len=6)

This was with the latest mercurial build from v4l-dvb but this doesn't seem to fix things and displays the same as the stock kernel modules. There were some disconnects with previous ubuntu kernel versions (gutsy and previous) but not nearly as frequent as is now happening. Looks like it's probabably an upstream issue as I've read of several other sufferers even with vanilla kernels. Could be my usb chipset or something more generic, lspci is below. Please let me know if I can provide any further debug.

david@davslaptop:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
02:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
02:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
02:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
02:04.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
02:04.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
02:04.4 SD Host ...

Read more...

Pedro Villavicencio (pedro) wrote :

If you think it's a bug it's not a yelp one.

Changed in yelp:
status: New → Invalid

doh, cocked up the form clearl., I can't seem to move it to linux or
linux modules, any chance of doing so?

Pedro Villavicencio wrote:
> If you think it's a bug it's not a yelp one.
>
> ** Changed in: yelp (Ubuntu)
> Status: New => Invalid
>
>

Changed in linux:
status: Invalid → New

Hi Anzi,

We're currently in Beta Freeze for Hardy so only critical bug fixes or extremely simple patches are being pulled into the Hardy kernel. I'm going to retarget this report for the Intrepid Ibex release. Thanks.

Changed in linux:
milestone: none → later
status: New → Confirmed

I'm experiencing the same problem with a DVB-T card on hardy. The fix for it apparently is one-line, in one file:

http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.24.y.git;a=commit;h=5475187c2752adcc6d789592b5f68c81c39e5a81

Without this patch, my tuner card (a Hauppauge Nova-T 500 dual tuner) disconnects multiple times a day, making Hardy Heron all but useless as a MythTV platform. Can we please revisit the decision to push this patch off to the next version?

Mark Cox (mark-coxy) wrote :

Hi,

I'd agree with that, I to use a Nova T-500, you can't have a simple issue like this in an LTS release, an LTS release is exactly what people would choose to base a mythtv system on. I don't mind pulling changes from v4l-dvb but I don't fancy building a new kernel to fix a simple issue.

dh (dcharvey) wrote :

There has been much discussion on v4l-dvb about this issue so I have
alerted them to the potential fix. I really think as a trivial patch
that this could save a lot of people a lot of headaches if it is the
root cause, so it at least warrants a revisit.

Cheers,

dh

Mark Cox wrote:
> Hi,
>
> I'd agree with that, I to use a Nova T-500, you can't have a simple
> issue like this in an LTS release, an LTS release is exactly what people
> would choose to base a mythtv system on. I don't mind pulling changes
> from v4l-dvb but I don't fancy building a new kernel to fix a simple
> issue.
>
>

Nico (nico-rdo) wrote :

Here, we go, +1

I would not like to be forced into compiling my own kernel just because a patch was not applied in time.

Nico
Nova-T-500, 2x USB devices and USB controller on a PCI board
Mythbuntu user

Tim Gardner (timg-tpi) wrote :

Cherry-picked b5f7a0ec11694e60c99d682549dfaf8a03d7ad97 from Linus' tree.

Changed in linux:
assignee: nobody → timg-tpi
milestone: later → ubuntu-8.04
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-14.24

---------------
linux (2.6.24-14.24) hardy; urgency=low

  [Amit Kucheria]

  * LPIA: Update from moblin
  * LPIA: Fix reboot problem after S3/S4
  * LPIA: Integrate latest Dabney thermal patches
  * LPIA: Change-umd_dbg-debug-level-to-KERN_INFO
  * LPIA: Compile modules into kernel to save on boot time
  * LPIA: lots of Dabney CONFIG options dissapeared
  * LPIA: Purge nonexistent config options

  [Jay Chetty]

  * UBUNTU:USBC:Integrated USBC 2.0.0.32L.0009

  [Misha Zhilin]

  * USB: ehci: handle large bulk URBs correctly (again)
    - LP: #204857

  [Tim Gardner]

  * frame buffer regression - screen blank except for blinking cursor after
    fbcon vtswitch
    - LP: #201591
  * Blacklist Bluetooth Dell Wireless 370 for SCO MTU
    - LP: #209715
  * Set CONFIG_FAIR_CGROUP_SCHED for server flavours.
    - LP: #188226
  * Add DMI IO_DELAY support.
    - LP: #200057

 -- Tim Gardner <email address hidden> Mon, 31 Mar 2008 11:19:49 -0600

Changed in linux:
status: Fix Committed → Fix Released
Antti Luoma (anluoma) wrote :

Hi,

Yes now it works! Thanks for the fix.

hugolp (hugolp2) wrote :

Is this suposed to be solved?

I installed Ubuntu from the alternate cd and I am getting this problem. Nova-t-500 working randomly and dmesg showing a lot of I2C read failed. My kernel is 2.6.22-14-generic (the one that got installed wiht the cd). Any solution wellcome as this is making my mythtv system unusable.

Hugo

David Morris (dave-greenacre) wrote :

I'm using the Nova-t-500 on Hardy, with kernel version 2.6.24-15-generic without any problems.

I think the 2.6.22-14-generic kernel is from Gutsy.

Mark Cox (mark-coxy) wrote :

Yes, I'm on 2.6.24-16 generic Hardy LTS and the issue seems solved for me.

2008/4/28 hugolp <email address hidden>:
> Is this suposed to be solved?
>
> I installed Ubuntu from the alternate cd and I am getting this problem.
> Nova-t-500 working randomly and dmesg showing a lot of I2C read failed.
> My kernel is 2.6.22-14-generic (the one that got installed wiht the cd).
> Any solution wellcome as this is making my mythtv system unusable.
>
> Hugo
>
> --
> USB port disabled by hup (EMI? re enabling)
> https://bugs.launchpad.net/bugs/204857
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Mario Limonciello (superm1) wrote :

hugolp wrote:
> Is this suposed to be solved?
>
> I installed Ubuntu from the alternate cd and I am getting this problem.
> Nova-t-500 working randomly and dmesg showing a lot of I2C read failed.
> My kernel is 2.6.22-14-generic (the one that got installed wiht the cd).
> Any solution wellcome as this is making my mythtv system unusable.
>
> Hugo
>
Hugo,

That is a gutsy kernel. Upgrade to hardy for resolution.

--
Mario Limonciello
<email address hidden>

dh (dcharvey) wrote :

I've been fine since 2.6.24-15 (I think). It was certainly an update
from the Ubuntu beta 4 disc but may be included now the official release
is out. system/apt-get upgrade should sort things out...

dh
Mark Cox wrote:
> Yes, I'm on 2.6.24-16 generic Hardy LTS and the issue seems solved for
> me.
>
> 2008/4/28 hugolp <email address hidden>:
>
>> Is this suposed to be solved?
>>
>> I installed Ubuntu from the alternate cd and I am getting this problem.
>> Nova-t-500 working randomly and dmesg showing a lot of I2C read failed.
>> My kernel is 2.6.22-14-generic (the one that got installed wiht the cd).
>> Any solution wellcome as this is making my mythtv system unusable.
>>
>> Hugo
>>
>> --
>> USB port disabled by hup (EMI? re enabling)
>> https://bugs.launchpad.net/bugs/204857
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>>
>
>

David Morris (dave-greenacre) wrote :

Out of interest I'm getting

[1392289.060402] mythbackend[21454]: segfault at 000000b8 eip b65eef01 esp b4349160 error 4

in my kernel log along with a mythbackend segfault. Is anyone else getting this every 24-36 hours using the T-500 to help me track down the fault.

hugolp (hugolp2) wrote :

Mario Limonciello and others. Sorry for the confusion, Im using gutsy still in my desktop computer and ssh to the server where I have Hardy with the mythtv backend and the nova-t-500. I though I had a terminal with a ssh session onto the server but it seems it wasnt, so uname -r gave me the gutsy kernel version of the desktop computer.

The correct kernel version that I am running on the server is: 2.6.24-16-generic (I installed from the alternate cd). I can confirm the nova-t-500 its not working. It gets detected but it randomly fails to lock on channels (actually most of the time).

Dmesg shows a lot of this:

[69124.200154] mt2060 I2C read failed
[69124.208157] mt2060 I2C read failed
[69125.355212] mt2060 I2C write failed (len=2)
[69125.355241] mt2060 I2C write failed (len=6)
[69125.355255] mt2060 I2C read failed
[69125.363523] mt2060 I2C read failed
[69125.371113] mt2060 I2C read failed

Hugo

hugolp (hugolp2) wrote :

To add more here are a couple of links of the Ubuntu forum with the same issue:

http://ubuntuforums.org/showthread.php?t=762872

http://ubuntuforums.org/showthread.php?t=751587

David Morris (dave-greenacre) wrote :

Hugo,

have you got the following line added to /etc/modprobe.d/options ?

options dvb-usb-dib0700 force_lna_activation=1

hugolp (hugolp2) wrote :

@David Morris

yes, thats one of the first things I did.

Hugo

Mario Limonciello (superm1) wrote :

I'm going to add the MythTV task to this bug so that the default on the nova-t 500 can be set higher preventing people from running into this in the future.

Changed in mythtv:
importance: Undecided → Medium
status: New → Confirmed
Octavi (ofullana) wrote :
Download full text (3.4 KiB)

I know it's an old bug but I'm still stuck with the I2C errors. I'm using Ubuntu 8.04 with kernel version 2.6.24-23 (upgraded from 7.10), and the errors are still there. I recently upgraded v4l drivers and switched to 1.20 firmware, with no luck. I also tried the delay solution founded by hugolp. Is it possible to continue with this issue? Here's an extract from my syslog:

Mar 30 21:48:53 HTPC kernel: [ 132.866291] irq 17: nobody cared (try booting with the "irqpoll" option)
Mar 30 21:48:53 HTPC kernel: [ 132.866300] Pid: 0, comm: swapper Tainted: P 2.6.24-23-generic #1
Mar 30 21:48:53 HTPC kernel: [ 132.866329] [__report_bad_irq+0x24/0x80] __report_bad_irq+0x24/0x80
Mar 30 21:48:53 HTPC kernel: [ 132.866350] [note_interrupt+0x27b/0x2c0] note_interrupt+0x27b/0x2c0
Mar 30 21:48:53 HTPC kernel: [ 132.866371] [<e089fccb>] usb_hcd_irq+0x2b/0x60 [usbcore]
Mar 30 21:48:53 HTPC kernel: [ 132.866397] [handle_IRQ_event+0x30/0x60] handle_IRQ_event+0x30/0x60
Mar 30 21:48:53 HTPC kernel: [ 132.866413] [handle_fasteoi_irq+0x86/0xe0] handle_fasteoi_irq+0x86/0xe0
Mar 30 21:48:53 HTPC kernel: [ 132.866429] [do_IRQ+0x3b/0x70] do_IRQ+0x3b/0x70
Mar 30 21:48:53 HTPC kernel: [ 132.866455] [common_interrupt+0x23/0x30] common_interrupt+0x23/0x30
Mar 30 21:48:53 HTPC kernel: [ 132.866462] [default_idle+0x0/0x60] default_idle+0x0/0x60
Mar 30 21:48:53 HTPC kernel: [ 132.866492] [native_safe_halt+0x2/0x10] native_safe_halt+0x2/0x10
Mar 30 21:48:53 HTPC kernel: [ 132.866504] [default_idle+0x3c/0x60] default_idle+0x3c/0x60
Mar 30 21:48:53 HTPC kernel: [ 132.866508] [cpu_idle+0x45/0xd0] cpu_idle+0x45/0xd0
Mar 30 21:48:53 HTPC kernel: [ 132.866521] [start_kernel+0x31f/0x3b0] start_kernel+0x31f/0x3b0
Mar 30 21:48:53 HTPC kernel: [ 132.866530] [unknown_bootoption+0x0/0x1e0] unknown_bootoption+0x0/0x1e0
Mar 30 21:48:53 HTPC kernel: [ 132.866562] =======================
Mar 30 21:48:53 HTPC kernel: [ 132.866564] handlers:
Mar 30 21:48:53 HTPC kernel: [ 132.866566] [<e089fca0>] (usb_hcd_irq+0x0/0x60 [usbcore])
Mar 30 21:48:53 HTPC kernel: [ 132.866584] [<e089fca0>] (usb_hcd_irq+0x0/0x60 [usbcore])
Mar 30 21:48:53 HTPC kernel: [ 132.866600] Disabling IRQ #17
Mar 30 21:48:55 HTPC kernel: [ 134.421448] mt2060 I2C write failed (len=2)
Mar 30 21:48:55 HTPC kernel: [ 134.421458] mt2060 I2C write failed (len=6)
Mar 30 21:48:55 HTPC kernel: [ 134.421463] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.426794] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.434797] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.442769] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.450753] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.458738] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.466728] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.474730] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.482704] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.490684] mt2060 I2C read failed
Mar 30 21:48:55 HTPC kernel: [ 134.647602] dvb-usb: could not submit URB no. 0 - get them all back
Mar 30 21:48:55 HTPC kernel: [ 134.647615] dvb-usb: error while enabling fi...

Read more...

Mario Limonciello (superm1) wrote :

Thank you for helping to improve Mythbuntu by opening this ticket. Unfortunately the Mythbuntu team does not foresee a time when they will be able to tackle this issue, so I am closing this ticket. With that being said, if someone else wants to write a patch for this, we will be happy to help push it upstream. Please do not let that action deter you from opening tickets on other issues that you find!

Changed in mythtv (Ubuntu):
status: Confirmed → Won't Fix
Kenneth Boyd (kjboyd) wrote :

Just got to say, I had this problem with Lubuntu - and it seems to be solved if you wrap the usb cable around some ferrite - there may be interference when a usb hard drive or other high emi device is plugged in or activated that sends the hub into a state of panic. Might be worth a shot .... worked for me :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers