[hardy beta] [amd64] squashfs errors on resume from desktop CD due to CD-ROM resume read failures

Bug #203984 reported by Chris Cheney on 2008-03-19
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Medium
Colin Ian King

Bug Description

The Ubuntu hardy amd64 desktop cd 20080318.1 works fine until trying suspend. When resuming it causes squashfs errors to appear and X doesn't come back completely. I was able to switch to console and see the console and I can see the X mouse cursor but nothing else, I am guessing due to the squashfs errors(?)

I copied various log files from the running system and will be attaching them.

Thanks,

Chris Cheney

In kern.log:
Mar 19 12:25:31 ubuntu kernel: [ 21.735853] SQUASHFS error: sb_bread failed reading block 0x80b02
Mar 19 12:25:31 ubuntu kernel: [ 21.735862] SQUASHFS error: Unable to read fragment cache block [202b6aa1]
Mar 19 12:25:31 ubuntu kernel: [ 21.735865] SQUASHFS error: Unable to read page, block 202b6aa1, size 9dbe

Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :
description: updated

I noticed the same squashfs errors when resuming from suspend.

description: updated
Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: New → Confirmed
Chris Cheney (ccheney) wrote :

I'm not completely certain the squashfs errors were what caused my resume not to work, but I saw them and it didn't work so I wanted to make sure the issue was reported.

Chris Cheney (ccheney) wrote :

Also on one of the attempts the squashfs errors were continually scrolling across the screen. I tried again and it didn't do that so I was able to copy the logs off the system.

Changed in linux:
importance: Undecided → Medium
status: Confirmed → Triaged
Chris Cheney (ccheney) wrote :

I forgot to mention that the same day's cd for i386 seemed to work fine for suspend/resume without having squashfs errors.

ska.ndal (ska.ndal) wrote :

i have this problem in hardy beta too.
i am using virtualbox with the iso-file, so it is not a failure in the cd .. but i will try it with a new download of the iso-image later again ...
if it is important: it's a x86-machine

ska.ndal (ska.ndal) wrote :

ok, the iso-file was damaged .. no it's working ..

Changed in linux:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Chris Cheney (ccheney) wrote :

Colin,

Hi, I see you assigned yourself to this bug, if you have any questions for me feel free to ask here or on IRC, my nick is calc and I am on both IRC networks. I can download updated CD images for testing, etc, but I will be gone next week, Wed-Sun, to GoOOCon in Prague.

Chris

Colin Ian King (colin-king) wrote :

Chris,

I've examined this bug by putting copious amounts of debug in squashfs and building a debugged version of the live CD. I've then tracking this through the scsi subsystem down to the ata driver level. I believe the bug is an underlying ata driver issue which may not be easily resolved in 2.6.24.

Basically, the squashfs filesystem is loop back mounted from the file casper/filesystem.squashfs on the live CD. When the system goes into suspend/cycle, the ata driver is not suspended/resumed correctly causing I/O reads in the block layer to fail which ultimately causes squashfs to produce the error messages.

Originally I thought this looked like just an 64 bit kernel issue, but one can reproduce this bug with the 32 it version as well by selection one of the consoles, suspending and resuming and immediately the machine resumes type a command that is not cached in memory. This forces squashfs to read some blocks off the CD (from the loop back mounted filesytem squashfs image) and the ata driver fails with an I/O error - mainly because it is in a unknown state because suspend may not be implemented for the ata controller.

One can show this is not a squashfs bug by inserting any CD-ROM and running dd on an installed Hardy system:

sudo dd if=/dev/scd0 of=/dev/zero

and doing a suspend resume cycle.

The mystery is why this succeeds with non CD-ROM drives such as a hard disk over a suspend/resume cycle, e.g.:

sudo dd if=/dev/sda of=/dev/zero

I conclude that the crux of the matter is the implementation of suspend resume for your ata driver. Looking at http://ata.wiki.kernel.org/index.php/Software_status it states:

"System suspend/resume (suspend-to-RAM, suspend-to-disk) is currently supported for ata_piix, ahci, sata_sil and sata_sil24 drivers.

ACPI support is also needed in certain situations, to ensure that Linux properly initializes the device on boot, and after resume. A patch from Intel is available in -mm and libata-dev.git for this. "

I shall see if the patch is applicable and resolved the issue.

Colin

Colin Ian King (colin-king) wrote :

Chris, one more thing, can you send me the output from:

sudo lspci -vv -nn

I'd just like to see a bit more information about the ata hardware.

Thanks

Colin

Chris Cheney (ccheney) wrote :
Colin Ian King (colin-king) wrote :

Hi Chris.

I am opening a discussion with the libata maintainer as I believe your chipset may not have a correctly working suspend/resume support and I need to double check this. I'v e checked upstream against 2.6.25-rc7 and the problem still exists, so I doubt if there any fixes upstream at present.

Meanwhile, if you can confirm that the problem is due to suspend/resume when doing I/O from the CD-ROM by inserting a CD-ROM into your drive and doing the following:

dd if=/dev/scd0 of=/dev/zero

and doing a suspend/resume cycle. If dd breaks with an I/O error then this confirms it's an underlying libata problem.

Thanks

Brian Murray (brian-murray) wrote :

I've the same IDE and SATA controllers and followed the test case outlined in comment 21 using kernel versin 2.6.24-14. I received an "Input/output error" after resuming.

00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 02) (prog-if 8a [Master SecP PriP])

00:1f.2 SATA controller [0106]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller [8086:27c5] (rev 02) (prog-if 01 [AHCI 1.0])

Brian Murray (brian-murray) wrote :

My CD / DVD drive information from dmesg follows:

[ 21.534296] ata5.00: ATAPI: Slimtype DVD A DS8AZH, NH61, max MWDMA2
[ 21.733301] ata5.00: configured for MWDMA2
[ 21.733360] ata6: port disabled. ignoring.
[ 21.735242] scsi 4:0:0:0: CD-ROM Slimtype DVD A DS8AZH NH61 PQ
: 0 ANSI: 5

Colin Ian King (colin-king) wrote :

I'm waiting for some feedback from the sata maintainer on this issue as it appears a generic suspend issue with this controller. However, I believe it's probably not going to get fixed in Hardy, but is probably a Hardy+1 fix.

Chris Cheney (ccheney) wrote :

That sounds great, even if it doesn't get corrected until hardy+1 that will be soon enough for me. I think this may be the primary reason that I am not able to properly resume on my laptop and I always run Ubuntu development releases anyway. :-)

I'm sorry I wasn't able to do further testing but I had been very busy with OOo and currently in Prague at a GoOOCon meeting. If you need any further tests once the sata maintainer sends you a patch (or it gets into mainline kernel) then just let me know and I should be able to test again.

Thanks!

Chris Cheney

Changed in linux:
status: In Progress → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Dimitrios Symeonidis (azimout) wrote :

could this be a hardware issue? https://help.ubuntu.com/community/SquashfsErrors

Changed in linux:
assignee: colin-king → nobody
status: In Progress → Confirmed

Hi Chris,

Just curious you've tested Intrepid and if the issue remains? Thanks.

Changed in linux:
status: Confirmed → Incomplete
Chris Cheney (ccheney) wrote :

I haven't tested an ubuntu desktop cd recently but amd64 does work on my laptop now in general. The last time I installed I used an alternate cd.

Chris

Chris Cheney (ccheney) wrote :

Marking this as Fix Released since I am pretty sure this bug doesn't happen anymore, or at least no longer causes a problem for me.

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers